[ Index ]

PHP Cross Reference of Unnamed Project

title

Body

[close]

/se3-clientslinux-2.3.1/debian/ -> rules (source)

   1  #!/usr/bin/make -f
   2  # -*- makefile -*-
   3  # Sample debian/rules that uses debhelper.
   4  #
   5  # This file was originally written by Joey Hess and Craig Small.
   6  # As a special exception, when this file is copied by dh-make into a
   7  # dh-make output file, you may use that output file without restriction.
   8  # This special exception was added by Craig Small in version 0.37 of dh-make.
   9  #
  10  # Modified to make a template file for a multi-binary package with separated
  11  # build-arch and build-indep targets  by Bill Allombert 2001
  12  
  13  # Uncomment this to turn on verbose mode.
  14  #export DH_VERBOSE=1
  15  
  16  # This has to be exported to make some magic below work.
  17  export DH_OPTIONS
  18  
  19  
  20  
  21  
  22  
  23  
  24  configure: configure-stamp
  25  configure-stamp:
  26      dh_testdir
  27      # Add here commands to configure the package.
  28  
  29      touch configure-stamp
  30  
  31  
  32  #Architecture
  33  build: build-arch build-indep
  34  
  35  build-arch: build-arch-stamp
  36  build-arch-stamp: configure-stamp  
  37  
  38      # Add here commands to compile the arch part of the package.
  39      #$(MAKE)
  40      touch $@
  41  
  42  build-indep: build-indep-stamp
  43  build-indep-stamp: configure-stamp  
  44  
  45      # Add here commands to compile the indep part of the package.
  46      #$(MAKE) doc
  47      touch $@
  48  
  49  clean: 
  50      dh_testdir
  51      dh_testroot
  52      rm -f build-arch-stamp build-indep-stamp configure-stamp
  53  
  54      # Add here commands to clean up after the build process.
  55      $(MAKE) clean
  56  
  57      dh_clean 
  58  
  59  install: install-indep install-arch
  60  install-indep:
  61      dh_testdir
  62      dh_testroot
  63      dh_clean -k -i 
  64      dh_installdirs -i
  65  
  66      # Add here commands to install the indep part of the package into
  67      # debian/<package>-doc.
  68      #INSTALLDOC#
  69  
  70      dh_install -i
  71  
  72  install-arch:
  73      dh_testdir
  74      dh_testroot
  75      dh_clean -k -s 
  76      dh_installdirs -s
  77  
  78      # Add here commands to install the arch part of the package into
  79      # debian/tmp.
  80      $(MAKE) DESTDIR=$(CURDIR)/debian/se3-clientslinux install
  81  
  82      dh_install -s
  83  # Must not depend on anything. This is to be called by
  84  # binary-arch/binary-indep
  85  # in another 'make' thread.
  86  binary-common:
  87      dh_testdir
  88      dh_testroot
  89      dh_installchangelogs 
  90      dh_installdocs
  91      dh_installexamples
  92  #    dh_installmenu
  93  #    dh_installdebconf    
  94  #    dh_installlogrotate    
  95  #    dh_installemacsen
  96  #    dh_installpam
  97  #    dh_installmime
  98  #    dh_python
  99  #    dh_installinit
 100  #    dh_installcron
 101  #    dh_installinfo
 102      dh_installman
 103      dh_link
 104      dh_strip
 105      dh_compress
 106      dh_fixperms
 107  #    dh_perl
 108      dh_makeshlibs
 109      dh_installdeb
 110      dh_shlibdeps
 111      dh_gencontrol
 112      dh_md5sums
 113      dh_builddeb
 114  # Build architecture independant packages using the common target.
 115  binary-indep: build-indep install-indep
 116      $(MAKE) -f debian/rules DH_OPTIONS=-i binary-common
 117  
 118  # Build architecture dependant packages using the common target.
 119  binary-arch: build-arch install-arch
 120      $(MAKE) -f debian/rules DH_OPTIONS=-s binary-common
 121  
 122  binary: binary-arch binary-indep
 123  .PHONY: build clean binary-indep binary-arch binary install install-indep install-arch configure


Generated: Tue Mar 17 22:47:18 2015 Cross-referenced by PHPXref 0.7.1