# CONTENTS

1 QElectroTech Manual
   1.1 Basics ......................................................... 3
   1.2 Interface .................................................... 10
   1.3 Preferences ............................................... 32
   1.4 Project ..................................................... 42
   1.5 Folio ......................................................... 63
   1.6 Element ..................................................... 117
   1.7 Conductor .................................................. 197
   1.8 Schema ...................................................... 208
   1.9 Drawing ..................................................... 289
   1.10 Reports ................................................... 291
   1.11 Export and print ......................................... 293
   1.12 Annex ....................................................... 299

2 Manuel QElectroTech 301

3 Manual QElectroTech 303

4 QElectroTech Handbuch 305
This is the official documentation from QElectroTech 0.7.
Select language to start.
1.1 Basics

1.1.1 Start QElectroTech on Linux

After installation, Linux allows the user launching applications from many different ways. Below, the most common ways are explained.

Start QElectroTech from terminal

To launch QElectroTech using the terminal, the command to be used is:

```
$ qelectrotech
```

The command mentioned above blocks the terminal for other processes. If the terminal should be available for other processes, the command to start QElectroTech is:

```
$ qelectrotech &
```

**Note:** If the command is not working, list the applications installed and check the name with which QElectroTech has been installed.

- Ubuntu command: `$ apt list --installed`

Fig. 1: Figure: Starting splash screen
Start QElectroTech from applications menu

As Windows, Linux operative systems allow the user to open applications from menus and icons. Where to go depends on the theme and distribution used. Below, some possibilities according some configurations are mentioned. That not everybody can use them is important to be remarked.

- Unity theme: The icon appears at the launcher bar.
- Gnome shell: The icon appears at [Menu], with the rest of applications.
- Gnome Classic: QElectroTech can be started from Applications > Graphics > QElectroTech.
- KDE: QElectroTech can be started from [Menu] at Graphics > QElectroTech.

Once QElectroTech has been started, the main window looks as follow:

![Main window QElectroTech](image)

Fig. 2: Figure: Main window QElectroTech

1.1.2 Start QElectroTech on Windows

After installation, QElectroTech can be launched from Windows Start Menu. If the shortcut icon has been created at the desktop during installation, QElectroTech can also be started from that icon.

1. Click the Windows [Start] button.
2. Select All Programs.
3. Open QElectroTech program group.
4. Click QElectroTech icon.

Once QElectroTech has been started, the main window looks as follow:

![Main window QElectroTech](image)

1.1.3 Start QElectroTech on Mac

After installation, QElectroTech can be launched from applications folder.
Fig. 3: Figure: Starting splash screen

Fig. 4: Figure: Main window QElectroTech
Note: For easier access, QElectroTech can be added to the dock. Just open the applications folder and drag QElectroTech to the dock.

Once QElectroTech has been started, the main window looks as follow:

1.1.4 QElectroTech help menu

QElectroTech has been designed with some tools which help the user and makes easier the searching of information. All those tools can be found at Help menu from Menu bar.
Tooltips

To support the user, tooltips are displayed when the mouse arrow is placed on an icon from the Toolbars. A tooltip is a short message which defines the action corresponding to the icon.

QElectroTech also allows the display from tooltips, or short description panels, at many different areas and objects from the main window. These panels are not displayed automatically with the placement of the mouse arrow on the object or area.

1. Select Help > What’s this? menu item.
2. Press on the object or area to display the description panel.

To increase the working efficiency, the description panel can also be displayed using keyboard shortcut. The user does not need to search at the Help menu.

1. Press shift + f1.
2. Press on the object or area to display the description panel.

Note: The tool What’s this? does not give the description from everything, it gives only the description for the different type of collections (Title Blocks, Elements, etc.), the Workspace, Project area and a few objects and areas more.

About QElectroTech

Many information related to QElectroTech can be found at the application without searching on internet. Everybody who launches the application can find the license text, version of the application launched, developers and collaborators, link to the official web and many others things at Help menu.

1. Select Help > About QElectroTech menu item to display the PopUP window with the basic information from QElectroTech project.

1.1. Basics
Online Manual

Help menu can address the user to the official online documentation.

1. Select Help > Online Manual menu item to open the official QEletroTech online documentation at default browser.

When the application is active on the computer, the user can also open the online manual at default browser using keyboard shortcut.

1. Press f1 to open the official online manual on the browser.

See also:
For more information about QEletroTech keyboard shortcut, please refers to Menu bar section.

Youtube Channel

Many different video tutorials about QEletroTech can be found on internet. Help menu can address the user to the official youtube channel of the project.

1. Select Help > Youtube Channel menu item to open the QEletroTech youtube channel at default browser.

Download new version

To download the last released version from the software, if the version launched is not the last one, Help menu can address the user to the official download page of the project.

1. Select Help > Download a new version menu item to open the official QEletroTech download page at default browser.

Support the project

If the user is satisfied with the work already made by the developer team from QEletroTech and he wants to help the project with an economical donation, Help menu can address the user to the official paypal account of the project.

1. Select Help > Support the project with a donation menu item to open the official paypal account from QEletroTech at default browser.

About Qt

QEletroTech has been designed using Qt framework and widget toolkit. Help menu allows going to the official web from Qt project without the need of searching on Internet.

1. Select Help > About Qt menu item to open the official web from Qt on the browser.

1.1.5 Exit QEletroTech

The user can exit QEletroTech at any time. The user does not need to close the project before closing the application.

If the current work wants to be saved before closing the project, please refers to Save project section. Even so, QEletroTech displays an automatic message to save the current job if any modification has been created.

As a large amount of applications which has been developed using Qt, QEletroTech can be closed from the close tab which can be found at top right from main window, from Menu bar or using the corresponding keyboard shortcut.
Exit QElectroTech from Menu bar

1. Select **File > Quit** menu item to quit QElectroTech.

Exit QElectroTech using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Press `Ctrl + q` to quit QElectroTech.

See also:

For more information about QElectroTech keyboard shortcut, please refers to **Menu bar** section.

1.2 Interface

1.2.1 Interface elements

QElectroTech has been designed using Qt framework and widget toolkit, this means that the main window from QElectroTech is the same for all platforms where is available (Windows, Linux/Unix and MacOS). The main window from QElectroTech looks like the figure bellow.
The main window from QElectroTech contains the following areas:

1. Menu bar
2. Toolbar
3. Panels
4. Workspace
5. Projects tab
6. Folios tab
7. Help bar
8. Search Menu

1.2.2 Menu bar

The framework and widget toolkit Qt allows the design of drop-down menus. The drop-down menus are a characteristic graphical control element from the desktop applications. Each of the drop-down menus contains a number of options to initiate an action. The Menu bar is placed at top from the main windows. The figure below shows how the menu bar from QElectroTech looks.

As is showed at the figure, QElectroTech bar contains the menus File, Edit, Project, Display, Settings, Windows and Help. A brief description of each such option can be read from Help or Information tool bar by hovering over the option with the cursor. The following tables summarizes the available options from the main Menu bar.
<table>
<thead>
<tr>
<th>Menu</th>
<th>Options</th>
<th>Function</th>
<th>Keyboard shortcut</th>
<th>Toolbar icon</th>
</tr>
</thead>
<tbody>
<tr>
<td>File</td>
<td>Latest files</td>
<td>Open a project from history (recently opened files)</td>
<td>Ctrl + n</td>
<td></td>
</tr>
<tr>
<td></td>
<td>New</td>
<td>Creates a new Project</td>
<td>Ctrl + n</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Open</td>
<td>Opens an existing project from the disk</td>
<td>Ctrl + o</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Save</td>
<td>Saves the current changes to the project (overwrites)</td>
<td>Ctrl + s</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Save as</td>
<td>Saves the current project as a different file on disk</td>
<td>Ctrl + s</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Close</td>
<td>Closes the current project (prompts for saving changes)</td>
<td>Ctrl + w</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Export</td>
<td>Opens a dialogue to export drawings from a project</td>
<td>Ctrl + Shift + x</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Print</td>
<td>Opens a dialogue to print drawings from a project</td>
<td>Ctrl + p</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Quit</td>
<td>Quits the QElectroTech main window (prompts for saving changes)</td>
<td>Ctrl + q/Alt + F4</td>
<td></td>
</tr>
<tr>
<td>Menu</td>
<td>Options</td>
<td>Function</td>
<td>Keyboard shortcut</td>
<td>Toolbar icon</td>
</tr>
<tr>
<td>----------</td>
<td>-------------</td>
<td>--------------------------------------------------</td>
<td>-------------------</td>
<td>--------------</td>
</tr>
<tr>
<td><strong>Edit</strong></td>
<td>Undo</td>
<td>Undo the last action in the active drawing (folio)</td>
<td>Ctrl + z</td>
<td><img src="image" alt="Undo" /></td>
</tr>
<tr>
<td></td>
<td>Redo</td>
<td>Recovers the last undo action in the active drawing (folio)</td>
<td>Ctrl + y</td>
<td><img src="image" alt="Redo" /></td>
</tr>
<tr>
<td></td>
<td>Cut</td>
<td>Equivalent to copy + delete the object (active folio)</td>
<td>Ctrl + x</td>
<td><img src="image" alt="Cut" /></td>
</tr>
<tr>
<td></td>
<td>Copy</td>
<td>Copies the object selected in the active drawing</td>
<td>Ctrl + c</td>
<td><img src="image" alt="Copy" /></td>
</tr>
<tr>
<td></td>
<td>Paste</td>
<td>Pastes the object from last copy or cut (any folio)</td>
<td>Ctrl + v</td>
<td><img src="image" alt="Paste" /></td>
</tr>
<tr>
<td></td>
<td>Select All</td>
<td>Selects all objects in the active drawing area</td>
<td>Ctrl + a</td>
<td><img src="image" alt="Select All" /></td>
</tr>
<tr>
<td></td>
<td>Select none</td>
<td>Removes all current selections in the active folio</td>
<td></td>
<td><img src="image" alt="Select none" /></td>
</tr>
<tr>
<td></td>
<td>Invert selection</td>
<td>Inverts selection of objects in the active folio</td>
<td>Ctrl + i</td>
<td><img src="image" alt="Invert selection" /></td>
</tr>
<tr>
<td></td>
<td>Delete</td>
<td>Deletes the selected object in the active folio</td>
<td>Del</td>
<td><img src="image" alt="Delete" /></td>
</tr>
<tr>
<td></td>
<td>Rotate</td>
<td>Rotates selected object(s) in the active folio</td>
<td>Space</td>
<td><img src="image" alt="Rotate" /></td>
</tr>
<tr>
<td></td>
<td>Choose texts orientation</td>
<td>Rotates selected text field(s) in the active folio</td>
<td>Ctrl + Space</td>
<td><img src="image" alt="Choose texts orientation" /></td>
</tr>
<tr>
<td></td>
<td>Find in the panel</td>
<td>Identifies the selected element in elements panel</td>
<td></td>
<td><img src="image" alt="Find in the panel" /></td>
</tr>
<tr>
<td></td>
<td>Edit the selected item</td>
<td>Opens properties window for the selected element</td>
<td>Ctrl + e</td>
<td><img src="image" alt="Edit the selected item" /></td>
</tr>
<tr>
<td></td>
<td>Group selected texts</td>
<td></td>
<td></td>
<td><img src="image" alt="Group selected texts" /></td>
</tr>
<tr>
<td></td>
<td>Reset conductors</td>
<td>Resets selected conductor(s) to a shortest path</td>
<td>Ctrl + k</td>
<td><img src="image" alt="Reset conductors" /></td>
</tr>
<tr>
<td></td>
<td>Folio properties</td>
<td>Opens the properties window for the active drawing</td>
<td>Ctrl + l</td>
<td><img src="image" alt="Folio properties" /></td>
</tr>
<tr>
<td></td>
<td>Add a column</td>
<td>Adds an additional column to the active drawing</td>
<td></td>
<td><img src="image" alt="Add a column" /></td>
</tr>
<tr>
<td></td>
<td>Remove a column</td>
<td>Removes a column from the active drawing</td>
<td></td>
<td><img src="image" alt="Remove a column" /></td>
</tr>
<tr>
<td></td>
<td>Add a row</td>
<td>Adds an additional row to the active drawing</td>
<td></td>
<td><img src="image" alt="Add a row" /></td>
</tr>
<tr>
<td></td>
<td>Remove a row</td>
<td>Removes a row from the active drawing</td>
<td></td>
<td><img src="image" alt="Remove a row" /></td>
</tr>
<tr>
<td></td>
<td>Bring to front</td>
<td>Selected object sent at top</td>
<td>Ctrl + Shift + Home</td>
<td><img src="image" alt="Bring to front" /></td>
</tr>
<tr>
<td></td>
<td>Raise</td>
<td>Selected object sent one level up</td>
<td>Ctrl + Shift + Up</td>
<td><img src="image" alt="Raise" /></td>
</tr>
<tr>
<td></td>
<td>Lower</td>
<td>Selected object sent one level down</td>
<td>Ctrl + Shift + Down</td>
<td><img src="image" alt="Lower" /></td>
</tr>
<tr>
<td></td>
<td>Send backwards</td>
<td>Selected object sent at bottom</td>
<td>Ctrl + Shift + End</td>
<td><img src="image" alt="Send backwards" /></td>
</tr>
<tr>
<td></td>
<td>Search / Replace</td>
<td>Display Search / Replace panel</td>
<td>Ctrl + f</td>
<td><img src="image" alt="Search / Replace" /></td>
</tr>
</tbody>
</table>
### Project Properties

<table>
<thead>
<tr>
<th>Menu</th>
<th>Options</th>
<th>Function</th>
<th>Keyboard shortcut</th>
<th>Toolbar icon</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project</td>
<td>Project properties</td>
<td>Display project properties PopUp window</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Add a folio</td>
<td>Adds a new folio (drawing sheet) to the active project.</td>
<td>Ctrl + t</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Delete this folio</td>
<td>Deletes the active folio (drawing sheet) of the project</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Clean project</td>
<td>Purges the active project of unused elements and empty categories and templates</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Add a summary</td>
<td>Creates an index folio for the active project</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Export parts list</td>
<td>Generates a .csv file summary of all elements used in the active project</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Launch the terminal block creation plugin</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
## Menu | Options | Function | Keyboard shortcut | Notes | Toolbar icon
---|---|---|---|---|---
**Settings** | Display | Display or hide toolbars and panels |  |  |  
| Full screen mode | Spreads the window to fill the screen | Ctrl + Shift + f | Entire screen gets occupied by the window |  
| Configure QElectroTech | Display QElectroTech configure PopUp window |  |  |  

## Menu | Options | Function | Keyboard shortcut | Toolbar icon
---|---|---|---|---
**Windows** | Close | Closes the current project (prompts for saving changes) | Ctrl + f4 |  
| Tile | Adds a new drawing sheet to the active project. (Folio means drawing sheet) |  |  
| Cascade | Deletes the active drawing of the project |  |  
| Next Project | Purges the active project of unused elements and empty categories and templates | Ctrl + tab |  
| Previous Project | Creates an index folio for the active project | Ctrl + Shift + Backtab |  
| (Opened Projects) | Below **Previous Project** QElectroTech list all opened projects to select the active project |  |  

## Menu | Options | Function | Keyboard shortcut | Toolbar icon
---|---|---|---|---
**Help** | What’s This? | Enquires main menu options | Shift + f1 |  
| About QElectroTech | Displays information about authors, contributors, translators and Licensing |  |  
| Online manual | Opens the explorer and redirects to the official QElectroTech documentation | f1 |  
| Youtube channel | Opens the explorer and redirects to the official QElectroTech Youtube channel |  |  
| Download a new version (dev) | Opens the explorer and redirects to the official QElectroTech download link |  |  
| Support the project with a donation | Opens the explorer and redirects to the official QElectroTech donation paypal account |  |  
| About Qt | Displays information about Qt, a C++ toolkit for cross platform applications |  |  

---

Chapter 1. QElectroTech Manual
### 1.2.3 Workspace

The workspace, also named graphical editor, is the area where the schematics and reports (Index table, component list, symbol glossary, etc.) are created.

At the figure below, the appearance from QElectroTech workspace can be found.

![QElectroTech Workspace](image)

**Fig. 13: Figure: QElectroTech Workspace**

### 1.2.4 Toolbars

In addition to the different Menus, QElectroTech also provides toolbars. The toolbars are groups of buttons with icons which initiate actions. In general, these buttons have its counterpart at one of the menus from the Menu bar. The aim from the toolbars is to make easier and more graphically the use of QElectroTech.

The different toolbars can be hidden or placed in one or more rows below Menu bar. The toolbars can also be placed on column at the left or right side from the main window.

**Note:** To help the user, a tooltip is displayed when the arrow is placed on each button.
Toolbar Tools

The different button from toolbar Tools are mentioned and described below.

<table>
<thead>
<tr>
<th>Toolbar Options</th>
<th>Function</th>
<th>Keyboard shortcut</th>
<th>Toolbar icon</th>
</tr>
</thead>
<tbody>
<tr>
<td>New</td>
<td>Creates a new Project</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Open</td>
<td>Opens an existing project from the computer</td>
<td>Ctrl + o</td>
<td></td>
</tr>
<tr>
<td>Save</td>
<td>Saves the current changes to the project (overwrites)</td>
<td>Ctrl + s</td>
<td></td>
</tr>
<tr>
<td>Save as</td>
<td>Saves the current project as a different file on disk</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Close</td>
<td>Closes the current project (prompts for saving changes)</td>
<td>Ctrl + w</td>
<td></td>
</tr>
<tr>
<td>Print</td>
<td>Opens a dialogue to print drawings from a project</td>
<td>Ctrl + p</td>
<td></td>
</tr>
<tr>
<td>Undo</td>
<td>Undo the last action in the active drawing (folio)</td>
<td>Ctrl + z</td>
<td></td>
</tr>
<tr>
<td>Redo</td>
<td>Repeat the last action in the active drawing (folio)</td>
<td>Ctrl + Shift + z</td>
<td></td>
</tr>
<tr>
<td>Cut</td>
<td>Equivalent to copy + delete the object (active folio)</td>
<td>Ctrl + x</td>
<td></td>
</tr>
<tr>
<td>Copy</td>
<td>Copies the object selected in the active drawing</td>
<td>Ctrl + c</td>
<td></td>
</tr>
<tr>
<td>Paste</td>
<td>Pastes the object from last copy or cut (any folio)</td>
<td>Ctrl + v</td>
<td></td>
</tr>
<tr>
<td>Delete</td>
<td>Deletes the selected object in the active folio</td>
<td>Del</td>
<td></td>
</tr>
<tr>
<td>Rotate</td>
<td>Rotates selected object(s) in the active folio</td>
<td>Space</td>
<td></td>
</tr>
</tbody>
</table>

Note: Select Settings > display > Tools menu item to display or hidden the toolbar Tools.

Toolbar Display

Fig. 14: Figure: QElectroTech toolbar Tools

Fig. 15: Figure: QElectroTech toolbar Display
The different button from toolbar **Display** are mentioned and described bellow.

<table>
<thead>
<tr>
<th>Toolbar</th>
<th>Options</th>
<th>Function</th>
<th>Keyboard shortcut</th>
<th>Toolbar icon</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Display</strong></td>
<td>Select</td>
<td>Use choose tool (default) to select individual elements, conductors in the workspace</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Move</strong></td>
<td></td>
<td>Use move tool to hold and drag the drawing sheet (folio) when zoomed in excess of display</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Display the grid</strong></td>
<td></td>
<td>Display or hide the grid from the folio</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Background color white / gray</strong></td>
<td></td>
<td>Change the background color from the folio, change color from white to gray or vice versa</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Zoom content</strong></td>
<td></td>
<td>The window magnifies to a level that fits all the elements of the active folio to display</td>
<td><strong>Ctrl + 8</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Fit in view</strong></td>
<td></td>
<td>Reset zoom levels to fit the active folio including grid and title block to display</td>
<td><strong>Ctrl + 9</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Reset zoom</strong></td>
<td></td>
<td>Reset zoom levels to a default value (zoom level just less than that of fit in view)</td>
<td><strong>Ctrl + 0</strong></td>
<td></td>
</tr>
</tbody>
</table>

**Note:** Select **Settings > Display > Display** menu item to display or hidden the toolbar **Display**.

**Toolbar Diagram**

![Fig. 16: Figure: QElectroTech toolbar Diagram](image)

The different button from toolbar **Diagram** are mentioned and described bellow.

<table>
<thead>
<tr>
<th>Toolbar</th>
<th>Options</th>
<th>Function</th>
<th>Keyboard shortcut</th>
<th>Toolbar icon</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Diagram</strong></td>
<td>Folio proper ties</td>
<td>Opens the properties window for the active drawing</td>
<td><strong>Ctrl + 1</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Reset conductors</strong></td>
<td></td>
<td>Resets selected conductor(s) to a shortest path</td>
<td><strong>Ctrl + k</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Automatic creation conductor</strong></td>
<td></td>
<td>Permits automatic conductors creation when two terminals of an element are aligned in either vertical or horizontal plane</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**1.2. Interface**
Note: Select Settings > Display > Diagram menu item to display or hidden the toolbar Diagram.

Toolbar Add

![Fig. 17: Figure: QElectroTech toolbar Add](image)

The different button from toolbar Add are mentioned and described bellow.

<table>
<thead>
<tr>
<th>Toolbar</th>
<th>Options</th>
<th>Function</th>
<th>Keyboard shortcut</th>
<th>Toolbar icon</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add</td>
<td>Add a textfield</td>
<td>Tool to inser a text field object in the workspace</td>
<td></td>
<td><img src="image" alt="Toolbar icon" /></td>
</tr>
<tr>
<td></td>
<td>Add a picture</td>
<td>Tool to inser a picture object in the workspace</td>
<td></td>
<td><img src="image" alt="Toolbar icon" /></td>
</tr>
<tr>
<td></td>
<td>Add line</td>
<td>Tool to inser a line basic object in the workspace</td>
<td></td>
<td><img src="image" alt="Toolbar icon" /></td>
</tr>
<tr>
<td></td>
<td>Add a rectangle</td>
<td>Tool to inser a rectangle basic object in the workspace</td>
<td></td>
<td><img src="image" alt="Toolbar icon" /></td>
</tr>
<tr>
<td></td>
<td>Add an ellipse</td>
<td>Tool to inser an ellipse basic object in the workspace</td>
<td></td>
<td><img src="image" alt="Toolbar icon" /></td>
</tr>
<tr>
<td></td>
<td>Add a polygon</td>
<td>Tool to inser a polygon basic object in the workspace</td>
<td></td>
<td><img src="image" alt="Toolbar icon" /></td>
</tr>
</tbody>
</table>

Note: Select Settings > Display > Add menu item to display or hidden the toolbar Add.

Toolbar Depth

![Fig. 18: Figure: QElectroTech toolbar Depth](image)

The different button from toolbar Depth are mentioned and described bellow.
<table>
<thead>
<tr>
<th>Toolbar</th>
<th>Options</th>
<th>Function</th>
<th>Keyboard shortcut</th>
<th>Toolbar icon</th>
</tr>
</thead>
<tbody>
<tr>
<td>Depth</td>
<td>Bring to front</td>
<td>The element or picture will be at the top and completely visible</td>
<td>Ctrl + shift + Home</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Raise</td>
<td>The element or image will be sent one level up</td>
<td>Ctrl + shift + Up</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Lower</td>
<td>The element or image will be sent one level down</td>
<td>Ctrl + shift + Down</td>
<td></td>
</tr>
<tr>
<td></td>
<td>send backwards</td>
<td>The element or picture will be at the bottom and probably will be partially covered</td>
<td>Ctrl + shift + End</td>
<td></td>
</tr>
</tbody>
</table>

**Note:** Select **Settings > Display > Depth** menu item to display or hidden the toolbar Depth.

### 1.2.5 Panels

**Projects panel**

The project panel displays the project tree, folios and enabled Title Blocks. The QET and user collection Title Blocks are also displayed at the project panel.

![Projects panel](image)

**Fig. 19:** Figure: QElectroTech Projects panel

To display the project panel:

1. Select **Settings > display > Projects** menu item to display the Projects panel.

The main functions from the project panel are structure the project and managing the Title Blocks collections. From the project panel the order of the folios is managed. Many other tasks can also be managed from the project panel.
Bellow are listed all the tasks which are able from the project panel:

- Manage folios (Add folios, define folio order at each project, etc.).
- Manage the project title block collection.
- Manage the User title block Collection.
- Define the active project.
- Define the active folio which should be displayed at the workspace.
- Display the folio properties PopUP window.
- Display the project properties PopUP window.

To make easier the work with the project panel, QElectroTech provides a filter. All folios, projects and Title Blocks without a name or part of string can be hidden from the panel.

Collection panel

The collection panel displays the QET, user and projects element collections.

![Collections panel](image)

Fig. 20: Figure: QElectroTech Collections panel

To display the collection panel:

1. Select **Settings > display > Collections** menu item to display the Collections panel.

The main functions from the collection panel is to manage elements. Bellow are listed all the tasks able from the collection panel:

- Manage user collection (Create, edit and delete elements from the collection).
- Edit elements from project collections.
- Search elements from the project collection at the workspace.
- Import elements from QET or user collection to the project (Add new element to the workspace).

To make easier the work with the collection panel, QElectroTech provides search tool that makes faster finding elements inside the different collections.
Selection properties panel

The Selection properties panel displays the properties from the select object. Only the properties from some object can be displayed at the panel. The Selection properties panel can display the properties from the following objects:

- Elements
- Some Basic objects: Line, Rectangle, Ellipse, Polygon and Picture.

![Selection properties panel](image)

Fig. 21: Figure: QELECTROTech Selection properties panel

To display the Selection properties panel:

1. Select **Settings > display > Selection properties** menu item to display the Selection properties panel.
The main function of the Selection properties panel is to manage the object properties. At QEElectroTech, the object properties can be different for each object, for this reason many different actions can be made from this panel. Below are listed the most important tasks able from the project panel:

- Manage the properties from the basic geometrical objects (Line, Rectangle, Ellipse and Polygon).
- Define the scale from the imported Pictures.
- Lock the position of the Basic objects (Line, Rectangle, Ellipse, Polygon and Picture).
- Manage the information from the elements (Label, Function, Manufacturer, Article number, Order number, etc.).
- Manage the Text and Dynamic text from element symbol.
- Display the general element properties (Element Name, Position, Dimensions, Number of terminals, etc.).
- Manage the element links (Cross references).

**Auto Numbering Selection panel**

The Auto Numbering Selection panel displays the active auto numbering pattern for:

- Folios
- Elements
- Conductors

![Auto Numbering Select Panel](image)

Fig. 22: Figure: QEElectroTech Auto Numbering Selection panel

To display the Auto Numbering Selection panel:

1. Select **Settings > display > Auto Numbering Selection** menu item to display the Auto Numbering Selection panel.

The main function from the Auto Numbering Selection panel is to manage auto numbering pattern.

- Select the active folio auto numbering pattern
- Select the active element auto numbering pattern
- Select the active conductor auto numbering pattern

**See also:**

For more information about how to use the Auto Numbering Select panel during folio addition, please refers to Add folio section.
Fig. 23: Figure: QElectroTech Auto Numbering Select panel

Fig. 24: Figure: QElectroTech Auto Numbering Select panel
For more information about how to use the Auto Numbering Select panel during element addition, please refer to Add element section.

For more information about how to use the Auto Numbering Select panel during conductor creation, please refer to Create conductor section.

**Undo panel**

The Undo panel displays the history since the last time that the document was saved. Once the project is saved, undo panel is automatically cleaned.

To display the collection panel:

1. Select **Settings > display > Undo** menu item to display the Undo panel.

The undo panel is used to return to the status after one of the actions made after last save. By clicking on one of the actions listed at undo panel, the project will return to the status after the action chose at the panel. While the project is not saved again, the user can go to the different status as many times he wants.
**Warning:** If you play with the panel, be sure that you are at the correct history status before continue working, saving project or any irreversible action like delete folio. Once the project is saved or an irreversible action is made, the history is deleted.

Why can be interested using the Uno panel?

- Coming back many steps only with one click.
- Recovering an object which was deleted many steps before. The object can be recovered coming back one step before the elimination, copying the object, coming back to the last history status and pasting it.
- Checking the project many steps before.
- Etc.

### 1.2.6 Help bar

The Help bar, also known as Information Toolbar, is the space below the control tabs, the bottom left corner from the main window. It is very useful for beginners of QElectroTech in the way that it gives information about the field that is pointed by the cursor. A user can learn about a field by simply pointing it with the mouse and reading the information from help bar.

![QElectroTech Help bar](image)

Fig. 26: Figure: QElectroTech Help bar

### 1.2.7 Projects tabs bar

The different opened projects from QElectroTech can be managed using PopUP windows under the Menu bar and toolbars or using a project tabs bar.

**Note:**
The project tabs bar allows the following actions:

1. Choosing the active project by simple click on the tab.
2. Closing the project by using the close tab which can be found at the right side from each project tab.

1.2.8 Folios tabs bar

The folio tabs bar can be considered part of the Workspace. The folio tabs bars contains one tab for each folio of the project. The folio tabs bar looks like the figure bellow.

The folio tabs bar allows the following actions:

1. Choosing the active folio by simple click on the tab.
2. Opening the properties PopUP window from an specific folio by doble click on the tab.
3. Adding new folio to the project by simple click on the Add folio icon from the right side.

1.2.9 Search menu

The search menu allows searching element, folios or conductor which have a text field or property with an specific value. The search menu allows finding automatically an element with a desired label, list the folios from an specific author, etc.

QElectrotech provides a basic and simple search menu composed by a text box which allows writing the desired text value which should be find and some buttons for closing the menu, actualizing the search and going to next and previous match.

QElectrotech also provides an advanced menu where filters can be defined inside a folio, element, text field and conductor tree. The advance mode allows also replacing actions.

To display the search menu:

1. Select Edit > Search menu item to display the search menu at the bottom from the Workspace.
1.2.10 GUI customization

Toolbars placement

The QE ElectroTech GUI allows having many different toolbars switched on to make easier the work of the user.

To display the toolbars:

1. Select Settings > Display menu item to display the panels and toolbars list.
2. Click on the different toolbars (Tools, Display, Diagram, Add and Depth) which should be displayed.

Note: The search menu can also be displayed using Ctrl + f shortcut keyboard.

All toolbars are placed by default under Menu bar, on one row. The user is free to change the organization of toolbars. The toolbars can be organized in many rows, on columns at the left or right side from the Workspace or as floating toolbar.

If the user wants to change the organization of toolbars, he should only make left click with the mouse on the left side from the toolbar and displace the mouse without releasing the button.
Fig. 32: Figure: QElectroTech user interface

Fig. 33: Figure: QElectroTech toolbars placement
Panels placement

The QElectroTech GUI allows having many different panels switched on to make easier the work of the user.

To display the panels:

1. Select **Settings > Display** menu item to display the panels and toolbars list.
2. Click on the different panels (Projects, Collections, Undo, Selection properties and Auto Numbering Select) which should be displayed.

![Figure: QElectroTech Settings > Display menu](image)

All panels that are displayed can be placed at right and left side from the Workspace. The panels can also be displayed as a PopUP (floating) windows.

At the case that the user places the panels at the right or left side from the Workspace, the user can choose if they are organized on column or by tabs.

If the user wants to change the organization of the panels, he should only make left click with the mouse on the title bar and displace the mouse without releasing the button.

Projects display

There is two different ways to manage the activation and hidden of the different opened project from QET, the projects can be organized at a project title bar that would be shown at the top from the folio title bar or as floating windows that can be displayed or minimized.

To manage the project display preferences:

1. Select **Display -> Display projects** menu item to display the project preference list.
2. Click on the desired option: using windows or using tabs

See also:

The project display preferences can also be defined at QElectroTech appearance settings.
Fig. 35: Figure: QElectroTech user interface

Fig. 36: Figure: QElectroTech panels placement
Full screen mode

QElectroTech provides the option of displaying full screen. The full screen mode can be selected from Menu bar and using keyboard shortcut.

Full screen mode from Menu bar

1. Select Settings > FullScreen Mode menu item to display QElectroTech in full screen mode.

Full screen mode using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Press Ctrl + Shift + f to display QElectroTech in full screen mode.

See also:

For more information about QElectroTech keyboard shortcut, please refers to Menu bar section.
1.3 Preferences

1.3.1 Display settings

QElectroTech allows the user customizing many settings: language, appearance, export and printing settings, pre-define new project settings, element collection paths, etc.

To display the QElectroTech settings:

1. Select Settings > Configure QElectroTech menu item to display QElectroTech settings PopUP window.

![QElectroTech Settings menu]

Fig. 39: Figure: QElectroTech Settings menu

1.3.2 QElectroTech appearance

1.3.3 Project settings

1.3.4 Element settings

Collection settings

QElectroTech allows choosing the path from the QET (Common) and User element collection. The path from User Title Block collection can also be choosed. The collections directory can be at the local Hard Disk, common users, or at local servers, common for companies.

The default element collection paths depend on the installation settings choosed during the installation process.

Example

**QET collection**

- **Windows** C/Program Files/QElectroTech/elements
- **Linux**
- **Mac**

**User collection**

- **Windows** C/users/user_name/Application Data/qet/elements
1.3. Preferences

Fig. 40: Figure: QElectroTech appearance settings

Fig. 41: Figure: QElectroTech general project settings
For changing the element collection paths of QEElectroTech:

1. Display QEElectroTech settings PopUP window.
2. Go to Elements section.
3. Search and choose the folder directory from the QET (Common) and User element collection at the Collection of elements section.
4. Press OK button to save the configuration changes and close settings PopUP window.

**Note:** QEElectroTech has to be restarted to implement the changes.

**Element management settings**

QEElectroTech provides the possibility to predefine the element author. In this way; when a new element is created, QEElectroTech defines automatically this element property.

For pre-defining the element author information:

1. Display QEElectroTech settings PopUP window.
2. Go to Elements section.
3. Defines the element author and license information at the text box from Elements management section.
4. Press OK button to save the configuration changes and close settings PopUP window.

1.3.5 Select language

QElectroTech is a multilanguage tool already translated to 19 languages.

To select the working language:
1. Display QElectroTech settings PopUP window.
2. Go to General section.
3. Go to Language tab.
4. Spread out the combo box and select the desired language.
5. Press OK button to save the configuration changes and close settings PopUP window.

Note: QElectroTech has to be restarted to implement the changes.

Fig. 43: Figure: QElectroTech configure language section

1.3.6 Dynamic text settings

1.3.7 New project settings
Folio settings

QElectroTech provides the option to store at the Data from the application some project properties pre-defined by the user. This feature allows the user avoiding to define many project properties each time that the user creates new projects.

The Folio tab from New project settings section allows pre-defining some folio properties:

- Folio size.
- Folio title block.
- Folio default variables values.
- Folio user variables.

To define folio settings:

1. Display QElectroTech settings PopUP window.
2. Go to New project section.
3. Go to Folio tab.
4. Define the desired parameters for each field.
5. Press OK button to save the configuration changes and close settings PopUP window.

Note: All pre-defined folio properties defined at QElectroTech settings PopUP window will be automatically defined during project creation at project properties. The folio properties can be found at Folio tab from New folio section.
Conductor settings

QElectroTech provides the option to storage at the Data from the application some project properties pre-defined by the user. This feature allows the user avoiding to define many project properties each time that the user creates new projects.

The **Conductor** tab from **New project** settings section allows pre-defining some conductor properties:

- Conductor type (Multiline or Single line).
- Conductor appearance.

To define conductor settings:

1. Display QElectroTech settings PopUP window.
2. Go to **New project** section.
3. Go to **Conductor** tab.
4. Define the desired parameters for each field.
5. Press **OK** button to save the configuration changes and close settings PopUP window.

---

**Note:** All pre-defined conductor properties defined at QElectroTech settings PopUP window will be automatically defined during project creation at project properties. The conductor properties can be found at Conductor tab from **New folio** section.
Folio referencings settings

QElectroTech provides the option to storage at the Data from the application some project properties pre-defined by the user. This feature allows the user avoiding to define many project properties each time that the user creates new projects.

The Folio referencings tab from New project settings section allows pre-defining the formula which should define the label variable from Reference folio following and Previous reference folio.

To define folio referencings settings:

1. Display QElectroTech settings PopUP window.
2. Go to New project section.
3. Go to Folio referencings tab.
4. Define the desired parameters for each field.
5. Press OK button to save the configuration changes and close settings PopUP window.

Note: All pre-defined folio referencings properties defined at QElectroTech settings PopUP window will be automatically defined during project creation at project properties. The folio referencings properties can be found at Folio referencings tab from New folio section.
Cross references settings

QElectroTech provides the option to store at the Data from the application some project properties pre-defined by the user. This feature allows the user avoiding to define many project properties each time that the user creates new projects.

The Cross references tab from New project settings section allows pre-defining some cross references properties:

- Cross references type (Coil, organ of protection or Switch/button).
- Cross references label
- Representation position cross references label (Under the label of the element or Footer).

To define cross references settings:

1. Display QElectroTech settings PopUP window.
2. Go to New project section.
3. Go to Cross references tab.
4. Define the desired parameters for each field.
5. Press OK button to save the configuration changes and close settings PopUP window.

Note: All pre-defined cross references properties defined at QElectroTech settings PopUP window will be automatically defined during project creation at project properties. The cross references properties can be found at Cross references tab tab from New folio section.


![QElectroTech New project cross references settings](image)

**Fig. 48: Figure: QElectroTech New project cross references settings**

### 1.3.8 Export settings

QElectroTech allows predefining export settings for reducing the working configuration effort each time that a project have to be exported.

The default exporting settings which can be choosed are:

- Default target directory.
- Default export format (**PNG**, **JPEG**, **Bitmap**, **SVG** or **DXF**).
- Default rendering options (Draw or not borders, title block and grid; keep conductor colors or monochrome, etc.).

To define default export settings:

1. Display QElectroTech settings PopUP window.
2. Go to **Export** section.
3. Select the desired setting values for each field.
4. Press **OK** button to save the configuration changes.

**See also:**

For more information about QElectroTech export options, please refers to **Export** section.
1.3.9 Printing settings

QERootTech allows predefining printing settings for reducing the working configuration effort each time that a project have to be printed.

The default exporting settings which can be choosed are:

- Default rendering options (Draw or not borders, title block, grid and terminals; keep conductor colors or monochrome).

To define default printing settings:

1. Display QERootTech settings PopUP window.
2. Go to Printing section.
3. Select the desired setting values for each field.
4. Press OK button to save the configuration changes.

See also:

For more information about QERootTech printing options, please refer to Printing section.
1.4 Project

1.4.1 What is a project?

The term project inside QEelectroTech can be assimilated to a “dababase”. A project is not a common database, it is a collection of information which is not structurated in columns and rows.

A project is a group of folios, elements and conductors represented inside the folios with the respective properties, properties which define the way how should be represented each folio (title block, dimensions, etc.), properties which define how the reports should be represented (folio index, component list, connector list, etc.), properties which define how to export or print the information, interconnection relation between elements from the same or different folios.
and the master data (project name, author, year of creation, revision, etc.).

The project is the base of QElectroTech to manage a work. The development team has focus the tasks on the electrical and control filed, even so, QElectroTech is a E-CAE software. For this reason, QElectroTech is an inter-disciplinary tool that allows the user to create many type of projects.

- Electrical projects: Purely electrical systems
- Automation projects: GRAFCET, diagrams, etc.
- Fluid power projects: Hydraulic, pneumatic and central lubrication systems
- Proces control projects: Proces Industrial Diagrams (PID)

### 1.4.2 Create new project

A new project can be created from Menu bar, toolbar and using the corresponding keyboard shortcut.

**Create new project from Menu bar**

1. Select File > New menu item to create a new project.

   ![QElectroTech File menu](image)

   Fig. 52: Figure: QElectroTech File menu

**Create new project from toolbar**

1. Select the icon ![icon](image) from the toolbar to create a new project.

**Note:** If the toolbar is not displayed, it can be displayed from Settings > Display > Tools

**Create new project using keyboard shortcut**

QElectroTech allows using keyboard shortcut to increase the working efficiency.
1. Press $\text{Ctrl} + \text{n}$ to create a new project.

See also:
For more information about QElectroTech keyboard shortcut, please refers to Menu bar section.

### 1.4.3 Open Project

Opening a project saved somewhere from the computer Hard Disk or local server can be done from Menu bar, toolbar and using the corresponding keyboard shortcut.

One project is conformed by only one file with the format .qet. The .qet extension is the native extension from QElectroTech. Even so, QElectroTech also allows working with Extensible Markup Language files, files with extension .xml.

**Open project from Menu bar**

1. Select **File > Open** menu item to open the search file PopUP window.
2. Search the project at the computer
3. Press **Open** button to close the search file PopUP window and open the project.

![QElectroTech File menu](image)

**Fig. 53: Figure: QElectroTech File menu**

**Open project from toolbar**

1. Select the icon from the toolbar to open the search file PopUP window.
2. Search the project at the computer
3. Press **Open** button to close the search file PopUP window and open the project.

**Note:** If the toolbar is not displayed, it can be displayed from Settings > Display > Tools
Open project using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Press Ctrl + o to open the search file PopUP window.
2. Search the project at the computer
3. Press Open button to close the search file PopUP window and open the project.

See also:

For more information about QElectroTech keyboard shortcut, please refers to Menu bar section.

Files history

At the case that QElectroTech has already been used previously, exists the possibility to open a project created, opened and/or saved previously. File History has been integrated to QElectroTech.

1. Select File > Latest files menu item to display the file history from QElectroTech.
2. Click on the project file that should be opened.

![Figure: QElectroTech File History](image)

1.4.4 Save Project

The current project can be saved from the Menu bar, toolbar and using the corresponding keyboard shortcut.

One project is composed by only one file with the format .qet. The .qet extension is the native extension from QElectroTech.

Save project from Menu bar

1. Select File > Save menu item to save the active project.

At the case that the project has already been saved and wants to be saved as a different project, different name and/or directory:
1. Select **File > Save as** menu item to save the active **project** as a new **project**.

**Save project from toolbar**

1. Select the icon from the **toolbar** to save the active **project**.

At the case that the **project** has already been saved and wants to be saved as a different **project**, different name and/or directory:

1. Select the icon from the **toolbar** to save the active **project** as a new **project**.

**Note:** If the toolbar is not displayed, it can be displayed from **Settings > Display > Tools**

**Save project using keyboard shortcut**

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Press **Ctrl + s** to save the active **project**.

**See also:**

For more information about QElectroTech keyboard shortcut, please refers to **Menu bar section**.

**Note:** QElectroTech allows creating backup from the **project** periodically. This option should be configured at **Settings > Configure QElectroTech > Projects**.

### 1.4.5 Close Project

The user can close a **project** at any time. If the current work wants to be saved before closing the project, please refers to **Save** section. Even so, QElectroTech display an automatic message to save the **project** if any modification has been created on it.
Closing the current project can be done from the Menu bar, toolbar, projects panel, projects tab bar and using the corresponding keyboard shortcut.

At the case that more than one project are opened, the active project will be the project which will be closed.

**Close project from Menu bar**

1. Select **File > Close** menu item to close the active project.

   ![QElectroTech File menu](image)

   **Fig. 56: Figure: QElectroTech File menu**

**Close project from toolbar**

1. Select the icon from the toolbar to close the active project.

   ![QElectroTech Save message](image)

   **Fig. 55: Figure: QElectroTech Save message**

**Note:** If the toolbar is not displayed, it can be displayed from **Settings > Display > Tools.**
Close project from projects panel

The advantage of closing projects from the projects panel is the possibility to close projects which are opened and are not the active project.

1. Right click on the project tree from the projects panel.
2. Select Close this project to close the selected project.

![Project panel]

Fig. 57: Figure: Project panel

**Note:** If the projects panel is not displayed, it can be displayed from Settings > Display > Projects.

Close project from projects tabs bar

All opened projects can be visible at the projects tab bar that is displayed at top from the workspace. The user can close an opened projects, regardless of whether the project is active, with a click on the close tab from the project.

At the case that the projects are displayed as PopUP windows, they can be closed with a click on the close tab which is placed at the top right corner.

**Note:** Displaying the projects using a tab bar or using PopUP windows can be choosed at Display > Display projects.

Close project using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Press Ctrl + f4 to close the active project.

See also:

For more information about QElectroTech keyboard shortcut, please refers to Menu bar section.
1.4.6 Clean project

QElectroTech stores on the project database every title block, conductor, element, etc. which is introduced by the user, if the user deletes one element or replace the title block from the folio, the element or title block will be deleted from the folio, but, it will still be storage at the project database.

QElectroTech allows cleaning the project database from Menu bar.

1. Select **Project > Clean project** menu item to open the cleaning project PopUP window.

![Cleaning Project Menu](image)

Fig. 58: Figure: QElectroTech cleaning project PopUP window

2. Select the check buttons desired (templates, elements, categories).

3. Press the button **OK** to clean the project and close the cleaning project PopUP window.

![Cleaning Project Window](image)

**Note:** Cleaning the project is recomended to reduce the size of the project file and increase the loading speed.

1.4.7 Project properties

Display project properties

The **project properties** can be displayed at a PopUP window from Menu bar and projects panel.

**Project properties from Menu bar**

1. Select **Project > Project properties** menu item to display the project properties PopUP window from the active project.
Warning: If more than one projects is opened, be sure that the active projects is the correct before changing properties.

Project properties from project panel

The advantage of displaying the project properties from the projects panel is the possibility to choose projects which are opened and are not the active project.

1. Right click on one project from the project tree of the projects panel.
2. Select Project properties to display the project properties PopUP window.

Note: If the projects panel is not displayed, it can be displayed from Settings > Display > Projects.
General properties

The general properties section from the project properties PopUP windows is the area where the user can define global project variables that later on can be used at the folios title block templates to automate the filling of the title block.

Creating general project variables is recommended, it increase the working efficiency. By default, the variables which can be found at this section are the following:

- `% {projecttitle}`: Project title
- `% {savedate}`: File saving date
- `% {savedfilename}`: Registered file name
- `% {savedfilepath}`: Saved file path
- `% {savedtime}`: File saving time

To create new project variables:

1. Display project properties PopUp window.
2. Go to General project properties section.
3. Define the variable name at the left cell from the last row of the project variables table.
4. Define the value of the variable at the right cell from the variable row.
5. Press the button OK to save the changes and close the PopUp window.

Fig. 61: Figure: General project properties window
See also:
For more information about QE ElectroTech default variables, please refer to Default QE ElectroTech variables section.

New folio properties

Folio properties

At QE ElectroTech, the folio properties can be common at all folios from the same project. QE ElectroTech also allows that each folio has its own properties. For example, two folios from the same project will have the same size and title block but they can be created by different authors or they can have different revision.

To increase the working efficiency, QE ElectroTech provides the option to store at the project Data some project properties pre-defined by the user. This feature allows the user avoiding to define many folio properties each time that the user creates new folio inside the project.

Note: QE ElectroTech allows defining automatically folio properties during project creation. For more information about how to standardize some folio properties from project to project, please refer to the QE ElectroTech folio settings section.

The Folio tab from New folio settings section allows pre-defining some folio properties:

- Folio size.
- Folio title block.
- Folio default variables values.
- Folio user variables.

To define folio properties:

1. Display project properties PopUP window.
2. Go to New folio section.
3. Go to Folio tab.
4. Define the desired parameters for each field.
5. Press OK button to save the configuration changes and close project properties PopUP window.

Note: All pre-defined folio properties at project properties will be automatically defined during folio creation at folio properties.

Conductor properties

Some conductor properties can be common at all or gran part of conductors from all or gran part of folios. For example, the conductor type is normally common for a complete project or for a group of folios.

To increase the working efficiency, QE ElectroTech provides the option to store at the project Data some project properties pre-defined by the user. This feature allows the user avoiding to define many conductor properties each time that the user creates new conductor inside the project.
Fig. 62: Figure: Project folio properties window
**Note:** QEelectroTech allows defining automatically conductor properties during project creation. For more information about how to standardize some conductor properties from project to project, please refer to the QEelectroTech conductor settings section.

The **Conductor** tab from *New folio* settings section allows pre-defining some conductor properties:

- Conductor type (Multiline or Single line).
- Conductor appearance.

![Conductor Properties Window](image)

**Fig. 63: Figure: Project conductor properties window**

To define conductor settings:

1. **Display** project properties PopUP window.
2. Go to **New folio** section.
3. Go to **Conductor** tab.
4. Define the desired parameters for each field.
5. Press **OK** button to save the configuration changes and close project properties PopUP window.
Note: All pre-defined conductor properties at project properties will be automatically defined during folio creation at folio properties.

Folio referencing properties

QElectroTech allows creating schemas with multiple folios, only part of the schema is represented at each folio. This means that part of a conductor can be at one folio and the continuation at a different folio.

QElectroTech provides folio referencing elements to indicate from where a conductor is coming or where it is going. These elements can display at the workspace from the folio some information about the folio referencing element linked. The information which should be displayed can be defined by the user at Folio referencing tab from New Folio section of the project properties.

See also:

For more information about folio referencing, please refers to Reference folio following and Previous reference folio.

Fig. 64: Figure: Project folio referencing properties window

To define folio referencing Label:
1. Display project properties PopUP window.
2. Go to New folio section.
3. Go to Folio referencing tab.
4. Define the desired parameters for each field.
5. Press OK button to save the configuration changes and close project properties PopUP window.

Cross references properties

The main advantage of using Master and Slave elements is the possibility to create cross references (links) between elements. At the case of cross references definition, QElectroTech provides the possibility to display automatically at the workspace some information from the Master or Slave element linked.

The definition or cross references properties inside a project can be costumized by the user at project properties.

Note: QElectroTech allows defining automatically cross references properties during project creation. For more information about how to standardize some cross references properties from project to project, please refers to the QElectroTech cross references settings section.

The Cross references tab from New folio settings section allows pre-defining some cross references properties:

- Cross references Master element type (Coil, organ of protection or Switch/button).
- Cross references label (Master and slave cross references label to be display at the workspace)
- Representation position from the cross references label (Under the element label or Footer).
- Display option from cross references

Note: The cross reference label can be created using the general variables from Master and Slave elements.

To define cross references settings:

1. Display project properties PopUP window.
2. Go to New folio section.
3. Go to Cross references tab.
4. Define the desired parameters for each field.
5. Press OK button to save the configuration changes and close project properties PopUP window.

Note: All pre-defined cross references properties defined at QElectroTech settings PopUP window will be automatically defined during project creation at project properties. The cross references properties can be found at Cross references tab tab from New folio section.

Auto numbering properties

For managing the projects during manufacturing, erection, commissioning and maintenance phase; a codification criteria have to be defined during engineering phase, otherwise, the work is unefficient and the project can be a caos.
Fig. 65: Figure: Project cross referencing properties window
QElectroTech allows defining auto numbering properties for the codification of elements, conductors and folios. Each time that one object is added to the workspace, QElectroTech assigns it a identify code automatically according the criteria defined at the beginning of the project. This is one of the features which makes powerfull QElectroTech on the creation of shemas.

Management properties

![Project management properties window](image)

Fig. 66: Figure: Project management properties window

Conductor properties

Element properties

Folio properties
Fig. 67: Figure: Project conductor properties window
Fig. 68: Figure: Project element properties window
Fig. 69: Figure: Project folio properties window
Fig. 70: Figure: Project folio auto numbering properties window
Folio auto numbering properties

1.5 Folio

1.5.1 What is a folio?

A folio is part of the project that can be considered as a unit. It can be the project index, part of the schema, the part list complete or partly, etc.

The folio defines the maximum part of the project information that can be displayed at the same time on the workspace, a folio from a project is equivalent to a page of a book. When a project is exported to PDF, each folio is one page from the document. When a project is exported to any other format (PNG, JPG, DXF, etc.), each folio is one file.

Inside a project, the folios should have an order. For an easy understanding of the schema, it is important that the user takes care about the position and information that is included at each folio.

1.5.2 Type of folio

Single line diagram

The single line conductor is a simplified notation for representing a two and three phase power system. It can also be used to simplify the pressure and return line at fluid pressure systems.

For simple line diagrams, only power lines are represented. The command lines should not be represented at single line diagrams. For other side, the connectors are represented without any text information. The main idea of single line diagrams is to describe the system minimizing the information.
Fig. 72: Figure: Single line diagram
At the case of fluid power systems, the main and return line can be represented as two phase system without Neutral and Ground. At the single line diagrams the pilot lines should not be represented at the schema.

**Multiline diagram**

The multiline diagram is the representation of each terminal, line and phase from the two and three phase power systems. The multiline diagram is also used for the representation of all the electric and control systems. The multiline diagram is the detailed representation of the system.

![Multiline diagram](image)

Fig. 73: Figure: Multiline diagram

Unlike single line conductor, the multiline conductor can display text informing about cable number, type of cable, nominal current through the cable, cable length, etc.

At the case of fluid power systems, the main and return line are represented using different graphical lines. The pilot lines are also represented at this case. The pipes can indicate some information as pipe number, nominal flow, diameter, length, etc.

**1.5.3 Add new Folio**

QE ElectroTech allows creating folios from **Menu bar**, projects panel, folios tabs bar and using the corresponding keyboard shortcut.
Add new folio from Menu bar

1. Select Project > Add a folio menu item to add a new folio to the active project.

   ![QElectroTech Project menu](image)

   Fig. 74: Figure: QElectroTech Project menu

Add new folio from projects panel

1. Right click on the project where a new folio should be added.
2. Click the option Add a folio to add a new folio to the project.

   ![QElectroTech Project panel](image)

   Fig. 75: Figure: QElectroTech Project panel

Note: If the projects panel is not displayed, it can be displayed from Settings > Display > Projects
Add new folio from folios tabs bar

1. Click on the Add folio icon from the right side of the folios tabs bar to add a new folio to the active project.

Add new folio using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Press Ctrl + t to add a new folio to the active project.

See also:
For more information about QElectroTech keyboard shortcut, please refers to Menu bar section.

1.5.4 Delete Folio

QElectroTech allows delete folios from a project from Menu bar and projects panel.

Delete folio from Menu bar

1. Select Project > Delete this folio menu item to delete the active folio.

![Fig. 76: Figure: QElectroTech Project menu](image)

Delete folio from projects panel

1. Right click on the folio which should be deleted.
2. Click the option Delete this folio to delete selected folio.

Note: If the projects panel is not displayed, it can be displayed from Settings > Display > Projects

1.5. Folio
1.5.5 Folio properties

Display folio properties

At QElectroTech the folio properties can be common at all folios from the same project. QElectroTech also allows that each folio has its own properties. For example, two folios can be created by different authors or they can have different revision.

Note: To reduce the creation time, QElectroTech allows creating some pre-setting for all future folios that will be created at the project. For more information about how to pre-define folio properties, please refer to Project properties section.

The folio properties window can be displayed from Menu bar, workspace, toolbar, projects panel, folios tabs bar and using the corresponding keyboard shortcut.

Display folio properties from Menu bar

1. Select Edit > Folio properties menu item to display the folio properties from the active folio.

Display folio properties from workspace

1. Right click on the workspace area. Should be somewhere without any element, conductor, table, etc.
2. Click the option Folio properties to display the folio properties from the active folio.

Display folio properties from toolbar

1. Select the icon from the toolbar to display the folio properties from the active folio.

Note: If the toolbar is not displayed, it can be displayed from Settings > Display > Diagram.
Fig. 78: Figure: Folio properties PopUP window
Fig. 79: Figure: QElectroTech Edit menu

<table>
<thead>
<tr>
<th>File</th>
<th>Edit</th>
<th>Project</th>
<th>Display</th>
<th>Settings</th>
<th>Windows</th>
<th>Help</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>Modify the title block</td>
<td>Ctrl+Z</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Redo</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Ctrl+Y</td>
</tr>
<tr>
<td>Cut</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Ctrl+X</td>
</tr>
<tr>
<td>Copy</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Ctrl+C</td>
</tr>
<tr>
<td>Paste</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Ctrl+V</td>
</tr>
<tr>
<td>Select All</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Select none</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Invert selection</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Ctrl+I</td>
</tr>
<tr>
<td>Delete</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Del</td>
</tr>
<tr>
<td>Rotate</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Space</td>
</tr>
<tr>
<td>Choose texts orientation</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Ctrl+Space</td>
</tr>
<tr>
<td>Find in the panel</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Edit the selected object</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Ctrl+E</td>
</tr>
<tr>
<td>Group selected texts</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Reset conductors</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Ctrl+K</td>
</tr>
<tr>
<td>Folio properties</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Ctrl+L</td>
</tr>
<tr>
<td>Add a column</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Remove a column</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Add row</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Remove a row</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Bring to front</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Ctrl+Shift+Home</td>
</tr>
<tr>
<td>Raise</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Ctrl+Shift+Up</td>
</tr>
<tr>
<td>Lower</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Ctrl+Shift+Down</td>
</tr>
<tr>
<td>Send backward</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Ctrl+Shift+End</td>
</tr>
</tbody>
</table>
Display folio properties from projects panel

1. Right click on the folio where any property should be defined, it can be an inactive folio from an inactive project.
2. Click the option Folio properties to display the folio properties from the active folio.

Note: If the projects panel is not displayed, it can be displayed from Settings > Display > Projects

Display folio properties from folios tabs bar

1. Double click on the folio tab to display the folio properties.

Display folio properties using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Press Ctrl + 1 to display the folio properties from the active folio.

See also:
For more information about QElectroTech keyboard shortcut, please refer to Menu bar section.

Folio size

QElectroTech defines the working area from the workspace as a grid of columns and rows. All columns have the same width and all the rows have the same height. Below, a folio with 17 columns (0 to 16) and 8 rows (A to H) is shown.

At the dimensions of folio section from the folio properties PopUp window, the following size parameters can be defined:
Fig. 81: Figure: QElectroTech Project panel

Fig. 82: Figure: QElectroTech folio tabs bar

Fig. 83: Figure: QElectroTech folio example
1. Number of columns.
2. Width from columns.
3. Column headers display or hidden.
4. Number of rows.
5. Height from rows.
6. Row headers display or hidden.

Fig. 84: Figure: Folio dimensions properties

The version 0.7 from QElectroTech works with pixels and there is no pre-defined folio sizes. The table below defines the pixels dimensions according ISO 216.

<table>
<thead>
<tr>
<th>ISO 216</th>
<th>A-</th>
<th>pixels</th>
</tr>
</thead>
<tbody>
<tr>
<td>-0</td>
<td>841 x 1189</td>
<td>3178 x 4494</td>
</tr>
<tr>
<td>-1</td>
<td>594 x 841</td>
<td>2245 x 3178</td>
</tr>
<tr>
<td>-2</td>
<td>420 x 594</td>
<td>1587 x 2245</td>
</tr>
<tr>
<td>-3</td>
<td>297 x 420</td>
<td>1122 x 1587</td>
</tr>
<tr>
<td>-4</td>
<td>210 x 297</td>
<td>794 x 1122</td>
</tr>
<tr>
<td>-5</td>
<td>148 x 210</td>
<td>559 x 794</td>
</tr>
<tr>
<td>-6</td>
<td>105 x 148</td>
<td>397 x 559</td>
</tr>
<tr>
<td>-7</td>
<td>74 x 105</td>
<td>280 x 397</td>
</tr>
<tr>
<td>-8</td>
<td>52 x 74</td>
<td>196 x 280</td>
</tr>
<tr>
<td>-9</td>
<td>37 x 52</td>
<td>140 x 196</td>
</tr>
<tr>
<td>-10</td>
<td>26 x 37</td>
<td>98 x 140</td>
</tr>
</tbody>
</table>

See also:
For more information about how to display folio properties, please refer to Display folio properties section.

Folio Title block

The title block section from the folio properties is the section used to define the ‘title block’ template used at the folio. This section is also the section where the folio variables can be manage.

Note: To reduce the creation time, QElectroTech allows creating some pre-setting for all the future folios that will be created on the project. The folio variable values and the folio title block can be predefined at the project properties. For more information about how to pre-define folio properties, please refer to Project properties section.
The title block section is organized on three different tab, the title block selection area, the Main tab and the Costum tab.

**Title block selection area**

The title block selection area is used to define the folio title block. At this area the following actions can be made:

1. Select the folio title block from the project title block collection.
2. Select the position of the title block in the folio, bottom or right side.
3. Duplicate or Edit the ‘title block’ displaying the title block editor.

![Template: DIN_A4_copy](image)

Fig. 85: Figure: Folio title block selection area

**See also:**

For more information about QEelectroTech title block, please refers to ‘title block’ section.

**Main tab folio title block section**

The Main tab is used to manage the default folio variables.

The default folio variables are:

- **Title**: Title from the folio.
- **Author**: Author from the folio.
- **Date**: Date of creation of the folio.
- **File**:
- **Folio**: Folio information (Label).
- **Plant**: Folio variable named Plant.
- **Location**: Folio variable named Location.
- **Rev index**: Revision index from the folio.
- **Page Num**: Auto numbering pattern from the folio.

**See also:**

For more information about how to call default folio variables, please refers to Variables section.

**Costum tab folio title block section**

The Costum tab is used to define and manage the user folio variables.

To define a user folio variable:

1. Define variable name at the **Name** column from the variables table.
2. Define variable value at the **Value** column from the variables table.
Fig. 86: Figure: Folio title block main properties
Fig. 87: Figure: Folio title block custom properties
See also:

For more information about how to display folio properties, please refer to Display folio properties section.

**Folio type**

To work efficiently and save time, QElectroTech allows defining the type of conductor which will be used at the folio. The user can pre-define the properties from all conductors that later on will be created inside the folio. This pre-definition avoid defining all properties during conductor creation.

The **Type** tab from folio properties PopUP window allows defining the type of conductor that later on will be drawn at the folio, multiline or Single line, and pre-define the parameters from the conductor.

The figure bellow shows an example of multiline conductor definition where the conductor text is the value of the auto numbering variable, the auto numbering pattern is the defined from the project conductor list and the conductor voltage is defined as 400 V.

![Fig. 88: Figure: QElectroTech folio type properties tab](image)
See also:
For more information about conductor properties, please refer to Conductor properties section.
For more information about how to display folio properties, please refer to Display folio properties section.

Folio appearance

To work efficiently and save time, QEelectroTech allows defining the appearance of conductor which will be used at the folio. The user can pre-define the appearance from all conductors that later on will be created inside the folio. This pre-definition avoid defining the appearance conductor one by one after creation.

The Appearance tab from folio properties PopUP window allows defining the appearance of conductor that later on will be drawn in the folio. QEelectroTech allows choosing the color, the type of line and the width from the lines. Exists the posibility to choose the properties for main lines and for secondary lines.

Fig. 89: Figure: Folio appearance properties

See also:
For more information about conductor properties, please refer to Conductor properties section.
For more information about how to display folio properties, please refer to Display folio properties section.

1.5.6 Title Block

What is the title block?

The title block of a drawing is a table which usually is placed at the bottom from the drawing. The title block is the responsible to provide all necessary information to identify and to verify its validity.

Some information which can be found at a title block is:

- Drawing / Schema title
- Drawing / Schema number
- Drawing / Schema size (Horizontal A3 sheet is the more common at electrical schemas)
- Revision index
Fig. 90: Figure: QElectroTech Title block example

- Author
- Date
- License (Ex.: The ISO 16016 norm should be mentioned when distributing the schema to third party is not allowed)
- Logo

**Note:** Please, refers to the IEC 61082-1 norms for more detailed information about the recommended information that should be included at the title block.

As table, the elements from a title block are the following:
1. Cell
2. Column
3. Row

**Properties Title Block**

**Title block parent collection**

The parent collection property from a title block defines the title block collection to which the title block belongs. This property defines the rights from the user to edit the title block. A title block with QET title block collection as parent collection can only be read by the user. A title block with User title block collection or Project title block collection as parent collection can be read and written (edited) by the user.

The parent collection from a title block can be defined during the save process.

Fig. 91: Figure: QElectroTech title block save PopUP window
Title block extra information

QElectroTech provides the option to define a string field property named **Extra information**. This property field is provided to allow the user defining the author and/or license from title block. Any other information can also be defined at this property field.

![PopUp window](image)

**Fig. 92: Figure: QElectroTech title block extra information PopUP window**

The extra information from title block cannot be displayed at the main window from QElectroTech, this information can only be found from title block editor.

**See also:**
For more information about how to find the extra information property from a title block, please referst to Define title block extra information section.

Title Block collections

What is a collection?

At QElectroTech, a title block collection is a database where all title block files are storaged and classified.

QElectroTech has two different title block collections integrated, **QET collection** and **User collection**. The title block collections can be found at the projects panel. Bellow a figure from the QElectroTech projects panel is shown.

QElectroTech displays also a third collection when a project is opened, the **project collection**. This collection is not part from the software structure and it is treated automatically by QElectroTech during the folio title block definition.

Title block QET collection

The QET collection is the default collection from QElectroTech. This collection is protected and the user can only read it, the QET collection cannot be edited. The user cannot add or delete any title block in the database.
Fig. 93: Figure: QElectroTech projects panel

Fig. 94: Figure: QET collection tree at project panel
**Title block User collection**

The User collection is the QElectroTech collection where the user can create title block, the user is allowed to read and edit the collection. The actions enumerated bellow are allowed at the user collection.

1. Add new title block.
2. Edit title block from collection.
3. Delete title block from collection.

![User title blocks](#)

- "A3" template
- "A4" template

Fig. 95: Figure: Example user collection tree at project panel

**Title block project collection**

The project collection is the only collection which is not part from the software structure. A project collection is a title block collection that is part of the project file, each project has its own title block collection.

![Project tree](#)

Fig. 96: Figure: QElectroTech project tree

QElectroTech does not allow to work on this collection, the user cannot add or delete manually any title block. The user can use the collection to access to the title blocks of the project for editing them.

The title block are copied from QET or User collection automatically by QElectroTech when the user introduces a new title block at one folio of the project. If the title block has already been used previously, QElectroTech does not need to add the title block again to the project collection.
If one title block is deleted from the project, QElectroTech does not delete the title block automatically from the project collection. The title block is marked on red as some of the title blocks showed at the figure above. For this reason, is recommended to clean the project at the end. Cleaning the project delete automatically all the title block from the project collection that are not used inside the project at the cleaning time and reduce the size of the project file.

Title block elements

Cell

Definition

As in a table, a cells from the title block is the most basic storage unit available. At the title block editor from QElectroTech, three different type of cells can be found: Empty cell, text cell and logo cell.

Empty cell

An empty cell is used when the area occupied by the cell should be empty and without any edge displayed. This type of cell has no properties.

![Fig. 97: Figure: QElectroTech Title block empty cell properties](image)

Text cell

An text cell is used when the area occupied by the cell should be filled by an string information inside a rectangle. This type of cell has different parameters that can be defined.

![Fig. 98: Figure: QElectroTech Title block text cell properties](image)

- **Name**: Name from cell
- **Label**: When the cell should display a variable from the folio or project properties, the label is the text that appears before the variable.
- **Text**: It can be a simple string defined by the user or a variable from the folio or project (Ex: Author, Revision, Date, project name, folio page, etc.).
Font  Font from the label and text of the cell.

Alignment  Vertical and horizontal position of the label and text from the cell inside the cell.

Logo cell

A logo cell is used when the area occupied by the cell should be filled by a picture inside a rectangle. This type of cell has different parameters that can be defined.

![Cell properties](image)

**Note:** Many different tools allows you to create Scalable Vector Graphics, SVG files. Inside the Open Source world, **Inkscape** is one of the recommended tools.

Row

Definition

As in a table, a row of cells from the title block is a group of cells that are placed one beside the other.

![Row properties](image)

Properties

At QElectroTech, a row from the title block has only one property, the height of the cells that are part of the row.

![Row height property](image)

QElectroTech works with pixels, the height of the row can only be defined according pixel unit.
Column

Definition

As in a table, a column of cells from the title block is a group of cells that are placed one over the other.

Properties

At QElectroTech, a column from the title block has only one property, the width of the cells that are part of columns.

QElectroTech works with pixels, the width is defined according pixel unit.

Unlike rows, the width of a column can be defined according absolut value, pixel units; or according relative value, percent of the total width of the title block.

Create new title block

Creating new templates from cero is not allowed at QElectroTech, one template can only be created starting from an other template. If no template is choosed, the default template from QET collection is the base to create a new title block template.

Create title block from Menu bar

1. Select Project > Project properties > New folio menu item to display the default folio properties from the project folios.
2. Go to the title block informations section and select the base title block that should be used to create the new one.
3. Select the option Duplicate and edit this template.
4. Choose the name for the new title block template and press OK to create it.
Fig. 104: Figure: QElectroTech New folio properties PopUP window

Fig. 105: Figure: QElectroTech New folio save PopUP window
Create title block from folio properties

1. Display the folio properties from one of the folios of the project. For more information, please refer to Folio properties section.

2. Go to the Title block informations section and select the base title block that should be used to create the new one.

3. Select the option Duplicate and edit this template.

4. Edit the template and save it.

5. Choose the parent collection and the name from the new title block template, then press OK to create it.

Create title block from project panel

1. Right click on the Embedded title blocks section from the project where a new title block should be created.

2. Click the option New template to add a new title block to the project.
Fig. 107: Figure: QE electro Tech New folio save PopUP window

Fig. 108: Figure: QE electro Tech Project panel
### Note: If the project panel is not displayed, it can be displayed from **Settings > Display > Projects**

---

### Edit title block

QElectroTech allows only editing the templates from the User collection or the title block from one project. The user is not allowed to edit the templates from the QET collection.

**Warning:** QElectroTech allows the user opening one title block template from the QET collection with the editor. The user can make modifications on the template but all this changes will not be lost if the user choose the option **Save as** and create a new template.

The command **Save** is not saving the changes and it is also not informing that all changes will be lost after closing the editor.

---

### Edit title block from Menu bar

1. Select **Project > Project properties > New folio** menu item to display the default folio properties from the project folios.
2. Go to the **title block informations** section and select the base title block that should be used to create the new one.
3. Select the option **Edit this template** to display the title block editor.

---

### Edit title block from folio properties

1. Display the folio properties from one of the folios of the project. For more information, please refer to Folio properties section.
2. Go to the **title block informations** section and select the base title block that should be used to create the new one.
3. Select the option **Edit this template** to display the title block editor.

---

### Edit title block from project panel

1. Right click on one title block template which should be edited.
2. Click the option **Edit this template** to open the template with the title block editor.

---

**Note:** If the project panel is not displayed, it can be displayed from **Settings > Display > Projects**

---

### 1.5. Folio
Fig. 109: Figure: QE electroTech new folio properties PopUP window
Fig. 110: Figure: QElectroTech folio properties PopUP window

Fig. 111: Figure: QElectroTech Project panel
Delete title block

The title blocks templates can only be deleted from the project panel. QElectroTech does not allow to delete templates from any Menu item.

**Note:** If the project panel is not displayed, it can be displayed from **Settings > Display > Projects**

It is important to make a difference between the Embedded collection from one project and the QET or User collection of templates. The Embedded collection is at the project “database”, delete information from the project does not change anything at QElectroTech or at the computer file system. Deleting information at the QET or User collection delete information from QElectroTech “database” and at the computer file system, the information deleted at this “database” can never be recovered.

**Delete title block from project**

1. Right click on one title block template from the project Embedded collection which should be deleted.
2. Click the option **Delete this template** to delete the template form the project “database”.

![Projects panel](image)

Fig. 112: Figure: QElectroTech Project panel

**Delete title block from collection**

1. Right click on one title block template from one of the collections that should be deleted.
2. Click the option **Delete this template** to delete the template form QElectroTech and from the file system.
3. Press the button **YES** from the confirmation PopUP window to confirm the action.
Fig. 113: Figure: QElectroTech Project panel

Fig. 114: Figure: QElectroTech delete title block confirmation PopUP window
**Warning:** The template deleted from one collection cannot be recovered, it will be deleted from the QEelectroTech “dataabse” and from the computer file system. Be sure about the operation.

**Title block editor**

**Interface title block editor**

**Elements title block window**

The title block editor window is a PopUP window from QEectroTech. It has been designed to looks similar to the main window from QElectroTech independent from the operative system where QElectroTech is running. The title block editor window looks like the figure bellow.

![QElectroTech Title block editor window](image)

**Fig. 115: Figure: QElectroTech Title block editor window**

As is indicated on the figure, the main window from QElectroTech is formed for the following areas:

1. Menu bar
2. Toolbar
3. Panels
4. Drawing area

**Title block editor Menu bar**

The framework and widget toolkit Qt allows the design of drop-down menus. The drop-down menus are a characteristic graphical control element from the desktop applications. Each of the drop-down menus contains a number of options to initiate an action. The Menu bar is placed at top from the main windows. The figure bellow shows how the menu bar from QElectroTech looks.

As is showed at the figure, QElectroTech Title block editor bar contains the Menus File, Edit, Display, Settings and Help.
### QElectroTech Elementeditor Menu bar

**File**

<table>
<thead>
<tr>
<th>Options</th>
<th>Function</th>
<th>Keyboard shortcut</th>
<th>Toolbar icon</th>
</tr>
</thead>
<tbody>
<tr>
<td>New</td>
<td>Creates a new Title Block</td>
<td>Ctrl + n</td>
<td></td>
</tr>
<tr>
<td>Open</td>
<td>Opens an existing Title Block from a library</td>
<td>Ctrl + o</td>
<td></td>
</tr>
<tr>
<td>Open from a file</td>
<td>Opens an existing Title Block from the disk</td>
<td>Ctrl + Shift + o</td>
<td></td>
</tr>
<tr>
<td>Save</td>
<td>Saves the current Title Block changes (overwrites)</td>
<td>Ctrl + s</td>
<td></td>
</tr>
<tr>
<td>Save as</td>
<td>Saves the Title Block as a new Title Block from a library</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Save to a file</td>
<td>Saves the Title Block as a different file on disk</td>
<td>Ctrl + Shift + s</td>
<td></td>
</tr>
<tr>
<td>Quit</td>
<td>Quits QElectroTech Title Block editor</td>
<td>Ctrl + q/Alt + F4</td>
<td></td>
</tr>
</tbody>
</table>

**Edit**

<table>
<thead>
<tr>
<th>Options</th>
<th>Function</th>
<th>Keyboard shortcut</th>
<th>Toolbar icon</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>Undo the last action at Title Block editor</td>
<td>Ctrl + z</td>
<td></td>
</tr>
<tr>
<td>Redo</td>
<td>Recovers the last undo action at Title Block editor</td>
<td>Ctrl + y</td>
<td></td>
</tr>
<tr>
<td>Cut</td>
<td>Equivalent to copy + delete the cell content and properties</td>
<td>Ctrl + x</td>
<td></td>
</tr>
<tr>
<td>Copy</td>
<td>Copies the content and properties from the selected cell</td>
<td>Ctrl + c</td>
<td></td>
</tr>
<tr>
<td>Paste</td>
<td>Pastes the cell content and properties from last copy or cut</td>
<td>Ctrl + v</td>
<td></td>
</tr>
<tr>
<td>Add a row</td>
<td>Adds an additional row to the Title Block</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Add a column</td>
<td>Adds an additional column to the Title Block</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Merge cells</td>
<td>Merges the selected cells</td>
<td>Ctrl + j</td>
<td></td>
</tr>
<tr>
<td>Split cells</td>
<td>Splits the selected cells previously merged</td>
<td>Ctrl + k</td>
<td></td>
</tr>
<tr>
<td>Manage logos</td>
<td>Displays the logos manager PopUp window</td>
<td>Ctrl + t</td>
<td></td>
</tr>
<tr>
<td>Edit extra information</td>
<td>Displays the extra information PopUp window</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Menu</td>
<td>Options</td>
<td>Function</td>
<td>Keyboard shortcut</td>
</tr>
<tr>
<td>------</td>
<td>---------</td>
<td>----------</td>
<td>-------------------</td>
</tr>
<tr>
<td><strong>Display</strong></td>
<td>Zoom In</td>
<td>Magnify the Title Block for a closer view</td>
<td>Ctrl + +</td>
</tr>
<tr>
<td></td>
<td>Zoom Out</td>
<td>Reduce magnification of the Title Block; develops a distant view of the Title Block</td>
<td>Ctrl + -</td>
</tr>
<tr>
<td></td>
<td>Fit in view</td>
<td>Define zoom level to fit the Title Block at workspace</td>
<td>Ctrl + 9</td>
</tr>
<tr>
<td></td>
<td>Reset zoom</td>
<td>Reset zoom levels to default value (zoom level just less than that of fit in view)</td>
<td>Ctrl + 0</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Menu</th>
<th>Options</th>
<th>Function</th>
<th>Keyboard shortcut</th>
<th>Notes</th>
<th>Toolbar icon</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Settings</strong></td>
<td>Display</td>
<td>Display or hide toolbars and panels</td>
<td></td>
<td>Hides or shows elements panel, tool bar etc.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Full screen mode</td>
<td>Spreads the window to fill the screen</td>
<td>Ctrl + Shift + f</td>
<td>Entire screen gets occupied by the window</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Configure QElectroTech</td>
<td>Display QElectroTech configure PopUp window</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Menu</th>
<th>Options</th>
<th>Function</th>
<th>Keyboard shortcut</th>
<th>Notes</th>
<th>Toolbar icon</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Help</strong></td>
<td>What’s This?</td>
<td>Enquires main menu options</td>
<td>Shift + f1</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>About QElectroTech</td>
<td>Displays information about authors, contributors, translators and Licensing</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Online manual</td>
<td>Opens the explorer and redirects to the official QElectroTech documentation</td>
<td>f1</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Youtube channel</td>
<td>Opens the explorer and redirects to the official QElectroTech Youtube channel</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Download a new version (dev)</td>
<td>Opens the explorer and redirects to the official QElectroTech download link</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Support the project with a donation</td>
<td>Opens the explorer and redirects to the official QElectroTech donation paypal account</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>About Qt</td>
<td>Displays information about Qt, a C++ toolkit for cross platform applications</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Drawing area

The Drawing Area or Grafical editor, is the area where the title block columns, rows and cells are managed.

At the figure below, how looks the Drawing Area from the Title Block editor can be found.

![Drawing Area](image)

Fig. 117: Figure: QElectroTech title block grafical editor

Toolbars

In addition to the different menus, QElectroTech provides also Toolbars. The Toolbars are groups of buttons with icons which initiate an action. In general, these buttons have their counterpart at one of the menus from the Menu bar. The aim from the Toolbar is to make easier and more graphically the use of QElectroTech.

The different Toolbars can be hidden or placed in one or more rows below the Menu bar. The Toolbars can also be placed on column at the left or right side from the main window.

**Note:** To help the user, a tooltip is displayed when the arrow is placed on each button.

Toolbar Tools

![Toolbar Tools](image)

Fig. 118: Figure: QElectroTech title block toolbar Tools

The different button from the Toolbar Tools are mentioned and described below.

<table>
<thead>
<tr>
<th>Toolbar</th>
<th>Options</th>
<th>Function</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tools</td>
<td>New</td>
<td>Creates a new title block</td>
<td>Ctrl + n</td>
</tr>
<tr>
<td></td>
<td>Open</td>
<td>Opens an existing title block from the collection</td>
<td>Ctrl + o</td>
</tr>
<tr>
<td></td>
<td>Save</td>
<td>Saves the current changes from the opened title block</td>
<td>Ctrl + s</td>
</tr>
<tr>
<td></td>
<td>Save as</td>
<td>Saves the current title block as a different file on disk</td>
<td></td>
</tr>
</tbody>
</table>

**Note:** Select **Settings > display > Tools** menu item to display or hidden the toolbar Tools.

Toolbar Edit

The different button from the toolbar Diagram are mentioned and described below.
Fig. 119: Figure: QElectroTech title block toolbar Element

<table>
<thead>
<tr>
<th>Toolbar</th>
<th>Options</th>
<th>Function</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Diagram</td>
<td>Undo</td>
<td>Undo the last action from the element editor</td>
<td>Ctrl + z</td>
</tr>
<tr>
<td></td>
<td>Redo</td>
<td>Once an action has been undone, allows redoing the action</td>
<td>Ctrl + y</td>
</tr>
<tr>
<td></td>
<td>Merge cells</td>
<td>Merge the selected cells from the title block</td>
<td>Ctrl + j</td>
</tr>
<tr>
<td></td>
<td>Split cells</td>
<td>Split the selected cells from the title block</td>
<td>Ctrl + k</td>
</tr>
</tbody>
</table>

**Note:** Select **Settings > display > Edit** menu item to display or hidden the toolbar Edit.

**Toolbar Display**

Fig. 120: Figure: QElectroTech title block toolbar Display

The different button from the toolbar Display are mentioned and described below.

<table>
<thead>
<tr>
<th>Toolbar</th>
<th>Options</th>
<th>Function</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display</td>
<td>Zoom in</td>
<td>Zoom in at the drawing area</td>
<td>Ctrl + +</td>
</tr>
<tr>
<td></td>
<td>Zoom out</td>
<td>Zoom out at the drawing area</td>
<td>Ctrl + -</td>
</tr>
<tr>
<td></td>
<td>Fit in view</td>
<td>Adjust the drawing area to the element</td>
<td>Ctrl + 9</td>
</tr>
<tr>
<td></td>
<td>Reset zoom</td>
<td>Reset zoom levels to a default value (zoom level just less than that of fit in view)</td>
<td>Ctrl + 0</td>
</tr>
</tbody>
</table>

**Note:** Select **Settings > display > Display** menu item to display or hidden the toolbar Display.

**Panels**

**Cell properties panel**

The Cell properties panel displays the properties from the selected cell.

To display the Cell properties panel:

1. Select **Settings > display > Cell properties** menu item to display the Cell properties panel.
Undo panel

The Undo panel displays the history since the last time that the Title Block was saved. Once the Title Block is saved, undo panel is automatically cleaned.

Open title block editor

QEElectroTech allows displaying the title block editor PopUP window by creating a new title block or by editing an existing title block template.

Open title block editor by creating a new title block

1. Refers to the section Link for opening the title block editor by creating a new title block from the project panel.

Open title block editor by editing an title block

1. Refers to the section Link for opening the title block editor by editing an title block from collection or anle.
2. Refers to section Link for opening the title block editor by editing an title block from the workspace.

Save title block

The current title block can be saved from the Menu bar, toolbar and using the corresponding keyboard shortcut.

One title block is conformed by only one file with the format .titleblock. The .titleblock extension is the native extension from QEElectroTech title blocks.
Save title block from Menu bar

1. Select **File > Save** menu item to save the title block changes.

![File menu](image)

Fig. 123: Figure: QElectroTech title block editor File menu

At the case that the opened title block has to overwrite an existing title block or it has to be saved as a new title block:

1. Select **File > Save as** menu item to display the **Save as title block** PopUP window.

![Save as title block window](image)

Fig. 124: Figure: QElectroTech Save as title block PopUP window

2. Select the title block which should be overwrited or the parent collection and the name for the new title block.
3. Press the **OK** button to save the title block and close the PopUP window.

The title block can also be directly saved as a new file in the Hard Disk directory desired:

1. Select **File > Save to a file** menu item to display the File system PopUp window.
2. Select the directory and the name from the title block file.
3. Press the **OK** button to save the title block and close the PopUP window.

Save title block from toolbar

1. Select the icon ![Save icon](image) from the toolbar to save the title block changes.
At the case that the opened title block has to overwrite an existing title block or it has to be saved as a new title block:

1. Select the icon \[\text{ }\] from the toolbar to display the Save as title block PopUP window.

![Save as title block PopUP window](image)

Fig. 125: Figure: QElectroTech Save as title block PopUP window

2. Select the title block which should be overwrited or the parent collection and the name for the new title block.

3. Press the OK button to save the title block and close the PopUP window.

**Note:** If the toolbar is not displayed, it can be displayed from Settings > Display > Tools

---

**Save title block using keyboard shortcut**

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Press Ctrl + s to save the title block changes.

The title block can also be directly saved as a new file in the Hard Disk directory desired:

1. Press Ctrl + Shift + s to display the File system PopUP window.

2. Select the directory and the name from the title block file.

3. Press the OK button to save the title block and close the PopUP window.

**See also:**

For more information about QElectroTech keyboard shortcut, please refer to Menu bar section.

---

**Quit title block editor**

The user can close QElectroTech Title Block editor at any time. The user does not need to save the changes on the Title Block before closing it.

If the current work wants to be saved before closing the Title Block editor, please refer to Save Title Block section. Even so, QElectroTech display an automatic message to save the current job if any modification has been created.

**Exit QElectroTech title block editor from Menu bar**

1. Select File > Quit menu item to quit QElectroTech Title Block editor.
Exit QElectroTech title block editor using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Press **Ctrl + q** to quit QElectroTech Title Block editor.

See also:
For more information about QElectroTech keyboard shortcut, please refers to Menu bar section.

Create or edit title block

Add row to title block

QElectroTech Title Block editor allows adding row from the Menu bar and from the Drawing area.

Add row from Menu bar

1. Select **Edit > Add a row** menu item to add a new row at the bottom from the Title Block.

Note: Adding a new row at the middle from the Title Block is only possible from the Drawing area.

Add row from drawing area

1. Right click on the head from the row below or above the position where the new row should be placed.
2. Click the option **Add a row (before)** or **Add a row (after)** to add a new row above or below the selected row.

![Edit menu](image)

**Fig. 128:** Figure: QEelectroTech title block editor, edit menu

Row height definition

The height from a row can only be defined from the row head, the left cell showed at which is given the Drawing area height value from the corresponding row. The head from the row is not displayed at the folio, it is only displayed at the Title Block editor.

1. Double click on row head to display the row height PopUp window.

2. Define the height value in pixels.
3. Press the button **OK**.
Delete row from title block

QElectroTech Title Block editor allows only deleting rows of the Title Block from the Drawing area.

1. Right click on the head from the row which should be deleted.
2. Click the option Delete this row to delete the selected row.

Add column to title block

QElectroTech Title Block editor allows adding columns from the Menu bar and from the Drawing area.

Add column from Menu bar

1. Select Edit > Add a column menu item to add a new column at the right side from the Title Block.

Note: Adding a new column at the middle from the Title Block is only possible from the Drawing area.
Add column from drawing area

1. Right click on the head from the column next to the position where the new column should be placed.
2. Click the option **Add a column (before)** or **Add a column (after)** to add a new column before or after the selected column.

Colum width definition

The width from a column can only be defined from the column head, the top cell from the Drawing area which is given the width value from the corresponding column. The head from the columns is not displayed at the folio, it is only displayed at the Title Block editor.

1. Double click on column head to display the column width PopUp window.
   Figure: QElectroTech Title block column width PopUP window
2. Select the click button corresponding to the desired units to define the column width (Absolute to pixels, relative to total, relative to remaining).
3. Define the width value.
4. Press the button **OK**.

**Note:** The global width from the **Title Block** has to be defined at QELECTROTech, for this reason, defining one column width as remaining of 100% is recommended.

![Fig. 135: Figure: QELECTROTech Title block](image1)

At the case that a remaining width is not desired, be sure that the global width from the **Title Block** matches with the sum of all column widths. At the case that the values are not matching, QELECTROTech will display the **Title Block** as bellow: part of the title block header will be displayed in red and the width difference will be displayed.

![Fig. 136: Figure: QELECTROTech Title block global width error](image2)

**Warning:** At the case of using **Relative to remaining**ing, be sure that the value from the width is 100%. Otherwise, spare area will appear at the **Title Block**.

**Delete column from title block**

QELECTROTech **Title Block editor** allows only deleting columns from the **Drawing area**.

1. Right click on the head from the **column** which should be deleted
2. Click the option **Delete this column** to delete the selected column.

![Fig. 138: Figure: QElectroTech title block editor, drawing area](image)

**Introduce a logo on the title block**

1. Select the cell where the logo should be introduced.
2. Go to properties and choose **Logo** at the **Cell type** Combo Box.

![Fig. 139: Figure: QElectroTech Title block cell properties](image)

3. Define the name of the cell, if it is desired.
4. Press the **Manage logo** button to display the logo manager PopUP window.
5. Press the button **Add a logo** to display the file explorer PopUP window.
6. Choose the SVG or Bitmap file with the desired logo and close the logo manager.
7. Choose the logo added previously at the **Logo** Combo Box.

**Define cell content**

QElectroTech **Title Block editor** allows defining two different type of content at the text cell type:

- **Plain text**
- **Variable**

QElectroTech works managing different database, the content of the **cells** are storage in the project database. QElectroTech provides the feature of defining the cell content in different languages, the cell content is defined at a cell value table. The content from the different **cells** of the **Title Block** are automatically displayed in the language defined.
Fig. 140: Figure: QElecroTech Title block logo manager PopUP window
Note: The working language from QElectroTech is defined at Setting > Configure QElectroTech.

QElectroTech works according ISO 639-1 norm. The text language is defined using 2 letter code which should be used at the language column from the cell value table.

![Language Text](image)

Fig. 141: Figure: QElectroTech title block editor, cell label PopUP window

Add text to cell

1. Select cell where the text should be introduced.
2. Press the button Edit from text field and the cell value PopUP window will be displayed.

3. Press the button Add a line to add a new row in the cell value table.
4. Define the 2 letter code that identifie the language from the text at the Language column.
5. Define the text at the Text column.
6. Press the button OK
Add variable to cell

A title block variable is the value of a project or folio property. At QElectroTech, a variable is called using the percent symbol before the variable name ($\{variable-name\}$).

**Note:** QElectroTech has some default variables that the user does not need to create (ex.: $\{author\}$, $\{date\}$, $\{title\}$, $\{folio\}$, $\{projecttitle\}$, etc.).

QElectroTech allows also the user the possibility to define extra variables

- Go to **Project > Project properties > General** to define costumized project variables.
- Go to **Edit > Folio properties > Title block informations > Costum** to define costumized folio variables.

When the content cell would be a variable, QElectroTech allos that the cell has a **Label** for the variable.

To define the label:

1. Select **cell** where the variable should be introduced.
2. Click the button **Display a label** to introduce a label at the cell. Click of the button and go to variable definition if the Label should not be displayed.
3. Press the button **Edit** from label field and the label value PopUP window will be displayed.
4. Press the button **Add a line** to add a new row in the Label value table.
5. Define the 2 letter code that identifies the language from the text at the **Language** column.
6. Define the text at the **Text** column.
7. Press the button **OK**

To define the variable:
Fig. 143: Figure: QElectroTech Title block text cell properties

Fig. 144: Figure: QElectroTech title block editor, cell value PopUP window
8. Press the button **Edit** from text field and the cell value PopUP window will be displayed.

9. Press the button **Add a line** to add a new row in the cell value table.

10. Define the 2 letter code that identify the language from the text at the **Language** column. Defining only one language is enough for default variables.

11. Define the variable at the **Text** column. A variable is defined as `{variable-name}`. The default variables can be copied to clipboard at the right bottom Combo Box and pasted (Ctrl + c) at the **Text** column.

![Fig. 145: Figure: QEelectroTech title block editor, cell value PopUP window](image)

12. Press the button **OK**

**See also:**
For more information about default variables, please refer to Default QEelectroTech variables section.

**Merge cells**

QEelectroTech **Title Block editor** allows merge cells from Menu bar and from Toolbar.

QEelectroTech has no restrictions merging cells, QEelectroTech allows merging cells from the same column and/or from the same row.

**Merge cells from Menu bar**

1. Select the cells which should be merged.

2. Select **Edit > Merge cells** menu item to merge the selected cells.
Note: To select more than one cell, press Ctrl from keyboard.

Merge cells from Toolbar

1. Select the cells which should be merged.
2. Select the icon from the Toolbar to merge the selected cells.

Note: If the Toolbar is not displayed, it can be displayed from Settings > Display > Edit

Merge cells using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.
1. Select the cells which should be merged.
2. Press Ctrl + j to merge the selected cells.

See also:
For more information about QElectroTech keyboard shortcut, please refers to Menu bar section.

Split cells

QElectroTech Title Block editor allows split cells previously merged from Menu bar and from Toolbar.
Split cells from Menu bar

1. Select the merged cells which should be split.
2. Select Edit > Split cells menu item to split the selected cells.

Split cells from Toolbar

1. Select the merged cells which should be split.
2. Select the icon from the toolbar to split the selected cells.

Note: If the Toolbar is not displayed, it can be displayed from Settings > Display > Edit

Split cells using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Select the merged cells which should be split.
2. Press Ctrl + k to split the selected cells.

See also:
For more information about QElectroTech keyboard shortcut, please refers to Menu bar section.
Fig. 148: Figure: QElectroTech title block editor, edit menu

Fig. 149: Figure: QElectroTech title block editor, edit menu
Define title block extra information

Define extra information from Menu bar

1. Select **Edit > Edit extra information** menu item to display the extra information PopUp window.

![Edit Menu](image)

Fig. 150: Figure: QElectroTech title block editor Edit Menu

2. Introduce the desired information to the text field.
3. Press the button **OK** to accept and close the extra information PopUp window.

Define extra information using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Press **Ctrl + y** to display the extra information PopUp window.
2. Introduce the desired information to the text field.
3. Press the button **OK** to accept and close the extra information PopUp window.

See also:
For more information about QElectroTech keyboard shortcut, please refers to Menu bar section.

1.6 Element

1.6.1 What is an element?

One element is an object which function is to reduce the engineering work. Working with elements reduce the time and work necessary for the creation of schemas, Bill Of Materials (BOM) and many other types of reports such terminal
lists, I/O lists, etc.

As can be understood from the previous paragraph, a QElectroTech element is something more than a graphic symbol. The information provided by an element is the following:

1. Graphical representation information, symbol displayed at the schema.
2. Element data such element position in the project, article number, manufacturer, supplier, link to any other element from the project, etc.

![QElectroTech thermal circuit breaker element](image)

**Fig. 151: Figure: QElectroTech thermal circuit breaker element**

At QElectroTech, all element can be classified at different element families. The graphical representation information characteristics are the same for all families. The element database fields possibilities and the possible interloking options are the characteristics which make differences between element families.

The element families from QElectroTech are the following:

- Simple
- Master
- Slave
- Reference folio following
- Previous reference folio
- Terminal block

1.6.2 Type of elements

**Simple element**

The simple element is used to represent devices such actuators (electric motors, cylinders, pneumatic or hydraulic valves, etc.), control devices (PLC, microcontrollers, etc.), circuit breakers, etc.

For simple element exist two type of variables, the general variables that are common for all type of elements and managed internally by QElectroTech, and the specific variables for this type of element.

QElectroTech allows defining variable values from simple element at the **Selection properties** panel. QElectroTech does not allow defining new variables. QElectroTech allows only displaying variables at dynamic texts and define value of the specific variables.
General variables

- % {F}: Label from the folio where the element can be found
- % {f}: Number from the folio where the element can be found
- % {M}: Plant variable from the folio where the element can be found
- % {LM}: Location variable of the folio where the element can be found
- % {l}: Folio line number from the workspace where the element can be found
- % {c}: Folio column number from the workspace where the element can be found
- % {id}: Folio position in the project (Schema number)

Specific variables

- **Label formula**: Definition of the formula which defines the **Label** value. If an auto numbering pattern is selected during terminal creation, QE ElectroTech defines `%autnum` as default formula.
- **Label**: Internal variable which is used to define the element code.
- **Annotation**: Internal variable, it cannot be a formula (group of other variables).
- **Textual description**: Internal variable, it cannot be a formula (group of other variables).
- **Article number**: Internal variable, it cannot be a formula (group of other variables).
- **Manufacturer**: Internal variable, it cannot be a formula (group of other variables).
- **Order number**: Internal variable, it cannot be a formula (group of other variables).
- **Supplier**: Internal variable, it cannot be a formula (group of other variables).
- **Auxiliary block 1**: Internal variable, it cannot be a formula (group of other variables).
- **Auxiliary block 2**: Internal variable, it cannot be a formula (group of other variables).
- **Internal number**: Internal variable, it cannot be a formula (group of other variables).
- **Location**: Internal variable, it cannot be a formula (group of other variables).

---

**Note**: If the Selection properties panel is not displayed, it can be displayed from **Settings > Display > Selection properties**.
• **Function:** Internal variable, it cannot be a formula (group of other variables).
• **Voltage/Protocol:** Internal variable, it cannot be a formula (group of other variables).

**Master element**

The master elements represent the devices from the command circuit such as the coil from a relay or contactor.

![Diagram of master element](image)

**Fig. 153: Figure: QElectroTech master element**

For master elements, there are two types of variables: general variables that are common for all types of elements and managed internally by QElectroTech, and specific variables for each type of element.

QElectroTech allows defining variable values from master elements at the **Selection properties** panel. QElectroTech does not allow defining new variables. QElectroTech allows only displaying variables at dynamic texts and defining the value of the specific variables.

**Note:** If the Selection properties panel is not displayed, it can be displayed from **Settings > Display > Selection properties**.

**General variables**

- % {F}: Label from the folio where the element can be found
- % {f}: Number from the folio where the element can be found
- % {M}: Plant variable from the folio where the element can be found
- % {LM}: Location variable of the folio where the element can be found
- % {l}: Folio line number from the workspace where the element can be found
- % {c}: Folio column number from the workspace where the element can be found
- % {id}: Folio position in the project (Schema number)

**Specific variables**

- **Label formula:** Definition of the formula which defines the **Label** value. If an auto numbering pattern is selected during terminal creation, QElectroTech defines %autnum as default formula.
- **Label:** Internal variable which is used to define the element code.
- **Annotation:** Internal variable, it cannot be a formula (group of other variables).
• **Textual description**: Internal variable, it cannot be a formula (group of other variables).

• **Article number**: Internal variable which, it cannot be a formula (group of other variables).

• **Manufacturer**: Internal variable, it cannot be a formula (group of other variables).

• **Order number**: Internal variable, it cannot be a formula (group of other variables).

• **Supplier**: Internal variable, it cannot be a formula (group of other variables).

• **Auxiliary block 1**: Internal variable, it cannot be a formula (group of other variables).

• **Auxiliary block 2**: Internal variable, it cannot be a formula (group of other variables).

• **Internal number**: Internal variable, it cannot be a formula (group of other variables).

• **Location**: Internal variable, it cannot be a formula (group of other variables).

• **Function**: Internal variable, it cannot be a formula (group of other variables).

• **Voltage/Protocol**: Internal variable, it cannot be a formula (group of other variables).

**Slave element**

The slave elements represent the power circuit devices such the main contactors from power contactors. The slave elements also represent the auxiliary contactors. Even if an auxiliary contactor is part of the command circuit, its activation is forced by another element.

For slave element exist two type of variables, the general variables that are common for all type of elements and managed internally by QEElectroTech, and the specific variables for this type of element.

QEElectroTech does not allow defining variable values for slave element. QEElectroTech does also not allows defining new variables. QEElectroTech allows only displaying the specific variables at dynamic texts.

**General variables**

• % {F}: Label from the folio where the element can be found

• % {f}: Number from the folio where the element can be found

• % {M}: Plant variable from the folio where the element can be found

• % {LM}: Location variable of the folio where the element can be found

• % {l}: Folio line number from the workspace where the element can be found

• % {c}: Folio column number from the workspace where the element can be found
• % {id}: Folio position in the project (Schema number)

Specific variables

• Position master element: Internal pre-defined variable which is automatically displayed under dinamic texts of the element. The default formula from the variable is (%id-%l%c), variables took from master element.

See also:
The default formula from the Position master element and the position where it should be displayed can be defined at cross references tab from New project preferences.

Note: QElectroTech allows also displaying the specific variables from the Master element at the dynamic text fields.

Reference folio following

Element which link the end of a conductor with the begining of the conductor represented at previous, following or the same folio.

<table>
<thead>
<tr>
<th>16</th>
<th>17</th>
</tr>
</thead>
<tbody>
<tr>
<td>▶</td>
<td>▶</td>
</tr>
<tr>
<td>L1</td>
<td>A</td>
</tr>
<tr>
<td>▶</td>
<td>▶</td>
</tr>
<tr>
<td>L2</td>
<td>L1</td>
</tr>
<tr>
<td>▶</td>
<td>▶</td>
</tr>
<tr>
<td>L3</td>
<td>L3</td>
</tr>
</tbody>
</table>

Fig. 155: Figure: QElectroTech reference folio following

For reference folio following element exist two type of variables, the general variables that are common for all type of elements and the specific variables for this type of element.

QElectroTech does not allow defining variable values for this type of element. QElectroTech does also not allows defining new variables. QElectroTech allows only displaying the specific variables at dynamic texts.

General variables

• % {F}: Label from the folio where the element can be found.
• % {f}: Number from the folio where the element can be found.
• % {M}: Plant variable from the folio where the element can be found.
• \%{LM}: Location variable of the folio where the element can be found.
• \%{l}: Folio line number from the workspace where the element can be found.
• \%{c}: Folio column number from the workspace where the element can be found.
• \%{id}: Folio position in the project (Schema number).

Specific variables
• **Function**: Function property from the conductor connected to the element terminal.
• **Label**: Internal variable which defines the position of the linked previous reference folio element.
• **Voltage/Protocol**: Voltage/Protocol property from the conductor connected to the element terminal.

**Note:** The **Label** property can be defined as a formula by the user at **New folio section from project properties**. By default the formula is \%id-%l%c, variables took from previous reference folio linked element.

For more information about how to define the **Label** formula, please refers to folio referencing project properties.

**Previous reference folio**

Element which link the begining of a conductor with the end of the conductor represented at previous, following or same folio.

For previous referencing folio element exist two type of variables, the general variables that are common for all type of elements and the specific variables for this type of element.

QElectroTech does not allow defining variable values for this type of element. QElectroTech does also not allows defining new variables. QElectroTech allows only displaying the specific variables at dynamic texts.

**General variables**
• % {F}: Label from the folio where the element can be found.
• % {f}: Number from the folio where the element can be found.
• % {M}: Plant variable from the folio where the element can be found.
• % {LM}: Location variable of the folio where the element can be found.
• % {l}: Folio line number from the workspace where the element can be found.
• % {c}: Folio column number from the workspace where the element can be found.
• % {id}: Folio position in the project (Schema number).

Specific variables
• **Function**: Function property from the conductor connected to the element terminal.
• **Label**: Internal variable which defines the position of the linked reference folio following element.
• **Voltage/Protocol**: Voltage/Protocol property from the conductor connected to the element terminal.

**Note**: The **Label** property can be defined as a formula by the user at New folio section from project properties. By default the formula is %id-%l%c, variables took from reference folio following linked element.

For more information about how to define the **Label** formula, please refers to folio referencing project properties.

**Terminal block**

Element which represents a terminal block, connection between two cables from the same potential.

![Terminal block diagram](image)

Fig. 157: Figure: QElectroTech Terminal block

For terminal block element exist two type of variables, the general variables that are common for all type of elements and managed internally by QElectroTech, and the specific variables for this type of element.

QElectroTech allows defining variable values from this type of element at the **Selection properties** panel. QElectroTech does not allow defining new variables. QElectroTech allows only displaying variables at dynamic texts and define value of the specific variables.

**Note**: If the Selection properties panel is not displayed, it can be displayed from **Settings > Display > Selection properties**.

General variables
• % {F}: Label from the folio where the element can be found
• % {f}: Number from the folio where the element can be found
• % {M}: Plant variable from the folio where the element can be found
• % {LM}: Location variable of the folio where the element can be found
• % {l}: Folio line number from the workspace where the element can be found
• % {c}: Folio column number from the workspace where the element can be found
• % {id}: Folio position in the project (Schema number)

Specific variables

• Label formula: Definition of the formula which defines the Label value. If a auto numbering pattern is selected during terminal creation, QElectroTech defiens %autnum as default formula.
• Label: Internal variable which is used to defines the element code.
• Annotation: Internal variable, it cannot be a formula (group of other variables).
• Textual description: Internal variable, it cannot be a formula (group of other variables).
• Article number: Internal variable, it cannot be a formula (group of other variables).
• Manufacturer: Internal variable, it cannot be a formula (group of other variables).
• Order number: Internal variable, it cannot be a formula (group of other variables).
• Supplier: Internal variable, it cannot be a formula (group of other variables).
• Auxiliary block 1: Internal variable, it cannot be a formula (group of other variables).
• Auxiliary block 2: Internal variable, it cannot be a formula (group of other variables).
• Internal number: Internal variable, it cannot be a formula (group of other variables).
• Location: Internal variable, it cannot be a formula (group of other variables).
• Function: Internal variable, it cannot be a formula (group of other variables).
• Voltage/Protocol: Internal variable, it cannot be a formula (group of other variables).

1.6.3 Element properties

Display element properties

The element properties can be displayed at the Selection properties panel or at a popUP window. At the case of working without Selection properties panel, the properties can be displayed from Menu bar, workspace or using keyboard shortcut.

Note: At the case of using the Selection properties panel, selecting the element is enough to display automatically the element properties at the panel. If the Selection properties panel is not displayed, it can be displayed from Settings > Display > Projects.

Display element properties from Menu bar

1. Select the element which properties should be displayed.
2. Select Edit > Edit this element menu item to display the element properties PopUP window.
### 1.6. Element

Fig. 158: Figure: QElectroTech Edit menu

<table>
<thead>
<tr>
<th>Tool</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>Ctrl+Z</td>
</tr>
<tr>
<td>Redo delete 1 element, 8 conductors</td>
<td>Ctrl+Y</td>
</tr>
<tr>
<td>Cut</td>
<td>Ctrl+X</td>
</tr>
<tr>
<td>Copy</td>
<td>Ctrl+C</td>
</tr>
<tr>
<td>Paste</td>
<td>Ctrl+V</td>
</tr>
<tr>
<td>Select All</td>
<td>Ctrl+A</td>
</tr>
<tr>
<td>Select none</td>
<td></td>
</tr>
<tr>
<td>Invert selection</td>
<td>Ctrl+I</td>
</tr>
<tr>
<td>Delete</td>
<td>Del</td>
</tr>
<tr>
<td>Rotate</td>
<td>Space</td>
</tr>
<tr>
<td>Choose texts orientation</td>
<td>Ctrl+Space</td>
</tr>
<tr>
<td>Find in the panel</td>
<td></td>
</tr>
<tr>
<td>Edit the element</td>
<td>Ctrl+E</td>
</tr>
<tr>
<td>Group selected texts</td>
<td></td>
</tr>
<tr>
<td>Reset conductors</td>
<td>Ctrl+K</td>
</tr>
<tr>
<td>Folio properties</td>
<td>Ctrl+L</td>
</tr>
<tr>
<td>Add a column</td>
<td></td>
</tr>
<tr>
<td>Remove a column</td>
<td></td>
</tr>
<tr>
<td>Add row</td>
<td></td>
</tr>
<tr>
<td>Remove a row</td>
<td></td>
</tr>
<tr>
<td>Bring to front</td>
<td>Ctrl+Shift+Home</td>
</tr>
<tr>
<td>Raise</td>
<td>Ctrl+Shift+Up</td>
</tr>
<tr>
<td>Lower</td>
<td>Ctrl+Shift+Down</td>
</tr>
<tr>
<td>Send backward</td>
<td>Ctrl+Shift+End</td>
</tr>
</tbody>
</table>
Display element properties from workspace

1. Right click on the element which properties should be displayed.
2. Select **Edit this element** option to display the element properties PopUP window.

![Element options menu](image)

Fig. 159: Figure: QEelectroTech element options

**Display element properties using keyboard shortcut**

QEelectroTech allows using keyboard shortcut to increase the working efficiency.

1. Select the element which properties should be displayed.
2. Press **Ctrl + e** to display the element properties PopUP window.

**See also:**

For more information about QEelectroTech keyboard shortcut, please refer to Menu bar section.

**General properties element**

**Texts from element**

**Element information**

**Element author and license**

QEelectroTech provides the option to define the author and the desired license from the element.

The author and the license from an element cannot be displayed at the main window from QEelectroTech, this information can only be found from element editor.

**See also:**

For more information about how to find the license and author from an element, please refer to Define author element information section.
Fig. 160: Figure: QElectroTech general element properties
<table>
<thead>
<tr>
<th>Property</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Label + comment</td>
<td>A2</td>
</tr>
<tr>
<td>A1</td>
<td></td>
</tr>
<tr>
<td>desc</td>
<td></td>
</tr>
</tbody>
</table>

Fig. 161: Figure: QElectroTech text element properties
Fig. 162: Figure: QElectroTech information element properties
QElectroTech allows an automatic codification of elements. This feature is very useful for the creation of reports, Bill Of Materials (BOM), and for the identification of devices at the physical installation and schemas.

QElectroTech allows the definition of multiple auto-numbering patterns. It also provides many flexibility on the creation of auto-numbering patterns using text, variables, and sequential numbers.

**Example**

An usual numbering pattern of elements is the following:

X  

<table>
<thead>
<tr>
<th><strong>X</strong></th>
<th><strong>AAAA</strong></th>
</tr>
</thead>
</table>

- **X**: Code defined by IEC 81346 norm.
  - **A**: Two or more purposes or tasks.
  - **B**: Converting an input variable into a signal for further processing.
  - **C**: Storing of energy, information or material.
  - **E**: Providing radiant or thermal energy.
  - **F**: Direct protection from dangerous or unwanted conditions.
  - **G**: Initiating a flow of energy or material.
  - **H**: Producing a new kind of material or product.
  - **K**: Processing signals or information.
  - **M**: Providing mechanical energy for driving purposes.
  - **P**: Presenting information.
  - **Q**: Controlled switching or varying a flow of energy, of signals or of material.
Fig. 164: Figure: QElectroTech element auto numbering
- **R**: Restricting or stabilizing motion or a flow of energy or material.
- **S**: Converting a manual operation into a signal for further processing.
- **T**: Conversion of energy maintaining the kind of energy.
- **U**: Keeping objects in a defined position.
- **V**: Processing (treating) of material or products.
- **W**: Guiding or transporting from one place to another.
- **X**: Connecting objects

AAAA Alphanumeric code which identify the element.

See also:

For more information about how to define auto numbering patterns, please refers to: project auto numbering properties section.

For more information about how to manage the codification of conductors, please refers to: Add element section.

### 1.6.4 Element collection

**What is a collection?**

At QElectroTech, an element collection is a database where all element files are stored and classified. The element collection gives the information about element name, element category (folder); element sub-categories (sub-folders) and element, category or sub-category path in the file system.

QElectroTech has two different element collections integrated, QET collection and User collection. Below a figure from the QElectroTech collections panel is shown.

QElectroTech displays also a third collection when a project is opened, the project collection. This collection is not part from the software structure and it is treated automatically by QElectroTech during the draw process from the workspace.

**QET collection**

The QET collection is the default collection from QElectroTech. This collection is protected and the user can only read it, the QET collection cannot be edited. The user cannot add any element, any category or sub-category and cannot re-organize the elements in the database.

The QET collection has the following categories:

- **Electric**: Collection of electrical components (motors, converters, switches, electrical protections, etc.)
- **Logic**: Logic signal symbols (AND, OR, NOT, NOR, etc.), Grafcet symbols, Ladder symbols and flow char symbols.
- **Hydraulic**: Collection of hydraulic components (Pumps, cylinders, pressure limit valves, pressure relief valves, directional valves, etc.)
- **Pneumatic**: Collection of hydraulic components (Compressor, cylinders, air filters, directional valves, etc.)
- **Energy**: Collection of elements used at the energy field (pumps, turbines, solar panels, heat exchangers, etc.)
Fig. 165: Figure: Collection panel

Fig. 166: Figure: QET collection tree at collection panel
User collection

The User collection is the QElectroTech collection where the user can create and organize elements, the user is allowed to read and edit the collection. The actions enumerated below are allowed at the user collection.

1. Add new elements.
2. Edit elements from the collection.
3. Delete elements from the collection.
4. Create new categories / folders.
5. Create new sub-categories / sub-folders.
6. Delete categories or sub-categories.
7. Re-organize the collection.

![User Collection Diagram]

Fig. 167: Figure: Example user collection tree at collection panel

Project collection

The project collection is the only collection which is not part from the software structure. A project collection is an element collection that is part of the project file, each project has its own element collection.

QElectroTech does not allow to work on this collection, the user cannot add or delete manually any element, category or sub-category. The user can only read the category or sub-category properties and use the collection to access to the elements of the project for editing them.

The elements are copied from QET or user collection automatically by QElectroTech when the user introduces a new element at one folio of the project. If the element has already been used previously, QElectroTech does not need to add the element again to the project collection.

If one element is deleted from the project, QElectroTech does not delete the element automatically from the project collection. The element is marked on red as some of the elements showed at the figure above. For this reason, it is recommended to clean the project at the end. Cleaning the project delete automatically all the elements from the project collection that are not used inside the project at the cleaning time and reduce the size of the project file.

Create category

Working with collections can only be done from the collections panel. Before starting to work with collections, the collections panel has to be displayed.

Note: Select Settings > Display > Collections menu item to display the Collections panel.
Fig. 168: Figure: QElectroTech project collection
QElectroTech allows creating categories at some collection. The user has only read rights at QET element collection, the user can create categories at all collections except QET collection.

1. Right click on the user collection or at a category / sub-category from the collection.

![Options at folder](image)

Fig. 169: Figure: Options at folder

2. Click the option **New folder** to open the new category PopUP window.

![New category PopUP window](image)

Fig. 170: Figure: New category PopUP window

3. Define the internal name for the file system.

4. Define the category name that will be displayed at the collection tree, it can bee defined in many languages.
5. Press **OK** to add the new category / sub-category.

**Note:** QElectroTech works according ISO 639-1 norm. The folder name language is defined using 2 letter code which should be used at the language column from the folder internal name table.

---

### Edit category

Working with collections can only be done from the collections panel. Before starting to work with collections, the collections panel has to be displayed.

**Note:** Select **Settings > Display > Collections** menu item to display the Collections panel.

1. Right click on the user collection or at a category from the collection which should be edited.

![Image: Options at folder]

Fig. 171: Figure: Options at folder

2. Click the option **Edit folder** to open the edit category PopUP window.

3. Edit the category name or add a new translation from the category name pressing **Add a line**.

4. Press **OK** to change the category properties.

**Note:** QElectroTech works according ISO 639-1 norm. The folder name language is defined using 2 letter code which should be used at the language column from the folder internal name table.

---

### Delete category

Working with collections can only be done from the collections panel. Before starting to work with collections, the collections panel has to be displayed.
QElectroTech allows deleting categories from some collection. The user has only read rights at QET element collection, the user can delete categories from all collections except QET collection.

1. Right click on the category / sub-category from the collection that should be deleted.

2. Click the option **Delete folder** to delete the category / sub-category.
3. A PopUP confirmation window will be displayed, press **OK** to confirm and delete the category / sub-category.

![Confirmation PopUP window](image)

**Fig. 174: Figure: Confirmation PopUP window**

**Warning:** Be sure about what you want to delete, the category / sub-category and all the elements will be deleted from the collection and from the file system.

---

**Folder properties**

At QElectroTech folder and category are the same. The properties from a folder are the following:

- Number of elements in the folder.
- Number of sub-folders (sub-categories) in the folder.
- Internal QElectroTech collection path from the folder.
- File system path from the folder.

Working with collections can only be done from the collections panel. Before starting to work with collections, the collections panel has to be displayed.

**Note:** Select **Settings > Display > Collections** menu item to display the Collections panel.

---

1. Right click on the category (folder) from the collection whose properties should be displayed.

![Options at folder](image)

**Fig. 175: Figure: Options at folder**
2. Click the option **Folder properties** to display the PopUP window which shows the folder properties.

![Folder properties PopUP window](image)

**Fig. 176: Figure: Folder properties PopUP window**

**Create element**

Working with collections can only be done from the collections panel. Before starting to work with collections, the collections panel has to be displayed.

**Note:** Select **Settings > Display > Collections** menu item to display the Collections panel.

QElectroTech allows creating element at some collection. The user has only read rights at QET element collection, the user can create element at all collections except QET collection.

There is two different ways to create a new element at the user collection. A new element can be created from cero or from an already existing element from the QET or user collection.

**Create element from cero**

1. Right click on the user collection or at the category / sub-category from the collection where the new element should be added.

![Options at folder](image)

**Fig. 177: Figure: Options at folder**
2. Click the option **New element** to start the element creation.
3. Confirm or change the category from the element.

![Step 1 of 3: Parent category](image)

4. Define the element file name.

![Step 2 of 3: Filename](image)

Fig. 178: Figure: File name definition PopUP window

5. Define the element name for the collection and project tree. It can be defined in many languages.

**Note:** QElectroTech works according ISO 639-1 norm. The element name language is defined using 2 letter code which should be used at the language column from the folder internal name table.

6. Once the element editor PopUP window is opened, design the symbol element and define the properties.
7. Save the element and it will appear at the collection.
See also:
For more information about the element editor, please refer to Element editor section.

**Create an element from an existing element**

1. Right click on the element which will be used as base for the new element.

![Element selection](image1)

2. Click the option **Edit element** to open the element at the element editor.
3. Select **File > Save as** menu item to open the save window.

4. Choose the element category at the collection tree.
5. Define the file name for the element.
6. Press the button **Save**.
### 1.6. Element

#### File Menu

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>New</td>
<td>Ctrl+N</td>
</tr>
<tr>
<td>Open</td>
<td>Ctrl+O</td>
</tr>
<tr>
<td>Open from a file</td>
<td>Ctrl+Shift+O</td>
</tr>
<tr>
<td>Starting the DXF converter plugin</td>
<td></td>
</tr>
<tr>
<td>Recently opened</td>
<td></td>
</tr>
<tr>
<td>Save</td>
<td>Ctrl+S</td>
</tr>
<tr>
<td>Save as</td>
<td>Ctrl+Shift+S</td>
</tr>
<tr>
<td>Save to a file</td>
<td></td>
</tr>
<tr>
<td>Reload</td>
<td>F5</td>
</tr>
<tr>
<td>Quit</td>
<td>Ctrl+Q</td>
</tr>
</tbody>
</table>

#### User Collection Menu

- **User Collection**
  - **Category 1**
    - **Sub-category 1**
      - **switchfuse P+N**
    - **Sub-category 2**
  - **Category 2**

Choose the element you wish to save your definition into.

- **New element name**
  - **Save**
  - **Cancel**
**Edit element**

Working with collections can only be done from the collections panel. Before starting to work with collections, the collections panel has to be displayed.

**Note:** Select **Settings > Display > Collections** menu item to display the Collections panel.

QElectroTech allows editing existing element from some collection. The user has only read rights at QET element collection, the user can edit already existing element from all collections except QET collection element.

1. Right click on the element which should be edited.

   ![User Collection](image)

   Fig. 181: Figure: Options at element

2. Click the option **Edit element** to open the element at the element editor.

3. Make the changes desired and save them.

**See also:**

For more information about the element editor, please refers to **Element editor** section.

**Delete element**

Working with collections can only be done from the collections panel. Before starting to work with collections, the collections panel has to be displayed.

**Note:** Select **Settings > Display > Collections** menu item to display the Collections panel.

QElectroTech allows deleting element from some collection. The user has only read rights at QET element collection, the user can delete element from all collections except QET collection.

1. Right click on the element which should be deleted.

2. Click the option **Delete element** to delete the element.
Warning: Be sure about your intention to delete, the element will be deleted from the collection and from the file system.

### 1.6.5 Element parts

#### Line

**Create line**

The line can only be added to the workspace by the tool bar.

1. Select the icon from the toolbar to add a line.
2. Click on the initial point from the line at the workspace.
3. Click on the end point from the line at the workspace.

**Note:** If the toolbar is not displayed, it can be displayed from Settings > Display > Parts.

#### Line properties

The properties from every element part can only be displayed at the properties panel when the part is selected.

**Note:** If the toolbar is not displayed, it can be displayed from Settings > Display > Information.

QElectroTech allows customizing different line properties:

**Appearance**

- **Color** The outline color and the filling color of the part can be defined from a list of predefined colors. At the case of the line part the filling color is None.
- **Style** The type of outline representation can be choosed from the following options: Normal (Continuous), Dashed, Dotted or, Dots and dashes.
**Thickness**  The thickness (Weight) from the outline can be choosed between: None, Thin, Normal, Strong or High.

**Geometry**

**Coordinates**  The coordinates (x, y) from the start point and end point can be defined.

**End point**  The extrem point from the line can be represented individually as:

- **Normal**  The extrem point is represented as the rest of the line, there is no different representation for the end point.
- **Simple arrow**  The extrem point is represented as a filled arrow.
- **Triangle arrow**  The extrem point is represented as an empty triangle arrow.
- **Circle**  The extrem point is represented as an empty circle.
- **Diamond**  The extrem point is represented as an empty diamond.

**Rectangle**

**Create rectangle**

The rectangle can only be added to the workspace by the tool bar.

1. Select the icon ![ ] from the toolbar to add a line.
2. Click on the initial point from the line at the workspace.
3. Click on the end point from the line at the workspace.
Note: If the toolbar is not displayed, it can be displayed from Settings > Display > Parts.

Rectangle properties

The properties from every element part can only be displayed at the properties panel when the part is selected.

Note: If the toolbar is not displayed, it can be displayed from Settings > Display > Information.

![Fig. 184: Figure: QElectroTech rectangle part from element](image)

QElectroTech allows customizing different rectangle properties:

**Appearance**

- **Color** The outline color and the filling color of the part can be defined from a list of predefined colors.
- **Style** The type of outline representation can be choosed from the following options: Normal (Continuous), Dashed, Dotted or, Dots and dashes.
- **Thickness** The thikness (Weight) from the outline can be choosed between: None, Thin, Normal, Strong or High.

**Geometry**

- **Coordinates** The coordinates \((x, y)\) from the upper left vertice can be defined.
- **Dimensions** The width and the height of the rectangle can be defined. The tangent point at the vertical and horizontal edges can also be defined at the case that round vertex is desired.
Rounding rectangle vertices

QElectroTech allows rounding the vertices from the rectangle at the information panel or at the workspace.

**Rounding rectangle vertices from information panel**

1. Select the rectangle to display the rectangle properties at the information panel.
2. Define the distance between the vertice and the intersection point at the vertical edges.
3. Define the distance between the vertice and the intersection point at the horizontal edges.
4. Press intro.

**Rounding rectangle vertices from workspace**

1. Select the rectangle drawn at the workspace. The rectangle outlines change to red color and the vertices and middle edge point to blue.
2. Select the rectangle again. The outlines continue in red and the points will change to green color.
3. Select the rectangle for third time. The outlines continue in red and at this time only one vertex is displayed, the color is pink.
4. Displace the pink points around the horizontal and vertical edge

**Ellipse**

**Create ellipse**

The ellipse can only be added to the workspace by the toolbar.

1. Select the icon \( \bigcirc \) from the toolbar to add an ellipse.
2. Click at the workspace the position from the ellipse center point.
3. Click at the workspace the position from one of the control points of the ellipse.

**Note:** If the toolbar is not displayed, it can be displayed from **Settings > Display > Parts**.

**Ellipse properties**

The properties from every element part can only be displayed at the properties panel when the part is selected.

**Note:** If the toolbar is not displayed, it can be displayed from **Settings > Display > Information**.

![Fig. 186: Figure: QElectroTech ellipse part from element](image)

QElectroTech allows customizing different ellipse properties:

**Appearance**
**Color**  The outline color and the filling color of the part can be defined from a list of pre-defined colors.

**Style**  The type of outline representation can be chosen from the following options: Normal (Continuous), Dashed, Dotted or, Dots and dashes.

**Thickness**  The thickness (Weight) from the outline can be chosen between: None, Thin, Normal, Strong or High.

**Geometry**

**Coordinates**  The coordinates (x, y) from the ellipse center point can be defined.

**Dimensions**  The horizontal and vertical (minimum and maximum or maximum and minimum) diameters from the ellipse can be defined.

---

**Polygon**

**Create polygon**

The polygon can only be added to the workspace by the toolbar.

1. Select the icon from the toolbar to add a polygon.
2. Click on the initial point from the polygon at the workspace.
3. Click on the rest of point from the polygon at the workspace.
4. Double click on the end position of the polygon to finish the polygon edition.

**Note:**  If the toolbar is not displayed, it can be displayed from **Settings > Display > Parts**.

---

**Polygon properties**

The properties from every element part can only be displayed at the properties panel when the part is selected.

**Note:**  If the toolbar is not displayed, it can be displayed from **Settings > Display > Information**.

QElectroTech allows customizing different polygon properties:

**Appearance**

**Color**  The outline color and the filling color of the part can be defined from a list of pre-defined colors. At the case of an open polygon part the filling color is **None**.

**Style**  The type of outline representation can be chosen from the following options: Normal (Continuous), Dashed, Dotted or, Dots and dashes.

**Thickness**  The thickness (Weight) from the outline can be chosen between: None, Thin, Normal, Strong or High.

**Geometry**

**Type of polygon**  QElectroTech has two different types of polygons, open polygon which is assimilated to a group of connected lines and close polygon which is assimilated to closed geometry as the rectangle.
Fig. 187: Figure: QElectroTech polygon part from element

**Coordinates** The coordinates \((x, y)\) from all polygon point can be defined and are stored at a list.

**Text field**

The normal text field is an object that display an static text. Once the element has been created, the text can only be changed if the element is edited. Any different value can be introduced from outside of the element editor.

**Create text**

The text field can only be added to the workspace by the tool bar.

1. Select the icon \(\text{A}\) from the toolbar to add a text field.
2. Click at the workspace the positional point from the text field where the text field should be introduced.

**Note:** If the toolbar is not displayed, it can be displayed from **Settings > Display > Parts**.

**Text properties**

The properties from every element part can only be displayed at the properties panel when the part is selected.

**Note:** If the toolbar is not displayed, it can be displayed from **Settings > Display > Information**.
QElectroTech allows customizing different text properties:

**Placement**
- **Position** The coordinates (x, y) from the text field positional point can be defined.
- **Text angle** The display angle from the text can be defined in the range of 0 to 360 degrees.

**Content**
- **Size** The text size can be defined.
- **Color** The color from the text can be choosed between balck and white.

**Arc**

**Create arc**

The arc can only be added to the workspace by the tool bar.

1. Select the icon from the toolbar to add an arc.
2. Click at the workspace the position from the start point of the arc.
3. Click at the workspace the position from on end point of the arc. The default arc has always an angle of 90 degrees.

**Note:** If the toolbar is not displayed, it can be displayed from **Settings > Display > Parts.**
Arc properties

The properties from every element part can only be displayed at the properties panel when the part is selected.

**Note:** If the toolbar is not displayed, it can be displayed from **Settings > Display > Information**.

QElectroTech allows customizing different arc properties:

**Appearance**

- **Color** The outline color and the filling color of the part can be defined from a list of predefined colors. At the case of the arc part the filling color is **None**.

- **Style** The type of outline representation can be choosed from the following options: Normal (Continuous), Dashed, Dotted or, Dots and dashes.

- **Thickness** The thickness (Weight) from the outline can be choosed between: None, Thin, Normal, Strong or High.

**Geometry**

- **Coordinates** The coordinates (x, y) from the ellipse center point can be defined.

- **Dimensions** The horizontal and vertical (minimum and maximum or maximum and minimum) diameters from the ellipse can be defined.

- **Point** The position of initial point and end point are defined as angle of the radius between the center and the respective point with the horizontal diameter. The angle value follows the mathematical rules, anti-clockwise for positive angles.
Arc extreme points definition

QElectroTech allows defining the arc extreme points at the information panel or at the workspace.

![Arc extreme points definition](image)

**Fig. 190: Figure: QElectroTech arc extreme point**

**Arc extreme points definition from information panel**

1. Select the arc to display the rectangle properties at the information panel.
2. Define the start angle, the angle from the diamete of the start point and the horizontal axes.
3. Define the angle from the initial point and the end point of the arc.
4. Press intro.

**Arc extreme points definition from workspace**

1. Select the arc drawn at the workspace. The arc line changes to red color and the control of the arc ellipse point to blue.
2. Select the arc again. The line continues in red and the points will change to green color.
3. Select the arc for third time. The line continues in red and at this time only one extreme points are, the color is pink.
4. Displace the pink points around the ellipse outline.

**Terminal**

A terminal is a part from the element that will allow a connection with one conductor during the schema creation.

**Create terminal**

The terminal can only be added to the workspace by the tool bar.

1. Select the icon from the toolbar to add a terminal.
2. Click on the initial point from the terminal at the workspace to add the terminal.

Note: If the toolbar is not displayed, it can be displayed from Settings > Display > Parts.

**Terminal properties**

The properties from every element part can only be displayed at the properties panel when the part is selected.

Note: If the toolbar is not displayed, it can be displayed from Settings > Display > Information.

![](image)

Fig. 191: Figure: QElectroTech terminal part from element

QElectroTech allows customizing different terminal properties:

**Position** The coordinates \((x, y)\) from the start point can be defined.
**Orientation**  The exit direction from the connector to the terminal can be defined. The four possible orientations are North, East, South and West.

**Dynamic text**

The dynamic text field is an object that display a text that is coming from a variable value. The text value is changing with the variable is changed, editing the part is not necessary to change the text content.

**Create dynamic text**

The text field can only be added to the workspace by the tool bar.

1. Select the icon from the toolbar to add a dynamic text field.
2. Click at the workspace the positional point from the text field where the dynamic text field should be introduced.

**Note:** If the toolbar is not displayed, it can be displayed from **Settings > Display > Parts**.

**Dynamic text properties**

The properties from every element part can only be displayed at the properties panel when the part is selected.

**Note:** If the toolbar is not displayed, it can be displayed from **Settings > Display > Information**.

Fig. 192: Figure: QElectroTech dynamic text field part from element

QElectroTech allows customizing different text properties:
Placement

Position  The coordinates (x, y) from the dynamic text field positional point can be defined.
Rotation  The display angle from the text can be defined in the range of 0 to 360 degrees.
Frame     The possibility to display the text inside a rectangle frame is provided.
Alignment The position of the text inside the frame can be defined. Left, center or right and top, middle or bottom.

Content

Source   The source content can be user text (similar to static text), element information parameter or composite text.
Size     The text size can be defined.
Color    The color from the text can be chosen from the RGB color code database.

1.6.6 Element cross reference

E-CAD softwares like QElectroTech allow creating projects where different type of subsystems or/and disciplines are combined. This means that one device can be represented many times.

An example of combining subsystems is an electrical control system where the command system and the power system are combined. The control coil from a power contactor is represented at the control command system and the electrical contactors are represented at the electrical power system.

An example of combining different disciplines is the representation of an hydraulic valve at the electrical schema and at the hydraulic schema.

The examples mentioned before are situations where different QElectroTech elements introduced at the project are representing the same device and later on they have to be listed as one item at the Bill Of Materials (BOM). For this reason, QElectroTech allow defining Master and Slave elements that later on will be linked. The link between master and slave elements is known at QElectroTech as cross reference.

Cross reference at master element

A master element can have many slave element linked. QElectroTech allows that one master element has more than one cross reference defined. This characteristic is similar to the physical devices, the component which manage the control signal can define the action from many different components of the device.

The master element is the element which should appear at the Bill of Materials (BOM), it is the element with all the information. All slave element linked are following the master element.

Cross reference at slave element

A slave element can only have one master element linked. QElectroTech does not allow that one slave element has more than one cross reference defined.

An slave element has only the properties which defines how the element should be represented, the information from the element is not necessary, the master element is the element which defines the device and the element which appear at the bill of materials (BOM), The information about the device can only be found at the master element.
Fig. 193: Figure: QElectroTech master element cross reference
1.6.7 Element editor

What is the element editor?

QElectroTech allows the user customizing elements from the user collection. The element editor is the editor provided by QElectroTech to modify existing element from the user collection and create new elements to the collection.

The element editor is displayed as a PopUP window from QElectroTech and looks like the picture bellow.

Interface element editor

Element editor window

The element editor window is a PopUP window from QElectroTech. It has been designed to looks similar to the main window from QElectroTech independent from the operative system where QElectroTech is running. The element editor window looks like the figure bellow.

As is indicated on the figure, the main window from QElectroTech consists of the following areas:

1. Menu bar
2. Toolbar
3. Panels
4. Drawing area

Element editor Menu bar

The framework and widget toolkit Qt allows the design of drop-down menus. The drop-down menus are a characteristic graphical control element from the desktop applications. Each of the drop-down menus contains a number of
options to initiate an action. The Menu bar is placed at top from the main windows. The figure bellow shows how the menu bar from QElectroTech looks.

As is showed at the figure, QElectroTech element editor bar contains the Menus File, Edit, Display, Settings and Help.
Fig. 196: Figure: QElectroTech Element editor window

Fig. 197: Figure: QElectroTech Element editor Menu bar
<table>
<thead>
<tr>
<th>Menu</th>
<th>Options</th>
<th>Function</th>
<th>Keyboard shortcut</th>
<th>Toolbar icon</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>File</strong></td>
<td>New</td>
<td>Creates a new Element</td>
<td>Ctrl + n</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Open</td>
<td>Opens an existing element from a library</td>
<td>Ctrl + o</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Open from a file</td>
<td>Opens an existing element from the disk</td>
<td>Ctrl + Shift + o</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Starting the DXF converter pluging</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Recently opened</td>
<td>Open an element from history (recently opened files)</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Save</td>
<td>Saves the current Element changes (overwrites)</td>
<td>Ctrl + s</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Save as</td>
<td>Saves the Element as a new element from a library</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Save to a file</td>
<td>Saves the Element as a different file on disk</td>
<td>Ctrl + Shift + s</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Reload</td>
<td>Reloads the opened element (all changes which are not saved are lost)</td>
<td>f5</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Quit</td>
<td>Quits QE ElectroTech Element editor</td>
<td>Ctrl + q/Alt + F4</td>
<td></td>
</tr>
<tr>
<td>Menu</td>
<td>Options</td>
<td>Function</td>
<td>Keyboard shortcut</td>
<td>Toolbar icon</td>
</tr>
<tr>
<td>---------</td>
<td>------------------</td>
<td>-----------------------------------------------</td>
<td>-------------------</td>
<td>--------------</td>
</tr>
<tr>
<td><strong>Edit</strong></td>
<td>Undo</td>
<td>Undo the last action at the element editor</td>
<td>Ctrl + z</td>
<td>![undo_icon]</td>
</tr>
<tr>
<td></td>
<td>Redo</td>
<td>Recovers the last undo action at the element editor</td>
<td>Ctrl + y</td>
<td>![redo_icon]</td>
</tr>
<tr>
<td></td>
<td>Select All</td>
<td>Selects all parts from the element</td>
<td>Ctrl + a</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Select none</td>
<td>Unselects all current selected parts in the element</td>
<td>Ctrl + Shift + a</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Invert selection</td>
<td>Inverts selection of element parts</td>
<td>Ctrl + i</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Cut</td>
<td>Equivalent to copy + delete element part/s</td>
<td>Ctrl + x</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Copy</td>
<td>Copies the selected element part/s</td>
<td>Ctrl + c</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Paste</td>
<td>Copies the selected element part/s</td>
<td>Ctrl + v</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Paste in the area</td>
<td>Pasters the object from last copy or cut in a selected area</td>
<td>Ctrl + Shift + v</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Paste from</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Delete</td>
<td>Deletes the selected element/s part/s</td>
<td>Del</td>
<td>![delete_icon]</td>
</tr>
<tr>
<td></td>
<td>Edit name and information of the element</td>
<td>Displays the element Edit names PopUp window</td>
<td>Ctrl + y</td>
<td>![edit_popup_icon]</td>
</tr>
<tr>
<td></td>
<td>Edit author information</td>
<td>Displays the element Edit author information PopUp window</td>
<td></td>
<td>![author_popup_icon]</td>
</tr>
<tr>
<td></td>
<td>Edit element properties</td>
<td>Displays the element property PopUp window</td>
<td></td>
<td>![property_popup_icon]</td>
</tr>
<tr>
<td></td>
<td>Bring to front</td>
<td>Selected element part sent at top</td>
<td>Ctrl + Shift + Home</td>
<td>![front_icon]</td>
</tr>
<tr>
<td></td>
<td>Raise</td>
<td>Selected element part sent one level up</td>
<td>Ctrl + Shift + Up</td>
<td>![raise_icon]</td>
</tr>
<tr>
<td></td>
<td>Lower</td>
<td>Selected element part sent one level down</td>
<td>Ctrl + Shift + Down</td>
<td>![lower_icon]</td>
</tr>
<tr>
<td></td>
<td>Send backwards</td>
<td>Selected element part sent at bottom</td>
<td>“Ctrl + Shift + End”</td>
<td>![send_icon]</td>
</tr>
</tbody>
</table>
### Display

<table>
<thead>
<tr>
<th>Menu</th>
<th>Options</th>
<th>Function</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display</td>
<td>Zoom In</td>
<td>Magnify the Element symbol for a closer view</td>
<td>Ctrl + +</td>
</tr>
<tr>
<td></td>
<td>Zoom Out</td>
<td>Reduce magnification of the Element symbol; develops a distant view of the Element</td>
<td>Ctrl + -</td>
</tr>
<tr>
<td></td>
<td>Fit in view</td>
<td>Define zoom level to fit the Element symbol at workspace</td>
<td>Ctrl + 9</td>
</tr>
<tr>
<td></td>
<td>Reset zoom</td>
<td>Reset zoom levels to default value (zoom level just less than that of fit in view)</td>
<td>Ctrl + 0</td>
</tr>
</tbody>
</table>

### Settings

<table>
<thead>
<tr>
<th>Menu</th>
<th>Options</th>
<th>Function</th>
<th>Keyboard shortcut</th>
<th>Notes</th>
<th>Toolbar icon</th>
</tr>
</thead>
<tbody>
<tr>
<td>Settings</td>
<td>Display</td>
<td>Display or hide toolbars and panels</td>
<td></td>
<td>Hides or shows elements panel, tool bar etc.,</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Full screen mode</td>
<td>Spreads the window to fill the screen</td>
<td>Ctrl + Shift + f</td>
<td>Entire screen gets occupied by the window</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Configure QElectroTech</td>
<td>Display QElectroTech configure PopUp window</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

### Help

<table>
<thead>
<tr>
<th>Menu</th>
<th>Options</th>
<th>Function</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Help</td>
<td>What’s This?</td>
<td>Enquires main menu options</td>
<td>Shift + f1</td>
</tr>
<tr>
<td></td>
<td>About QElectroTech</td>
<td>Displays information about authors, contributors, translators and Licensing</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Online manual</td>
<td>Opens the explorer and redirects to the official QElectroTech documentation</td>
<td>Shift + f1</td>
</tr>
<tr>
<td></td>
<td>Youtube channel</td>
<td>Opens the explorer and redirects to the official QElectroTech Youtube channel</td>
<td>Shift + f1</td>
</tr>
<tr>
<td></td>
<td>Download a new version (dev)</td>
<td>Opens the explorer and redirects to the official QElectroTech download link</td>
<td>Shift + f1</td>
</tr>
<tr>
<td></td>
<td>Support the project with a donation</td>
<td>Opens the explorer and redirects to the official QElectroTech donation paypal account</td>
<td>Shift + f1</td>
</tr>
<tr>
<td></td>
<td>About Qt</td>
<td>Displays information about Qt, a C++ toolkit for cross platform applications</td>
<td>Shift + f1</td>
</tr>
</tbody>
</table>

### Drawing area

The drawing area or graphical editor, is the area where the element is created.
At the figure bellow, how looks the drawing area from the element editor can be found.

![QElectroTech Workspace](image)

Fig. 198: Figure: QElectroTech Workspace

By default, the scrollbars are not appearing when the element editor is displayed. At the beginning the drawing area has the dimension that is shown. To increase the area, rolling the wheel from the mouse is enough.

**Toolbars**

In addition to the different menus, QElectroTech provides also toolbars. The toolbars are groups of buttons with icons which initiate an action. In general, these buttons have its counterpart at one of the menus from the Menu bar. The aim from the toolbars is make easier and more graphically the use of QElectroTech.

The different toolbars can be hidden or placed in one or more rows bellow the Menu bar. The toolbars can also be placed on column at the left or right side from the main window.

**Note:** To help the user, a tooltip is displayed when the arrow is placed on each button.

**Toolbar Tools**

The different button from the toolbar Tools are mentioned and described bellow.
Fig. 199: Figure: QElectroTech toolbar Tools

<table>
<thead>
<tr>
<th>Toolbar</th>
<th>Options</th>
<th>Function</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tools</td>
<td>New</td>
<td>Creates a new element</td>
<td>Ctrl + n</td>
</tr>
<tr>
<td></td>
<td>Open</td>
<td>Opens an existing element from the collection</td>
<td>Ctrl + o</td>
</tr>
<tr>
<td></td>
<td>Save</td>
<td>Saves the current changes from the opened element</td>
<td>Ctrl + s</td>
</tr>
<tr>
<td></td>
<td>Save as</td>
<td>Saves the current element as a different file on disk</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Reload</td>
<td>Delete all the changes made since last save</td>
<td>f5</td>
</tr>
<tr>
<td></td>
<td>Undo</td>
<td>Undo the last action from the element editor</td>
<td>Ctrl + z</td>
</tr>
<tr>
<td></td>
<td>Redo</td>
<td>Once an action has been undone, allows redoing the action</td>
<td>Ctrl + y</td>
</tr>
<tr>
<td></td>
<td>Delete</td>
<td>Deletes the selected object from the drawing area</td>
<td>Del</td>
</tr>
</tbody>
</table>

Note: Select Settings > display > Tools menu item to display or hidden the toolbar Tools.

Toolbar Display

Fig. 200: Figure: QElectroTech toolbar Display

The different button from the toolbar Display are mentioned and described below.

<table>
<thead>
<tr>
<th>Toolbar</th>
<th>Options</th>
<th>Function</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display</td>
<td>Fit in view</td>
<td>Adjust the drawing area to the element</td>
<td>Ctrl + 9</td>
</tr>
<tr>
<td></td>
<td>Reset zoom</td>
<td>Reset zoom levels to a default value (zoom level just less than that of fit in view)</td>
<td>Ctrl + 0</td>
</tr>
</tbody>
</table>

Note: Select Settings > display > Display menu item to display or hidden the toolbar Display.

Toolbar Element

Fig. 201: Figure: QElectroTech toolbar Element

The different button from the toolbar Diagram are mentioned and described below.
QElectroTech Documentation, Release 2018

### Tool-Part

<table>
<thead>
<tr>
<th>Tool-bar</th>
<th>Options</th>
<th>Function</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Diagram</strong></td>
<td>Edit name and information of the element</td>
<td>Opens the element name window for the active element to introduce the name in the desired language</td>
<td>Ctrl + e</td>
</tr>
<tr>
<td></td>
<td>Edit element properties</td>
<td>Opens the element name window for the active element</td>
<td></td>
</tr>
</tbody>
</table>

**Note:** Select **Settings > display > Diagrams** menu item to display or hidden the toolbar Diagram.

---

### Toolbar Parts

![Toolbar Parts](image)

Fig. 202: Figure: QElectroTech toolbar Parts

The different button from the toolbar Add are mentioned and described bellow.

<table>
<thead>
<tr>
<th>Toolbar Add</th>
<th>Options</th>
<th>Function</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Add line</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Add a rectangle</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Add an ellipse</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Add a polygon</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Add text</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Add an arc</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Add a terminal</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Add a dynamic text field</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Note:** Select **Settings > display > Diagrams** menu item to display or hidden the toolbar Add.

---

### Toolbar Depth

![Toolbar Depth](image)

Fig. 203: Figure: QElectroTech toolbar Depth

The different button from the toolbar Depth are mentioned and described bellow.
<table>
<thead>
<tr>
<th>Toolbar</th>
<th>Options</th>
<th>Function</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Depth</td>
<td>Bring to front</td>
<td>The element or picture will be at the top and completely visible</td>
<td>Ctrl + shift + Home</td>
</tr>
<tr>
<td></td>
<td>Raise</td>
<td>The element or image will be sent one level up</td>
<td>Ctrl + shift + Up</td>
</tr>
<tr>
<td></td>
<td>Lower</td>
<td>The element or image will be sent one level down</td>
<td>Ctrl + shift + Down</td>
</tr>
<tr>
<td></td>
<td>send back-wards</td>
<td>The element or picture will be at the bottom and probably will be partially covered</td>
<td>Ctrl + shift + End</td>
</tr>
</tbody>
</table>

**Note:** Select **Settings > display > Diagrams** menu item to display or hidden the toolbar Depth.

**Element editor panels**

**Parts panel**

The parts panel lists all parts (lines, terminals, rectangles, dynamic texts, etc.) which make up the element.

![Fig. 204: Figure: QElectroTech Parts panel](image)

To display the parts panel

1. Select **Settings > display > Parts** menu item to display the Parts panel.

**Selection properties panel**

The Selection properties panel display the appearance and geometry properties from the selected part (line, terminal, rectangle, dynamic text, etc.).

To display the Selection properties panel:

1. Select **Settings > display > Selection properties** menu item to display the Selection properties panel.
und panel

The Undo panel list all actions made by the user inside the element editor form the last save time.

To display the Undo panel:

1. Select Settings > display > Undo menu item to display the Undo panel.

See also:

For more information about for which actions can be usefull the Undo panel, please refers to Undo panel section from QELECTROTech Main window.
Open element editor

QElectroTech allows displaying the element editor PopUP window by creating a new element or by editing an existing element.

Open element editor by creating a new element

1. Refers to the section link for opening the element editor by creating a new element from the project panel.

Open element editor by editing an element

1. Refers to the section Link for opening the element editor by editing an element from collection oanle.
2. Refers to section Link for opening the element editor by editing an element from the workspace.

Save element

The current element can be saved from the Menu bar, toolbar and using the corresponding keyboard shortcut.

One element is conformed by only one file with the format .elmt. The .elmt extension is the native extension from QElectroTech elements.

Save element from Menu bar

1. Select File > Save menu item to save the element changes.

At the case that the opened element has to overwrite an existing element or it has to be saved as a new element:

1. Select File > Save as menu item to display the Save as element PopUP window.
2. Select the element which should be overwrited or the category and the name for the new element.

3. Press the Save button to save the element and close the PopUP window.

The element can also be directly saved as a new file in the Hard Disk directory desired:

1. Select File > Save to a file menu item to display the File system PopUP window.

2. Select the directory and the name from the element file.

3. Press the Save button to save the element and close the PopUP window.

**Save element from toolbar**

1. Select the icon from the toolbar to save the element changes.

At the case that the opened element has to overwrite an existing element or it has to be saved as a new element:

1. Select the icon from the toolbar to display the Save as element PopUP window.

---

Fig. 208: Figure: QElectroTech Save as element PopUP window

Fig. 209: Figure: QElectroTech Save as element PopUP window
2. Select the **element** which should be overwritten or the **category** and the name for the new **element**.

3. Press the **Save** button to save the **element** and close the PopUP window.

**Note:** If the **toolbar** is not displayed, it can be displayed from **Settings > Display > Tools**

---

**Save element using keyboard shortcut**

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Press **Ctrl + s** to save the element changes.

**See also:**
For more information about QElectroTech keyboard shortcut, please refers to **Menu bar** section.

**Quit element editor**

The user can close **QElectroTech element editor** at any time. The user does not need to **save** the changes on the **element** before closing it.

If the current work wants to be saved before closing the **element editor**, please refers to **Save** section. Even so, QElectroTech display an automatic message to **save** the current job if any modification has been created.

![Do you wish to save the element Magneto-thermal circuit breaker GV?](image)

**Fig. 210:** Figure: QElectroTech element editor save message

**Exit QElectroTech element editor from Menu bar**

1. Select **File > Quit** menu item to quit QElectroTech element editor.

**Exit QElectroTech element editor using keyboard shortcut**

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Press **Ctrl + q** to quit QElectroTech element editor.

**See also:**
For more information about QElectroTech keyboard shortcut, please refers to **Menu bar** section.

**Create or edit elements**

**Graphic definition**
Working with parts

Add part to element

Adding parts to the Drawing area from the element editor can only be done from the parts toolbar.

Note: If the toolbar is not displayed, it can be displayed from Settings > Display > Parts.

For more information about how to add each type of part (Line, Rectangle, Ellipse, Arc, Polygon, Terminal, text and dynamic text field), please refers to the Element part section.

Select parts from workspace

Select one part

At QElecroTech, one part (Line, Rectangle, Ellipse, Arc, Polygon, Terminal, text and dynamic text field) from the workspace can be selected by a simple left click on the part.

Select multiple parts

As many CAD tools, many parts (Line, Rectangle, Ellipse, Arc, Polygon, Terminal, text and dynamic text field) from QElecroTech workspace can be selected at the same time.

Select multiple objects using keyboard and mouse

QElecroTech allows selecting multiple parts from the workspace, graphical area, combining the use of the keyboard and mouse.

1. Select the first part.
2. Press `Ctrl`.

3. Select the rest of parts without releasing `Ctrl`.

**Select multiple objects by selecting area**

QElectroTech allows selecting all parts from an area using the mouse to select the desired area.

1. Left click on the initial point from the rectangular area to be selected and displace the mouse without releasing the button.

**Select all Parts**

QElectroTech allows selecting all parts from the workspace, all parts from the opened element, at the same time.

All parts can be selected from Menu bar, workspace or using the corresponding keyboard shortcut.

**Select all parts from Menu bar**

1. Select `Edit > Select all` menu item to select all parts from the opened element.
1.6. Element

Fig. 213: Figure: QElectroTech schema

Fig. 214: Figure: QElectroTech selecting on workspace
### Fig. 215: Figure: QE ElectroTech Edit menu

<table>
<thead>
<tr>
<th>Menu Item</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>File - Undo</td>
<td>Ctrl+Z</td>
</tr>
<tr>
<td>File - Redo</td>
<td>Ctrl+Y</td>
</tr>
<tr>
<td>Edit - Select All</td>
<td>Ctrl+A</td>
</tr>
<tr>
<td>Edit - Select none</td>
<td>Ctrl+Shift+A</td>
</tr>
<tr>
<td>Edit - Invert selection</td>
<td>Ctrl+I</td>
</tr>
<tr>
<td>Edit - Cut</td>
<td>Ctrl+X</td>
</tr>
<tr>
<td>Edit - Copy</td>
<td>Ctrl+C</td>
</tr>
<tr>
<td>Edit - Paste</td>
<td>Ctrl+V</td>
</tr>
<tr>
<td>Edit - Paste in the area...</td>
<td>Ctrl+Shift+V</td>
</tr>
<tr>
<td>Edit - Paste from...</td>
<td></td>
</tr>
<tr>
<td>Edit - Delete</td>
<td>Del</td>
</tr>
<tr>
<td>Edit - Edit name and information of the element</td>
<td>Ctrl+E</td>
</tr>
<tr>
<td>Edit - Edit author information</td>
<td>Ctrl+Y</td>
</tr>
<tr>
<td>Edit - Edit element properties</td>
<td></td>
</tr>
<tr>
<td>Edit - Bring to front</td>
<td>Ctrl+Shift+Home</td>
</tr>
<tr>
<td>Edit - Raise</td>
<td>Ctrl+Shift+Up</td>
</tr>
<tr>
<td>Edit - Lower</td>
<td>Ctrl+Shift+Down</td>
</tr>
<tr>
<td>Edit - Send backward</td>
<td>Ctrl+Shift+End</td>
</tr>
</tbody>
</table>
Select all parts from workspace

As many other CAD tools, QElectroTech allows selecting all parts from the workspace, graphical area, using the mouse.

1. Left click on the initial point from the rectangular area to be selected and displace the mouse without releasing the button.

![Diagram of QElectroTech element editor selecting on workspace](image)

Fig. 216: Figure: QElectroTech element editor selecting on workspace

Select all objects using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Press Ctrl + a to select all parts from the opened element.

See also:

For more information about QElectroTech keyboard shortcut, please refers to Menu bar section.

Select none

To be sure that any part is selected before any action, QElectroTech provides the option to unselect all parts from the workspace. This option is useful for avoiding undesired changes.

Unselecting all parts can be done from Menu bar or using the corresponding keyboard shortcut.

1.6. Element
Select none from Menu bar

1. Select Edit > Select none to unselect all selected parts.

![Edit menu](image)

Fig. 217: Figure: QELECTROTECH Edit menu

Select none using keyboard shortcut

QELECTROTECH allows using keyboard shortcut to increase the working efficiency.

1. Press Ctrl + Shift + a to unselect all selected parts.

See also:

For more information about QELECTROTECH keyboard shortcut, please refers to Menu bar section.

Invert the selection

Some times is easier to select the parts from the workspace which are not interested for the desired action than the parts which should be selected. For this reason, QELECTROTECH provides the option to invert the selection.
Inverting the selection can be done from **Menu bar** or using the corresponding keyboard shortcut.

**Invert selection from Menu bar**

1. Select the part/s from the opened element which are not interested for the desired action.
2. Select **Edit > Invert selection** to invert the selection.

![Fig. 218: Figure: QElectroTech Edit menu](image)

**Invert selection using keyboard shortcut**

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Select the part/s from the opened element which are not interested for the desired action.
2. Press Ctrl + i to invert the selection.

**See also:**

For more information about QElectroTech keyboard shortcut, please refers to **Menu bar** section.
Cut part

QElectroTech element editor allows cutting the different possible type of parts to paste them later on at different place from the element editor workspace.

**Note:** Multiples parts can be cut at the same time, pressing Ctrl is necessary to select more than one part.

Cutting parts can be done from the Menu bar, by right click on the part and from the corresponding keyboard shortcut.

**Cut part from Menu bar**

1. Select the part which should be cut.
2. Select **Edit > Cut** menu item to cut the part.

![Fig. 219: QElectroTech Edit menu](image)

**Cut part by right click**

1. Right click on the part which should be cut.
2. Select the option **Cut** to cut the part.

![QElectroTech right click PopUP window](image)

**Fig. 220: Figure: QElectroTech right click PopUP window**

**Cut part using keyboard shortcut**

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Select the **part** which should be cut.
2. Press **Ctrl + x** to cut the **part**.

**See also:**

For more information about QElectroTech keyboard shortcut, please refers to **Menu bar** section.

**Copy part**

QElectroTech element editor allows copying the different possible type of **parts** to paste them later on at different place from the element editor workspace.

**Note:** Multiple **parts** can be copied at the same time, pressing **Ctrl** is necessary to select more than one **part**.

Copying parts can be done from the **Menu bar**, by right click on the **part** and using the corresponding keyboard shortcut.

**Copy part from Menu bar**

1. Select the **part** which should be copied.
2. Select **Edit > Copy** menu item to copy the **part**.
Fig. 221: Figure: QElectroTech element editor Edit menu
Copy part by right click

1. Right click on the part which should be copied.
2. Select the option Copy to copy the part.

![QElectroTech right click PopUP window](image)

Fig. 222: Figure: QElectroTech right click PopUP window

Copy part using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.
1. Select the part which should be copied.
2. Press Ctrl + c to copy the part.

See also:
For more information about QElectroTech keyboard shortcut, please refers to Menu bar section.

Paste part

QElectroTech element editor allows pasting the different possible type of parts which has already been copied or cut from the Drawing area.

---

**Note:** Multiples parts can be pasted at the same time, check Copy part or Cut part section to check how multiples parts can be copied or cut.

Pasting parts can be done from the Menu bar, by right click on the Drawing area and using the corresponding keyboard shortcut.

Paste part from Menu bar

1. Select Edit > Paste menu item to paste the part copied or cut previously from the Drawing area.
<table>
<thead>
<tr>
<th>File</th>
<th>Edit</th>
<th>Display</th>
<th>Settings</th>
<th>Help</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>Ctrl+Z</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Redo</td>
<td>Ctrl+Y</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Select All</td>
<td>Ctrl+A</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Select none</td>
<td>Ctrl+Shift+A</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Invert selection</td>
<td>Ctrl+I</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cut</td>
<td>Ctrl+X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Copy</td>
<td>Ctrl+C</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Paste</td>
<td>Ctrl+V</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Paste in the area...</td>
<td>Ctrl+Shift+V</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Paste from...</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Delete</td>
<td>Del</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Edit name and information of the element</td>
<td>Ctrl+E</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Edit author information</td>
<td>Ctrl+Y</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Edit element properties</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Bring to front</td>
<td>Ctrl+Shift+Home</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Raise</td>
<td>Ctrl+Shift+Up</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Lower</td>
<td>Ctrl+Shift+Down</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Send backward</td>
<td>Ctrl+Shift+End</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Fig. 223: Figure: QEelectroTech element editor Edit menu
### Paste part by right click

1. Right click somewhere from the Drawing area.
2. Select the option Paste to paste the part copied or cut previously.

![Select All, Invert selection, Paste, Paste in the area, Paste from...]

Fig. 224: Figure: QElectroTech right click PopUP window

### Paste part using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Press Ctrl + v to paste the part copied or cut previously from the Drawing area.

See also:

For more information about QElectroTech keyboard shortcut, please refers to Menu bar section.

### Note:
The procedure defined at this section only allows pasting the parts at the right grid point from the copied or cut part position. To be able to choose the place where to paste the part, please refers to the Paste in area section.

### Paste in area

Past in are is similar command to paste part, the main difference is the place where the part can be pasted. At normal paste command QElectroTech pastes the part automatically at a predefined position, at paste in area command the user is free to choose the place where to paste the object by left click on the desired place.

Pasting parts in area can be done from the Menu bar, by right click on the Drawing area and from the corresponding keyboard shortcut.

### Paste part from Menu bar

1. Select Edit > Paste in the area... menu item to paste the part copied or cut previously from the workspace.
2. Left click at the Drawing area point where the part should be pasted.

### Paste part by right click

1. Right click somewhere from the Drawing area.
2. Select the option Paste in the area... to paste the part copied or cut previously.
3. Left click at the Drawing area point where the part should be pasted.
### QElectroTech Edit Menu

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>Ctrl+Z</td>
</tr>
<tr>
<td>Redo</td>
<td>Ctrl+Y</td>
</tr>
<tr>
<td>Select All</td>
<td>Ctrl+A</td>
</tr>
<tr>
<td>Select none</td>
<td>Ctrl+Shift+A</td>
</tr>
<tr>
<td>Invert selection</td>
<td>Ctrl+I</td>
</tr>
<tr>
<td>Cut</td>
<td>Ctrl+X</td>
</tr>
<tr>
<td>Copy</td>
<td>Ctrl+C</td>
</tr>
<tr>
<td>Paste</td>
<td>Ctrl+V</td>
</tr>
<tr>
<td>Paste in the area...</td>
<td>Ctrl+Shift+V</td>
</tr>
<tr>
<td>Paste from...</td>
<td></td>
</tr>
<tr>
<td>Delete</td>
<td>Del</td>
</tr>
<tr>
<td>Edit name and information of the element</td>
<td>Ctrl+E</td>
</tr>
<tr>
<td>Edit author information</td>
<td>Ctrl+Y</td>
</tr>
<tr>
<td>Edit element properties</td>
<td></td>
</tr>
<tr>
<td>Bring to front</td>
<td>Ctrl+Shift+Home</td>
</tr>
<tr>
<td>Raise</td>
<td>Ctrl+Shift+Up</td>
</tr>
<tr>
<td>Lower</td>
<td>Ctrl+Shift+Down</td>
</tr>
<tr>
<td>Send backward</td>
<td>Ctrl+Shift+End</td>
</tr>
</tbody>
</table>

*Fig. 225: Figure: QElectroTech Edit menu*

### QElectroTech Right Click PopUP Window

<table>
<thead>
<tr>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select All</td>
</tr>
<tr>
<td>Invert selection</td>
</tr>
<tr>
<td>Paste</td>
</tr>
<tr>
<td>Paste in the area...</td>
</tr>
<tr>
<td>Paste from...</td>
</tr>
</tbody>
</table>

*Fig. 226: Figure: QElectroTech right click PopUP window*
Paste part using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Press \texttt{Ctrl + Shift + v} to paste the part copied or cut previously from the Drawing area.
2. Left click at the Drawing area point where the part should be pasted.

See also:
For more information about QElectroTech keyboard shortcut, please refers to Menu bar section.

Delete part

QElectroTech element editor allows deleting parts which has been added or pasted at the element editor workspace previously.

Deleting parts can be done from the Menu bar, toolbar, by right click on the part and using the corresponding keyboard shortcut.

Delete part from Menu bar

1. Select the part which should be deleted.
2. Select \textit{Edit > Delete} menu item to delete the part from the workspace.

Delete part from toolbar

1. Select the part which should be deleted.
2. Select the icon \includegraphics[height=0.5cm]{delete_icon.png} from the toolbar to delete the part from the workspace.

\textbf{Note:} If the toolbar is not displayed, it can be displayed from Settings > Display > Tools

Delete part by right click

1. Right click on the part which should be deleted.
2. Select the option \textit{Delete} to delete the part from the workspace.

Delete part using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Select the part which should be deleted.
2. Press \texttt{Del} to delete the part from the workspace.
Fig. 227: Figure: QElectroTech element editor Edit menu

Fig. 228: Figure: QElectroTech right click PopUP window
See also:
For more information about QElectroTech keyboard shortcut, please refers to Menu bar section.

Layers in element editor

Overlap of part, graphical elements, may occur at the graphical representation of an element. QElectroTech allows defining the representation order from the part. Working with layers will be necessary, for example, when a filled part as rectangle or ellipse hides a text.

The definition of layer level from each part can only be done from the Menu bar.

1. Select the element part which layer level should be defined.
2. Select Edit from the main bar and the desired layer action.

Fig. 229: Figure: QElectroTech element editor Edit Menu

Regarding the layer actions allowed by QElectroTech, the following table defines all possibilities.

<table>
<thead>
<tr>
<th>Action</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>Ctrl+Z</td>
</tr>
<tr>
<td>Redo</td>
<td>Ctrl+Y</td>
</tr>
<tr>
<td>Select All</td>
<td>Ctrl+A</td>
</tr>
<tr>
<td>Select none</td>
<td>Ctrl+Shift+A</td>
</tr>
<tr>
<td>Invert selection</td>
<td>Ctrl+I</td>
</tr>
<tr>
<td>Cut</td>
<td>Ctrl+X</td>
</tr>
<tr>
<td>Copy</td>
<td>Ctrl+C</td>
</tr>
<tr>
<td>Paste</td>
<td>Ctrl+V</td>
</tr>
<tr>
<td>Paste in the area...</td>
<td>Ctrl+Shift+V</td>
</tr>
<tr>
<td>Paste from...</td>
<td></td>
</tr>
<tr>
<td>Delete</td>
<td>Del</td>
</tr>
<tr>
<td>Edit name and information of the element</td>
<td>Ctrl+E</td>
</tr>
<tr>
<td>Edit author information</td>
<td>Ctrl+Y</td>
</tr>
<tr>
<td>Edit element properties</td>
<td></td>
</tr>
<tr>
<td>Bring to front</td>
<td>Ctrl+Shift+Home</td>
</tr>
<tr>
<td>Raise</td>
<td>Ctrl+Shift+Up</td>
</tr>
<tr>
<td>Lower</td>
<td>Ctrl+Shift+Down</td>
</tr>
<tr>
<td>Send backward</td>
<td>Ctrl+Shift+End</td>
</tr>
</tbody>
</table>
### Icon | Action | Definition | Keyboard shortcut
---|---|---|---
| | Bring to front | The element or picture will be at the top and completely visible | Ctrl + Shift + Home |
| | Raise | The element or image will be sent one level up | Ctrl + Shift + Up |
| | Lower | The element or image will be sent one level down | Ctrl + Shift + Down |
| | Send backwards | The element or picture will be at the bottom and probably will be partially covered | Ctrl + Shift + End |

#### Change element size

QElectroTech provide the feature of changing the size of the graphical symbol from an element. This feature is equivalent to the scale feature from CAD tools and graphical vector editors.

**Note:** The current version from QElectroTech, version 0.7, does not provide the option of defining the proportion to scale.

To change the size from element symbol:

1. Open the element desired using the element editor.
2. Select all element parts from workspace.
3. Press one of the control points from the global element symbol rectangle (green points from the figure).
4. Move the point without releasing the left button of the mouse.
5. Once the element symbol has been scaled, save changes and close element editor.

#### Element properties definition

**Define element name**

The element name is used to identify the element at QElectroTech. The name has no relation with the element file name, they can be completely different. The name file is the name from the file which contains the information from the element. The element name is the name which represent the element at the different collection.

The element name can be defined in many different languages. Depending on the chosen language at QElectroTech settings, the name is displayed for the user at one language or at another.

**Note:** QElectroTech works according ISO 639-1 norm. The text language is defined using 2 letter code which should be used at the language column from the cell value table.
Fig. 230: Figure: QELECTROTECH element editor workspace

Fig. 231: Figure: QELECTROTECH element name PopUP window
Define element name from Menu bar

1. Select **Edit > Edit name and information of the element** menu item to display the name editor PopUp window.

2. Press the button **+ Add a line** to introduce a new row at the element name table.
3. Define the 2 letter code language at the language column.
4. Define the element name with the defined language at the text column.
5. Press the button **OK** to accept and close the name editor PopUp window.

Define element name from toolbar

1. Press the icon from the toolbar to display the name editor PopUp window.
2. Press the button **+ Add a line** to introduce a new row at the element name table.
3. Define the 2 letter code language at the language column.
4. Define the element name with the defined language at the text column.
5. Press the button OK to accept and close the name editor PopUp window.

Note: If the toolbar is not displayed, it can be displayed from Settings > Display > Element.

Define element name using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Press Ctrl + e to display the name editor PopUp window.
2. Press the button + Add a line to introduce a new row at the element name table.
3. Define the 2 letter code language at the language column.
4. Define the element name with the defined language at the text column.
5. Press the button OK to accept and close the name editor PopUp window.

See also:
For more information about QElectroTech keyboard shortcut, please refers to Menu bar section.

Define author element information

Define author element information from Menu bar

1. Select Edit > Edit author information menu item to display the author information PopUp window.

2. Introduce the desired information to the text field.
3. Press the button OK to accept and close the author information PopUp window.

Define author element information using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Press Ctrl + y to display the author information PopUp window.
2. Introduce the desired information to the text field.
3. Press the button OK to accept and close the author information PopUp window.

See also:
For more information about QElectroTech keyboard shortcut, please refers to Menu bar section.

Edit element properties

Edit element properties from Menu bar

1. Select Edit > Edit element properties menu item to display the element properties PopUp window.
### Fig. 233: Figure: QElectroTech element editor Edit Menu

<table>
<thead>
<tr>
<th>File</th>
<th>Edit</th>
<th>Display</th>
<th>Settings</th>
<th>Help</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>Ctrl+Z</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Redo</td>
<td>Ctrl+Y</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Select All</td>
<td>Ctrl+A</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Select none</td>
<td>Ctrl+Shift+A</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Invert selection</td>
<td>Ctrl+I</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cut</td>
<td>Ctrl+X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Copy</td>
<td>Ctrl+C</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Paste</td>
<td>Ctrl+V</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Paste in the area...</td>
<td>Ctrl+Shift+V</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Paste from...</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Delete</td>
<td>Del</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Edit name and information of the element</td>
<td>Ctrl+E</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Edit author information</td>
<td>Ctrl+Y</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Edit element properties</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Bring to front</td>
<td>Ctrl+Shift+Home</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Raise</td>
<td>Ctrl+Shift+Up</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Lower</td>
<td>Ctrl+Shift+Down</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Send backward</td>
<td>Ctrl+Shift+End</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Fig. 234: Figure: QElectroTech element editor Edit Menu

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>Ctrl+Z</td>
</tr>
<tr>
<td>Redo</td>
<td>Ctrl+Y</td>
</tr>
<tr>
<td>Select All</td>
<td>Ctrl+A</td>
</tr>
<tr>
<td>Select none</td>
<td>Ctrl+Shift+A</td>
</tr>
<tr>
<td>Invert selection</td>
<td>Ctrl+I</td>
</tr>
<tr>
<td>Cut</td>
<td>Ctrl+X</td>
</tr>
<tr>
<td>Copy</td>
<td>Ctrl+C</td>
</tr>
<tr>
<td>Paste</td>
<td>Ctrl+V</td>
</tr>
<tr>
<td>Paste in the area</td>
<td>Ctrl+Shift+V</td>
</tr>
<tr>
<td>Paste from...</td>
<td></td>
</tr>
<tr>
<td>Delete</td>
<td>Del</td>
</tr>
<tr>
<td>Edit name and information of the element</td>
<td>Ctrl+E</td>
</tr>
<tr>
<td>Edit author information</td>
<td>Ctrl+Y</td>
</tr>
<tr>
<td>Edit element properties</td>
<td></td>
</tr>
<tr>
<td>Bring to front</td>
<td>Ctrl+Shift+Home</td>
</tr>
<tr>
<td>Raise</td>
<td>Ctrl+Shift+Up</td>
</tr>
<tr>
<td>Lower</td>
<td>Ctrl+Shift+Down</td>
</tr>
<tr>
<td>Send backward</td>
<td>Ctrl+Shift+End</td>
</tr>
</tbody>
</table>
2. Select the element family, the base type from the element, at **Type** tab.

![QElectroTech element properties Type tab](image)

Fig. 235: Figure: QElectroTech element properties Type tab

For **Simple, Reference folio** or **Terminal block elements**:

3. Go to **Informations Tab**.

![QElectroTech element properties Information tab](image)

Fig. 236: Figure: QElectroTech element properties Information tab

4. Fill each predefined field with the desired information.

5. Press the button **OK** to accept and close the element properties PopUp window.

For **Master elements**:

3. Choose the type of **Master element** desired at **Type tab**.

4. Go to **Informations Tab**.
5. Fill each predefined field with the desired information.
6. Press the button **OK** to accept and close the element properties PopUp window.

For **Slave elements**:

3. Choose the type of **Slave element** desired at Type tab.
4. Press the button **OK** to accept and close the element properties PopUp window.

**Edit element properties from toolbar**

1. Press the icon from the toolbar to display the element properties PopUp window.
2. Follow same procedure defined at the previous section starting from step 2.

**Note**: If the toolbar is not displayed, it can be displayed from **Settings > Display > Element**.

## 1.7 Conductor

### 1.7.1 What is a conductor?

A **conductor** or conduit represents the means of transmission of information, electric power, flow power (pressure or flow volume) between the source and the target.

At the real life, T-cross are used at fluid lines and terminal blocks are used to feed different electrical devices from the same source. QElectroTech also allows multiple connections between the source and the target.

The conductors can be classified in different families according to the type:

**Multiline**  Multiline conductors are used at multiline diagrams. Multiline conductors are used for the representation of each terminal, line and phase from two and three phase power systems. Multiline conductors are used for the individual representation of all electric and control systems.
At the fluid power schemas, a multiline conductor represents each line, pressure, return and pilote line.

**Single line** The Single line conductors is used at single line diagrams. Single line conductors are the simplified notation for representing two and three phase power system drawing using a common conductor. Single line conductors are only used to represent power system, control systems are normally not represented.

At fluid power schemas, the pressure and return line are represented by the same conductor.

### 1.7.2 Type of conductors

**Single line conductor**

The single line conductor is often used at Single line diagrams. QElectroTech represents a single line conductor as a simple line with an overlapping symbol which can be costumized.

QElectroTech does not allow defining any conductor property at single line conductor. The single line conductors do not have the possibility of text linking.

The most common sigle line conductors used at Single line diagrams of power electric systes can be found bellow.

**Multiline conductor**

The multiline conductor is often used at Multiline diagrams. QElectroTech represents a multiline conductor as a simple line. The main difference of multiline with respect to single line conductors is the possibility to display text which is linked to the conductor properties.

The main features of multiline conductors are the following:

1. Possibility to define properties (Function and voltage/protocol)
2. Text linked to the conductor which can be displayed and its position is relative to the conductor position.
3. Possibility of displaying variables values at the conductor text (Autonumbering, Function or voltage/protocol).
4. Possibility of using the conductor variables at element dynamic text (Function and voltage/protocol).

### 1.7.3 Conductor properties

**Display conductor properties**

The conductor properties window can be displayed from the Menu bar, from the workspace or using keyboard shortcut.
Fig. 239: Figure: QElectroTech single line conductors

Fig. 240: Figure: Common single line conductors

1.7. Conductor
Fig. 241: Figure: Multiline conductor
Display conductor properties from Menu bar

1. Select the conductor which properties should be displayed.
2. Select **Edit > Edit conductor** menu item to display the conductor properties PopUP window.

Display conductor properties from workspace

1. Right click on the conductor which properties should be displayed.
2. Select **Edit conductor** option to display the conductor properties PopUP window.

Display conductor properties using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Select the conductor which properties should be displayed.
2. Press **Ctrl + e** to display the conductor properties PopUP window.

See also:

For more information about QElectroTech keyboard shortcut, please refer to Menu bar section.

Conductor type

Multiline conductor

For the multiline conductors, QElectroTech allows defining many different parameters from the conductor text. All parameters which can be defined are listed below.

1. **Text size**: Size of the text displayed.
2. **Text formula**: To be used if a variable value is desired at the **Text** field during conductor creation.
3. **Text**: Text field content to be displayed at folio.
4. **Function**: Variable from conductor, it is used to define the phase from the conductor (L1, L2, L3, N, etc.).
5. **Voltage/Protocol**: Variable from the conductor, it is used to define the voltage (0v, 230V, 400V, 6kV, etc.) or the network protocol (IP).
6. Positioning and orientation from the text displayed at folio, vertical and horizontal conductor.

**Note**: Display the conductor TAG (code) at multiline diagrams is usual for an easily manage of the manufacturing, erection, commissioning and maintenance phase of the product.

QElectroTech allows an automatic conductor number definition for the text using the variable **$autonum** at the **Text formula** field. This field have to be defined at Folio properties before starting the conductor creation.

Single line conductor

For single line conductors, the conductors are represented without any text information. Only the type of power system should be defined to have the correct symbol representation.
<table>
<thead>
<tr>
<th>File</th>
<th>Edit</th>
<th>Project</th>
<th>Display</th>
<th>Settings</th>
<th>Windows</th>
<th>Help</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>Ctrl+Z</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Redo</td>
<td>Ctrl+Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cut</td>
<td>Ctrl+X</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Copy</td>
<td>Ctrl+C</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Paste</td>
<td>Ctrl+V</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Select All</td>
<td>Ctrl+A</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Select none</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Invert selection</td>
<td>Ctrl+I</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Delete</td>
<td>Del</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Rotate</td>
<td>Space</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Choose texts orientation</td>
<td>Ctrl+Space</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Find in the panel</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Edit conductor</td>
<td>Ctrl+E</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Group selected texts</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Reset conductors</td>
<td>Ctrl+K</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Folio properties</td>
<td>Ctrl+L</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Add a column</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Remove a column</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Add row</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Remove a row</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Bring to front</td>
<td>Ctrl+Shift+Home</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Raise</td>
<td>Ctrl+Shift+Up</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Lower</td>
<td>Ctrl+Shift+Down</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Send backward</td>
<td>Ctrl+Shift+End</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Search</td>
<td>Ctrl+F</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Fig. 242: Figure: QE ElectoTech Edit menu

Fig. 243: Figure: QE ElectoTech conductor options
Fig. 244: Figure: Multiline conductor properties
QELECTROTECH allows the following options for single line conductors:

1. System with or without **Ground**
2. System with or without **Neutral**
3. **PEN** system, system where the **Neutral** and the **Ground** are the same conductor.
4. Systems with one, two or three phases

![Diagram of single line conductor properties](image)

Fig. 245: Figure: Single line conductor properties
Conductor appearance

QElectroTech allows choosing the color, the type of line and the width from the lines. Exists the possibility to choose the properties for main lines and for secondary lines.

Note: The secondary line is used when a dashes line with double color is desired.

![Conductor with red secondary line](image)

Fig. 246: Figure: Conductor with red secondary line

On reference to the color, it can be choosed by the RGB range or using the HTML code.

On reference to the line Style, the line can be:

- **Solid line**
- **Dashed line**
- **Dots and dashes**

On reference to the width, many different values starting from 0.4 can be choosed (0.4, 0.6, 0.8, 1.0, 1.2, 1.4, 1.6, etc.).

Note: QElectroTech provides the option to pre-define the appearance of conductor before starting to draw conductors at the folio. This feature increase the working efficiency and avoid defining the appearance conductor by conductors after the creation.

For more information about appearance pre-definition, please refer to Folio properties section.

Conductor numbering

QElectroTech allows an automatic codification of conductors. This feature is very useful for the creation of reports, conductor list, and for the identification of conductors at the physical systems and schemas.

QElectroTech allows the definition of multiple auto numbering patterns. It also provides many flexibility on the creation of auto numbering patterns using text, variables and sequential numbers.

Example

Taking the content from the image above:

```
W  X  XX  XXX  N
```

W Code defined by IEC 81346 norm.

- **W**: Guiding or transporting from one place to another.

X Alphanumeric code corresponding to the following coding:

- **H**: High voltage
- **B**: 400 V AC
- **C**: 230 V AC
- **D**: Digital signal
Fig. 247: Figure: Multiline conductor appearance
1.7. Conductor

Fig. 248: Figure: QElectroTech select color PopUP window

Fig. 249: Figure: QElectroTech conductor auto numbering
- A: Analog signal
- @: Network

**XX** Installation or functional unit to which the cable belongs (schema where the cable can be found).
- 001: Incoming plant
- 002: Global auxiliary power
- 003: Distribution Network
- 004: installation 1
- 005: installation 2
  - ...
- 999: ...

**XXX** Folio where the cable is represented.

**N** Cable number.

See also:
For more information about how to define auto numbering patterns, please refers to project auto numbering properties section.
For more information about how to manage the codification of conductors, please refers to create conductor section.

### 1.8 Schema

#### 1.8.1 What is a schema?

#### 1.8.2 Working with elements

**Add element**

**Note:** Before adding an element, selecting the auto numbering pattern is necessary. This selection can only be done from Auto Numbering Select panel.

If the Auto Numbering Select panel is not displayed, it can be displayed from **Settings > Display > Auto Numbering Select**.

To add an element to the workspace:

1. Search the element at the collection panel.
2. Left Click on the desired element. Without releasing move the mouse to the workspace area, once the mouse is at the workspace it can be released.
3. Search for the desired element position and left click on the place to add the element, multiples elements can be added with multiple clicks at different places.
4. Press esc to finish the adding action.
Note: Select Settings > Display > Collections menu item to display the Collections panel.

**Edit element**

To edit an element:

1. Display element properties. At the case that the Selection properties panel is displayed, one click on the element is enough.
2. Go to General properties tab and click on the button **Edit element** to display the element editor.

**Note:** If the Selection properties panel is not displayed, it can be displayed from Settings > display > Selection properties.

**See also:**
For more information about how to edit elements, please refers to Element editor section.

**Working with cross reference**

**Bind slave item**

Some times one device should be represented in the project using different elements, power and control subsystem and auxiliary subsystems. All these elements should be always considered as one device. For this reason QelectroTech works with Master and Slave elements which are linked using cross references.

A Slave element can be linked to a Master element as follow:

1. Select the Master element which should be linked from the project collection or from the workspace.
2. Right click on the selected element and choose the option **Edit the element**.

3. Display the **Cross-reference (Master)** tab from the element editor PopUP window.
Fig. 251: Figure: QElectroTech general element properties

Fig. 252: Figure: QElectroTech element options
4. Search and select the desired Slave element from the Available elements table.

5. Press **Bind item** to link the Slave element to the Master element.

6. Press **Apply** to accept and save the changes.

**Note:** At the available elements table, the Slave element can also be linked by right click on the element and selecting the option **Link the item.**

**Bind master item**

Some times one device should be represented in the project using different elements, power and control subsystem and auxiliary subsystems. All these elements should be always considered as one device. For this reason QelectroTech works with Master and Slave elements which are linked using cross references.

A Master element can be linked to a Slave element as follow:
Fig. 254: Figure: QEelectroTech cross reference tab element properties
1. Select the **Slave element** which should be linked from the project collection or from the workspace.

2. Right click on the selected **element** and choose the option **Edit the element**.

![QElectroTech element options](image)

Fig. 255: Figure: QElectroTech element options

3. Display the **Cross-reference (Slave)** tab from the element editor PopUP window.

4. Search and select the desired **Master element** from the available master elements table.

5. Right click on the **Master element** and select the option **Link the item** to link the Master element to the **Slave element**.

6. Press **Apply** to accept and save the changes.

**Untie slave item**

Some times is necessary to delete previous work, QElectroTech allows breaking/deleting links between elements (cross references).

A **Slave element** can be unlinked from a **Master element** as follow:

1. Select the **Master element** which should be unlinked from the project collection or from the workspace.

2. Right click on the selected **element** and choose the option **Edit the element**.

3. Display the **Cross-reference (Master)** tab from the element editor PopUP window.

4. Search and select the desired **Slave element** from the **Element related** table.

5. Press the **Untie item** button ![Untie item](image) to unlink the **Slave element** from the **Master element**.

---

1.8. **Schema**
Fig. 256: Figure: QElectroTech cross reference tab element properties

Fig. 257: Figure: QElectroTech cross reference tab element properties
Fig. 258: Figure: QElectroTech element options

Fig. 259: Figure: QElectroTech cross reference tab element properties
6. Press **Apply** to accept and save the changes.

**Note:** The Slave element can also be unlinked by right click on the element and select the option **Unlink the item**.

---

**Fig. 260:** Figure: QElectroTech cross reference tab element properties

---

**Untie master item**

Some times is necessary to delete previous work, QElectroTech allows breaking/deleting links between elements (cross references).

A Master element can be unlinked from a Slave element as follow:

1. Select the Slave element which should be unlinked from the project collection or from the workspace.
2. Right click on the selected element and choose the option **Edit the element**.
3. Display the **Cross-reference** (Slave) tab from the element editor PopUP window.
Fig. 261: Figure: QElectroTech element options

Fig. 262: Figure: QElectroTech cross reference tab element properties
4. Press **Unlink** to delete the cross reference with the **Master element**.

5. Press **Apply** to accept and save the changes.

**Show linked item**

One of the advantages of working with cross references on E-CAE tools like QE electroTech is the possibility to find the linked elements automatically. QE electroTech allows finding a linked element easily.

If the **Master** and **Slave/s** element/s are at the same **folio**, only by placing the mouse at one element, the other/s will be remarked in blue. The linked element/s can also be found from the element properties.

![Cross reference diagram](image)

Fig. 263: Figure: QE electroTech elements cross reference

At the case that the **elements** are at different **folios**, the linked element/s can only be found from the element properties.

**Show slave linked item**

1. Select the **Slave element** which should be linked from the **project collection** or from the **workspace**.
2. Right click on the **element** selected and choose the option **Edit the element**.

3. **Display** the Cross-reference (Slave) tab from the element editor PopUP window
Fig. 264: Figure: QElectroTech element options

Fig. 265: Figure: QElectroTech cross reference tab element properties
4. Search and select the desired Slave element from the Element related table.

5. Right click on the Slave element and select the option Show item to find and display the Master element.

![Cross Reference (slave) tab element properties](image)

**Fig. 266: Figure: QElectroTech cross reference tab element properties**

**Show Master linked item**

1. Select the Slave element from the project collection or from the workspace.

2. Right click on the selected element and choose the option Edit the element.

3. Display the Cross-reference (Slave) tab from the element editor PopUP window

4. Press See the linked item to find and display the Master element.

**1.8.3 Working with conductors**

**Create conductor**

---

**Note:** Before creating a conductor, selecting the auto numbering pattern is necessary. This selection can only be done from Auto Numbering Select panel.
Fig. 267: Figure: QElectroTech element options

Fig. 268: Figure: QElectroTech cross reference tab element properties

1.8. Schema
If the Auto Numbering Select panel is not displayed, it can be displayed from Settings > Display > Auto Numbering Select.

**Manual conductor creation**

To create manually a conductor:

1. Click on the initial terminal from the conductor.
2. Without releasing, move the mouse to the end terminal of the conductor.
3. Once the end terminal is automatically identified by QElectroTech, release the mouse to create the terminal.
Automatic conductor creation

To increase the working efficiency, QElectroTech can create automatically conductors when an element is added to the workspace.

To create automatically a conductor:

1. Check that the icon from the toolbar is selected. If it is not selected, select the icon.
2. Add element to the workspace. Take care that the element is at the right position for the conductor, the initial terminal and the end terminal have to be at the same vertical or horizontal line.

![Figure: QElectroTech automatic conductor creation](image)

Note: If the toolbar is not displayed, it can be displayed from Settings > Display > Tools.

Warning: At the case that the initial and end terminal are different potentials, QElectroTech considers two terminals from the same element as different potentials, QElectrotech will inform you by a warning PopUP window.

![Figure: QElectroTech different potentials warning](image)

Nevertheless, QElectroTech will create the conductor and is responsibility of the designer to take care on deleting the conductor.

Modify conductor

By default QElectroTech draws a conductor minimizing the horizontal and vertical lines. Some times is necessary changing the route of the conductor for a clear understanding of the schema. QElectroTech allows modifying the route.
To modify the route of the conductor:

1. Select the conductor which route should be modified.
2. Press one of the control points, blue points, from the conductor selected.
3. Without releasing the control point, displace the control point horizontally or vertically until desired position.

**Reset conductors**

Once a conductor route has been modified QElectroTech provides the possibility to return to the default route by a simple click.
To reset the route of a conductor, QElectroTech allows realizing the action from the Menu bar, toolbar, workspace or using keyboard shortcut.

**Reset conductor from Menu bar**

1. **Select the conductor** which route should be reseted.
2. Select Edit > Reset conductors menu item to rest the conductor route.

**Reset conductor from toolbar**

1. **Select the conductor** which route should be reseted.
2. Select the icon ![icon](image) from the toolbar to rest the conductor route.

**Note:** If the toolbar is not displayed, it can be displayed from Settings > Display > Tools.

**Reset conductor from workspace**

1. Right click on the conductor which route should be reseted.
2. Select the option **Reset conductors** to rest the conductor route.

**Reset conductor using keyboard shortcut**

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. **Select the conductor** which route should be reseted.
2. Press `Ctrl + k` to rest the conductor route.

**See also:**

For more information about QElectroTech keyboard shortcut, please refers to Menu bar section.

**Define text at conductor**

QElectroTech allows defining and display information text at each conductor.

**Note:** Only multiline conductors allow text definition.

For defining the conductor text:

1. **Select the conductor** which should be edited.
2. Display conductor properties PopUp window.
3. Go to the multiline section of the **Type** tab.
4. Choose the desired parameters for text positioning, text content or formula, text size, etc.
### Fig. 274: Figure: QElectroTech Edit menu

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>Ctrl+Z</td>
</tr>
<tr>
<td>Redo</td>
<td>Ctrl+Y</td>
</tr>
<tr>
<td>Cut</td>
<td>Ctrl+X</td>
</tr>
<tr>
<td>Copy</td>
<td>Ctrl+C</td>
</tr>
<tr>
<td>Paste</td>
<td>Ctrl+V</td>
</tr>
<tr>
<td>Select All</td>
<td>Ctrl+A</td>
</tr>
<tr>
<td>Select none</td>
<td></td>
</tr>
<tr>
<td>Invert selection</td>
<td>Ctrl+I</td>
</tr>
<tr>
<td>Delete</td>
<td>Del</td>
</tr>
<tr>
<td>Rotate</td>
<td>Space</td>
</tr>
<tr>
<td>Choose texts orientation</td>
<td>Ctrl+Space</td>
</tr>
<tr>
<td>Find in the panel</td>
<td></td>
</tr>
<tr>
<td>Edit conductor</td>
<td>Ctrl+E</td>
</tr>
<tr>
<td>Group selected texts</td>
<td></td>
</tr>
<tr>
<td>Reset conductors</td>
<td>Ctrl+K</td>
</tr>
<tr>
<td>Folio properties</td>
<td>Ctrl+L</td>
</tr>
<tr>
<td>Add a column</td>
<td></td>
</tr>
<tr>
<td>Remove a column</td>
<td></td>
</tr>
<tr>
<td>Add row</td>
<td></td>
</tr>
<tr>
<td>Remove a row</td>
<td></td>
</tr>
<tr>
<td>Bring to front</td>
<td>Ctrl+Shift+Home</td>
</tr>
<tr>
<td>Raise</td>
<td>Ctrl+Shift+Up</td>
</tr>
<tr>
<td>Lower</td>
<td>Ctrl+Shift+Down</td>
</tr>
<tr>
<td>Send backward</td>
<td>Ctrl+Shift+End</td>
</tr>
<tr>
<td>Search</td>
<td>Ctrl+F</td>
</tr>
</tbody>
</table>

### Fig. 275: Figure: QElectroTech conductor options
Fig. 276: Figure: QElectroTech multiline conductor text section
5. Choose if the changes should be saved for the conductor selected or also for the rest of conductors with the same potential, conductors with common initial or end terminal.

6. Press OK Button to save and apply the property changes.

See also:
For more information about multiline properties, please refers to conductor type properties section.
For more information about automatic text definition during conductor creation, please refers to project folio properties section.

**Change appearance conductor**

QElectroTech allows changing the conductors appearance, the line style and color can be defined for each conductor.

For changing the conductor appearance:

1. Select the conductor which should be edited.
2. Display conductor properties PopUp window.
3. Go to Appearance tab.
4. Choose the desired parameters for each appearance property.
5. Click or unclick the option Apply properties to all conductors of this potential.
6. Press OK Button to save and apply the property changes.

See also:
For more information about conductor appearance, please refers to Conductor Appearance section.

### 1.8.4 Working with text field

**Insert text field**

**Note:** To insert object to the workspace more easily, the folio grid can be displayed from Display > Display the grid or from the toolbar icon.

The text field can only be added to the workspace by the toolbar.

1. Select the icon from the toolbar to add a rectangle.
2. Click on the workspace place point where the text field should be placed.
3. Write the desired text.
4. Click anywhere from the workspace to top the edition process and save the text content.

**Note:** If the toolbar is not displayed, it can be displayed from Settings > Display > Add.
1.8. Schema 229

Fig. 277: Figure: QElectroTech conductor appearance PopUP window
Edit text field

Edit text field from Menu bar

1. Select the text editor which should be edited.

2. Select **Edit > Edit the selected object** menu item to display the text editor PopUP window.

   ![QElectroTech Edit menu](image.png)

   Fig. 278: Figure: QElectroTech Edit menu

Edit text field by right click

1. Right click on the text editor which should be edited.
2. Select the option **Edit the text field** to display the text editor PopUP window.

![Fig. 279: Figure: QElectroTech text field option](image.png)

**Edit text field using keyboard shortcut**

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Select the text editor which should be edited.

2. Press **Ctrl + e** to display the text editor PopUP window.

**See also:**

For more information about QElectroTech keyboard shortcut, please refer to the Menu bar section.

**Text editor**

QElectroTech works with text as html code. Even so, the user does not need to take care about the html code. Learning html is not necessary to use and add text on the workspace from QElectroTech.

The text editor from QElectroTech provides the possibility to write and format text as it looks, like any other document tools as LibreOffice Write, and the possibility to write and format the text writing html code.

**Rich text tab**

The Rich text tab from the text editor allows the user writing text as will be displayed at the text box and formatting the text using different tools from the top toolbar which define the text color, size, underline, bold style, italic style, etc.
Source tab

The source tab from the text editor allows the user writing html code which defines how the text should be displayed. QElectroTech allows the user writing and/or copying code from an external html code generator at the code box.

Move text

For QElectroTech, the text field is considered as an object similar to the rest (element, line, rectangle, ellipse, picture, etc.). The text can be move arround the workspace using the mouse or the keyboard.

Move text field by mouse

1. Left click on the text field which should be moved.
2. Without releasing, move the mouse to the new desired position.

Move text field by keyboard

1. Select the text field which should be moved.
2. Press the corresponding arrow (Downwards, Rightward, Leftwards or Upwards) to move the text field one grid row or column.

Rotate text

Exist two different ways to rotate the text field on QElectroTech. The text field can be rotated as object or the text orientation can be defined inside the text field object.
Rotate the text field

The text field is considered an object by QEelectroTech, it can be selected, placed and rotated as the elements and pictures.

This means that, as the rest of objects, it can be rotated 90, 180 or 270 degrees.

1. Right click on the text field which should be rotated.

2. Select the option Rotate to rotate the text field object 90 degrees on the clock direction.

See also:

For more information about rotating objects at the workspace, please refers to Rotate object section.

Define text orientation

Defining the orientation of the text only rotates the content from the text field, the option rotate change the orientation of the complete object.

The advantage of choosing the text orientation is the possibility to choose any angle value inside the range -360 ÷ 360 degrees.

1. Right click on the text field which should be oriented.

2. Select the option Choose text orientation to display the text orientation PopUP window.

3. Define the angle of orientation from the text.
Fig. 282: Figure: QELECTROtech text field options

Fig. 283: Figure: QELECTROtech text field options
Fig. 284: Figure: QElectroTech choose orientation PopUP window

4. Press **Accept** to save the changes and close the text orientation PopUP window.

**Insert URL link**

QElectroTech works with text as html code. This property allows the user introducing at the **workspace** anything that is possible with HTM code. This section explains how the user can create an URL link for a text.

**Note:** The URL link is only actived at the PDF version of the document. The link is not actived at the native QElectroTech format.

At the current released version, version 0.7, QElectroTech allows creating an URL link internally or using external html code generators.

**Insert URL link from QElectroTech text editor**

1. Display the **text editor** by editing the desired **text field**.

2. Press the icon **Insert link** from the **Menu bar** for displaying the Insert link PopUP window.

3. Define the text which should be displayed at the **workspace** and the desired **URL** where the link should redirect.

4. Press the button **OK** to close the Insert link PopUP window and add the link to the text field content.

5. Press the button **OK** to save the text field content and close the **text editor**.

**Insert URL link using external html code generators**

At the case that something special should be included or any propertie should be different, QElectroTech allows creating the html source code using an external code generator and later on introduce the code.

1. Display the **text editor** by editing the desired **text field**.

2. Select the source Tab.
Fig. 285: Figure: QElectroTech text editor

Fig. 286: Figure: QElectroTech Insert link PopUP window
Fig. 287: Figure: QElectroTech text editor

Fig. 288: Figure: QElectroTech Text field PopUP window source tab
3. Copy the html code from the html code generator.
4. Press the button **OK** to save the text field content and close the text editor.

**Note:** Many different HTML Table Generator can be found on internet or can be installed at the computer. One internet example is the following:


### 1.8.5 Working with tables

QElectroTech 0.7 does not have any tool or Menu item which creates automatically tables with the number of rows and columns desired. QElectroTech allows importing html text, this is the way to create tables.

1. Select icon **Add textfield** ![Add textfield](image) from the toolbar.
2. Click on the area from the workspace where the table should be created.
3. Right click on text field and choose **Edit the text field** item from the menu.

![Fig. 289: Figure: QElectroTech text field option](image)

4. Choose the **source** tab from the text field editor.
5. Copy the ‘html’ code generated by the HTML Table Generator.
6. Choose the **Rich Text** tab from the text field editor.
7. Fill the headers and cells with the corresponding information.
8. Press **OK** button and the table will be created at the workspace.
Fig. 290: Figure: Source tab text field editor

Fig. 291: Figure: Rich text tab text field editor
Note: If the toolbar is not displayed, it can be displayed from Settings > Display > Add.

The table can be moved and rotated over the folio area like a text field, it is a text field object.

Note: Many different HTML Table Generator can be found on interned or can be installed at the computer. One internet example is the following:


1.8.6 Working with basic objects

In addition to working with elements and conductors, QElectroTech also allows drawing primitive 2D geometries (line, rectangle, ellipse and polygon) at the workspace.

Working with lines

Create line

Note: To draw more easily, the folio grid can be displayed from Display > Display the grid or from the tool bar icon.

The line can only be added to the workspace by the tool bar.

1. Select the icon from the toolbar to add a line.
2. Click on the initial point from the line at the workspace.
3. Click on the end point from the line at the workspace.

Note: If the toolbar is not displayed, it can be displayed from Settings > Display > Add.

Line properties

QElectroTech allows costumize the type of line, the thikness from the line and the color of the line.

With reference to the type of line, QElectroTech allows choosing between the following type of lines:

- Normal
- Dashed
- Dotted
- Dots and dashes
- Dash dot dot
- Custom Dash line
With reference with to the thickness from the line, QElectroTech allows choosing a thickness line between 0.2 and 50 mm (0.2, 0.4, 0.8, 0.6, 0.8, 1, 1.2, 1.4, … , 50).

With reference to the color from the line, QElectroTech allows choosing the color inside the RGB scale range. The color can be chosen by the RGB code or by the HTML color code.

![QElectroTech Color selection PopUP window](image)

**Note:** The position from the line can be locked to prevent involuntary movement. Go to line properties and check the **Lock position** button.

The line properties can be displayed from the Menu bar, by right click on the line, from selection properties panel and using keyboard shortcut.

**Line properties from Menu bar**

1. Select the line which should be edited.
2. Select **Edit > Edit the selected object** menu item to display the line properties PopUP window.

**Line properties by right click**

1. Right click on the line which should be edited.
2. Select the option **Edit the selected object** to display the line properties PopUP window.
<table>
<thead>
<tr>
<th>Menu Item</th>
<th>Keyboard Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>Ctrl+Z</td>
</tr>
<tr>
<td>Redo delete 1 element, 8 conductors</td>
<td>Ctrl+V</td>
</tr>
<tr>
<td>Cut</td>
<td>Ctrl+X</td>
</tr>
<tr>
<td>Copy</td>
<td>Ctrl+C</td>
</tr>
<tr>
<td>Paste</td>
<td>Ctrl+V</td>
</tr>
<tr>
<td>Select All</td>
<td>Ctrl+A</td>
</tr>
<tr>
<td>Select none</td>
<td></td>
</tr>
<tr>
<td>Invert selection</td>
<td>Ctrl+I</td>
</tr>
<tr>
<td>Delete</td>
<td>Del</td>
</tr>
<tr>
<td>Rotate</td>
<td>Space</td>
</tr>
<tr>
<td>Choose texts orientation</td>
<td>Ctrl+Space</td>
</tr>
<tr>
<td>Find in the panel</td>
<td></td>
</tr>
<tr>
<td>Edit the element</td>
<td>Ctrl+E</td>
</tr>
<tr>
<td>Group selected texts</td>
<td></td>
</tr>
<tr>
<td>Reset conductors</td>
<td>Ctrl+K</td>
</tr>
<tr>
<td>Folio properties</td>
<td>Ctrl+L</td>
</tr>
<tr>
<td>Add a column</td>
<td></td>
</tr>
<tr>
<td>Remove a column</td>
<td></td>
</tr>
<tr>
<td>Add row</td>
<td></td>
</tr>
<tr>
<td>Remove a row</td>
<td></td>
</tr>
<tr>
<td>Bring to front</td>
<td>Ctrl+Shift+Home</td>
</tr>
<tr>
<td>Raise</td>
<td>Ctrl+Shift+Up</td>
</tr>
<tr>
<td>Lower</td>
<td>Ctrl+Shift+Down</td>
</tr>
<tr>
<td>Send backward</td>
<td>Ctrl+Shift+End</td>
</tr>
</tbody>
</table>

Fig. 293: Figure: QELECTROTECH Edit menu
Line properties from selection properties panel

1. Select the line which should be edited and the properties from the line will appear at the selection properties panel.

![Selection properties panel]

Fig. 295: Figure: QElectroTech Line properties panel

**Note:** If the properties panel is not displayed, it can be displayed from **Settings > Display > Selection properties**

Line properties using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Select the line which should be edited.
2. Press `Ctrl + e` to display the line properties PopUP window.

**See also:**

For more information about QElectroTech keyboard shortcut, please refers to **Menu bar section**.

Working with rectangles
Create rectangle

Note: To draw more easily, the folio grid can be displayed from Display > Display the grid or from the tool bar icon.

The rectangle can only be added to the workspace by the tool bar.

1. Select the icon from the toolbar to add a rectangle.
2. Click on the initial vertex from the rectangle at the workspace.
3. Click on the end vertex from the rectangle at the workspace.

Note: If the toolbar is not displayed, it can be displayed from Settings > Display > Add.

Rectangle properties

The edges and the internal area from the triangle can be costumized at QElectroTech.

With reference to edges from the rectangle, for QElectroTech the edges are lines. Please refers to the Line properties section for more information.

With reference to the internal area from the rectangle, QElectroTech allows defining the color and how to fill the area (None, Solid or many different types of grid).

Regarding to the color from the rectangle area, QElectroTech allows choosing the color inside the RGB scale range. The color can be choosed by the RGB code or by the HTML color code.

Note: The position from the rectangle can be locked to prevent involuntary movement. Go to rectangle properties and check the Lock position button.

The rectangle properties can be displayed from the Menu bar, by right click on one rectangle edge, from selection properties panel and using keyboard shortcut.

Rectangle properties from Menu bar

1. Select one of the edges from the rectangle which should be edited.
2. Select Edit > Edit the selected object menu item to display the rectangle properties PopUP window.

Rectangle properties by right click

1. Right click on one of the edges from the rectangle which should be edited.
2. Select the option Edit the selected object to display the rectangle properties PopUP window.
Rectangle properties from selection properties panel

1. Select one of the edges from the rectangle which should be edited and the properties from the rectangle will appear at the selection properties panel.

Note: If the properties panel is not displayed, it can be displayed from Settings > Display > Selection properties

Rectangle properties using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Select one of the edges from the rectangle which should be edited.
2. Press Ctrl + e to display the rectangle properties PopUP window.

See also:
For more information about QElectroTech keyboard shortcut, please refers to Menu bar section.

Working with ellipses

Create ellipse
Fig. 297: Figure: QElectroTech Edit menu
Fig. 298: Figure: QElectroTech rectangle selection PopUP window

Fig. 299: Figure: QElectroTech Rectangle properties panel
To draw more easily, the folio grid can be displayed from Display > Display the grid or from the tool bar icon .

The ellipse can only be added to the workspace by the tool bar.

1. Select the icon from the tool bar to add an ellipse.
2. Click on the initial controlling point from the ellipse at the workspace.
3. Click on the end controlling point from the ellipse at the workspace.

If the toolbar is not displayed, it can be displayed from Settings > Display > Add.

### Ellipse properties

The border and the internal area from the ellipse can be customized at QElectroTech.

With reference to border from the triangle, for QElectroTech the border are arcs that can be customized as lines. Please refers to the Line properties section for more information.

With reference to the internal area from the ellipse, QElectroTech allows defining the color and how to fill the area (None, Solid or many different types of grid).

Regarding to the color from the ellipse area, QElectroTech allows choosing the color inside the RGB scale range. The color can be chosen by the RGB code or by the HTML color code.

The position from the ellipse can be locked to prevent involuntary movement. Go to rectangle properties and check the Lock position button.

The ellipse properties can be displayed from the Menu bar, by right click on border from the ellipse, from selection properties panel and using keyboard shortcut.

### Ellipse properties from Menu bar

1. Select the border from the ellipse which should be edited.
2. Select Edit > Edit the selected object menu item to display the ellipse properties PopUP window.

### Ellipse properties by right click

1. Right click on the border from the ellipse which should be edited.
2. Select the option Edit the selected object to display the ellipse properties PopUP window.

### Ellipse properties from selection properties panel

1. Select one the border from the ellipse which should be edited and the properties from the ellipse will appear at the selection properties panel.
Note: If the properties panel is not displayed, it can be displayed from Settings > Display > Selection properties.

**Ellipse properties using keyboard shortcut**

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Select the border from the ellipse which should be edited.
2. Press Ctrl + e to display the ellipse properties PopUP window.

See also:
For more information about QElectroTech keyboard shortcut, please refers to Menu bar section.

**Working with polygons**

**Create polygon**

Note: To draw more easily, the folio grid can be displayed from Display > Display the grid or from the tool bar icon.

The polygon can only be added to the workspace by the tool bar.
<table>
<thead>
<tr>
<th>File</th>
<th>Edit</th>
<th>Project</th>
<th>Display</th>
<th>Settings</th>
<th>Windows</th>
<th>Help</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Ctrl+Z</td>
</tr>
<tr>
<td>Redo</td>
<td>Redo delete 1 element, 8 conductors</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Ctrl+V</td>
</tr>
<tr>
<td>Cut</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Ctrl+X</td>
</tr>
<tr>
<td>Copy</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Ctrl+C</td>
</tr>
<tr>
<td>Paste</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Ctrl+V</td>
</tr>
<tr>
<td>Select All</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Ctrl+A</td>
</tr>
<tr>
<td>Select none</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Invert selection</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Ctrl+I</td>
</tr>
<tr>
<td>Delete</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Del</td>
</tr>
<tr>
<td>Rotate</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Space</td>
</tr>
<tr>
<td>Choose texts orientation</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Ctrl+Space</td>
</tr>
<tr>
<td>Find in the panel</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Edit the element</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Ctrl+E</td>
</tr>
<tr>
<td>Group selected texts</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Reset conductors</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Ctrl+K</td>
</tr>
<tr>
<td>Folio properties</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Ctrl+L</td>
</tr>
<tr>
<td>Add a column</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Remove a column</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Add row</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Remove a row</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Bring to front</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Ctrl+Shift+Home</td>
</tr>
<tr>
<td>Raise</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Ctrl+Shift+Up</td>
</tr>
<tr>
<td>Lower</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Ctrl+Shift+Down</td>
</tr>
<tr>
<td>Send backward</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Ctrl+Shift+End</td>
</tr>
</tbody>
</table>

Fig. 301: Figure: QE ElectroTech Edit menu
Fig. 302: Figure: QElectroTech ellipse selection PopUP window

Fig. 303: Figure: QElectroTech ellipse properties panel
1. Select the icon from the toolbar to add a polygon.

2. Draw connected lines by simple click on the beginning and end point from each line.

3. Doble Click on the end vertex/point from the polygon at the workspace.

**Note:** At everytime from the polygon creation, the previous line can be deleted without stopping the creation process. Right click will delete the previous line without losing all the work.

**Note:** If the toolbar is not displayed, it can be displayed from Settings > Display > Add.

### Polygon properties

The QElectroTech polygon is not necessarily a poligon, the polygon tools allows creating polygons and poly-lines, group of lines connected.

The poly-line is assimilated to a line and the customization possibilities are the same than a line. The initial point and the end point can or cannot be the same point. Please refers to the Line properties section for more information.

At the case that a closed polygon is desired, the **Closed polygon** check button from the polygon properties panel should be selected. At that case, QElectroTech allows the same type of customization than on a rectangle. Please refers to the Rectangle properties section for more information.

**Note:** The a closed polygon is desired but the initial point and the end point are not the same, QElectroTech will create automatically one new line to close the polygon.

The polygon properties can be displayed from the Menu bar, by right click on one polygon edge/line, from selection properties panel and using keyboard shortcut.

### Polygon properties from Menu bar

1. Select one of the edges/lines from the polygon which should be edited.

2. Select Edit > Edit the selected object menu item to display the polygon properties PopUP window.

### Polygon properties by right click

1. Right click on one of the edges/lines from the polygon which should be edited.

2. Select the option **Edit the selected object** to display the polygon properties PopUP window.

### Polygon properties from selection properties panel

1. Select one of the edges/lines from the polygon which should be edited and the properties from the polygon will appear at the selection properties panel.

**Note:** If the properties panel is not displayed, it can be displayed from Settings > Display > Selection properties
<table>
<thead>
<tr>
<th>Menu Item</th>
<th>Keyboard Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>Ctrl+Z</td>
</tr>
<tr>
<td>Redo delete 1 element, 8 conductors</td>
<td>Ctrl+Y</td>
</tr>
<tr>
<td>Cut</td>
<td>Ctrl+X</td>
</tr>
<tr>
<td>Copy</td>
<td>Ctrl+C</td>
</tr>
<tr>
<td>Paste</td>
<td>Ctrl+V</td>
</tr>
<tr>
<td>Select All</td>
<td>Ctrl+A</td>
</tr>
<tr>
<td>Select none</td>
<td></td>
</tr>
<tr>
<td>Invert selection</td>
<td>Ctrl+I</td>
</tr>
<tr>
<td>Delete</td>
<td>Del</td>
</tr>
<tr>
<td>Rotate has orientation</td>
<td>Space</td>
</tr>
<tr>
<td>Choose texts orientation</td>
<td>Ctrl+Space</td>
</tr>
<tr>
<td>Find in the panel</td>
<td></td>
</tr>
<tr>
<td>Edit the element</td>
<td>Ctrl+E</td>
</tr>
<tr>
<td>Group selected texts</td>
<td></td>
</tr>
<tr>
<td>Reset conductors</td>
<td>Ctrl+K</td>
</tr>
<tr>
<td>Folio properties</td>
<td>Ctrl+L</td>
</tr>
<tr>
<td>Add a column</td>
<td></td>
</tr>
<tr>
<td>Remove a column</td>
<td></td>
</tr>
<tr>
<td>Add row</td>
<td></td>
</tr>
<tr>
<td>Remove a row</td>
<td></td>
</tr>
<tr>
<td>Bring to front</td>
<td>Ctrl+Shift+Home</td>
</tr>
<tr>
<td>Raise</td>
<td>Ctrl+Shift+Up</td>
</tr>
<tr>
<td>Lower</td>
<td>Ctrl+Shift+Down</td>
</tr>
<tr>
<td>Send backward</td>
<td>Ctrl+Shift+End</td>
</tr>
</tbody>
</table>

Fig. 304: Figure: QE ElectroTech Edit menu
Fig. 305: Figure: QELECTROTECH polygon selection PopUP window

Fig. 306: Figure: QELECTROTECH Polygon properties panel
Polygon properties using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Select one of the edges/lines from the polygon which should be edited.
2. Press Ctrl + e to display the polygon properties PopUP window.

See also:
For more information about QElectroTech keyboard shortcut, please refer to Menu bar section.

Add new point to polygon

1. Right click on the place from the edges/lines of the polygon where the new point should be created.
2. Select the option Add a point to create the new point at the polygon.

Delete point to polygon

1. Right click on the point from the polygon which should be deleted.
2. Select the option Delete this point to delete the point from the polygon.

1.8.7 Working with pictures

QElectroTech allows adding and working with pictures at the folios. The format from the picture should be PNG, JPG, JPEG, SVG or Bitmap.

Add picture

1. Select icon Add a picture from the toolbar to open the search file PopUP window.
Fig. 308: Figure: QElectroTech polygon selection PopUP window

Fig. 309: Figure: Cover Arduino project
2. Select the picture at the corresponding directory.
3. Select **Open** button to add the picture.
4. Left click on the **workspace** area where the picture should be placed.

**Note:** If the toolbar is not displayed, it can be displayed from **Settings > Display > Add.**

**Resize picture**

1. Right click on the picture.
2. Select the option **Edit the image** to display the picture editor. 2. Choose the scale desired. 3. Press **Apply** button to change the size of the picture.

![Image size](image.png)

Fig. 310: Figure: QElectroTech picture editor

**Note:** The picture editor can also be displayed with double click on the picture.

**Move picture**

1. Left click from the mouse on the picture.
2. Move the picture without releasing the button.

**Note:** The position from the picture can be locked to prevent involuntary movement. Go to picture editor and check the **Lock position** button.

**1.8.8 Select objects from workspace**

**Select one object**

At QElectroTech, one object (**elements**, **conductors**, **text fields**, **basic objects** and **pictures**) from the **workspace** can be selected by a simple left click on the object.
Fig. 311: Figure: QElectroTech schema
Select multiple objects

As many CAD tools, many objects (elements, conductors, text fields, basic object and pictures) from QElectroTech workspace can be selected at the same time.

Select multiple objects using keyboard and mouse

QElectroTech allows selecting multiple objects from the workspace, graphical area, combining the use of the keyboard and mouse.

1. Select the first object.
2. Press Ctrl.
3. Select the rest of objects without releasing Ctrl.

Select multiple objects by selecting area

QElectroTech allows selecting all objects from an area using the mouse to select the desired area.

1. Left click on the initial point from the rectangular area to be selected and displace the mouse without releasing the button.
Fig. 313: Figure: QElectroTech selecting on workspace
Select all objects

QElectroTech allows selecting all objects from the workspace, all objects from the activated folio, at the same time. All objects can be selected from Menu bar, workspace or using the corresponding keyboard shortcut.

Select all objects from Menu bar

1. Select **Edit > Select all** to select all objects from the activated folio.

<table>
<thead>
<tr>
<th>Menu Item</th>
<th>Keyboard Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>Ctrl+Z</td>
</tr>
<tr>
<td>Redo</td>
<td>Ctrl+V</td>
</tr>
<tr>
<td>Cut</td>
<td>Ctrl+X</td>
</tr>
<tr>
<td>Copy</td>
<td>Ctrl+C</td>
</tr>
<tr>
<td>Paste</td>
<td>Ctrl+V</td>
</tr>
<tr>
<td>Select All</td>
<td>Ctrl+A</td>
</tr>
<tr>
<td>Select none</td>
<td>Ctrl+I</td>
</tr>
<tr>
<td>Invert selection</td>
<td></td>
</tr>
<tr>
<td>Delete</td>
<td>Del</td>
</tr>
<tr>
<td>Rotate</td>
<td>Space</td>
</tr>
<tr>
<td>Choose texts orientation</td>
<td>Ctrl+Space</td>
</tr>
<tr>
<td>Find in the panel</td>
<td></td>
</tr>
<tr>
<td>Edit the element</td>
<td>Ctrl+Enter</td>
</tr>
<tr>
<td>Group selected texts</td>
<td></td>
</tr>
<tr>
<td>Reset conductors</td>
<td>Ctrl+K</td>
</tr>
<tr>
<td>Folio properties</td>
<td>Ctrl+L</td>
</tr>
<tr>
<td>Add a column</td>
<td></td>
</tr>
<tr>
<td>Remove a column</td>
<td></td>
</tr>
<tr>
<td>Add row</td>
<td></td>
</tr>
<tr>
<td>Remove a row</td>
<td></td>
</tr>
<tr>
<td>Bring to front</td>
<td>Ctrl+Shift+Home</td>
</tr>
<tr>
<td>Raise</td>
<td>Ctrl+Shift+Up</td>
</tr>
<tr>
<td>Lower</td>
<td>Ctrl+Shift+Down</td>
</tr>
<tr>
<td>Send backward</td>
<td>Ctrl+Shift+End</td>
</tr>
</tbody>
</table>

Fig. 314: Figure: QElectroTech Edit menu
Select all objects from workspace

As many other CAD tools, QE lectroTech allows selecting all elements from the workspace, graphical area, using the mouse.

1. Left click on the initial point from the rectangular area to be selected and displace the mouse without releasing the button.

Fig. 315: Figure: QE lectroTech selecting on workspace

Select all objects using keyboard shortcut

QE lectroTech allows using keyboard shortcut to increase the working efficiency.

1. Press Ctrl + a to select all objects from the activated folio.

See also:
For more information about QE lectroTech keyboard shortcut, please refers to Menu bar section.

Select none

To be sure that any object is selected before any action, QE lectroTech provides the option to unselect all objects from the workspace. This option is useful for avoiding undesired changes such as the properties from an element.
The Unselection of objects can only be done from the Menu bar.

1. Select **Edit > Select none** to unselect all selected object.

![QElectroTech Edit menu](image)

Fig. 316: Figure: QElectroTech Edit menu

**Invert the selection**

Some times is easier to select the objects from the workspace which are not interested for the desired action than the objects which should be selected. For this reason, QElectroTech provides the option to invert the selection.

Inverting the selection can be done from Menu bar or using the corresponding keyboard shortcut.
Invert selection from Menu bar

1. ‘Select the object/s’ from the activated folio which are not interested for the desired action. 2. Select Edit > Invert selection to invert the selection.

<table>
<thead>
<tr>
<th>File</th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>Ctrl+Z</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Redo</td>
<td>Ctrl+Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cut</td>
<td>Ctrl+X</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Copy</td>
<td>Ctrl+C</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Paste</td>
<td>Ctrl+V</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Select All</td>
<td>Ctrl+A</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Select none</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Invert selection</td>
<td>Ctrl+I</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Delete</td>
<td>Del</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Rotate</td>
<td>Space</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Choose texts orientation</td>
<td>Ctrl+Space</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Find in the panel</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Edit the element</td>
<td>Ctrl+E</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Group selected texts</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Reset conductors</td>
<td>Ctrl+K</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Folio properties</td>
<td>Ctrl+L</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Add a column</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Remove a column</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Add row</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Remove a row</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Bring to front</td>
<td>Ctrl+Shift+Home</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Raise</td>
<td>Ctrl+Shift+Up</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Lower</td>
<td>Ctrl+Shift+Down</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Send backward</td>
<td>Ctrl+Shift+End</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Fig. 317: Figure: QElectroTech Edit menu

Invert selection using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Select the object/s from the activated folio which are not interested for the desired action.
2. Press Ctrl + i to invert the selection.

See also:
For more information about QElectroTech keyboard shortcut, please refers to Menu bar section.

1.8.9 Copy object

QElectroTech allows copying objects (elements, conductors, text fields, basic objects and pictures) to paste them later on at the same folio or at different folio and/or project.

Note: Multiples objects can be copied at the same time selecting multiple objects.

Warning: The elements would suffer data loss if the intention is to paste them at different project.

Copying objects can be done from the Menu bar, toolbar, by right click on the object and from using the corresponding keyboard shortcut.

Copy object from Menu bar

1. Select the object/s which should be copied.
2. Select Edit > Copy menu item to copy the object.

Copy object from toolbar

1. Select the object/s which should be copied.
2. Select the icon from the toolbar to copy the object.

Note: If the toolbar is not displayed, it can be displayed from Settings > Display > Tools.

Copy object by right click

1. Right click on the object which should be copied.
2. Select the option Copy to copy the object.

Copy object using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Select the object/s which should be copied.
2. Press Ctrl + c to copy the object.

See also:
For more information about QElectroTech keyboard shortcut, please refers to Menu bar section.
Fig. 318: Figure: QElectroTech Edit menu
1.8.10 Cut object

QE ElectroTech allows cut objects (elements, conductors, text fields, basic object and pictures) to paste them later on at the same folio or at different folio and/or project.

Note: Multiples objects can be cut at the same time selecting multiple objects.

Warning: The elements would suffer data loss if the intention is to paste them at different project.

Cutting objects can be done from the Menu bar, toolbar, by right click on the object and using the corresponding keyboard shortcut.

Cut object from Menu bar

1. Select the object/s which should be cut.
2. Select Edit > Cut menu item to cut the object.

Cut object from toolbar

1. Select the object/s which should be cut.
2. Select the icon from the toolbar to cut the object.

Note: If the toolbar is not displayed, it can be displayed from Settings > Display > Tools.
Fig. 320: Figure: QElecTech Edit menu
Cut object by right click

1. Right click on the object which should be cut.
2. Select the option **Cut** to cut the object.

![Cut object by right click PopUP window](image)

Fig. 321: Figure: QEElectroTech right click PopUP window

Cut object using keyboard shortcut

QEElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Select the object/s which should be cut.
2. Press **Ctrl + x** to cut the object.

See also:
For more information about QEElectroTech keyboard shortcut, please refer to Menu bar section.

1.8.11 Paste object

QEElectroTech allows paste objects (elements, conductors, text fields, basic object and pictures) which has already been copied or cut at the same folio or at different folio and/or project.

**Note:** Multiples objects can be pasted at the same time copying or ‘cutting’ multiple objects.

**Warning:** The elements would suffer data loss if the intention is to paste them at different project.

Pasting objects can be done from the **Menu bar, toolbar**, by right click at the **workspace** and using the corresponding keyboard shortcut.
Paste object from Menu bar

1. Select **Edit > Paste** menu item to paste at the active folio an object copied or cut previously.

![QElectroTech Edit menu]

Fig. 322: Figure: QElectroTech Edit menu

Paste object from toolbar

1. Select the icon ![icon] from the toolbar to paste at the active folio an object copied or cut previously.

**Note:** If the toolbar is not displayed, it can be displayed from **Settings > Display > Tools.**
Paste object by right click

1. Right click at the workspace area where the object should be pasted.
2. Select the option Paste to paste an object copied or cut previously.

Paste object using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Press Ctrl + v to paste at the active folio an object copied or cut previously.

See also:
For more information about QElectroTech keyboard shortcut, please refers to Menu bar section.

1.8.12 Multiple paste

For making more efficient the schema creation, QElectroTech provides the feature multiple paste. This feature allows copy and paste one or more objects automating some object definition actions.

As a difference to the standard copy and paste feature, the multiple paste feature provides the following options:

- Copy and paste an object (elements, conductors, text fields, etc.) multiple times in one action.
- Use QElectroTech auto-connection feature for element terminals which are at the same horizontal or vertical line.
- Self-numbering of the copied element/s, the standard copy feature does not allow using auto-numbering patterns.
- Self-numbering of the copied/created conductor/s, the standard copy feature does not allow using auto-numbering patterns.

To copy and paste multiple times on or more object:

1. Select the object/s which should be copied.
2. Right click on the selected object/s.
Fig. 324: Figure: QElectroTech multiple paste

Fig. 325: Figure: QElectroTech element right click PopUP window
3. Select the option **Multiple paste** to display the multiple paste PopUP window.

![Multiple paste PopUP window](image)

Fig. 326: Figure: QElectroTech multiple paste PopUP window

4. Define the $x$ and $y$ offset between original and copy.
5. Define the number of copies desired.
6. Click the desired options about **Auto-connection**, **Self-numbering of elements** and **Self-numbering of conductors**.
7. Press **OK** Button to close the multiple paste PopUP window and create the copies.

### 1.8.13 Delete object

Choosing the correct elements, conductors, text fields, etc. from the beginning is always nice, even so, QElectroTech allows deleting all type of object that can be add to the folios (elements, conductors, text fields, basic objects and pictures).

**Note:** Multiple objects can be deleted at the same time selecting multiples object.

Deleting objects can be done from the **Menu bar**, **toolbar**, by right click on the object and using the corresponding keyboard shortcut.

#### Delete object from Menu bar

1. Select the object/s which should be delete.
2. Select **Edit > Delete** menu item to delete the object.

#### Delete object from toolbar

1. Select the object/s which should be deleted.
2. Select the icon ![Trash Can](image) from the toolbar to delete the object.

**Note:** If the toolbar is not displayed, it can be displayed from **Settings > Display > Tools**.
<table>
<thead>
<tr>
<th>File</th>
<th>Edit</th>
<th>Project</th>
<th>Display</th>
<th>Settings</th>
<th>Windows</th>
<th>Help</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>Ctrl+Z</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Redo delete 1 element, 8 conductors</td>
<td>Ctrl+Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cut</td>
<td>Ctrl+X</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Copy</td>
<td>Ctrl+C</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Paste</td>
<td>Ctrl+V</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Select All</td>
<td>Ctrl+A</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Select none</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Invert selection</td>
<td>Ctrl+I</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Delete</td>
<td>Del</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Rotate</td>
<td>Space</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Choose texts orientation</td>
<td>Ctrl+Space</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Find in the panel</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Edit the element</td>
<td>Ctrl+E</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Group selected texts</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Reset conductors</td>
<td>Ctrl+K</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Folio properties</td>
<td>Ctrl+L</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Add a column</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Remove a column</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Add row</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Remove a row</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Bring to front</td>
<td>Ctrl+Shift+Home</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Raise</td>
<td>Ctrl+Shift+Up</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Lower</td>
<td>Ctrl+Shift+Down</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Send backward</td>
<td>Ctrl+Shift+End</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Fig. 327: Figure: QElecroTech Edit menu
Delete object by right click

1. Right click on the object which should be deleted.
2. Select the option **Delete** to delete the object.

![Right click PopUP window](image)

Fig. 328: Figure: QElectroTech right click PopUP window

Delete object using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Select the object/s which should be deleted.
2. Press `delete` to delete the object.

See also:

For more information about QElectroTech keyboard shortcut, please refers to Menu bar section.

1.8.14 Rotate object

QElectroTech allows choosing the orientation from many object which are represented at the folio. The objects which orientation can be choosed are the following:

- Elements-
- Pictures.
- Text fields-

QElectroTech does not allow all orientations for the objects mentioned before, only 4 different orientations are possible: 0, 90, 180 and 270 degrees.

**Note:** QElectroTech only offers the possibility to rotate 90 degrees on the clock direction.

- To rotate 180 degrees the actions should be repited once.
- To rotate 270 degrees the actions should be repited twice.
Note: Multiples objects can be rotated at the same time selecting multiples object

Rotating objects can be done from Menu bar, toolbar, by right click on the object and using the corresponding keyboard shortcut.

**Rotate object from Menu bar**

1. Select the object which should be rotated.
2. Select Edit > Rotate menu item to rotate the object.

**Rotate object from toolbar**

1. Select the object which should be rotated.
2. Select the icon from the toolbar to rotate the object.

Note: If the toolbar is not displayed, it can be displayed from Settings > Display > Tools.

**Rotate object by right click**

1. Right click on the object which should be rotated.
2. Select the option Rotate to delete the object.

**Rotate object using keyboard shortcut**

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Select the object which should be rotated.
2. Press Space to rotate the object.

See also:

For more information about QElectroTech keyboard shortcut, please refers to Menu bar section.

### 1.8.15 Working with layers

Overlap of elements or pictures may occur at workspace, QElectroTech allows defining the level order from elements and pictures at each folio.

QElectroTech allows the actions defined bellow:
### Fig. 329: Figure: QElectroTech Edit menu

<table>
<thead>
<tr>
<th>Item</th>
<th>Key Combination</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>File</strong></td>
<td></td>
</tr>
<tr>
<td>Undo</td>
<td>Ctrl+Z</td>
</tr>
<tr>
<td><strong>Edit</strong></td>
<td></td>
</tr>
<tr>
<td>Cut</td>
<td>Ctrl+X</td>
</tr>
<tr>
<td>Copy</td>
<td>Ctrl+C</td>
</tr>
<tr>
<td>Paste</td>
<td>Ctrl+V</td>
</tr>
<tr>
<td>Select All</td>
<td>Ctrl+A</td>
</tr>
<tr>
<td>Select none</td>
<td></td>
</tr>
<tr>
<td>Invert selection</td>
<td>Ctrl+I</td>
</tr>
<tr>
<td><strong>Project</strong></td>
<td></td>
</tr>
<tr>
<td>Delete</td>
<td>Del</td>
</tr>
<tr>
<td>Rotate</td>
<td>Space</td>
</tr>
<tr>
<td>Choose texts orientation</td>
<td>Ctrl+Space</td>
</tr>
<tr>
<td>Find in the panel</td>
<td></td>
</tr>
<tr>
<td><strong>Display</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Settings</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Windows</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Help</strong></td>
<td></td>
</tr>
<tr>
<td>Group selected texts</td>
<td>Ctrl+E</td>
</tr>
<tr>
<td>Reset conductors</td>
<td>Ctrl+K</td>
</tr>
<tr>
<td>Folio properties</td>
<td>Ctrl+L</td>
</tr>
<tr>
<td>Add a column</td>
<td></td>
</tr>
<tr>
<td>Remove a column</td>
<td></td>
</tr>
<tr>
<td>Add row</td>
<td></td>
</tr>
<tr>
<td>Remove a row</td>
<td></td>
</tr>
<tr>
<td>Bring to front</td>
<td>Ctrl+Shift+Home</td>
</tr>
<tr>
<td>Raise</td>
<td>Ctrl+Shift+Up</td>
</tr>
<tr>
<td>Lower</td>
<td>Ctrl+Shift+Down</td>
</tr>
<tr>
<td>Send backward</td>
<td>Ctrl+Shift+End</td>
</tr>
</tbody>
</table>

1.8. Schema
Fig. 330: Figure: QElectroTech right click PopUP window

<table>
<thead>
<tr>
<th>Icon</th>
<th>Action</th>
<th>Definition</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image.png" alt="Icon" /></td>
<td>Bring to front</td>
<td>The element or picture will be at the top and completely visible</td>
<td>Ctrl + Shift + Home</td>
</tr>
<tr>
<td><img src="image.png" alt="Icon" /></td>
<td>Raise</td>
<td>The element or image will be sent one level up</td>
<td>Ctrl + Shift + Up</td>
</tr>
<tr>
<td><img src="image.png" alt="Icon" /></td>
<td>Lower</td>
<td>The element or image will be sent one level down</td>
<td>Ctrl + Shift + Down</td>
</tr>
<tr>
<td><img src="image.png" alt="Icon" /></td>
<td>Send backwards</td>
<td>The element or picture will be at the bottom and probably will be partially covered</td>
<td>Ctrl + Shift + End</td>
</tr>
</tbody>
</table>

Note: The layer level from multiples objects can be defined at the same time selecting multiple objects.

The definition of layer level from each element or picture level can be made from the Menu bar, toolbar, by right click on the object and using the corresponding keyboard shortcut.

**Define object layer from Menu bar**

1. Select the object/s which layer level should be defined.
2. Select Edit from the Menu bar and the desired action.

**Define object layer from toolbar**

1. Select the object/s which layer level should be defined.
2. Select the corresponding icon from toolbar (icons from above table) to realize the desired action.
<table>
<thead>
<tr>
<th>File</th>
<th>Edit</th>
<th>Project</th>
<th>Display</th>
<th>Settings</th>
<th>Windows</th>
<th>Help</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>redo delete 1 element, 8 conductors</td>
<td>Ctrl+Z</td>
<td>Ctrl+V</td>
<td>Ctrl+Y</td>
<td>Ctrl+X</td>
<td>Ctrl+A</td>
</tr>
<tr>
<td>Cut</td>
<td></td>
<td>Ctrl+X</td>
<td>Ctrl+C</td>
<td>Ctrl+V</td>
<td></td>
<td>Ctrl+I</td>
</tr>
<tr>
<td>Copy</td>
<td></td>
<td>Ctrl+C</td>
<td></td>
<td>Ctrl+V</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Paste</td>
<td></td>
<td>Ctrl+V</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Select All</td>
<td></td>
<td>Ctrl+A</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Select none</td>
<td></td>
<td>Ctrl+D</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Invert selection</td>
<td></td>
<td>Ctrl+I</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Delete</td>
<td></td>
<td>Del</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Rotate</td>
<td></td>
<td>Space</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Choose texts orientation</td>
<td></td>
<td>Ctrl+Space</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Find in the panel</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Edit the element</td>
<td></td>
<td>Ctrl+E</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Group selected texts</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Reset conductors</td>
<td></td>
<td>Ctrl+K</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Folio properties</td>
<td></td>
<td>Ctrl+L</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Add a column</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Remove a column</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Add row</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Remove a row</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Bring to front</td>
<td></td>
<td>Ctrl+Shift+Home</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Raise</td>
<td></td>
<td>Ctrl+Shift+Up</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Lower</td>
<td></td>
<td>Ctrl+Shift+Down</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Send backward</td>
<td></td>
<td>Ctrl+Shift+End</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Fig. 331: Figure: QElectroTech Edit menu
Define object layer by right click

1. Select the object/s which layer level should be defined.
2. Right click and select the desired layer definition action.

![QElectroTech element right click items](image)

Fig. 332: Figure: QElectroTech element right click items

Define object layer using keyboard shortcut

As many other tools, QElectroTech is an applications which allows using keyboard shortcut.

1. Select the object/s which layer level should be defined.
2. Press the corresponding keyboard shortcut (keyboard shortcut from above table) to realize the desired action.

See also:
For more information about QElectroTech keyboard shortcut, please refers to Menu bar section.

1.8.16 Search

To find information inside a schema easily, QElectroTech provides the search feature. This feature allows finding automatically Folios, Elements, Conductors and Text fields (plain text) which contains an string at one of the properties.

To find an object which contains an string:

1. Go to search menu.

![QElectroTech search menu](image)

Fig. 333: Figure: QElectroTech search menu
2. Write at the text box from the menu the string which should be search over the project.

3. Press Intro and QEElectroTech will zoom and display the first object from the list of matches at the workspace after the search process.

4. Press button to zoom the next or previous object from the list of matches.

5. Press button to clean the search.

Note: If the search menu is not displayed, it can be displayed from Edit > Search / Replace menu item.

QEElectrotech provides also some advanced properties for searching. Before searching, a filter can be defined to reduce the list of matches according to the following criteria:

- Text fields (Plain text).
- Whole words (Text fields (Plain text), Conductor properties, Element properties, Folio properties)

To create an advanced search:

1. Go to search menu.

2. Press button to display the filter tree.

3. Select the type of text to be searched (Plain text or Whole words) at the combobox from the right side of the text box.

4. Click / unclick the button which selects Case sensitive.

5. From here, follow the steps from the standard search.

1.8.17 Replace

Replace text field content

QEElectroTech provides the feature of searching and replacing text field content automatically. This option allows replacing the complete content from a text field which contains the string searched. The string searched can be the complete text field content or part of the text field content.
Note: If the search menu is not displayed, it can be displayed from Edit > Search / Replace menu item.

To replace text field content over a project:

1. **Search** the string which should be replaced (Ex.: Folio).

![Fig. 335: Figure: QElectroTech search menu](image1)

2. Define the new text content at the replace text box (Ex.: Sheet reserve).

![Fig. 336: Figure: QElectroTech search menu](image2)

3. Select at the objects tree the text field which content should be replaced.

4. Press **Replace all** button to replace the content from the selected text field.

5. Press actualize button to refresh the search.

**Note:** Replace action can also be applied object by object. The button **Replace** will only apply the action to the displayed object at the workspace, the buttons and can be used to display the previous and next text field from the search result.

**Warning:** The replacing feature from QElectroTech replaces the text field content completely. Changing the text field content partly cannot be done.
**Replace folio property**

QElectroTech provides the feature of automatic searching of folios with an specific property for replacing folio properties without the need of opening the folio properties PopUp window.

**Note:** If the search menu is not displayed, it can be displayed from Edit > Search / Replace menu item.

To replace some folio properties:

1. Search the content which should identify the folio from which a property has to be changed.

![QElectroTech search menu](image)

Fig. 337: Figure: QElectroTech search menu

2. Press the Folio button to display the folio properties PopUp window.

3. Fill the text line box from the folio property/ies which should be changed.

   **Note:** QElectroTech also allows deleting and making empty a filled property. Click at the clicked button from the folio property/ies which should be deleted.

4. Press Accept.

5. From the folios found at the search process, select the folios where the replace action have to be applied. The selection can be made at the object tree from the search menu.

6. Press Replace all button to apply the replace action to all selected folios.

**Note:** Replace action can also be applied folio by folio. The button Replace will only apply the action to the displayed folio at the workspace. The buttons and can be used to display the previous and next folio from the search result.

**Replace element property**

QElectroTech provides the feature of automatic searching of element with an specific property for replacing element properties without the need of searching the element manually arround the project.
Fig. 338: Figure: QElectroTech search menu
Note: If the search menu is not displayed, it can be displayed from Edit > Search / Replace menu item.

To replace some element properties:

1. Search the property (Manufacturer, Label, etc.) which identifies the element from which a property has to be changed.

Fig. 339: Figure: QElectroTech search menu

2. Press the Element button to display the element properties PopUp window.

Fig. 340: Figure: QElectroTech search menu
3. Fill the text line box from the element property(ies) which should be changed.

**Note:** QElectroTech also allows deleting and making empty a filled property. Click at the clicked button from the element property(ies) which should be deleted.

4. Press Accept.

5. From the elements found at the search process, select the elements where the replace action have to be applied. The selection can be made at the object tree from the search menu.

6. Press Replace all button to apply the replace action to all selected elements.

**Note:** Replace action can also be applied element by element. The button Replace will only apply the action to the displayed element at the workspace. The buttons and can be used to display the previous and next element from the search result.

### Replace conductor property

QElectroTech provides the feature of automatic searching of conductor with an specific property for replacing conductor properties without the need of searching the conductor manually arround the project.

**Note:** If the search menu is not displayed, it can be displayed from Edit > Search / Replace menu item.

To replace some conductor properties:

1. Search the property (Manufacturer, Lable, etc.) which identifies the conductor from which a property has to be changed.

![Find](image.png)

**Fig. 341:** Figure: QElectroTech search menu

2. Press the Conductor button to display the conductor properties PopUp window.

3. Fill the text line box from the conductor property(ies) which should be changed.
Fig. 342: Figure: QE lectroTech search menu
Note: QElectroTech also allows deleting and making empty a filled property. Click at the clicked button from the conductor property/ies which should be deleted.

4. Press Accept.

5. From the conductors found at the search process, select the conductors where the replace action have to be applied. The selection can be made at the object tree from the search menu.

6. Press Replace all button to apply the replace action to all selected conductors.

Note: Replace action can also be applied conductor by conductor. The button Replace will only apply the action to the displayed conductor at the workspace. The buttons and can be used to display the previous and next conductor from the search result.

Advanced replace

QElectroTech provides the feature of searching and replacing text information automatically.

Warning: QElectroTech only provides the feature of replacing all text field or property content, changing the text fields content or any folio, elements or conductors property partly is not possible.

Note: If the search menu is not displayed, it can be displayed from Edit > Search / Replace menu item.

To replace text information from project objects:

1. Search the text content which should be replaced (Ex.: SIEMENS).

Fig. 343: Figure: QElectroTech search menu

2. Define the new text content at the replace text box (Ex.: SCHNEIDER).

Fig. 344: Figure: QElectroTech search menu
3. Press the folio properties button and select the properties which should be replaced (Ex.: Revision item).

![en/schema/replace/graphics/qet_replace_options_folio.png](en/schema/replace/graphics/qet_replace_options_folio.png)

Fig. 345: Figure: QElectroTech search menu folio properties PopUP window

4. Press the element button and select the properties which should be replaced (Ex.: Manufacturer)

![en/schema/replace/graphics/qet_replace_options_element.png](en/schema/replace/graphics/qet_replace_options_element.png)

Fig. 346: Figure: QElectroTech search menu element properties PopUP window

5. From the objects found at the search process, select the objects where the replace action have to be applied. The selection can be made at the object tree.

6. Press **Replace all** button to apply the replace action.

**Note:** Replace action can also be applied element by element. The button **Replace** will only apply the action to the displayed object at the workspace and the buttons `←` and `→` can be used to display the previous and next object from the search.

### 1.9 Drawing

#### 1.9.1 Design mounting plate

QElectroTech is not only a tool for diagrams and schemas, QElectroTech allows also drawing 2D drawings. Electrical boxes, buttons, switches, screens and any other type of components can be drawn at the workspace.

2D drawings from electrical component can be created at the element editor from QElectroTech as elements. After the creation of component drawings, assembled panel drawings can be created introducing the elements at the workspace from QElectroTech. At the category Graphics from QET collection some common electrical components front views are provided as elements.

**Note:** For more information about how to create elements, please refers to Create or edit element section.
For more information about how to introduce elements at QE electroTech workspace, please refer to Working with element section.

The advantage of drawing mounting plates using QE electroTech and not with a different CAD tool is the possibility to create links between the elements. A link between the elements which represents the electrical component at the schema and the elements which represents the component at the drawing will reduce the future effort; the effort from the manufacturing, installation and maintenance phase of the project.

1.9.2 Design Local Control Panel (LOP)

QE electroTech is not only a tool for diagrams and schemas, QE electroTech allows also drawing 2D drawings. Electrical boxes, buttons, switches, screens and any other type of components can be drawn at the workspace.

2D drawings from electrical component can be created at the element editor from QE electroTech as elements. After the creation of component drawings, assembled panel drawings can be created introducing the elements at the workspace from QE electroTech. At the category Graphics from QET collection some common electrical components front views are provided as elements.

**Note:** For more information about how to create elements, please refer to Create or edit element section.
For more information about how to introduce **elements** at QElectroTech workspace, please refers to Working with element section.

The advantage of drawing control panels using QElectroTech and not with a different CAD tool is the possibility to create links between the **elements**. A link between the **elements** which represents the electrical component at the **schema** and the **elements** which represents the component at the drawing will reduce the future effort; the effort from the manufacturing, installation and maintenance phase of the project.

![Image of control panel example](image)

Fig. 348: Figure: QElectroTech Local Control Panel example

### 1.10 Reports

#### 1.10.1 Project index

A **project** can be a group of **folios**, for this reason the possibility to make index which shows some information about the different **folios** is necessary. QElectroTech allows creating this index as a table in an automatic way. The figure bellow shows how looks the table of folios in QElectroTech.

To create the table of folios automatically, the steps described bellow should be follow.

1. **Select Project > Add a summary** to add a new **folio** in second position of the project tree and create the list of folios.

**Note:** The list of folios can be created at any time and it will be automatically updated if any **folio** is added or deleted. It will also be automatically updated if any folio data is changed (ex.: revision, author, date, etc.)
## Fig. 349: Figure: QElectroTech List of folios

<table>
<thead>
<tr>
<th>Folio</th>
<th>Title</th>
<th>Plans</th>
<th>Location</th>
<th>Rev</th>
<th>Author</th>
<th>Date</th>
</tr>
</thead>
<tbody>
<tr>
<td>1/13</td>
<td>page de garde</td>
<td></td>
<td></td>
<td>TDP</td>
<td>10/03/2014</td>
<td></td>
</tr>
<tr>
<td>2/13</td>
<td>Liste de folios</td>
<td></td>
<td></td>
<td>TDP</td>
<td>10/03/2014</td>
<td></td>
</tr>
<tr>
<td>3/13</td>
<td>Poulpe</td>
<td></td>
<td></td>
<td>TDP</td>
<td>10/03/2014</td>
<td></td>
</tr>
<tr>
<td>4/13</td>
<td>General commande</td>
<td></td>
<td></td>
<td>TDP</td>
<td>10/03/2014</td>
<td></td>
</tr>
<tr>
<td>5/13</td>
<td>Privautes</td>
<td></td>
<td></td>
<td>TDP</td>
<td>10/03/2014</td>
<td></td>
</tr>
<tr>
<td>6/13</td>
<td>Commande</td>
<td></td>
<td></td>
<td>TDP</td>
<td>10/03/2014</td>
<td></td>
</tr>
<tr>
<td>7/13</td>
<td>Coffret de commandes</td>
<td></td>
<td></td>
<td>TDP</td>
<td>10/03/2014</td>
<td></td>
</tr>
<tr>
<td>8/13</td>
<td>Système de furtheres</td>
<td></td>
<td></td>
<td>TDP</td>
<td>10/03/2014</td>
<td></td>
</tr>
<tr>
<td>9/13</td>
<td>Système de furtheres</td>
<td></td>
<td></td>
<td>TDP</td>
<td>10/03/2014</td>
<td></td>
</tr>
<tr>
<td>10/13</td>
<td>Inventaire</td>
<td></td>
<td></td>
<td>TDP</td>
<td>10/03/2014</td>
<td></td>
</tr>
<tr>
<td>11/13</td>
<td>Inventaire</td>
<td></td>
<td></td>
<td>TDP</td>
<td>10/03/2014</td>
<td></td>
</tr>
<tr>
<td>12/13</td>
<td>Chapeau</td>
<td></td>
<td></td>
<td>TDP</td>
<td>27/06/2014</td>
<td></td>
</tr>
<tr>
<td>13/13</td>
<td>Inventaire</td>
<td></td>
<td></td>
<td>TDP</td>
<td>27/06/2014</td>
<td></td>
</tr>
</tbody>
</table>

## Fig. 350: Figure: QElectroTech Project menu

- Project properties
- Add a folio
- Delete this folio
- Clean project
- Add a summary
- Export parts list
- Launch the terminal block creation plugin
1.10.2 Component list

1.10.3 Conductor list

1.10.4 I/O list

1.11 Export and print

1.11.1 Print project

The active project can be printed from Menu bar, toolbar and using the corresponding keyboard shortcut.

**Warning:** Check that the active project is the project that should be printed.

**Print project from Menu bar**

1. Select **File > Print** menu item to open the printing PopUp window.
2. Click **Print to a physical printer** check button.

![Image of printing PopUp window](image)

Fig. 351: Figure: QElectroTech printing PopUp window

3. Press **Ok** Button to open the selection printer PopUp window.
4. Select printer and the preview printing window will be displayed.
5. Select the **folios** which should be printed.
6. Select the printing option.
7. Press **Print** Button.

**Note:**

- If the folio list is not displayed, select the icon ![folio icon] from the toolbar.
- If the printing options panel is not displayed, select the icon ![printer icon] from the toolbar.
Print project from toolbar

1. Select the icon from the toolbar to open the printing PopUP window.
2. Follow the steps defined at the Printing project from Menu bar section.

Note: If the toolbar is not displayed, it can be displayed from Settings > Display > Tools

Print project using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Press Ctrl + p to open the printing PopUP window.
2. Follow the steps defined at the Printing project from Menu bar section.

See also:
For more information about QElectroTech keyboard shortcut, please refer to Menu bar section.

See also:
QElectroTech allows predefining printing settings for reducing the working configuration effort each time that a project have to be printed. Please refer to Printing settings section for more information.

1.11.2 Create a PDF from a project

QElectroTech allows to create a PDF from the active project. The procedure to create a PDF file is similar to the printing procedure.
The active project can be exported to PDF from the Menu bar, toolbar and using the corresponding keyboard shortcut.

**Note:** Check that the active project is the project that should be exported to PDF.

**Warning:** The current version from QelectroTech, version 0.7, does not allow to maintain the element links on the PDF.

### Export project to PDF from Menu bar

1. Select **File > Print** menu item to open the printing PopUP window.
2. Select Print to PDF a file check button.
3. Select the directory where to save the PDF file

![What kind of printing do you wish?](image)

*Fig. 353: Figure: QElectroTech printing PopUP window*

4. Press **Ok** Button to open the preview printing PopUP window.

5. Select the folios that should be printed.
6. Select the printing option.
7. Press **Print** Button.

**Note:**

- If the folio list is not display, select the icon from the toolbar.
- If the print options panel is not display, select the icon from the toolbar.
Export project to PDF from toolbar

1. Select the icon from the toolbar to open the printing PopUP window. The rest of steps to be followed are the same than the exporting procedure from the menu bar.

**Note:** If the toolbar is not displayed, it can be displayed from Settings > Display > Tools

Export project to PDF using keyboard shortcut

QElectroTech allows using keyboard shortcut to increase the working efficiency.

1. Press Ctrl + p to open the printing PopUP window. The rest of steps to be followed are the same than the exporting procedure from the menu bar.

**See also:**
For more information about QElectroTech keyboard shortcut, please refer to Menu bar section.

1.11.3 Export schema

QElectroTech allows exporting the different folios to many type of formats: PNG, JPEG, Bitmap, SVG and DWX.

1. Select **File > Export** menu item to display export PopUP window.

**Note:** QElectroTech allows using keyboard shortcut to increase the working efficiency.
1. Press Ctrl + Shift + X to display export PopUP window.

For more information about QElectroTech keyboard shortcut, please refers to Menu bar section.

2. Choose the folios you wish to export and specify their size.

3. Choose target directory and format.

4. Choose rendering options.

5. Press Export button to create the files.

QElectroTech creates one file for each folio choosed at the target directory defined.

See also:
QElectroTech allows predefining export settings for reducing the working configuration effort each time that a project have to be exported. Please refers to Export settings section for more information.

1.11.4 Export component list

QElectroTech allows creating CSV files which contain a list of all element from the project. The CSV file can be opened and edited with tools as LibreOffice Calc.

The different field properties are listed by columns and the elements are ordered by folio.

To export the component list to CSV file:

1. Select Project > Export parts list menu item to open the PopUP window.

2. Choose target directory.

3. Press Save button to create the file with extension .csv.
Choose the folios you wish to export and specify their size:

<table>
<thead>
<tr>
<th>Title of folio</th>
<th>Filename</th>
<th>Dimensions</th>
</tr>
</thead>
<tbody>
<tr>
<td>page de garde</td>
<td>1_page_de_garde.png</td>
<td>1050px * 710px</td>
</tr>
<tr>
<td>List of folios</td>
<td>2_list_of_folios.png</td>
<td>1050px * 720px</td>
</tr>
<tr>
<td>Puissance</td>
<td>3_puissance.png</td>
<td>1050px * 710px</td>
</tr>
<tr>
<td>General commande</td>
<td>4_general_commande.png</td>
<td>1050px * 710px</td>
</tr>
<tr>
<td>Preventa</td>
<td>5_preventa.png</td>
<td>1050px * 710px</td>
</tr>
<tr>
<td>Commande</td>
<td>6_commande.png</td>
<td>1170px * 870px</td>
</tr>
<tr>
<td>Coffret de commande</td>
<td>7_coffret_de_commande.png</td>
<td>1050px * 710px</td>
</tr>
<tr>
<td>Signalisation defaults</td>
<td>8_signalisation_defaults.png</td>
<td>1050px * 710px</td>
</tr>
<tr>
<td>bornier puissance</td>
<td>9_bornier_puissance.png</td>
<td>1050px * 710px</td>
</tr>
<tr>
<td>bornier orgenes</td>
<td>10_bornier_orgenes.png</td>
<td>1050px * 710px</td>
</tr>
</tbody>
</table>

Target directory: C:\Program Files\QElectroTech\examples

Format: **PNG (.png)**

- Export fully folio
- Draw the border
- Draw the title block
- Keep conductors colors

Fig. 356: Figure: QElectroTech export PopUP window

Fig. 357: Figure: QElectroTech exporting formats combo box
1.12 Annex

1.12.1 Default QE lectroTech variables

To systematize title block templates and allow auto numbering of elements, conductors and folios; QE lectroTech provides the possibility to work with variables.

The variables are used to define the content of text field and properties from elements, folios and conductors. Depending on the conditions during the creation of the object (folio, element, conductor, etc,) the variable of the text or property field is replaced by a different value.

A property is identified as a string which starts with the symbol %. The default variables provided by ElectroTech can be found at this section.

General project variables

The following variables are global variables which can be used to create title block templates.

- % {projecttitle}: Project title
- % {projectpath}: Project path
- % {projectfilename}: Project file name
- % {saveddate}: File saving date
- % {filename}: Project file name
- % {savedfilename}: Registered file name
- % {savedfilepath}: Saved file path
- % {savedtime}: File saving time
- % {folio-total}: Total number of folios in the project
- % {version}: Software version
- % {machine}: Project functional group name
variables related to folio

The following variables are specific variables for each folio. They can be used to create title block templates.

- `% {folio-id}`: Folio position in the project
- `% {title}`: Folio title
- `% {author}`: Folio author
- `% {date}`: Folio date
- `% {folio}`: Folio information (Label)
- `% {indexrev}`: Folio revision index
- `% {locmach}`: Name of the location in the project functional group
- `% {previous-folio-num}`: Number previous folio
- `% {next-folio-num}`: Number next folio

variables related to element

The following variables are specific variables for each element. They can be used to create auto numbering patterns.

- `% {F}`: Label from the folio where the element can be found
- `% {f}`: Number from the folio where the element can be found
- `% {M}`: Plant variable from the folio where the element can be found
- `% {LM}`: Location variable of the folio where the element can be found
- `% {l}`: Folio line number from the workspace where the element can be found
- `% {c}`: Folio column number from the workspace where the element can be found
- `% {id}`: Folio position in the project (Schema number)

variables related to conductor

The following variables are specific variables for each conductor. They can be used to create auto numbering patterns.

- `% {F}`: Label from the folio where the conductor can be found
- `% {f}`: Number from the folio where the conductor can be found
- `% {M}`: Plant variable from the folio where the conductor can be found
- `% {LM}`: Location variable of the folio where the conductor can be found
- `% {l}`: Folio line number from the workspace where the conductor can be found
- `% {c}`: Folio column number from the workspace where the conductor can be found
- `% {id}`: Folio position in the project (Schema number)
CHAPTER FOUR

QELECTROTECH HANDBUCH