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Preface

1. About Mandriva Linux

Mandriva Linux is a GNU/Linux distribution supported by Mandriva S.A., which was born on the Internet in
1998. Its main goal was and still is to provide an easy-to-use and friendly GNU/Linux system. Mandriva’s two
pillars are open source and collaborative work.

Note: In April 2005, the Mandrakesoft company changed its name to Mandriva to reflect its merger with Brazil-based
Connectiva. Its core product, Mandrakelinux, became Mandriva Linux.

1.1. Contacting the Mandriva Linux Community

The following are various web links pointing you to the most important Mandriva Linux-related sources. If you
want to know more about the Mandriva company, connect to our web site (http://www.mandriva.com/). You
can also check out the Mandriva Linux distribution web site (http://www.mandriva.com/community/) and all
of its derivatives.

Mandriva Expert (http://www.mandrivaexpert.com/) is Mandriva’s support platform. It offers a new expe-
rience based on trust and the pleasure of rewarding others for their contributions.

We also invite you to subscribe to the various mailing lists (http://www.mandriva.com/community/
resources/newsgroups) where the Mandriva Linux community demonstrates its high spirits and keen debates.

Please also remember to connect to our security page (http://www.mandriva.com/security). It gathers all
security-related material about Mandriva Linux distributions. You will find security and bug advisories, as well
as kernel update procedures, the different security-oriented mailing lists which you can join, etc. This page is
a must for any server administrator or user concerned about security.

1.2. Join the Club!

Mandriva Club is the place where users meet to help each other out, exchange valuable information about
Mandriva Linux, and get informed of the latest Mandriva, Linux and Open Source news. Club subscribers
have privileged access to an even wider array of services.

With your Mandriva ID, you have free access to:

• help (forums, chat, Knowledge Base with tutorials, how-tos, tips and tricks);

• news;

• more Mandriva- and community-contributed content.

As a Club member, you have exclusive access to:

• 50,000 software packages, including commercial software, drivers, and demos;

• super-fast download servers;

• official Mandriva Linux documentation;

• access to expert and eTraining online;

• permanent special discounts at Mandriva Store;

• ... and much more!

Mandriva Club is where you get the best Mandriva Linux experience, learning from others, teaching others,
accessing exclusive features and contributing to the development of Mandriva Linux and Free and Open
Source Software in general.
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1.3. Purchasing Mandriva Products

Mandriva Linux users may purchase products on-line through the Mandriva Store (http://store.mandriva.
com/). You will not only find Mandriva Linux software, operating systems and “live” boot CDs, such as Live, but
also special subscription offers, support, third-party software and licenses, documentation, GNU/Linux-related
books, as well as other Mandriva goodies.

We couldn’t close this section without mentioning the latest innovation from Mandriva. Mandriva Flash is a
pre-installed Mandriva Linux distribution on a simple 2GB USB 2.0 key. You only need to plug the key in to
start your Linux system anywhere, and save and exchange your data on the free 1GB space.

1.4. Contributing to Mandriva Linux

The skills of the many-talented folks who use Mandriva Linux can be very useful in the making of the Mandriva
Linux system:

• Packaging. A GNU/Linux system is mainly made of programs found on the Internet. These need to be pac-
kaged in order to work together.

• Programming. There are many projects directly supported by Mandriva: find the one that most appeals to
you and offer your help to the main developer(s).

• Internationalization. You can help us translate web pages, programs and their respective documentation.

Consult the development projects (http://www.mandriva.com/en/community/contribute/join) page to
learn more about how you can contribute to the evolution of Mandriva Linux.

2. About this User Guide

The aim of this manual is to give you a better understanding of the Mandriva Linux system. In it, we focus on
graphical applications that allow you to perform your daily tasks, such as writing documents and e-mails,
surfing the Web, and listening to music. We also show you how to configure your desktop to your liking,
install software, and to configure the whole system in general.

3. Conventions Used in this Book

3.1. Typing Conventions

Formatted Example Meaning

inode Used to emphasize a technical term.

ls -lta Used for commands and their arguments. (see Commands Synopsis, page 3).

a_file Used for file names. It may also be used for RPM package names.

ls(1) Reference to a man page. To read the page, simply type man 1 ls, in a
command line.

$ ls *.pid Formatting used for text snapshots of what you may see on your screen
including computer interactions, program listings, etc.

localhost Literal data which does not generally fit in any of the previously defined
categories. For example, a key word taken from a configuration file.

OpenOffice.org Defines application names. Depending on context, the application and
command name may be the same but formatted differently. For example, most
commands are written in lowercase, while applications names usually begin
with an uppercase character.

Files Indicates menu entries or graphical interface labels. The underlined letter, if
present, informs you of a keyboard shortcut, accessible by pressing the Alt key
plus the letter in question.
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Formatted Example Meaning

Le petit chaperon rouge Identifies foreign language words.

Warning! Reserved for special warnings in order to emphasize the importance of words.
Read out loud.

Note: Highlights a note. Generally, it gives additional information about a specific area.

Tip: Represents a tip. It could be general advice on how to perform a particular action, or hints about nice features, such
as shortcuts, which could make your life easier.

Warning

Be very careful when you see this icon. It always means that very important information about a specific subject
will be dealt with.

3.2. General Conventions

3.2.1. Commands Synopsis

The example below shows the symbols you will see when the writer describes the arguments of a command:

command <non literal argument> [--option={arg1,arg2,arg3}] [optional arg ...]

These conventions are standard and you will find them elsewhere such as in the man pages.

The “<” (lesser than) and “>” (greater than) symbols denote a mandatory argument not to be copied as is,
which should be replaced according to your needs. For example, <filename> refers to the actual name of a
file. If this name is foo.txt you should type foo.txt, not <foo.txt> or <filename>.

The square brackets (“[ ]”) denote optional arguments, which you may or may not include in the command.

The ellipsis (“...”) means an arbitrary number of arguments may be included.

The curly brackets (“{ }”) contain the arguments authorized at this specific place. One of them is to be placed
here.

3.2.2. Special Notations

From time to time, you will be asked to press, for example, the keys Ctrl-R, which means you need to press
and hold the Ctrl key and tap the R character right after as well. The same applies for the Alt and Shift keys.

Note: We use capital letters to represent the letter keys; this doesn’t mean that you have to type them capitalized.
However, there might be programs where typing R is not the same than typing r. You will be informed when dealing with
such programs.

Regarding menus, going to menu item File→Reload user config (Ctrl-R) means: click on the File text displayed
on the menu (generally located in the upper-left of the window). Then in the pull-down menu, click on the Re-
load user config item. Furthermore you are informed that you can use the Ctrl-R key combination (as described
above) to get the same result.

3
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3.2.3. System-Generic Users

Whenever possible, we use two generic users in our examples:

Queen Pingusa queen This is our default user, used through most examples
in this book.

Peter Pingus peter This user can be created afterward by the system
administrator and is sometimes used to vary the text.

4. Quick Install

If your computer is not already installed with Mandriva Linux you only need the installation media (DVD or
CDs), very basic computer skills (of the “move the pointer and click” kind), common sense, and a few minutes.

Installing Mandriva Linux implies copying the required system and application files on your system and ans-
wering a few questions regarding the system’s configuration and security. Once this is done, all that is left is
to fine tune your system... and enjoy it. We concentrate on installation here. System configuration and security
are subjects we touch upon in the rest of this book.

4.1. Performing the Installation

If your computer already has another operating system installed, you might want to first check the notes in
Co-existing With Other Operating Systems, page 4.

All recent systems can boot from a CD-ROM, configure your computer to boot from the CD, insert the 1st CD
(or the DVD), boot the system and follow the on-screen instructions.

The installer asks you some simple questions regarding the desired language, keyboard layout (if applica-
ble), security level, disk partitioning scheme and package selection; it is usually safe to accept the defaults
proposed.

Please refer to Part III in if you have doubts about what to answer on any given install step.

4.2. Co-existing With Other Operating Systems

You can install Mandriva Linux alongside other operating systems, such as Windows®, or other versions of
GNU/Linux. Have the documentation for those OSes handy and make sure to:

1. Backup existing data. This is always the safest choice to ensure no data is lost.

2. Defragment the disk. This is mostly needed with all variants of Windows®. GNU/Linux file systems have
very little fragmentation, so there is no need to defragment them.

3. Make room for Mandriva Linux. A few GB should be enough. DrakX can resize existing installations of
Windows® and GNU/Linux without the risk of losing data.

Once Mandriva Linux is installed, and the system is restarted, a menu appears from which you can select the
operating system to start: use the arrow keys to highlight the one you want, then press Enter to boot it.
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Using Mandriva Linux on a Daily Basis

The following chapters introduce the applications available under Mandriva Linux for your daily needs.



6



Chapter 1. Using KDE

1.1. Discovering the K Desktop Environment

This chapter introduces the K Desktop Environment (KDE). It discusses where to find your usual folders,
and how to customize your desktop. It also talks about how to search for files and introduces the concept of
KDE sessions. The range of features KDE offers as well as its degree of personalization is huge and you are
encouraged to refer to its integrated help to learn more about this great desktop environment.

1.1.1. The Desktop

Figure 1-1. The KDE Desktop

KDE is very much like any modern desktop. In the figure above, you see the desktop itself with some icons
on it, while the panel sits at the bottom. This figure also introduces something new if you come from the
Windows® world: virtual desktops (see Virtual Desktops, page 8).

Note: Virtual desktops are not an exclusive KDE concept. Other GNU/Linux desktop environments and window managers
also make use of them.

The icons on the desktop represent files, directories, applications, devices, web pages, etc. Almost everything
can be placed on the desktop. Clicking on an icon opens its associated application.

Here are some of your desktop’s default icons, along with a brief explanation for each of them.

Home. Gives access to all your personal files. Under UNIX®-like operating systems (Mandriva Linux
is one of these), every user has a personal directory usually named /home/login_name.

Trash. Gives access to all deleted files (the equivalent of Windows®’ Recycle Bin). Files can also
be deleted without being thrown into the trash can (“direct” file deletion) so some deleted files may not be
accessible through the trash can.

7
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Devices. Gives you access to all the storage media present in the system, fixed and removable: hard
disk partitions, CD/DVD drive, floppy disk drive, ZIP/JAZ drives, USB storage devices, and others. Double
clicking on a device icon opens the corresponding medium.

1.1.2. The Panel

Figure 1-2. The KDE Panel

The panel is the bar which sits at the bottom of your desktop1 and contains the following main components:

The Main Menu. Allows you to access the software installed on your system. It is the equivalent of
Windows®’ Start Menu. Programs are arranged into convenient categories, so you can quickly and easily find
the applications you want to run.

Show Desktop. Use this to minimize all currently opened windows. Pressing it again will restore
the windows to the state they were previously in. Handy when your desktop is full of opened windows and
you want to access, for example, a folder on your desktop.

Desktop Preview and Switching Applet. Displays icons of applications currently opened in the vir-
tual desktops, and makes switching between virtual desktops as easy as one, two, three. See Virtual Desktops,
page 8 for more information.

Various Launchers and Applets. You also find some icons to launch applications (Firefox and KMail for exam-
ple) and other useful applets at the far right: clipboard management, a tasks organizer, network status and
config, world clock, etc.

1.1.3. Virtual Desktops

Think of virtual desktops as having several screens available but with only one monitor. Right click on the
desktop switching applet and select Configure Desktops to add or remove virtual desktops and change desktop
names for more meaningful ones such as Work, Play or Internet.

The Desktop Preview and Switching Applet makes it easier to quickly spot your applications and distinguish
between them. To switch between virtual desktops just click on the desktop number in the desktop switching
applet et voilà !

You can also move application windows from one desktop to another. To do so, simply click an application’s
icon in a virtual desktop, then drag-and-drop it to the desktop you want. Rolling your mouse over a virtual
desktop enables you to preview its content.

When you log in into KDE, the virtual desktop you were in when you closed your last session is re-opened.

1.2. How to Access Folders

If you come from the Windows® world, you may be a bit disoriented at the beginning, but once you know how
folders are organized, you will see how simple it is to find your usual folders, access removable media (CDs,
DVDs, USB storage devices, etc.), and external resources.

1.2.1. Welcome Home!

Double-click on the home folder icon to open the folder containing all your personal files.

1. By default the panel is at the bottom, but it may be placed on any border of the desktop by grabbing it with the mouse.

8
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Figure 1-3. Home Folder Content

Documents

This is where all the documents you create are saved by default. It corresponds to the MyDocuments folder
on a Windows® system.

Download

This is where the files you download from the Internet are stored. It corresponds to the MyDownloads folder
on a Windows® system.

Music

This is where your music is saved by default. It corresponds to the MyMusic folder on a Windows® system.
Please refer to amaroK Audio Player, page 37 to learn about how to play music files.

Pictures

This is where pictures you download from your digital camera are saved. It corresponds to the
MyPictures folder on a Windows® system.

Video

This is where you can store all your videos. It corresponds to the MyVideos folder on a Windows® system.
Please refer to Playing Movies, page 40 to learn about how to watch your videos.

You can create, remove, and rename files and folders inside your personal (Home) folder.

1.2.2. Accessing Other Folders

You can also browse the file system tree by clicking on your Home directory, then on the Root fol-
der on the sidebar. These folders contain all your system configuration settings and the installed
programs, among other things. If you need to change the system’s settings, use the Mandriva Linux

Control Center (refer to Part II in for more information).
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1.2.3. Accessing Removable Media

Mandriva Linux has integrated auto-detection of removable media, which makes accessing and managing CDs,
DVDs and USB storage devices easy. When a removable medium is inserted, a dialog pops up and shows you
a set of actions according to the type of medium.

Figure 1-4. An Audio CD has Been Inserted

Check Always do this for this type of media if you want your selected action to be performed again when
subsequent media of the same type is inserted. If you choose to do so, the dialog won’t show again.

Note: Actions can be configured in the KDE Control Center (choose System+Configuration→Control Center from the
main menu, then open the Peripherals→Storage Media section) and can even be completely disabled.

1.2.4. Accessing Remote Shares

You can easily access shared resources on remote systems on your network through Remote Places. Here’s
how:

1. Open your Home folder

2.
On the left side of the window, click on the System tab.

3. Open Remote Places→Samba Shares→YourWorkgroupName.

4. Select a system, whose content you want to view, and navigate down to the resource that interests you.
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Figure 1-5. Accessing Remote Shares

You can then access the files on the share as if they were located on your own system.

1.3. Personalizing Your Desktop

All your desktop features can be personalized through the KDE Control Center. In this section, we focus on
how to change the look and feel of the desktop and the panel.

1.3.1. Changing Your Desktop’s Appearance

To change the desktop color scheme, choose System+Configuration+KDE+Appearance & Themes→Colors from
the main menu. In the Color Scheme list are predefined color schemes. Select the one you like and click Apply.
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Figure 1-6. Changing KDE’s Color Scheme

You can also define custom color schemes: click on the element you want to change (for example, Active
Window to change the active window colors), then on the color bar. Then, choose the color you like and click
OK to apply it.

Figure 1-7. Changing KDE’s Background Wallpaper

To change the desktop background, choose System+Configuration+KDE+Appearance & Themes→Background
from the main menu. Select the Picture option in the Background section and background scaling, colors and
blending in the Options section.
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Tip: All desktop background settings can be applied on a per-desktop basis using the Setting for desktop pull-down list.
Please note that doing so consumes more memory.

1.3.2. Customizing Your Panel

KDE’s panel is highly customizable. All features, from the panel’s position to its appearance, can be set up to
better suit your preferences. Right click on the panel and choose Configure Panel from the menu.

You can also enrich the panel with the applets you use most frequently to have them handy. Right click on the
panel and select Add Applet to Panel from the menu. Then search and add the applet you want. In the example,
we add a file find and web search applet.

Figure 1-8. Adding an Applet to the Panel

1.4. Searching for Files

You may already know KDE’s web browser: Konqueror. But did you know that it is also a powerful file mana-
ger, that it can help you find files on your disk?

1. Choose Internet+Web Browsers→Konqueror from the main menu to launch Konqueror.

2. Click the Home button in the navigation toolbar to go to your personal folder or to search on your hard
disk (instead of surfing on the Internet).

3. Choose Tools→Find File from the menu to open the search dialog.

4. Enter the name of the file you are looking for. You can use an asterisk (*) to mean “anything” or an
question mark (?) to mean “any single character”.
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Figure 1-9. Performing a Search with Konqueror

5. Click the Find button to launch the search. Results are displayed at the bottom of the search window.

1.5. KDE Sessions

KDE and its applications support sessions. This feature allows the system to save the state of all applications
that are in use when the user logs out of the desktop environment, and to restore them when the user logs
back in.

Note: Please bear in mind that non-KDE applications, and even some KDE ones, may have limited session support. The
degree of session recovery is up to the application, ranging from just opening the application again, to opening it along
with all the files that were open inside that application.

By default, KDE automatically saves sessions whenever you log out of the desktop environment. To change the
default behavior, open the Session Manager (System+Configuration+KDE+ KDE Components→Session Manager
from the main menu), make your choices and click the OK button. The settings are effective the next time you
log into KDE.

1.6. Manipulating the 3D Desktop

If you have configured your desktop to use 3D effects (Configuring a 3D Desktop, page 84), here are some hints
about the most useful features, depending on the type of implementation you have chosen.

1.6.1. Manipulating the 3D Desktop with Compiz

Effect Manipulation or Keyboard
Shortcut

Comment

Show all windows of current
desktop

Move the cursor to the top right
corner of screen. Keyboard
Shortcut: Ctrl-Alt-↑.

All windows are scattered on the
desktop, click the one you wish to
use.
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Effect Manipulation or Keyboard
Shortcut

Comment

Move window to next cube face Grab the window and drag it to
the left or right desktop edge

This rotates the cube and allows
you to place the window on the
next face

Switch face Ctrl-Alt-←− or Ctrl-Alt-−→ Rotates the cube left or right

Show faces Ctrl-Alt-↓ “Flattens” the cube so more than
one face become visible

Make active window transparent Alt-Mouse wheel Control the transparency level of
the window by moving the wheel
up (less transparent) and down
(more transparent). Objects behind
the window appear in
transparency

Table 1-1. 3D Desktop Manipulations with Compiz

1.6.2. Metisse, an Innovative Windows Manipulation System

Figure 1-10. Metisse in Action

Effect Manipulation or Keyboard
Shortcut

Comment

Temporary Window Move Double-click the window title, and
maintain the mouse button down,
then move the window..

Useful to temporarily see what’s
behind the window.

Windows Maximize Click and hold the maximize icon
of the titlebar and then move the
cursor to one of the edges or top
right corner

Windows gets maximized to fit the
edge.

Table 1-2. Basic Windows Manipulations
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Effect Manipulation or Keyboard
Shortcut

Comment

Scale and zoom Click and hold any window
border and choose action

Clicking on an edge or on a
corner (where the mouse pointer
becomes a double-head arrow)
and holding the button makes
appear various options
Resize

Same effect as simply
dragging the window border.

Scale

Allows to actually resize
any element inside the
window, so they are actually
shown bigger or smaller.

Rotate

Rotates the window
according to the chosen axis
while moving the mouse.

Zoom Window In and Out Place the mouse on window title
and use mouse wheel.

The mouse sticks to the title while
the window resize.

Restore Original Window
Appearance

Click the middle button mouse on
the window title.

Useful after you have played too
much.

Table 1-3. Advanced Window Effects

Effect Manipulation or Keyboard
Shortcut

Comment

Show or Hide Pager Press Super key and roll wheel. You can then move your desktop
to another page by clicking on it.

Move Desktop Press key combination
Ctrl-Alt-Arrow key.

You can see the desktop move on
the pager (bottom right).

Zoom Current Desktop: Press Super-F8/F9

Table 1-4. Pager Actions2

Tip: This was just an introduction to Metisse capabilities, for more effects, please check the Metisse page at Man-
driva (http://www.mandriva.com/en/projects/metisse/functionalities) and the official documentation (http:
//insitu.lri.fr/metisse/docs/using.html).

2. This allows you to move from one “desktop” or “page”to another, and zoom through them. Note that the Super key
is generally the Windows key on your keyboard.
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Chapter 2. Using the Internet

2.1. Writing E-mails

KMail is KDE’s mail client. It is both full-featured and easy to use. This section focuses on KMail’s common
features. We encourage you to refer to the integrated help to learn more about its advanced features.

Launch KMail by choosing Internet+Mail→KMail from the main menu.

The first time you run KMail, a wizard appears to help you set up the mail account you will use with KMail.
You only need to enter some connection data. Press the Next button to validate the information you entered
and proceed with the setup.

2.1.1. Mail Configuration

Figure 2-1. Mail Account Type

Select the account type from the proposed list and advance to the next step. Please bear in mind that the POP3
protocol downloads messages to the local computer (they can be kept on the server too), while the IMAP
protocol doesn’t. Both IMAP and POP3 account setups are the same.

Figure 2-2. Your Personal Data

Then you have to provide your account information and fill in your personal data. Note that the name you
input in the Real name field is the one that will appear on your outgoing mails.
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Figure 2-3. Account Credentials

Then you must give the account credentials: enter your login and password. Your ISP or system administrator
should have provided this information together with your e-mail address.

Figure 2-4. Mail Servers

You are finally asked to provide mail server parameters. Again, your ISP or system administrator should
have provided you with the incoming and outgoing mail server information. Outgoing servers are usually
of the smtp.provider.net form. Incoming POP3 servers are usually of the pop.provider.net or
pop3.provider.net forms. Incoming IMAP servers are usually of the imap.provider.net form. The
mail.provider.net form is also common for both incoming and outgoing mail servers.

2.1.2. Mail Client Interface

Folder
List

Message 
View Pane

Message List

Toolbar

Figure 2-5. KMail Client Interface
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Toolbar. Where the main action buttons lie. See table 2-1.

Message List. Where information (subject, date, sender, etc.) about messages stored in the currently selected
folder is displayed.

Message View Panel. Where the contents of the currently selected message are displayed.

Folder List. Where all folders are listed. The default folders are inbox (incoming messages), outbox (unsent
templates), sent-mail (already sent messages), trash (deleted messages), drafts (draft messages) and
templates (templates for writing messages). There is also a special folder named Searches which contains
the results of a search for messages.

The following table shows the most important buttons available in KMail’s toolbar, their equivalent keyboard
shortcuts, and a brief explanation of the functions they provide.

Button Keyboard
Shortcut

Function

Ctrl-N Compose a New Message.

Ctrl-L
Get new messages for all defined e-mail accounts. Keep this button
pressed to display a list of all defined accounts. Select the one you want
to get mail from to retrieve messages only for that account.

R Reply to the author of the selected message. A message-compose
window pops up with some fields already set.

F Forward (send to a third party) the selected message.

Del
Delete the selected messages. Deleted messages are moved to the
Trash folder. You can recover messages moved to the trash folder,
but deletion from the Trash folder cannot be undone: be careful!

Table 2-1. KMail’s Toolbar Buttons

Note: Some of those buttons have a little black arrow (

) at the bottom right corner. An additional menu with related actions can be displayed by pressing the mouse
button a little longer.
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2.1.3. Composing a Message

Message 
Recipients

Message 
Body

Toolbar

Figure 2-6. The Message-Compose Window

Toolbar. This is where the main message composition buttons reside. See table 2-2.

Message Body. The area where you type the content of your message.

Message Recipients. The list of all recipients of this message. The following options are shown:

• To: the principal intended recipient of this message.

• CC (Carbon Copy): not-hidden secondary intended recipient(s) of this message. All recipients have access
to the mail addresses to which this message is sent.

• BCC (Blind Carbon Copy): these recipients are also secondary but are hidden from the other recipients of
this message. No recipients of the message have access to the other mail addresses to which this message is
sent.

The following table shows the buttons which are mostly used in the message-composition window, their
equivalent keyboard shortcuts, and a brief explanation of the functions they provide.

Button Keyboard
Shortcut

Function

Ctrl-Enter Sends the message immediately (your network connection must be
active). A copy of the message is kept in the sent-mail folder.

Queue the message. The message is saved in the outbox folder and is
sent the next time you request mail to be sent (File→
Send Queued Messages).
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Button Keyboard
Shortcut

Function

Attach a file to the message. This function is also accessible through the
Attach→
Attach File menu. A standard file dialog pops up. Select the file you
want to attach and click on Attach. Repeat for multiple files.

Table 2-2. Message-Composition Toolbar Buttons

2.2. Stay Informed With News Feeds

Akregator is a feed reader (or aggregator) which can check on RSS-enabled sites for the latest headlines
or articles. RSS is typically used on blogs and personal Web sites but also on major media sites such as
those from CNN, BBC and Reuters. Choose Internet+News→Akregator from the main menu to launch

it.

Toolbar

News
Channels

Article
List

Article View
Pane

Figure 2-7. Akregator’s Interface

Toolbar. Where the main action buttons lie.

News Channels. It shows a tree of all news feed channels with the channels’ names. A number between
parenthesis indicates the number of unread articles on the channel.

Article List. Where the subject and date of articles for the currently selected news channel are displayed. Select
an article to display it in the Article View Pane.

Article View Pane. Where the currently selected article’s contents are displayed. Some news feeds don’t pro-
vide the article’s contents but a link to them instead. Clicking on that link opens the article on a new tab inside
Akregator.

As an example, let’s add a feed for the CNN World News Feed (http://rss.cnn.com/rss/cnn_world.rss).
Right-click on the All Feeds folder at the top of Akregator’s tree structure and select Add Feed from the pop-
up menu. Type the URL (http://rss.cnn.com/rss/cnn_world.rss) in the Feed URL field and accept
your settings.

Tip:

Look for the RSS icon on a web site, or an RSS link to get the URL for the available RSS feeds.
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Figure 2-8. Feed Properties

Click on
to fetch new articles for the currently selected feed. Click on

to update all news feeds. By default, feeds are updated every 30 minutes. Right-click on a given feed,
then select Edit Feed, put a check mark in the Use a custom update interval option and select the desired

update interval, as shown in figure 2-8.

2.3. Browsing the Web

Today, most people know how to use a web browser. So, this section focuses on describing the characteristics
of Firefox. It also tells you how to install some of the more popular plugins.

Launch Firefox by selecting Internet+Web Browsers→Mozilla Firefox from the main menu.

Bookmarks
Toolbar

Navigation Buttons
and Location Bar

Search Bar

Page Display
Area

Figure 2-9. Firefox’s Interface

The main components of Firefox’s interface are:

Page Display Area. Where the contents of the pages you browse are displayed.

Navigation Buttons and Location Bar. Buttons allowing you to move around pages you visit: go back, go
forward; refresh a page; stop loading page elements; and go to your home page. The location bar is where you
enter a web site’s URL (or a local file using file:// as the protocol part of the URL).

Bookmarks Toolbar. You can hide or display the bookmark bar, and add additional buttons to it. To do so,
simply select View→Toolbars→Customize and select the items you want to add, and click Done.
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Search Bar. Located at the upper-right corner, it allows you to perform web searches, dictionary searches, and
others.

2.3.1. Tab Browsing

One of Firefox’s most convenient features is the ability to browse many websites at the same time, without
being confused with all the open windows. Each website is opened in a new tab. This is called “tabbed brow-
sing”.

Browser Tabs

Figure 2-10. Tabbed Browsing with Firefox

To open a new tab, click File→New Tab. To close a tab, right-click on the tab, and select Close Tab. You can also
click on the cross located at the right of the tab.

Tip: To quickly open new tabs, simply press Ctrl-T as many times as you want tabs. Pressing Ctrl-W closes the currently
open tab.

Firefox enables you to manage tabs easily. You can choose to close, refresh, mark-up all tabs on the fly, or just
the one currently displayed. To do so, right-click on a tab, then select the option you want.

You can also move tabs. Click on a tab, hold the mouse button down and drag it where you want. When you
see a little purple downward-pointing arrow, you can drop the tab to its new location on the tab browsing bar.

Figure 2-11. Moving a Tab

If you want to duplicate a tab, “grab” the tab’s URL (when rolling your mouse over the icon before the URL:
a little hand pointer appears) in the location bar, drag-and-drop it onto an empty tab.

2.3.2. Built-in Search Bar

Firefox has a built-in search bar which allows you to search the web using the most popular search engines. To
perform a search, type the text to be searched for, select the search engine (using the arrow and icon at the left
of the search bar) and press the Enter key. Search results are shown in the Page Display Area.
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Tip: If you are looking for a website, and you cannot remember its exact address, just enter some keywords in the Location
Bar, press the Enter key, and you will be taken to the related website. For example, entering new york times in the
location bar, opens the New York Times website.

2.3.3. Installing Plugins

Plugins are programs which let your browser handle content other than HTML and graphics, such as ani-
mations, streaming audio, Javatm applets, and so on. Firefox’s plugins are stored in the /usr/lib/mozilla/
plugins directory and installing plugins requires root privileges.

Tip: Entering about:plugins in the Location Bar displays a page showing installed plugins and some details about
them.

We look at the procedures to install Javatm and Flash® plugins. If you own a commercial version of Mandriva
Linux, installation is greatly simplified and all the required packages are on the provided media. See “Package
Management”, page 71, for information on how to install RPM packages.

Note: If you have a Mandriva Club user name and password, you may be able to install even newer versions of the
software mentioned here.

2.3.3.1. Javatm

Install the jre RPM package.

You can get the Java plugin on the Java Plug-in Home Page (http://java.sun.com/products/plugin/). Fo-
llow the links to J2SEtm (Java 2, Standard Edition) and download the JRE for Linux. Choose the RPM file for the
Linux Platform, make it executable once the download is finished (chmod 700 jre*.rpm.bin) and execute
it. Accept the license and a “real” RPM will be created.

2.3.3.2. Flash®

You can retrieve the Flash plugin on the Adobe® web site (http://www.adobe.com). Follow the link to the
Flash Player and download and install the RPM. Test the plugin by opening the Flash web site (http://www.
flash.com) URL in the browser.
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Chapter 3. Doing Office Work

Mandriva Linux can be used to perform office work with the OpenOffice.org office suite: we show you how to
write documents with OpenOffice.org Writer, spreadsheets with OpenOffice.org Calc and presentations with
OpenOffice.org Impress. OpenOffice.org tools are Microsoft® Office-compatible, meaning that you can easily
exchange documents between them. We also show you how to print and send faxes from applications.

Tip:

With OpenOffice.org, you can export your documents in PDF format (choosing File→Export as PDF from
the menu). This allows you to publish your documents in the Adobe® Reader® format.

3.1. Writing Documents

Choose Office+Wordprocessors→OpenOffice.org Writer from the main menu to launch OpenOffice.org Writer.

3.1.1. Word Processor Interface

Format Bar

Work
Area

Rulers

Page
Style

Insertion
Point

Figure 3-1. OpenOffice.org Writer’s Main Window

Format Bar. This is the standard format bar for all OpenOffice.org applications which you can use to change
fonts, colors, alignment, etc. of the application’s data.

Rulers. Define the horizontal location of the text and format elements. Rulers are very useful when you want
to establish tabulation and paragraph indentation.

Work Area. Where you enter the content of your document: words, numbers, images, tables, hyperlinks, etc.

Insertion Point. All characters typed on your keyboard will be placed at the left of this point. Also called the
cursor.

Page Style. Many elements define style: page size, margins, text-orientation, etc. Page style can be changed by
choosing Format→Page from the menu. You may use the predefined styles, or define your own.
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3.1.2. Styles

Word processor users often waste a lot of time formatting their documents: changing paragraph alignment,
font family, weight and size, etc. Instead, they should concentrate on document structure and content writing.

Styles provide a structure-centric approach to writing documents with a word processor, while nor-
malizing document formatting and layout, and easily automating the generation and maintenance of
tables of contents (TOC), indexes, references, etc. In OpenOffice.org Writer, styles are handled using

the Stylist. Click on its icon in the Format Bar to open or close it.

When you have a... Then apply the ... style

Chapter Title Heading 1

Section Title Heading 2

Sub-Section Title Heading 3

Sub-Subsection Title Heading 4

Paragraph Text Body, First Line Indent

List Item List

Table 3-1. Suggested Text Styles

Use the styles listed in table 3-1 as a guide. Select the region of the document to apply the style to, and in the
Stylist window, double-click on the style you want to apply to that region.

3.1.3. Lists

Use lists to enumerate the properties of an object (“unordered” or “bullet” list), or the steps to be performed
to do a task (an “ordered” or “numbered” list).

Click on this button to format the selected text into an unordered list. Select the list items and choose
Format→Bullets and Numbering from the menu to select the bullet type from a predefined set.

Clicking on this button formats the selected text into an ordered list. The same rules as for unordered
lists apply to the numbering format.

3.1.4. Page Headers and Footers

By default page headers and footers are common to all pages of a document. Use them to describe aspects of
a document’s content, for example: page number, total number of pages, chapter, section, document title, etc.

Choose Insert+Header→Default from the menu to add a page header to your document, and choose In-
sert+Footer→Default to add a page footer to your document. Just type the header or footer text or use one
or more of the Insert→Fields menu items to compose your headers and footers.

3.2. Calculations and Simulations

Choose Office+Spreadsheets→OpenOffice.org Calc from the main menu to launch OpenOffice.org Calc.
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3.2.1. Spreadsheet Interface

Select
All

Work
Area

Format
BarFormula

Bar

Sheet Changing
Buttons and Tabs

Figure 3-2. OpenOffice.org Calc’s Main Window

Format Bar. This is the standard format bar for all OpenOffice.org applications, you can use it to change fonts,
colors, alignment, etc. of the application’s data.

Formula Bar. Use it to enter, edit or delete formulas inside cells.

Work Area. This is where you enter the data in the spreadsheet: numbers, dates, formulas, images, etc.

Select All. Clicking on this little area at the top left corner of the Work Area selects all cells at once. It’s useful
when you need to make changes which are “global” to the spreadsheet. For example, changing all font sizes
in the cells to 10pts (points).

Sheet Changing Buttons and Tabs. Spreadsheets usually contain more than one sheet. You can use these
buttons to easily navigate through each of the spreadsheet’s sheets. From left to right they are: Go to the first
sheet, Go to the previous sheet, Go to the next sheet and Go to the last sheet. You may also use the tabs to switch
between sheets.

3.2.2. Entering Data

To enter data into a cell, navigate to the cell and type the data in it, pressing the Enter key when you are
finished.

Auto-completion simplifies data entry “guessing” the next cell’s value using the current cell’s value as a base.
It works for any kind of data which can be associated to a simple series of integral numbers.
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Figure 3-3. Simplifying Data Entry Using Auto-Completion

To use auto-completion, put your mouse over the base cell “handle” (the little square located at the bottom
right of the cell border), click on it and drag the cell. The cell values are then shown in a tool-tip (see figure
3-3). Release the mouse button to complete the cells once the desired final value is shown.

Cell data can also be sorted according to different criteria. Select the cells you want to sort and then open the
sort options dialog choosing Data→Sort from the menu. Specify the sort criteria, order and additional options
and click on OK to sort the cells.

Tip: Make sure you also select columns and rows which act as “headers” for the data so they “follow” the sorting of the
data.

3.2.3. Adding Formulas

Formulas can be used to “automate” the spreadsheet. For example, you can run complex simulations. Within
cells, formulas are defined by preceding all cell data with the = sign. Anything else is treated as “static” data.

Operations are expressed using conventional algebraic notation. For example, =3*A25+4*(A20+C34/B34)
divides the value in cell C34 by the value in cell B34, adds the value in A20 to the result, multiplies that by 4
and adds it to 3 times the value of cell A25. Therefore, rather complex expressions can be made using simpler
ones as a base.

OpenOffice.org Calc gives you many pre-defined functions which you can use in your formulas. You can explore
them by choosing the Insert→Function menu.

Tip:

You can also click on the function wizard button for assistance with formula entry.

3.2.4. Charts: Explaining Data in a Simpler Way

When a spreadsheet contains too much information, it becomes difficult to understand how pieces of data
relate to one another: too many numbers and too little meaning. The best way to represent this kind of data is
through a chart.

As in all data-analysis functions, you must select the region you intend to show in the chart. So, select a range
of cells and then choose Insert→Chart from the menu to bring up the chart assistant.
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Make your selections for the chart type, variant, title, axis titles, etc., and then click Create to create and insert
the chart in the spreadsheet (see figure 3-4).

Figure 3-4. A 3D Chart Inside the Spreadsheet

Tip: Charts are “dynamic” in the spreadsheet, which means that when you change data in a cell belonging to a chart,
the chart is automatically updated.

Tip: Double clicking and then right-clicking on an inserted chart brings up a menu showing options to change many
chart parameters.

3.3. Communicating Your Ideas

Choose Office→Presentations→OpenOffice.org Impress from the main menu to launch OpenOffice.org Impress.
A wizard offers you assistance for creating a presentation, but we won’t detail it here. Just create an empty
presentation by clicking Create.
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3.3.1. Presentation Interface

Toolbar

Work
Area

Slide Format Bar

Layout
TemplatesSlide

Navigation

Figure 3-5. OpenOffice.org Impress’ Main Window

Slide Format Bar. There are options for changing the slide shading, background color, line thickness, etc.

Work Area. This is where you compose the slides which build your presentation.

Toolbar. Contains the main tools you use to create your slides: the text, shapes, curves, lines and arrow input;
object rotate, alignment and arrangement; and others.

Tip: Some of these buttons contain a little triangle on one side. Keeping these buttons pressed opens a menu of options
for that tool. For example: filled or hollow rectangles, sharp or round edges, etc.

Layout Templates. Contains a gallery of the templates available. Just click on the template you want to switch
the current slide to it.

Slide Navigation. Displays a list of all the slides comprising the presentation. Slides are displayed as minia-
tures, so you can see what they look like at a glance. To open a slide, search for it in the list, then click on
it.

3.3.2. Adding Slides to Your Presentation

Choose Insert→Slide from the menu to add a new slide, after the current one, with the currently
selected slide template.

Tip: Choose Insert→Duplicate Slide instead if you want to base your new slide’s content on the current one.

3.3.3. Simple Charts

Choose Insert→Chart from the menu to insert a chart diagram into the current slide. A “default” bar
chart is inserted and OpenOffice.org Impress switches to chart mode. Click “outside” the chart area to
return to the slide design mode.

You can drag the border handles to adjust the chart’s size. Double click on the drawn chart, then right-click on
it and select Chart Data to enter the data according to the chart you want to build (see figure 3-6).
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Figure 3-6. Entering Chart Data

Once you have entered the chart’s data, close the data entry window and click on Yes to update the chart in
the slide.

Repeat the double-click / right-click sequence to change the chart’s title, legends, axis, type (2D or 3D, bar,
pie, points, lines, etc.), selecting the appropriate entries from the pop-up menu.

3.3.4. Slide Background

Use the Format→Page menu and click the Background tab to define colors, gradients, patterns, or bitmapped
backgrounds for the slide. Each background type has options of its own. Feel free to explore them.

Note: Using bitmaps for backgrounds increases the file’s size considerably. This could lead to a performance hit, especially
on older systems.

Once the background is selected, you can make that background the default one for all slides. Make your
choice and the slide(s) background(s) will be changed.

3.3.5. Transitions, Animations and Effects

The Slide Show menu has slide transitions, animations and effects options and wizards which let you add
“dynamism” to your presentations. However, you should try not to overuse transitions, animations and effects
because they can be distracting to your audience, turning their attention to the effects themselves instead of
the content of your presentation.

3.3.6. Running Your Presentation

Choose Slide Show→Slide Show, or press the F5 key to run your presentation. The presentation then takes up
the entire screen. Press the Esc key to stop the presentation.

3.4. Going Further

The tutorials available at the Tutorials for OpenOffice (http://www.tutorialsforopenoffice.org) Web site
are helpful if you want to learn more about the use of OpenOffice.org suite’s major components. Check the
tutorials for Writer (http://www.tutorialsforopenoffice.org/category_index/wordprocessing.html),
Calc (http://www.tutorialsforopenoffice.org/category_index/spreadsheet.html), and Impress (http:
//www.tutorialsforopenoffice.org/category_index/presentation.html).

You can also use the inline help which is accessible through the Help→OpenOffice.org Help menu, or
by pressing the F1 key. You are bound to find the answers to your questions.
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3.5. Printing and Faxing from Applications

GNU/Linux applications support a simple printing method based on a program called KPrinter which can even
be used to build PDF files and to send faxes.

3.5.1. Accessing KPrinter

Just click on any application’s print button to invoke the printing interface. In most cases, this is KPrinter.
Select the required print settings and click on the Print button to start printing.

3.5.2. KPrinter’s Interface

KPrinter allows you to set many options for printing your documents1, such as the output device (generally a
physical, local or remote printer), the number of copies, the paper size, the printer resolution, etc.

Figure 3-7. KPrinter Window

Choose the printer using the pull-down list in the Printer section. You can further configure the printer settings
by clicking on the Properties button. Click on the Options >> button at the bottom to set more printing options
and on the System Options button to access global printing configuration.

Tip: Usually, your local printer, the “Print to file” printers (both PDF and Postscript) and the “Fax” printer are listed.
However, if you are in a network, all printers available on the network are listed too, so network printing becomes very
simple.

1. The actual printing options you are able to set depend on the output device you have selected.
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3.5.2.1. Printer Properties

Figure 3-8. Printer Properties Window

One option worth mentioning is Pages per sheet (set to 2 in the example). This allows you to put up to 4 pages
onto a single sheet of paper (or 8 if you can print on both sides). This is a nice feature to save paper when
printing book drafts or other lengthy material which changes often.
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Figure 3-9. Changing Printer Resolution

Click on the Driver Settings tab to change printer-specific options such as the resolution of the printing device.
When you click on the Resolution option the available resolutions are displayed, select the one you want from
the list.

Other settings include printing modes which use less toner or ink (search for something like “Economy Mode”,
“Toner Density” or “Toner Saving”). However, the output is much paler. If this is not available, choosing a
lower resolution often has similar effects.

Tip: Use the Save button to store current settings, making them the defaults for subsequent printing jobs.

3.5.3. Building PDF Files

Select the Print To File (PDF) special printer, enter the file name in the Output file field as shown in figure 3-10,
and click on Print to build a PDF file.
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Figure 3-10. Generating a PDF File

3.5.4. Sending Faxes

3.5.4.1. Through a Modem

The special Send To Fax printer allows you to send the document you are working on directly by fax2. When
you click on the Print button, a dialog similar to the one shown in figure 3-11 appears.

Figure 3-11. Faxing Main Window

The first time you select this function you need to make sure that your fax modem is properly configured,
select Settings→Configure KdeprintFax from the menu. Fill the information under the Personal section with
your name, company and fax number. In the System section make sure that the correct faxing system and its
corresponding parameters are set. An example is shown in figure 3-12.

2. Of course a modem fax must be installed on your computer and connected to the phone line.
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Select the fax number from the list (or add a new entry for the number you are trying to reach) and click
on the Send Fax button, or press the Enter key, to send the fax immediately.

The View Log button (Ctrl-L) shows a window with the fax activity log (check it to make sure your fax
has been sent correctly).

The Address Book button (Ctrl-A) opens the KDE address book to let you select fax numbers to dial.

Figure 3-12. Fax Settings

3.5.4.2. Through an HP Multifunction Device

If you are the owner of an HP multifunction printer (print, scan, fax), and already installed it (see Configuring
Printers with PrinterDrake, page 87), then you have a special virtual printer available that queues documents to
be faxed.

Print to the Fax Queue

1. Using any application, just print your document using the special “Fax printer” (something like
HPOJe6110FAX).

Tip: You can print various documents to have them sent in a single fax session.

2. Launch the HP Send Fax application from the main menu (Office+Communications+Fax→HP Sendfax).

Send the Fax

1. Documents to be faxed

Check the documents you printed appear in the items list.

2. Specify recipients

Click the Address Book button and add new recipients if necessary. Then put a check mark for the recipients
in the Recipients tab.

3. Send Faxes

Just press the Send Fax button when you’re set.
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4.1. Audio Applications

This section introduces the main audio applications you may need for your entertainment: Amarok the music
player, KsCD the CD player, and KMix the sound mixer. They can all be accessed by choosing Multimedia→
Sound from the main menu.

4.1.1. amaroK Audio Player

Amarok is “the” multimedia application to listen to your favorite music. You can organize your music into
collections, get information about recordings such as artist, lyrics, album covers, and more. We only describe
its essential features. You can safely Skip the wizard that appears the 1st time you run Amarok.

Playlist
Browser

Volume
Control

Play
Controls

Figure 4-1. amaroK’s Main Window

figure 4-1 shows the main interface components of Amarok:

Browser. This displays various information depending on the function selected using the tabs at its left.

Playlist. Where the files to be played are shown. Right click on any file to access a menu allowing you to play
the file, remove it from the playlist, etc.

Play Controls. Amarok’s play controls are “standard” audio equipment ones: Previous/Next Tracks, Play,
Stop. The Play button doubles as a Pause button too. Keep the Stop button pressed to select whether to stop
playing immediately, after the current playing song has finished, or after the whole playlist has been played.

Volume Control. Slide it right to increase the volume and left to decrease it. Right click on it and select Equalizer
from the menu that pops up to open an equalizer window where you can enhance bass and treble, and even
select some preset equalization curves.

Note:

Once Amarok is launched, this icon appears on the panel. Right click on it to access its options.

You access Amarok’s main features by clicking on the tabs located at the left of the Browser.

37



Chapter 4. Audio, Movie and Video Applications

The context browser which spreads out on three tabs: Music, Lyrics, and Artist, gives you various
information on the music currently playing.

The Collection browser enables you to view and organize your entire music collection. To use it, you
need to create a collection first: click on the

button, check all the folders you want Amarok to look in for music files, and click OK to start building
the collection.

Figure 4-2. Music Collection

Warning

If you added files from removable devices (such as a USB key or an external hard drive), make sure they are mounted
at the same location as when you originally added them to your collection or Amarok won’t be able to find the
files they contain.

Tip: If you add music files to the folders part of a collection, choose Tools→Rescan Collection from the menu to update
the collection.

The playlist browser lets you roam your playlists and podcasts. If you don’t have any, you can listen
to the Cool-Streams, which is a collection of online radio broadcasts. To create a playlist, simply drag
tunes into the playlist, then select PlaylistSave Playlist As and give it a name. To add new podcasts,

click the Add button, select Podcast and add the podcast’s URL into the dialog.

The File Browser allows you to access and search your local file system. You can use it as an alternative
to Amarok’s Collection.

The Media Device Browser allows you to transfer songs to your portable audio device, such as an
iPod.
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4.1.2. KsCD CD Player

When you insert an audio CD in your CD drive, a window pops up; if you choose to play the CD, the KsCD
player starts up.

Figure 4-3. KsCD’s Main Window

Tip:

Once KsCD is launched, this quick-launch icon appears near the clock. Right click on it, to access KsCD’s
main features.

On the left, you have the typical CD player controls: Play/Pause, Stop, Eject, etc. The ones below alter the pla-
ying order. The CDDB button can be used if your CD information doesn’t appear automatically, it will display
the CD’s title, artist and tracklist information. The Extras button lets you access more advanced configuration
options.

4.1.3. Using the KMix Mixer

KMix is a sound mixing application for KDE. It allows you to fine-tune your sound card’s audio levels through
various sliders.

Note: The availability and type of the controls discussed below depend on your particular sound card. Some controls
may even be absent for your hardware.

When KMix starts, this quick-launch icon appears near the clock. Click on it, then click Mixer to view
the full mixer window.

Figure 4-4. KMix Main Window
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The Output tab controls the volume levels of the sound sources of your sound card. The most important one is
the Master which controls the general volume. By right clicking on each slider, you have extra options such as
Split Channels, Muted Hide, etc. Clicking on the green dot at the top of a column mutes or unmutes that sound
source.

Tip: Clicking on the quick-launch icon pops up a slider which lets you control the master volume and mute all sound.

The Input tab controls the volume levels of the recording sources of your sound card. If you use videoconfe-
rencing software or are a musician, this is where you’ll want to adjust your microphone and your auxiliary
devices. Clicking on the green dot at the top of a column mutes or unmutes that recording source, the red dot
at the bottom enables or disables it.

The Switches tab goes deeper into your sound card’s configuration. Boosting your microphone, using an exter-
nal amplifier: these features are for advanced users who want to really master their sound system. To activate
them, simply click on the dot at the top of each column.

Finally, the horizontal slider enables you to balance your sound between the left and right speakers. Notice
that if your sound card supports separate levels for master’s right and left, the Output’s Master controllers are
be modified following the movement of the horizontal balance slider.

4.2. Playing Movies

4.2.1. Introduction

Most popular video codecs are proprietary, which means that implementing them in a free software applica-
tion requires reverse-engineering techniques. This may limit the availability of such codecs in a free operating
system such as Mandriva Linux.

However, codecs for many of those popular video formats do have their free software equivalents, and are
included with Mandriva Linux, allowing you to play many video file types, except maybe one or two. You may
also need to download a decrypting library to play the so called commercial DVDs.

Warning

The information included here is meant to help Mandriva Linux users who know that, in their country, using these
codecs and plugins is legal. Mandriva does not encourage law violation and you should verify the law(s) which
apply in your case before you download and use these codecs and plugins.

4.2.2. KMPlayer

Choose Multimedia+Video→KMPlayer from the main menu to launch KMplayer.
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Player
Controls

Status

Tool Bar

Display
Area

Figure 4-5. KMplayer’s Interface

Tool Bar. The tool bar has buttons to open media, control playback (Play, Pause, Stop buttons), switch to or
from full-screen display, and others.

Player Controls. The set of the usual VCR controls: Eject, Previous, Play (keyboard shortcut: R), Next, Stop
(keyboard shortcut: S) and Pause (keyboard shortcut: P).

Display Area. Where the movie being played is shown. Press the F key to switch between full-screen and
windowed modes.

Status. Located at the bottom of KMplayer’s window, it shows information about the player status and the
movie being played.

How to Play a Video File

1. Choose Source→Open to display a standard open file dialog.

2. Go to the folder containing the movie you want to play and select it.

3. Click Open. The movie starts playing immediately.

How to Play a DVD

1. Insert the DVD title on the drive.

2. Choose Source→DVD→Open DVD.

3. The disc is read and starts playing immediately.

Note: DVD titles usually have a menu where you can select options such as the language and subtitles for the movie:
browse through the menus with the mouse and select options by clicking on them.
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4.3. CD and DVD Burning

In this section, we concentrate on using K3b to perform common CD burning operations. DVD recording is
very similar to its CD counterpart.

Copyrighted Material. Please note that data, audio, video CD or DVD copying is often forbidden by copyright law. We
assume that if you want to duplicate copyrighted material, it’s because you have the right to do so.

4.3.1. Getting Started

Choose System+Archiving+CD burning→K3b from the main menu to start K3b. figure 4-6 shows K3b’s interface
with a new data project open.

File
Manager

Project
Manager

Toolbar

Figure 4-6. K3b’s Interface

Toolbar. Where buttons to perform common actions lie. See table 4-1.

File Manager. To choose which files to include in the burned CD. Use the left-side tree to navigate the file
system, then drag-and-drop the files you want to include into the Project Manager.

Project Manager. Where all files which will be on the burned CD are shown and handled. Files can be removed
and their location (directory) on the CD can be changed here.

The following table shows the most important buttons available in K3b’s toolbar, their equivalent keyboard
shortcuts, and a brief explanation of the functions they provide.

Note: Not all buttons are enabled at all times. For example, the Save button is not enabled if there is no active project.
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Button Keyboard
Shortcut

Function

Create a New Project. When you click on this button, a list of available
project types is shown:
New Data CD Project creates a data CD; (see Burning Data CDs, page
43); New Data DVD Project creates a data DVD; New Audio CD Project
creates an audio CD; (see Burning Audio CDs (CDDA), page 46); New
Mixed Mode CD Project creates a mixed mode (data+audio) CD; New
Video CD Project creates a digital compressed video CD; New Video DVD
Project creates a video DVD; that is a video DVD that can be played
on any DVD player; New eMovix CD Project creates an eMovix (http:
//movix.sourceforge.net) CD; New eMovix DVD Project creates an
eMovix DVD.

Ctrl-O
Open an existing project. A standard file dialog opens from where you

can choose the project you want to open. Select the project you are
interested in and click Open.

Ctrl-S
Save the current project. A standard file dialog opens where you can

enter the name under which you want to save the current project. Type
the name of the project and click Save.

Copy a CD. To make an exact copy of a CD. It opens a window which
asks for the copy settings. Refer to Duplicating a CD, page 48, for more
information. Please note that you cannot duplicate copyrighted DVD
movies with this function, as they are encrypted.

Erase a CD-RW. To erase re-writable CD medium. It opens a window
which asks for the erase operation settings. Please refer to Erasing
CD-RW media, page 49, for more information.

Format a DVD-RW. To format a re-writable DVD medium. It opens a
window which asks for the formatting settings.

Table 4-1. K3b’s Toolbar Buttons

4.3.2. Burning Data CDs

4.3.2.1. Burning a Set of Files or Directories

Choose File+New Project→New Data CD Project from K3b’s menu . Then drop into the Project Manager the
files and directories you want to include on the CD (see figure 4-7).
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Figure 4-7. Selecting Files and Directories to Include on a CD

Note: Adding directories containing lots of files can take some time. Please be patient and wait until the Adding files
to Project PROJECT_NAME message disappears.

The space occupied by the selected files and directories is shown by a color-coded bar at the bottom of the Pro-
ject Manager, together with the volume expressed in MB and the available MB of the medium’s total capacity.
The bar’s color codes are as follows:

Green

The size of the set is less than that of the selected medium’s capacity (700 MB by default). There are no
capacity-related problems.

Yellow

The size of the set is nearly equal the selected medium’s capacity. If it’s a few MB below the medium’s
capacity, there won’t be any capacity-related problems; if it’s a few MB above, the CD might be written
without problems, but there’s little guarantee of success.

Red

The size of the set exceeds the medium’s capacity by many MB. The CD won’t be burnt properly.

Right clicking on any file or directory in the Project Manager pops up a contextual menu with options to
remove and rename files, create new (empty) directories, etc. Files and directories can be relocated (change the
directory under which you want them to appear) on the CD using drag-and-drop.

Tip: Renaming the top element of the left side tree in the Project Manager changes the CD’s volume name (K3b data
project by default for data CDs).

Insert a recordable medium in the CD burner and click on the Burn button or choose the Project→Burn menu
entry. Then select writing parameters (see figure 4-8) and click the Burn button to start writing the CD.
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Figure 4-8. Setting Writing Parameters

4.3.2.2. Burning an ISO Image

Let’s assume you have downloaded a CD-ROM image from the Internet and you want to burn it on a CD.
Choose Tools→Burn CD Image from K3b’s menu. Click the “open file” button to browse for the CD image file
and select the file in the standard open file dialog. The CD image is then verified and information about it is
displayed (see figure 4-9).
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Figure 4-9. Burn CD Image Options

Once the image is verified, you can insert the recordable medium and click Start to write it to the disc.

Tip: The Speed pull-down list should be set to Auto to make K3b select the fastest possible recording speed supported
by the combination of your CD burner and the currently inserted recordable medium. The “slowest” speed of the two
determines the recording speed.

4.3.3. Burning Audio CDs (CDDA)

By audio CDs, we mean the ones you play in your car or home stereo equipment, not data CDs containing
OGG, MP3 or any other digital audio format files.

K3b supports recording audio CDs from tracks digitized in Wave (*.wav), Ogg Vorbis (*.ogg), and MP3 (*.
mp3) formats. You can mix digital audio formats since K3b decompresses the compressed ones on-the-fly. K3b
can also create digital audio tracks from audio CDs, also known as “ripping” (see Audio CD Extraction or
Ripping, page 47).

Choose File+New Project→New Audio CD Project from K3b’s menu. Select K3b’s File Manager’s filter to Sound
Files, navigate to where the digitized audio files are and then drag the audio tracks and drop them in the
Project Manager (see figure 4-10).
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Figure 4-10. Selecting Audio Tracks to Include on the CD

Use drag-and-drop to move the files up and down the compilation. Once you have the tracks compiled in the
order you want in the Project Manager, you can write them to CD.

4.3.4. Audio CD Extraction or Ripping

Insert the audio CD to rip tracks from and click on the drive in the left side of the File Manager. The CD is
read and, by default, all tracks are marked to be ripped. To remove the check mark from those you don’t want
to rip, right click on them and choose Uncheck Track from the menu that pops up.

Note: Make sure that enough temporary space is available. You can check the available space in K3b’s status bar. Bear
in mind that each minute of CD-quality digitized uncompressed audio takes a bit more than 10MB of disk space.

Click this button to review the different ripping options (see figure 4-11), especially the file naming
ones. Once you’re satisfied with your settings, click Start Ripping.
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Figure 4-11. CD Ripping Options

4.3.5. Duplicating a CD

Figure 4-12. Setting Options to Copy a CD

Choose Tools→Copy CD from the menu. Select the number of copies (1 in the example), whether to remove
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the temporary image or not (yes), the reader and burning devices (automatically set), and click Start. The
“source” CD is then read, an image of it is made, and the “target” CD is written.

4.3.6. Erasing CD-RW media

Figure 4-13. Setting CD-RW Blanking Options

You might want to format your CD-RW media in order to write it with different data. To do so, insert the
medium in the CD burner and choose Tools→Erase CD-RW from the menu (see figure 4-13). The Erase Type
can be set to Fast (the CD-RW is quickly erased in up to 3 minutes); Complete (the CD-RW is completely erased
taking up to 90 minutes); and a few options related to multi-session recording are also available. Click Start to
erase the CD-RW.
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5.1. Graphic Art And Image Manipulation

This chapter concentrates mainly on GIMP, and introduces other interesting applications you may wish to
explore on your own.

5.1.1. GIMP

The GNU Image Manipulation Program (GIMP) is a free software program challenging proprietary applica-
tions such as Adobe® Photoshop® or Corel® Painter™, allowing advanced photo editing tasks such as cropping,
resizing, painting, drawing, modifying colors, etc. Its true beauty lies in its extensibility and its scripting op-
tions, which opens GIMP to full integration in programs and scripts therefore enabling it to act as a mass
production image rendering application.

5.1.1.1. Introduction

5.1.1.1.1. Strengths

For normal users, GIMP will seduce you with its advanced functions for web images and formats. You can
easily create animations and optimize your art for web publishing, and take advantage of GIMP’s extensive
photo manipulation features.

Power users, publishers and document management specialists truly benefit from GIMP through its advanced
scripting capabilities and the programs’ function accessibility.

5.1.1.1.2. Weaknesses

GIMP, like most Free Software graphic design applications, suffers from the fact that prepress standards, such
as PANTONE® Color Systems, are proprietary and closed. So for GIMP, it means that there are no usable imple-
mentations of these standards. Also, because the press world is dominated by Apple-compatible computers
you will have to put in some extra effort to print professionally with GIMP, although it is feasible. Another
limitation is the internal 8 bit-per-channel representation for images, which may not be sufficient for the pro-
fessional digital photographer (16 bits-per-channel would be required).

5.1.1.1.3. Finding More Information

GIMP includes extensive documentation. If the gimp-help package is installed, pressing the F1 key lets you
access a help index for the current “active” item, and pressing Shift-F1 gives you access to contextual help.

On the net, GIMP is a very well documented application and a lot of information is freely available. Please
refer to The GIMP web site (http://www.gimp.org/docs/) for more information about the available GIMP
documentation.

5.1.1.2. Starting GIMP and its Interface

Choose Multimedia+Graphics→Image Editor (GIMP) from the main menu to start GIMP.

Unlike Adobe® Photoshop®, when you open GIMP a few dialogs appear, the main one being the toolbox (see
figure 5-1). It offers GIMP’s core functions and allows you to initiate other tasks.
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Active
Tool

Options

Tools
Buttons

Figure 5-1. GIMP’s Main Interface

5.1.1.3. Concepts

GIMP embraces differences. Therefore, there are usually many ways to achieve the same goal. The following
is a brief description of some concepts and the way they work under GIMP.

5.1.1.3.1. Menu

From GIMP’s main window (called the tool box), you can access the basic program options such as opening a
file, creating a new file, etc.

5.1.1.3.2. Right-clicks

Once an image is opened or created, you can right-click in the image window and access the image’s specific
options such as Close, Save, Save as, Dialogs, Filters, etc. We call this the “image menu” in the following sections.

5.1.1.3.3. Layers, Image Modes and File Formats

Some of the key concepts to grasp in order to truly benefit from an advanced graphic design application like
GIMP are those to do with layers, formats and file modes. Roughly put, digital image editing adds a 4th dimen-
sion: layers. Images are built vertically (as are animations), and each layer has user-defined properties which
determine other tasks that can be accomplished. File mode defines the inner logic of the graphic elements.
Hence, an RGB image allows for different operations and capabilities that you would not have for a gray scale
image. Finally, the file format also impacts on which operations can be done on that file.

If you face difficulties accomplishing any task described below, check those three elements before jumping to
conclusions.
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5.1.1.4. Using GIMP

5.1.1.4.1. Basic Operations

Opening a File. Choose File→Open from the menu. Your image appears in a new window. From that window,
you can access the image’s menu (File, Edit, Select, etc.) or right-click as explained in Right-clicks, page 52.
Depending on the file format you want to open, you may have to answer some questions pertaining to the
details of that format and its conversion. Keyboard shortcut: Ctrl-O.

Creating a New File. Choose File→New from the menu. A dialog appears allowing you to determine image
dimensions in different measurement units (pixels, inches, millimeters, etc.), image orientation (landscape or
portrait) and some advanced options (see figure 5-2). You may also specify a Template from the pulldown list
and have most image parameters filled for you. Once you click on the OK button the image is created in a new
window. Keyboard shortcut: Ctrl-N.

Figure 5-2. Creating a New File

Saving a File. The first time you Save, or when you Save as, a dialog pops up which allows you to set the name
and location of your image. More importantly, this is the place to define the file type such as JPEG or PNG.
Keyboard shortcut: Ctrl-S for Save, Shift-Ctrl-S for Save as.

Note: New users, at the stage of saving their work, run into multiple problems such as losing layers or simply damaging
their work. Most of these problems come from the specific options allowed for each file format. If you have no idea,
preserve the image format or save in XCF, GIMP’s own file format. You can always try saving the image under different
formats later.

5.1.1.4.2. The Tool Box

The tool box contains your basic graphic design tools. If you move your mouse over any item, its name and
keyboard shortcut pops up in a help balloon. Tool options are accessible through the Active Tools Options
section of the tool box. We will not detail each tool in this guide as there are already books written about GIMP
to assist you. Remember that all operations take place in the current active layer.

Note: If you close the tool box, GIMP and all windows are closed. Closing any other window only affects that window.
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5.1.1.4.3. Image Window

Figure 5-3. GIMP Picture

This window manages either new or opened images and it is where tools selected in the tool box may be used.

5.1.1.4.4. View Size

At the bottom of the image window is a numeric value shown as a percentage. This is the zoom ratio. Click on
it to choose another zoom ratio. You can also press the + key to increase zoom or the - key to decrease it. Press
the 1 key to set zoom to 100%.

Tip: Go to menu entry View→Navigation Window to launch a window navigator allowing you to pan and change the
zoom ratio of an image window.

5.1.1.4.5. Undo and Redo

All operations can be undone and redone. You can change how far, as a minimum, you can go back in the
commands “history” and how much memory to reserve for it, by choosing File+Preferences from the menu,
then selecting the Environment section. Please bear in mind that both settings have a large impact on RAM
usage which might make it difficult, or even impossible, to manipulate a large image file.

Choose Edit→Undo from the image menu, or press the Ctrl-Z keys, to undo the last operation.

Choose Edit→Redo from the image menu, or press the Ctrl-Y keys, to redo the last undo operation.

5.1.1.4.6. Copy, Cut and Paste

GIMP allows you to copy (Ctrl-C), cut (Ctrl-X) and paste (Ctrl-V) within any window, as well as between any
GIMP image window. You can also paste as layers.

5.1.1.4.7. Layers, Channels and Paths

Choose Dialogs→Layers (or press the Ctrl-L keys); Dialogs→Channels; Dialogs→Paths from the image menu to
access the layers, channels and paths dialogs respectively (see figure 5-4).
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Figure 5-4. Layers, Channels and Paths Dialogs

GIMP allows for an unlimited number of layers. Each layer has a specific set of properties.

In a RGB color image there are three channels, one for red, one for green and one for blue. The channels dialog
lets you turn a channel off or on, as well as add and remove other channels. Clicking on the eye at the left of a
channel name turns it on or off depending of its original status.

Paths let you manipulate your selections in very complex ways. You can transform selections into paths which
let you treat the selection as a curve, giving you more control over it since you can, for example, add points to
the curve to manipulate it.

5.1.1.4.8. Filters

Filters are a set of programmed actions which modify your image according to specified options. GIMP offers
a vast range of filters such as blurs, noise effects or image enhancement operations that may be applied to
selections and layers. Feel free to explore them all.

Figure 5-5. Filter’s Menu

5.1.1.5. Dialogs

Dialogs give any tool further options. There is quite a large number of them and for the purpose of this
introduction, we only discuss the Color Selection and Brushes dialogs.
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5.1.1.5.1. Color Selection

Figure 5-6. Color Selection Dialog

Choose the Dialogs→Colors menu to open the color selection dialog. Use the buttons at the top to select the
color “space” you want to use for color selection: GIMP (which lets you select colors using different palettes:
Red, Green, Blue, Hue, Saturation and Value), CMYK, color triangle, watercolor, a reduced color palette or
scales. The fore/background colors are handled the same way they are in GIMP’s tool box. Selected colors are
active immediately after choosing them. Rule of thumb: try to work in RGB so you can have a wider number
of formats to save your work into.

5.1.1.5.2. Brushes

Figure 5-7. Brushes Dialog

This dialog lets you define the type and size of the brushes which apply to most drawing and erasing tools.
Click on the active brush section of the tool box, or choose the Dialogs→Brushes menu to open this dialog.
Keyboard shortcut: Ctrl-Shift-B.

5.1.1.6. Printing

GIMP is ideal for web development but printing from GIMP is sometimes tricky. Because of the absence of
PANTONE® Color Systems support, GIMP might not be ideal for prepress work, although CMYK images are
supported.

Internally GIMP supports many printers and it is always feasible to filter images through GhostScript or print
to file (PostScript). Therefore, you can print images relatively easily. Remember to adjust your resolution to
match your printer’s capabilities.
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A lot of online documentation is available to further your knowledge about printing with GIMP, and we
encourage you to explore further.

5.1.1.7. Plugins

Plugins are external applications which extend a program’s core functions. GIMP, like Adobe® Photoshop®,
relies on a vast range of plugins to extend its capabilities. You may also contribute plugins to the community.
Most of them are free to use and distribute.

Choose Xtns→Plug-In Browser from the menu to view all installed plugins.

5.1.1.8. Conclusion

Hopefully, this brief introduction caught your interest for this amazing piece of software. GIMP is a first-class
application and should be considered by any GNU/Linux graphic artist.

5.1.2. Vector Graphic Applications

GIMP is a bitmap graphics applications, however for enterprise logos, diagrams, maps or any kind of drawing
(as opposed to photo), a vector graphics application is preferred.

Dia

Dia is a diagramming application which can be considered as an alternative to Microsoft® Visio®. It
contains a set of predefined symbols for different types of diagrams you may use. Just like GIMP,
Dia offers many common look-and-feel features. Right-clicking in the image gives you image-specific
menus, and allows you to modify the image to your needs. Please refer to the Dia web site (http:
//www.gnome.org/projects/dia/) for more information.

Kivio

Very much like Microsoft® Visio®. Kivio possesses a very complete stencil set and it can even use Dia
stencils. Worth a try if you are familiar with Microsoft® Visio®. Please refer to the Kivio web site (http:
//www.koffice.org/kivio/) for more information.

Inkscape

Inkscape could be considered the “star” of current vector drawing applications for Linux. With it you
can draw anything you want (unlike Dia and Kivio). It’s a very mature application available under both
GNU/Linux and Windows® and it saves in the SVG format by default, easing interoperability and the
support of standards. Please refer to the Inkscape web site (http://inkscape.sourceforge.net/) for
more information.

5.2. Digital Cameras

5.2.1. Configuring Your Digital Photo Camera

This section describes the different functions of digiKam. We go through basic configuration, image transfer
from your camera to your computer, image editing, and creating web albums.

To start using digiKam, plug your camera in a free USB slot, turn it on into “play” mode1, and choose
Multimedia+Graphics→digiKam from the main menu to launch digiKam. The 1st time you do this ope-
ration, you must provide a folder to store pictures into: you can accept the default. If your camera

is not listed in the Camera menu, then choose Add Camera and click on Auto-Detect. If detection fails, click on
Add and look for your camera in the list, or fill the parameters corresponding to your camera, and accept your
settings.

1. As opposed to “record” mode, which is the mode used to take pictures.
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Check GPhoto2’s supported cameras list (http://www.gphoto.org/proj/libgphoto2/support.php) for more
information on camera support. If your camera uses the Picture Transfer Protocol (PTP), it may be supported
even if it’s not in the Gphoto2 list. You can also consult the very complete Digital Camera Support for UNIX,
Linux and BSD (http://www.teaser.fr/~hfiguiere/linux/digicam.html) web page.

Note: Although there are still serial-connected (RS-232) digital cameras around, all recent digital cameras use USB, so
we assume that you have a USB camera.

5.2.2. Handling Digital Camera Storage Media

If your digital camera is not recognized, you can still try to use a USB “card reader” which lets you plug in
the camera’s memory. They usually appear mounted under the /media folder, so you can access them as you
would any other storage device. Many card readers support multiple memory card types: Compact Flash,
Secure Digital, etc.

If you have a laptop computer with a PCMCIA slot, you can use the ATA photo memory PCMCIA card
adapters. They are mounted just like any other ATA device (CD-ROM, hard disk, etc.) in order to access your
pictures. This is the fastest method to access photo cards. It also means the camera’s batteries could last longer.

Note: When you use a card reader or adapter, any type of file can be accessed, not only pictures. You can put whatever
file you want on your memory card.

5.2.3. Transferring Pictures

1. Choose Camera→Your Digital Camera Model from the menu.

2. Select the photos you want to transfer in the digiKam camera import window. New in-camera images are
then marked in the upper-right border.

3. Click on Download and select the Download Selected option.

4. Choose the album to store photos into and click OK. Click on Create and enter an album name to create a
new album.

5. Selected pictures are transferred to that album2.

Tip: If the camera saves rotation information in the picture, then the picture is automatically rotated while transfe-
rring it. If the picture is not rotated automatically, you can still rotate it by hand, see Rotation, page 59.

5.2.4. Touching Up Pictures

Warning

All transformations on pictures are made on the on-disk file, digiKam doesn’t make a backup of the transformed
pictures. Transformations may affect the quality of the picture’s on-disk file and are, when possible, loss-less.

Select a picture and click on this button to open the image edit window. Bear in mind that on-screen
rendering is quite different from printing your digital pictures on photographic paper. So if you in-
tend to both print and publish your pictures for online viewing, it might be wise to treat both copies

differently from the beginning.

2. Albums are stored in the /home/user_name/Pictures folder.
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Tip: Press Ctrl-Z to undo the last transformation operation. However, once you have saved the image, changes cannot
be undone.

5.2.4.1. Rotation

Simply choose one of the entries (90o, 180o or 270o) from the Transform+Rotate menu.

Note: When rotating pictures “by hand”, it is better to correct the EXIF orientation information in order for the EXIF
information to reflect the picture correctly. Choose the appropriate entry from the Image→Correct Exif Orientation Tag
menu.

5.2.4.2. Brightness, Contrast and Gamma

Choose Fix+Colors→Brightness/Contrast/Gamma from the menu and use the sliders to adjust the
brightness, contrast and gamma of the picture using the picture copy as a guide.

5.2.4.3. Sharpen

Choose Fix→Sharpen from the menu, drag the rectangle to the part of the image to be used as a guide,
and use the slider to sharpen the picture.
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5.2.4.4. Red-Eye Reduction

Before After

Select the pupil of the eye to fix, choose Fix→Red Eye Reduction from the menu, and then select the
aggressive (only part of the eye selected) or mild (more than the eye selected) option to reduce the
red-eye flash effect. Repeat for the other eye, if needed.

5.2.4.5. Image Resizing and Cropping

Multi-megapixel images are excellent for photographic paper print-ups, but are far from adequate for
e-mailing or publishing on the Web. Choose Transform→Resize from the menu, then select the desired
size, either in pixels or in percentage, and whether or not to keep (recommended) the aspect ratio.

You can also crop an image to a desired size while keeping aspect ratio. Choose Transform→Aspect
Ratio Crop from the menu, drag the rectangle to frame the part of the image you are interested on, and
select the aspect ratio, orientation, width and height (one follows the other according to the aspect

ratio selected).

Tip: For electronic publication, the usual aspect ratio is 4:3, while for printing the usual aspect ratio is 3:2.
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Usually a size of 640x480 is enough when e-mailing a photo, while 800x600 is enough for web publishing.

5.2.5. EXIF Photographic Settings, Comments and Tags

You can use the tabs located at the right of digiKam’s window to view EXIF information, add comments and
tags, etc.

Most digital cameras produce EXIF (Exchangeable Image File Format) files. EXIF provides extra tags
containing information about the image such as the date, camera model, exposure time, ISO speed
setting, aperture, etc. Select the picture, open the Metadata tab, and select the EXIF tab.

To add a comment to a picture, open the Comments/Tags tab, then enter your Comments (see figure
5-8). Using the same tab you can also add tags to your pictures, for example, to organize them. Click
on Apply once you are satisfied with your settings.

Figure 5-8. Adding a Comment and a Tag to a Picture

5.2.6. Web Albums

If you want to share your pictures with your family and friends, you can easily create a “Web Album” of
your pictures. Choose Album+Export→HTML Gallery from the menu, select the album options (theme, picture
and thumbnails size and format, etc.), finally provide a Destination folder to store the album and click Finish to
create it: the album is then opened inside the browser for you to preview it (see figure 5-9). You are ready to
upload the album to the Web.
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Figure 5-9. Previewing a Web Album

5.3. Scanning Documents and Images

This section explains how to use a scanner with Kooka and GIMP. Please refer to Installing and Sharing Scanners,
page 97 for instructions on how to set up your scanner.

5.3.1. Scan Documents with Kooka

While there are many scanning applications available, we chose Kooka because it is both simple and complete.
Make sure the kooka package is installed.

You can launch Kooka through the Multimedia+Graphics→Kooka menu item.

Choosing the Scanning Media Device. The first time you launch Kooka, a dialog prompts you to choose the
scanning device to use. Check the box to always use this device.
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Figure 5-10. Kooka Main Interface

1. Place your document into the scanner, and click the Preview Scan button. The image appears in the right
pane.

2. Click and drag your mouse over the preview image to select the area to be scanned

3. Set the scan parameters, especially the Scan mode and Resolution.

4. Click Final Scan to launch the actual document scan.

5. In the window that pops up, choose the image format to be used to store that scan. The image then stacks
on the images list, top left.

6.
Check the result by opening the final scan tab. You can then change parameters and scan again if

required.

7. If all looks fine, you can save your image wherever you want by right clicking on it in the list of images.
Remember to clean that list from time to time by deleting items from it.

5.3.2. Scan Images with The Gimp

Install the xsane-gimp package to be able to import your images directly into GIMP for image retouching tasks
(see Graphic Art And Image Manipulation, page 51). Choose File+Acquire→XSane: SCANNER DEVICE NAME to
launch XSane.

Then, click on Acquire preview in XSane’s Preview SCANNER DEVICE NAME window, select the area to be
scanned by dragging the selection square and its borders around, and click on Scan on XSane window. The
image is sent directly to GIMP.
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5.3.3. A Note About the Resolution

Most modern scanners boast high resolutions, such as 1200, 1600 or 2400 DPI (Dots Per Inch). But it would be
a mistake to perform all of your scanning at the maximum available resolution. You will notice very little —
if any — quality difference between a 300 and a 600 DPI image scan, but the file size will grow exponentially,
up to many MBs of disk space for a single image file.

The resolution value should be chosen according to the device on which the image is to be reproduced. For
images to be viewed on computer monitors, e.g. for web sites, the resolution should be close to typical mo-
nitor resolution values, between 70 and 100 DPI. Higher values will result not only in bigger images, but the
dimensions will also increase, so that an image scanned at 160 DPI instead of 80 will be about twice as large3.

If you intend to print your images, a resolution of 300 DPI should be enough for most home printers. Increase
this value if you have a very high quality printer.

Higher values should be chosen only for specific uses, such as enlarged images on very high quality printers,
or quality scans of black and white originals. You will have to experiment a little until you’re satisfied with
the results.

5.3.4. Extracting Text from Scanned Documents (OCR)

By installing the ocrad package, you will be able to use Kooka to perform OCR tasks. The figure 5-11 shows
Kooka with a document scanned as explained in Scan Documents with Kooka, page 62.

Tip: For better results, you should set the scanning mode to Lineart and the resolution to no less than 300 DPI.

3. However scanning at a higher resolution and then reducing the resulting image size using graphic manipulation soft-
ware such as GIMP is one method often used to obtain better results than directly scanning at the desired final resolution.

64



Chapter 5. Graphics Tools And Practical Devices

Figure 5-11. Scanned Document in Kooka

Once the document is scanned, you can click on this icon (Image→OCR Image) and click on Start OCR.
The resulting text appears along with a spell-correction window.

Note: Depending on your hardware and the quality of the document you want to scan, you might need to adjust some
parameters until you obtain a rendering that satisfies you. For more information on Kooka, please read its handbook
(Help→Kooka Handbook).
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6.1. MCC’s Components

The Mandriva Linux Control Center (MCC) enables the system administrator to configure the hardware and the
services used by all users in a friendly way.

Access the Mandriva Linux Control Center through the main menu (System+Configuration→Configure
Your Computer).

Tools Availability: Some of the Control Center tools will be shown only when they are actually installed on the system.

Figure 6-1. The Control Center’s Main Window

Here are some of the available menu entries:

• Options→Display Logs. When activated this option displays a Tools Logs window. It shows all system mo-
difications made by the configuration tools launched from within Mandriva Linux Control Center.

• Options→Expert mode. Gives you access to some of the more advanced tools, which are shown in the table
below.

• Help→Help. Opens the help browser which displays documentation about the active configuration tool.

• Help→Report Bug. Allows you to report a bug to the development team. See Raise an Issue, page 69.

The tools are sorted into categories. The following table lists them all and refers to the corresponding sections
of this manual.
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Software Management “Package Management”, page 71

Hardware Configuring Your Hardware, page 79

Controlling the Graphical Configuration, page 80

Configuring a 3D Desktop, page 84

Changing Your Keyboard Layout, page 86

Changing Your Mouse, page 86

Configuring Printers with PrinterDrake, page 87

Installing and Sharing Scanners, page 97

Setting up your UPS, page 100

Network & Internet Network and Internet Connection Management, page 103

Proxy Settings, page 109

Sharing an Internet Connection, page 111

Activating and Managing Network Profiles, page 110

Managing Wireless Connections (Roaming), page 113

Configure VPN Connections: Allows you to setup a Virtual Private
Network with a remote VPN server. Protocols supported are Cisco VPN
Concentrator and OpenVPN.

Manage host definitions: If you have fixed IP addresses on your
network, this tool allows you to associate names to those IPs, easier to
remember.

System

Menu style configuration: This utility allows you to switch the menu
style from the “Discovery” one, to the more complete “Mandriva” one.

Display manager chooser: allows you to choose the X11 display manager
for users who graphically log onto the machine. Basically, all display
managers offer the same features, it’s just a question of taste.

Configuring Start-Up Services, page 117

Managing Fonts on your System with DrakFont, page 117

Setting your Machine’s Date and Time, page 119

Select the language and the country or region: This utility allows you to
switch the main language of the system, as well as local settings. First
choose the language to be used, then the country or region.

Monitoring System Activity, page 120

Console: simply opens a terminal to directly enter commands from the
administrator account (root).

Managing Users and Groups, page 121

Backing Up and Restoring your Files, page 123

Mount Points Managing your Hard Drive Partitions with DiskDrake, page 131

Managing Removable Devices, page 132

Importing Remote NFS Directories, page 134

Manage NFS Shares: Allows you to create and maintain shares to be
mounted by other UNIX® machines on the local network.

Importing Remote SMB Directories, page 133

Allowing Users to Share Folders, page 135

Manage Samba configuration: This tool allows you to manage the
folders and printers of your machine shared with Windows® machines
on the local network. It also allows you to manage Samba users for
shares access control.
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Securing your Internet Access via DrakFirewall, page 142

Boot Configuring the Login Mode, page 147

Changing Your Boot-up Configuration, page 147

Customizing your Boot Theme, page 149

Table 6-1. Overview of Graphical Tools

Note: Additionally, the Online Administration category only appears if the rfbdrake package is installed. This tool allows
you to take control of a remote host (Linux/UNIX®, Windows®).

Some other categories and tools appear if the drakwizard package is installed. The documentation for those server wizards
is available in the Server Administration Guide. Those wizards enable you to do basic configuration of common LAN
services such as web, FTP, mail and database servers.

6.2. Raise an Issue

If you encounter unexpected behavior in Mandriva Linux-specific tools, Drakbug allows you to report it to the
development team.

Note: To be able to report bugs using Drakbug, you need a working Internet connection as well as a Drakbug account
(http://qa.mandriva.com/createaccount.cgi).

To run Drakbug, go to the Help→Report Bug menu entry of the faulty tool, or run it from Mandriva Linux Control
Center’s own menu. Drakbug can also be triggered automatically by a crashed Mandriva Linux tool.

Figure 6-2. Reporting a Bug

1. Identify the Faulty Package

In order to correctly report a bug, it is important to identify the package it is related to. To make this task
easier, enter the application name in the Application Name (or Full Path) field and click on the Find Package
button.

2. Fill in the Report

Click on the Report button. Your web browser will then open. If you are not logged in to the Mandriva
Bugzilla web site (http://qa.mandriva.com/) you will be asked to log in. Once you are logged on the
site, complete the bug report as completely and accurately as possible and click on Commit.
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To begin with, a bit of vocabulary.

Package
Software needs to be broken down into different files to ease its development and management. An
application ends up being lots of pieces: the binaries, the documentation and the resources the application
needs (images, icons, translations, sounds, etc.). A package is the set of all of an application’s components,
stored in a single file in a way that’s very simple to install, update and remove.

Dependency
Applications rely on software libraries or components made by different developers to perform a given
set of functions, not part of the main functionality but needed to achieve it. A dependency is a package
another package needs in order to work properly. Mandriva Linux’s package management tool takes care
of all the dependencies automatically.

Update
Software is a living thing: new features are added, existing ones are enhanced and problems (bugs) are
fixed. An update is a package which brings in some or all of these enhancements and fixes into an existing
application. It is recommended that you check for updates often in order to keep your system in good
shape and free from bugs and security threats.

Source
A source is a repository of packages, and the place where packages are installed from. Sources for the
media used during system installation are automatically created, you can add your own sources for
updates and packages you find on the Internet.

Media
The place where (software) packages are stored, physically, be it CDs, DVDs, or an FTP server.

Repository
Centralized place containing media (and thus, packages).

Mandriva Linux uses the RPM packaging system. Mandriva Linux provides convenient tools to simplify pac-
kage maintenance. The urpmi set of tools is command line based and discussed briefly in ; here we will con-
centrate on Rpmdrake: Mandriva Linux’s graphical software installation tool and the Software Media Manager.
figure 7-1 shows the Software Management section of Mandriva Linux Control Center.
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Figure 7-1. Software Management in the Mandriva Linux Control Center

Rpmdrake can be used in one of three modes: install

, remove

and update

, each explained in Adding and Removing Software, page 72. Media management is covered in The Software
Media Manager, page 75.

7.1. Adding and Removing Software

Adding Extra Media on First Launch: When you launch this tool for the first time, you are prompted to add new
official installation media. That will give you access, over the Internet, to many more packages than those that could fit
in your CD or DVD. Add them if you have a fast Internet link.

When launching Rpmdrake you have to wait a few seconds while the package databases are scanned. Then
you are presented with Rpmdrake’s main interface.
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Package
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Figure 7-2. Rpmdrake Interface

Package Set. Use this pulldown list to select the types of package to be displayed: all of them (installed or not);
only installed ones (to be uninstalled); only uninstalled ones (to be installed); and a few options for updated
packages (all, security fixes, bug fixes, normal updates). Each time a package set is selected, the Categories
Tree is rebuilt to display matching packages only.

Package Search. If you are not sure about a package name, use this facility to search for it. Type the string to
be searched for, select the criteria using the pulldown list, and click Search. You can search for package names
(in names), package descriptions (in descriptions) and the package providing a given file (in file names).

Note: If your software media repositories are configured to use the synthesized package lists (the summary synthesis files,
not the full hdlist ones) you will not be able to look for the package providing a given file. You will only be able to
search for package names and descriptions.

Categories Tree. To ease management, packages are classified into categories (Networking, Office, Games,
Development, Graphics, etc.). Open a category to display packages which match the current criteria set using
Package Set and Package Search.

Package List. Where currently matching packages (Set, Category and Search Criteria) are displayed. This is
where you select packages to be installed, removed and upgraded.

Package Details. Displays details about the currently selected package in the Package List.

Actions on Packages

1. Limit List of Packages Displayed

Use the Package Set pulldown list, the Categories Tree and, optionally, the Package Search facility to brow-
se for packages to be installed, removed or updated.

2. Select Packages

In the Packages List, select packages to be installed, removed or updated. If the checkbox by the package
name is empty, it means that the package can be installed or upgraded, once selected it will be marked
with the

icon. If the checkbox by the package name has the

icon, it means the package is already installed, select it for removal and it will be marked with the

icon.

3. Apply Changes
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Once you are satisfied with your choices, click on Apply to perform the actual install, remove and upgrade
of these packages. A new window appears, where you can see the progress of actions being taken. If you
prefer to leave without doing anything, you can just click on Quit.

Handling Dependencies

It may happen that you select a package which requires dependencies (additional libraries or another tool)
or which is a dependency of other packages. In this case Rpmdrake displays an information window allowing
you to choose whether to accept the selected dependencies, to Cancel the operation, or to get More info on the
operation (figure 7-3).

Figure 7-3. Dependency Alert Box

Alternative Dependencies. You may also want to install a package which requires dependencies, and various
packages are capable of providing that dependency. The list of alternatives is then presented (figure 7-4).
You may read the additional information presented by clicking the Info... button to help you choose the best
alternative.

Figure 7-4. Alternative Packages

Note: Due to dependencies, the disk space required by the selected packages might be greater than the size required by
the chosen package by itself.

7.2. Updating Packages

This simple interface allows you to quickly check for available updates and to install them with one
click.

Adding Update Media. The first time you launch this tool, you are prompted to add update media. Follow
the instructions to do so.
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Figure 7-5. Updating Packages

1. By default, all updates (except the kernel ones) are selected for installation, review the list.

2. Click Update to launch the update process which consists of downloading and installing all selected up-
dated packages.

Kernel Update: Kernel updates are not selected by default. You will need to manually select the corresponding
kernel-*-latest package.

Updates notification: The Mandriva Update applet, sitting on your panel, can warn you of updates availability once
update media is configured. It shows a red icon

when updates are available and a green one

when your system is up to date.

7.3. The Software Media Manager

Use this tool to configure the package media repositories. figure 7-6 shows some media already
defined: “Main”, “Contrib”, etc. You can also add other software media: a CD from a magazine
containing RPMs, a Web repository, etc.
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Figure 7-6. The “Software Media Manager”

Use check boxes of the left-hand columns to flag the repositories

Enabled?

Uncheck this box to temporarily disable the corresponding medium. The packages contained in this me-
dium will not be available until you enable the medium again.

Updates?

This box must be checked for update media, that is, media that contains updates of packages that are
already in another medium, albeit with an older version number. Thus only update media are taken into
account when looking for updates.

Action Buttons on the Right

Remove

Discard a medium which you no longer use. Simply select the medium to be removed in the list and click
this button.

Edit

Change the medium’s parameters: the URL or the relative path to the synthesis/hdlist (if you do not
know what we are talking about, it is wise to leave this window via Cancel instead of Save changes).

In case you need to pass through a specific proxy to access this particular medium, you can configure it
here by clicking on Proxy.

Faster Media Updates. The relative path string allows you to change from using hdlist files to
synthesis files, which are much smaller but with less information on packages. Synthesized files only
carry information about package names, their dependencies and a short summary, so you won’t be able
to search for files inside packages from synthesized lists. Also, you won’t be able to see the full description
for a package if you click on its name.

To switch to the synthesis form of hdlist, simply prefix the file name with synthesis., so that for
example: media_info/hdlist_main.cz becomes media_info/synthesis.hdlist_main.cz.

76



Chapter 7. Package Management

Add

Add to your system all publicly available official package sources from Internet repositories. This is useful
for example if you have a fast Internet connection or only have the first installation CD at hand. Choose a
mirror geographically near to your location.

After choosing a mirror and clicking Ok, package information for the source you chose is downloaded
and all included packages will be available.

Add custom

This button provides access to a new dialog, in which you define all needed parameters for a new software
package medium. Please bear in mind that the required parameters, and available options, depend on the
type of medium being defined.

Figure 7-7. Adding a Custom Package Repository Media

Update

You are shown a list of already defined, enabled, media; select the ones you want to update the list of
available packages for, and click Update. This is useful for remote media to which new packages are being
added.

Manage keys

It is important that any package you install is authenticated. To do so, each package can be electronically
signed with a “key”, and you can allow/disallow keys on a per-medium basis. On figure 7-8, you can
see that the Mandriva Linux key is allowed for medium “Main”. Click on Add to allow another key for
the selected medium (beware, do this with care, as with all security-related questions), and on Remove to
remove a key from the selected medium.

Figure 7-8. Package Repository Authentication Key Management
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Proxy

If you are sitting behind a firewall and you still need to access remote media (especially for package
updates), you can do so if you have a proxy server which leads to the Internet (at least in an area where
you can find a package server). Normally it should be enough to fill in the Proxy hostname to get it working
(figure 7-9). If you need a user / password combination to get through the proxy, you can also specify
these here. Just confirm your changes by clicking on OK and you are done.

Figure 7-9. Specifying a Proxy for Remote Media

Parallel

If you are running a large network of computers, you may want to install a package on all the computers
in parallel; this button opens a dialog window allowing the configuration of the “Parallel” mode. As it
is rather complicated and only useful to a limited group of people, this short introduction will not give
further details about it.

Global options

This button allows you to configure the program used to retrieve remote packages and whether the pac-
kages should be checked against a key. These choices affect all package sources.

Up and Down arrows

These buttons allow changing the order in which sources will be used when installing packages. By de-
fault, the newest version of a given package will always be installed, but if the same version is found on
two different media, the one from the first medium in the list will be installed.

Tip: Therefore, it is better to move fastest media up...
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8.1. Configuring Your Hardware

8.1.1. Hardware Detection and Configuration

The HardDrake project has been developed to simplify hardware detection and configuration
under GNU/Linux by providing a user-friendly interface.

8.1.1.1. Introducing HardDrake

HardDrake is a service for hardware detection, run at system boot time, and also a full GUI-based tool which
ties together many of the tools already included in a GNU/Linux distribution. It automates and simplifies the
process of installing new hardware. For the most part, HardDrake is able to detect most devices.

On one hand, HardDrake is used to display information, and on the other, it can launch configuration tools.
With its easy-to-use interface, you can browse all the hardware your system contains.

8.1.1.2. Using HardDrake

To launch HardDrake, you can start it through:

• the Mandriva Linux Control Center: click on the Hardware category, and then on the Hardware icon.

• a terminal: type harddrake2 as root. You can also pass parameters to HardDrake through the command
line (type harddrake2 -h to get a list of possible parameters).

• the desktop: go to the main menu. The HardDrake entry is an item in the System+Configuration→Hardware
sub-menu.

After all devices have been detected, the main HardDrake window appears (see figure 8-1).

On the left is the device tree that shows all the hardware categories.

Figure 8-1. Selected Device
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By selecting a device, you see additional information about it in the right frame. To better understand the
meaning of the information presented, you can consult the help page accessible by choosing Help→Fields
description from the menu.

Depending on the device selected, other buttons may appear:

• Set current driver options. This pops up a window with all the module device parameters listed. For experts
only!

• Run config tool. Launches the Mandriva Linux configuration tool (available through Mandriva Linux Control
Center) associated with that device.

Unknown hardware. A special category called Unknown/Others might also show up, containing all the
unknown hardware in your system, as well as known hardware which does not fit into any existing categories
(such as thermal sensors, random number generators, etc.).

8.1.2. Problems and Troubleshooting

If you think you have found a bug related to HardDrake, report it using the Mandriva Linux bug reporting
tool (see Raise an Issue, page 69).

Sound Cards. HardDrake does not probe for ISA PnP devices. If you have an ISA PnP sound card, run
sndconfig or alsaconf from the command line. You may need to install the sndconfig or alsa-utils pac-
kage.

8.2. Controlling the Graphical Configuration

This set of tools allows you to configure your graphical display. With it, you can change your video card, your
resolution and your monitor. It can be useful if you change one of your graphical components after the initial
installation.

If you don’t see a graphical login at boot: If the graphical server cannot start because of a configuration error, a dialog
offers to reconfigure the graphical server. You get a tool similar to the one described in Controlling All Video Parameters,
page 82, but in text mode.

The graphical configuration tools are accessible through different icons in the Hardware section of the Mandriva
Linux Control Center.

8.2.1. Changing the Monitor

This tool allows you to change the monitor type currently in use. When you click on it, a window
pops up, listing many monitor models (see figure 8-2). If your monitor was automatically detected,
it is listed as Plug’n Play along with its model.
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Figure 8-2. Choosing a New Monitor

If your monitor wasn’t automatically detected, you can choose it from the list. If you don’t find your monitor
or a compatible one, choose one with parameters corresponding to the monitor from the Generic entry, at the
bottom.

8.2.2. Changing the Resolution

This tool enables you to change the current screen resolution (800x600, 1024x768, 1152x864,
etc.) and the color depth. Simply choose the one you want to use.
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Figure 8-3. Changing the Resolution of Your Screen

The monitor in the window displays what the desktop will look like with the chosen configuration (see fi-
gure 8-3). If it looks good, click OK. The changes will be activated after you quit and restart your graphical
environment.

Monitor and Resolution Ratio. By default, the available resolution list only shows resolutions supported
by your video card and monitor combination. There is a special entry named Other that adds more possible
resolutions along with their ratios. Bear in mind that most monitors are designed with a 4:3 horizontal vs.
vertical ratio.

8.2.3. Controlling All Video Parameters

If you change your video card after installing your system, or want to have full control over the
graphic configuration, run this tool.
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Figure 8-4. XFdrake Main Window

The buttons allow you to change aspects of the graphical configuration:

Graphic Card

The button displays the name of the graphic card currently configured. Click on it if you want to change
it. Depending on your card, different servers may be available, with or without 3D acceleration. You may
need to try different ones until you get the best result.

Note: You may be asked if you want to use a proprietary driver for your card, answer Yes to use the driver provided
by the card’s manufacturer. This driver may give you access to more features and also make your card perform
better on 3D applications, like games.

In case you cannot find the graphic card you have, but you know which driver supports it, select it from
the Xorg entry at the bottom.

Monitor

Enables you to change the monitor with the tool described in Changing the Monitor, page 80.

Resolution

Enables you to change the pixel resolution and the color depth with the tool described in Changing the
Resolution, page 81.

Changing the resolution using the desktop applet:

If you are using KDE, you can also change the screen resolution on the fly by using the screen resize applet,
accessible by choosing System+Configuration+Hardware→Screen Resize & Rotate from the main menu.

Other buttons are also available:
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Test

Allows you to verify that your modifications actually work. It is highly recommended that you do test it,
because if it does not work, it will be harder to recover a working graphical environment later. If the test
fails, simply wait until it ends. If you are not satisfied with the suggested settings, choose No during the
test, and you will return to XFdrake’s main menu.

If the test is not available: Depending on your video card, video testing may not be available. You will be warned
of such a situation. If it happens that the settings are incorrect and your display does not work, launch XFdrake
as root in the console to use XFdrake’s text version.

Options

Graphic card options

Depending on your hardware capabilities, you can choose to enable or disable specific features such
as 3D acceleration or special visual effects (translucency).

Graphical interface at startup

Use this option to choose whether you want your machine to automatically switch to a graphical
interface at boot. Obviously, you may want to select the No option if your machine is to act as a
server, or if you were not successful in getting the display configured.

Quit

If you modify your graphical display in some way, the current configuration is displayed and XFdrake
asks you whether you want to keep your changes or not. This is your last chance to go back to the old
configuration. If all seems OK, click on Yes. If you want to restore the previous parameters, click on No.

The changes are activated after you confirm them and you restart your graphical environment.

8.3. Configuring a 3D Desktop

This tool is accessible from the Hardware section of Mandriva Linux Control Center and lets you configure
a 3D desktop for stunning visual effects on your desktop, together with a change from a flat desktop
to a cubic one.

Note: The first time you run Drak3D, a few required packages may be installed. Then, its main window is displayed (see
figure 8-5).
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Figure 8-5. Activating 3D Desktop Effects

You can choose between the following special featured desktops:

• Metisse;

• 3D desktop (cube workspace).

8.3.1. Metisse

Metisse is a window manager developed by the In Situ project (http://www-ihm.lri.fr/). Available under
the GPL License and exclusively for Mandriva Linux, Metisse differs from a classic 3D desktop (“the cube”, see
below 3D desktop Cube Workspace, page 85) because it focuses on an innovative interaction with windows.

Activate Metisse. Clicking OK will install the required packages and suggest that you log out in order to
activate the changes.

Once you’re logged in again, you will see nine squares at the bottom right of your desktop. Those represent
the nine virtual desktops you can use to organize your applications. The main options of Metisse are detailed
in Metisse, an Innovative Windows Manipulation System, page 15.

8.3.2. 3D desktop Cube Workspace

Select the 3D desktop (cube workspace) option to enable the 3D desktop. Click Advanced settings to check your
options (see figure 8-5).

Optional Configuration

1. Choose a Graphical Server

There are two approaches: native support and Xgl. Depending on your hardware, Drak3D selects the most
appropriate one for you.

2. Choose a 3D Window Manager

Two options are available: Compiz and Beryl. The former is simpler and better tested, the latter has more
effects. See the Beryl Project Page (http://www.beryl-project.org/) for more details.
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To try out that 3D desktop, click OK. Changes take effect the next time you log into your computer.

Once the 3D desktop is active, the desktop manager (KDE or GNOME) shows 4 virtual desktops, corresponding
to the viewports (the cube faces): explore and enjoy them!

Please see Manipulating the 3D Desktop with Compiz, page 14 for more information on keyboard shortcuts and
mouse usage with the 3D desktop.

8.3.3. No 3D desktop effects

Select the No 3D desktop effects option to disable the 3D desktop completely, and return to your normal desk-
top.

8.4. Changing Your Keyboard Layout

This tool allows you to define another keyboard layout, useful when the keyboard you want
to use is different from the one chosen at installation time.

Figure 8-6. Choosing a Different Keyboard Layout

Select your keyboard’s layout (which is closely associated to the language you speak) and then its type (or
model) from the lists shown in figure 8-6. If you own a multimedia keyboard and it is listed in the list of ma-
nufacturers, chances are that most multimedia keys on it will be supported. Otherwise, choose your keyboard
type under the Generic branch. Changes are effective immediately after clicking OK.

Note: If you choose a keyboard layout based on a non-Latin alphabet, you are asked to choose the key combination that
will switch the keyboard configuration between the Latin and non-Latin layouts.
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8.5. Changing Your Mouse

This tool enables you to set up a different mouse, which is useful if the mouse you are currently
using is not the same as the one you chose at installation time.

Note: The Synaptics Touchpad function is automatically configured to work with almost every touch pad found on
notebook computers. The same goes for Wacom® tablets.

Figure 8-7. Choosing a Different Mouse

Mice are sorted into a tree according to their connection type and model (see figure 8-7). Highlight the mouse
of your choice and click OK. Changes take effect immediately after the mouse test is done.

Tip: The Any PS/2 & USB mice option works with virtually all modern mice.

8.6. Configuring Printers with PrinterDrake

This tool allows you to:

• Configure a newly installed printer;

• configure your machine to act as a server for a printer connected to your local network;

• set up your machine to access network printers served by other servers.

8.6.1. Automatic Installation

If you connect and power on a USB printer, a dialog pops up.
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Figure 8-8. A new Printer was Detected

Deactivate Automatic Detection. If you don’t want the “automatic setup” popup to show again, check Do not
setup printer automatically again.

Then just click Ok, all required packages will be installed, and the printer configured for you to let you use it
right away: nothing else to do!

Configuration. It is however recommended that you check the printer default parameters, especially paper
size. To do this launch PrinterDrake from the Mandriva Linux Control Center and follow the instructions from
Reconfiguring an Existing Printer, page 95.

8.6.2. Manual Configuration

Tip: If you have just installed a printer that wasn’t available when you installed Mandriva Linux, make sure it is correctly
connected and powered on before launching the configuration tool.

When you first launch the PrinterDrake tool, it may be in one of these states:

8.6.2.1. There is no printer directly connected to the computer.

Figure 8-9. Activate Printing
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The tool did not detect any local printers. However you can print on network printers, or manually installed
printers which weren’t detected by clicking on Yes.

Figure 8-10. Activating Network Printers

• Select the Local CUPS printing system option if you wish to configure your machine to act as a print server
for either a local printer which was not detected, or a networked printer connected to your local network.

Any required software will be installed and then the main configuration interface (see figure 8-12) appears.
Click on Add Printer to install the network printer.

• Select the Remote server option if you wish to be able to print on printers served by another CUPS print
server on the network. Your applications will immediately have access to all public printers served by that
server. You only need to provide the hostname or IP address of that server in the field (ask your system
administrator).

When this is done, the main configuration interface (see figure 8-12) appears. The Configured on other machi-
nes tab will be filled with the available network printers.

8.6.2.2. New Printer Detected

The following window appears when PrinterDrake detects a new printer at launch time.
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Figure 8-11. A New Printer Is Detected

Simply confirm the automatic installation of the new printer. The main configuration interface (see figure 8-12)
is then displayed. Make sure you check that the printer parameters fit your needs (see Reconfiguring an Existing
Printer, page 95).

8.6.2.3. A Printer is Already Configured

The main configuration interface (see figure 8-12) is shown. Make sure that the printer parameters fit your
needs (see Reconfiguring an Existing Printer, page 95).

8.6.3. The Printer Management Interface

Local and Remote Printers. Use the printer configuration tool’s first tab for locally connected printers
(Configured on this machine), and the other tab for printers available on your local network (Configured on
other machines).
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Figure 8-12. Managing Printers

The following buttons give you access to all available maintenance tasks:

• Add Printer: launches the printer configuration wizard described in The Printer Configuration Wizard, page
94.

• Set as default: sets the selected printer as the default printer when no specific printer is chosen at print time.
A cross appears in the Def. column of that printer.

• Edit: opens the printer configuration dialog described in Reconfiguring an Existing Printer, page 95.

• Delete: removes the selected printer from the available printer pool.

• Refresh: updates the list of available printers, especially useful for networked printers.

• Configure CUPS: by default, your system is open. PrinterDrake uses all of the network’s available printers and
shares all of its local printers with the local network. Click on this button if you don’t want to access network
printers, or if you want to restrict the access to your local printers. This dialog also lets you configure access
to print servers outside the local network (see Print Server General Configuration, page 91).

Note: The Options→Expert mode menu adds extra features to the tool. See Expert Mode, page 97.

8.6.4. Print Server General Configuration

The Configure CUPS button allows you to control the behavior of printers connected to your machine and to
your network.
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Figure 8-13. CUPS Printer Server Configuration

This dialog enables you to switch between the client and server printing modes through the Remote CUPS
server and no local CUPS daemon button.

This button enables you to select between two remote server access methods.

In the first method your server must have a CUPS daemon running and be listening on port 631 in order
to manage the print queue and to listen for jobs coming in from applications. In this case the CUPS server
broadcasts its presence to the entire network. This is the default configuration.

In the second method, the CUPS daemon is still required to manage the queue and to handle jobs coming in
on port 631, but it does not broadcast its presence to the network. In this case the clients do not need to run a
CUPS daemon, instead they have a configuration file which contains the IP address of the server. In this way
the clients know they can sent jobs directly to the IP address.

Advantages Disadvantages

Method 1 No client configuration required Runs with at least one open port
and consumes extra machine
resources

Method 2 No local printing system. No open
ports

If the IP of the server changes or
the client changes to another
network, then reconfiguration is
required.

Table 8-1. Considerations
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8.6.4.1. Client Mode

Figure 8-14. Client Mode Configuration

Select the On option to connect to another printer server. Then you only need to specify the name or IP address
of that server in the next field below.

If you choose this mode, your printing configuration is now finished. Accept the options by clicking the OK
buttons, and you will be able to check the list of available printers in the Configured on other machines tab of
the main interface (see figure 8-12).

8.6.4.2. Server Mode

If you want your machine to access locally connected printers (through parallel or USB ports), or network
printers not already configured on another server, you need to select the Off option. Click OK to fine tune your
printer server (see figure 8-13).

A number of options are available to further secure and enhance your print server features:

The printers on this machine are available to other computers

Allows other computers to print on printers configured locally. Remember to restrict access by clicking
on Printer sharing on hosts/networks (see below).

Automatically find available printers on remote machines

Tells your print server to automatically make all printers found on other servers available to the local
network, as if they were locally connected to your print server. This way your system’s users are able to
print on any printer the print server can “see”. If the remote printers you intend to use are served by a
server not on your local network, you can still tell the print server to use them with the Additional CUPS
servers button (see below).

Printer sharing on hosts/networks

Allows you to specify from which networks the local printers are made available.

Additional CUPS servers

Allows you to specify one or more CUPS servers to which you can connect and access printers. Specify
the IP address and port of the CUPS server in the dialog.
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Japanese text printing mode

Replaces the original text filter for one more suited to Japanese texts, but with less features. Use it if you
have to print Japanese text-only files.

8.6.5. The Printer Configuration Wizard

Click on Add printer and the configuration wizard comes up.

8.6.5.1. Detect Printers or Specify Access Path

The first step serves to either specify an access address to a network printer, or to activate auto-detection of
locally connected printers, network printers, and finally printers served by SMB (Windows®) servers.

Figure 8-15. Printer Type

Specifying the Location. If you happen to know all parameters required to access a specific network printer,
select Enter host name/IP address of network printer. Configuration steps are then similar to the ones involved
in auto-detection procedure.

8.6.5.2. Choose the Printer

Figure 8-16. Detected Printers List

1. Choose the Printer to be Configured

Select the printer you want to add from the list of detected printers. If the detected printer isn’t the correct
one check the Manual configuration box and proceed with the printer model step. If autodetection fails,
remove the check mark from all check boxes, click on Next and follow the instructions below.
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2. Specifying the Driver Manually

PrinterDrake displays your printer’s model name. Choose Select model manually if it’s incorrect. Select the
printer you have or a compatible one (see Choose the Printer, page 94) if yours is not specifically listed.

3. Manufacturer-Supplied Driver

If you want to install the driver supplied by your printer manufacturer, click on the Install a manufacturer-
supplied PPD file button and select the medium containing the PPD file and browse to it. Accept subsequent
dialogs to use your chosen PPD file.

4. HP Multifunction Devices

If you own a multi-function device such as those of HP or Sony, an information window pops up and
gives you information about your scanner and scanner software (Installing and Sharing Scanners, page 97).
Additional required packages are also installed.

Fax Virtual Printer. If your device also provides fax functions, you are given an option to create a virtual
fax printer that will actually queue the printed documents so they can be later sent via fax. See Through an
HP Multifunction Device, page 36 to learn how to send faxes.

5. Optional Configuration Step

If your printer has optional add-on devices (finishers, extra paper trays, etc.), you are asked which features
are actually installed.

8.6.5.3. Printer Test

Several test pages are available (see figure 8-17). We recommend you print at least one test page so you can
immediately correct the parameters if something is incorrect. The printer should begin to print almost imme-
diately.

Figure 8-17. Testing the Printer

8.6.5.4. It’s Done

If you’re not satisfied with your test page, answer the appropriate question with No and you will be led to the
printer configuration menu (see figure 8-18) where you can correct the settings. See Reconfiguring an Existing
Printer, page 95.

Your printer will now appear in the list of available printers in the main window (see figure 8-12).
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8.6.6. Reconfiguring an Existing Printer

Double-clicking on a printer’s name in the list, or clicking on the Edit button, displays a menu where you can
choose actions to take on the selected printer (figure 8-18). You can change the printer name, options, etc.

Figure 8-18. Modifying an Existing Printer

Here are some of the most useful entries:

• Printer name, description, location. If you have many printers around it is better to give them explicit names,
and meaningful descriptions, plus a location so people don’t end up looking desperately for their printouts
in many floors.

• Printer Options. Shows the different options available for that printer (paper size, printout mode, etc.), so
you can set a default value for them.

• Make this printer invisible for other computers. Printers are normally made available to other computers in the
local network. Using this option you can disable this behavior for the currently selected printer.

• Disable Printer. Use this option to remove a printer from those to the system’s users. You might need to
temporarily disable a printer under maintenance so that users don’t try to use it in the meantime. When a
printer is disabled, that option changes to Enable printer.

• Learn how to use this printer. Displays information on how to use a particular printer model. In the case of a
multi-function device from HP, additional information for the “extra” functions is also displayed.

• Remove printer. Deletes that printer’s configuration from the system.

Select an action in the dialog and then click on the Do it! button to perform it.

8.6.7. Controlling Automatic Installations

Open the Options→Configure Auto Administration menu to go to the automatic installation options form.
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Figure 8-19. Set Automatic Installation Options

You can here configure whether new printers should be automatically detected, automatically configured, etc.

8.6.8. Expert Mode

The expert mode activates additional features in the application.

More Technical Installation Wizard. The installation wizard displays more technical information and allows
you to configure printer name and other options directly from within the wizard.

Choose a Different Printer Driver. Different drivers are available for the same printer. In expert mode, a
third level appears in the printer model selection list (see Choose the Printer, page 94) letting you change each
printer’s driver.

No Automatic Configuration. If PrinterDrake is in expert mode, it doesn’t automatically configure new local
printers on start-up. Use the Add printer button to configure the printer. However you can choose to Configure
Auto Administration from the Options menu to override that behavior.

Automatic correction of CUPS configuration. This new option appears in the CUPS server configuration
window (figure 8-13. It is activated by default. Leave the mouse over the option name to get more information
about what it does.

8.7. Installing and Sharing Scanners

The ScannerDrake wizard helps you install your scanner. Make sure your scanner is powered
on and launch ScannerDrake by clicking on the Scanners entry of the Mandriva Linux Control
Center’s Hardware section.

Tip: Please note that not all scanners are supported under GNU/Linux. Before buying new hardware, remem-
ber to check out Mandriva’s Hardware Database (http://hcl.mandriva.com) and the SANE home page (http:
//www.sane-project.org/) for compatibility issues.
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8.7.1. Main Interface and Scanner Installation

The program tries to detect your scanner’s manufacturer and model. If it finds the scanner then information
about it is displayed in the upper part of the wizard’s main window. The window also offers a few action
buttons (figure 8-20).

Figure 8-20. Installing your Scanner

Search for new scanners

Click on this button to autodetect a new scanner you have just plugged in.

Add a scanner manually

Use this button if the automatic detection fails and then look for the specific model you own by browsing
through the list of available scanners and models.
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Figure 8-21. The Tree-list of All Known Scanner Models

Choose the right Port. After choosing the appropriate model, you can leave the default Auto-detect available
ports option unless you have a parallel port scanner, in which case selecting /dev/parport0 in the pull-down
list should be the right choice.

HP multi-function devices

Note that HP multi-function devices, such as the OfficeJet and PSC printers, must be configured through Printer-
Drake. Please refer to Configuring Printers with PrinterDrake, page 87. The scanning part of non-HP multi-function
devices can be set up with ScannerDrake as a stand-alone scanner.

Test the Scanner. Once your scanner appears in ScannerDrake main window, you can test its configuration by
referring to Scanning Documents and Images, page 62.

8.7.2. Share your Scanner

ScannerDrake allows for scanner sharing between users connected via a LAN.
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Figure 8-22. Sharing Scanners within a LAN

Share Your Own Scanner

1. Check the The scanners on this machine are available to other computers box.

2. Click the Scanner sharing to hosts button and then Add host to specify which hosts will be actually allowed
to access your scanner.

Use Other People Scanners

1. Check the Use scanners on remote computers box.

2. Click the Use the scanners on hosts button and then Add host to specify which hosts serve the scanner you
wish to use.

8.8. Setting up your UPS

This tool will configure the NUT (Network UPS Tool) service for you. The service checks the UPS
connected to your machine and automatically shuts it down when the UPS is about to run out of battery
power.

Automatic Installation. Open the Mandriva Linux Control Center in the hardware section and click on Set up a
UPS for power monitoring to launch DrakUPS. Check the Connected through a serial port or a USB cable button
to let DrakUPS autodetect your UPS.

Manual Configuration (Serial Port)

1. Select the Manual configuration option.

2. Select your UPS from the list of manufacturers and models.
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3. Then assign a Name, Driver, and Port1.

If all went well your UPS should now be configured and ready to help avoid bad power outage surprises.

1. The Name and Driver fields should automatically be filled. Of course, you can change its name but we recommend you
keep the driver name.
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Chapter 9. Setting up your Network and Accessing the Web

9.1. Network and Internet Connection Management

Tip: Before connecting to the Internet, you are encouraged to set up a firewall on your machine so as to avoid bad
surprises such as intrusions into your system. You can set up a very simple, yet effective firewall using DrakFirewall.
Please refer to Securing your Internet Access via DrakFirewall , page 142 for more information.

The drakconnect set of tools allows you to easily configure your network access, whether it be to the Internet
or to a local network. Open Mandriva Linux Control Center and select the Network & Internet section to access
drakconnect tools. A view of the main interface is shown in figure 9-1. The Internet connection sharing tool is
described in Sharing an Internet Connection, page 111.

Figure 9-1. DrakConnect Tools

9.1.1. Setting Up a New Network Interface

drakconnect supports different types of Internet and network connections. The first step consists
of choosing which type of connection you want to configure. Always make sure you have all the
information provided by your ISP or network administrator at hand.

Note: After a connection has been configured, it can be further modified using the Manage Connections interface (see
Reconfiguring Interfaces, page 107).
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9.1.1.1. Wired Ethernet Connection

1. Select the Ethernet type

Your NICs are detected automatically; if you have more than one, you need to select the one you want to
configure. You can also load a driver for your NIC manually.

2. Automatic or Static Configuration

You now have to specify whether the network parameters are automatically set up (Automatic IP
(BOOTP/DHCP)) or not (Manual configuration): fill the next steps with the parameters that your ISP or
network administrator gave you.

3. Connection Control

Allow users to manage the connection

If you want users to be able to bring up or shutdown the connection without having to provide the
root password (see Monitoring Connections, page 108) check this box.

Start the connection at boot

Uncheck this if you want the connection to be activated on demand only.

The Net Applet: An applet appears in the desktop’s panel indicating that the connection is up

or down

. Right click on it to access a menu that also lets you control the connection’s state, as well as other parameters.

9.1.1.2. Wireless Connection

This entry allows you to configure WiFi PCMCIA or PCI devices.

1. Select the Wireless type

If your WiFi card is not listed, choose the Use a Windows driver entry. Then, select the driver from the
manufacturer’s card drivers CD.

2. Choose Network

A list of detected networks is then shown. Select yours; otherwise, choose unlisted.

3. Wireless Settings

Operating Mode

The mode the card will operate on, with respect to the other WiFi devices in the network. The most
common one is Managed to simply connect to an existing access point.

Network Name (ESSID)

The name of the network you want to connect to. Ask your network administrator.

Encryption Mode

This depends on the network settings, ask your network administrator.
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Encryption Key

This also depends on the network settings, ask your network administrator for the key the network
uses.

4. Network Configuration

This is similar to the traditional Ethernet network setup: see Wired Ethernet Connection, page 103.

5. Connection Control

Check the Allow access point roaming box if you want the connection to automatically switch from one
access point to another, depending on its signal strength. This is particularly useful when moving a laptop
around.

Managing Connections. Consult Managing Wireless Connections (Roaming), page 113 to learn how to configure
and manage various wireless networks.

9.1.1.3. ISDN Connection

Simply make sure you select the right parameters in all steps, concerning your area and provider.

The last step gives you the option to handle the connection status through the net applet. This can prove useful
if you only need the Internet connection from time to time.

9.1.1.4. Modem Connection (POTS)

1. A list of detected modems is shown. If no modem was detected, only the Manual choice option is shown,
click on Next and choose the communications port the modem is connected to. The required packages are
installed.

2. You then see a list of countries/ISPs. If yours is listed, select it and continue to the next step: some para-
meters (connection name, phone number to dial, and authentication scheme) will be automatically set. If
not, select the Unlisted - edit manually option.

3. Verify the parameters, add the missing ones provided by your ISP.

Figure 9-2. Entering Dial-up Connection Parameters

All parameters should be obvious, except for the authentication type. The value in the Authentication pull-
down depends on what your ISP supports: Script-based (an old type of authentication method based on
“expect” and “send” types of chat between your system and your ISP); Terminal based (a terminal window
pops up when the connection is made and you have to login interactively); PAP, CHAP, or PAP/CHAP
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(authentication information exchange protocols, CHAP is preferred because it is more secure, PAP/CHAP
will automatically choose the supported one).

4. Then come the IP, DNS and gateway settings. Nowadays, most ISPs provide them automatically when a
connection is made, so selecting the Automatic option on them is usually a safe bet.

5. Connection Control

Allow users to manage the connection

You are then asked whether you want to allow users to start the connection. That allows them to do
so without needing the root password.

Start the connection at boot

It is probably safer and cheaper to choose No.

6. Finally you are asked to test the connection: we recommend you to do so to make sure all parameters are
accurate. You can now control your Internet connection using the net applet. You can also use the kppp
remote access connection dialer (package kppp) by choosing Internet+Remote Access→KPPP from the main
menu.

9.1.1.5. DVB Connection

This connection type is used for satellite connections.

1. Choose the connection card you want to configure, and then the adapter settings.

2. Network configuration is then similar to the LAN connection type (see Wired Ethernet Connection, page
103).

9.1.1.6. GPRS, Edge and 3G

This connection type supports Internet connections through cellular phone networks, accessed through a
PCMCIA card. Third generation (3G) technologies, as well as older ones (GPRS/Edge) are supported. Support
for newest HSDPA standard is also available.
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9.1.2. Internet Settings

Figure 9-3. Configuring the Internet Access

This tool allows you to specify Internet access parameters if they need to be modified after your
initial configuration. Please bear in mind that these parameters are system-wide and apply to all
interfaces. To change the gateway address see Reconfiguring Interfaces, page 107.
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9.1.3. Reconfiguring Interfaces

Figure 9-4. Managing Network Connections

This tool allows you to modify network interface-specific parameters, after you have set them up
through the new interface wizard (see Setting Up a New Network Interface, page 103). Use the drop-
down list at the top to select the interface you want to configure. The tabs allow you to change
parameters and options according to the network interface type selected.
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9.1.4. Monitoring Connections

Figure 9-5. Real-Time Network Connection Monitoring

This tool shows network interface activity. You can specify some options for the traffic graphic
and statistics: update interval, scale, etc. (see figure 9-5). It can also be used to control the status of
the network connection, bringing it up or down using the button at the lower left.

Note: The network monitoring interface can be brought up by users through the net applet to monitor traffic.

9.1.5. Removing a Connection

This tool simply allows you to remove a network interface. Select the interface to be removed in
the Net Device pull-down list.

Warning

You will not be asked for confirmation. Once an interface is selected for removal, pressing the Next button deletes
it immediately.

9.1.6. Proxy Settings

If your Internet connections must (or can) pass through a proxy, this tool allows you to define
the hostnames or IP addresses of proxies for the FTP and HTTP protocols. Fill the fields with the
required values and click OK.

What’s a Proxy. A proxy is a server that retrieves information from the Internet on your behalf, keeping a local
copy of the web pages that are most frequently requested. They are referred to as “caching proxies”, and opti-
mize bandwidth usage. In some organizations, you cannot access the Internet directly. You must pass through
a proxy that authenticates you before allowing you to connect to the Internet. This is usually combined with
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a firewall that only guarantees the proxy direct access to the Internet. They are referred to as “authentication
proxies”. In corporate or business environments, proxies perform both caching and authentication functions
for performance and security reasons.

9.2. Activating and Managing Network Profiles

Mandriva Linux Control Center profiles enable you to store different configuration sets for your machi-
ne, for example for different locations. This is especially useful for laptops that need different confi-
gurations for home, at the office, the coffee shop, etc. The parameters that can change from one profile

to another are:

Network Configuration

Activates different interfaces, with different configurations, for wireless-type connections, for example.

Services Configuration

Allows you to activate different services from one profile to another, for example a firewall at home and
no firewall at the office (see Configuring Start-Up Services, page 117).

9.2.1. Profile Handling

New profiles you want to create are based on the active one. All modifications are automatically recorded in
the active profile. A single menu (Profiles) lets you manage them.

Figure 9-6. The Network Profiles Interface

Activate

Make the selected profile active.

Clone

Creates a new profile based on the settings of the selected one. A dialog pops up asking for the name of
the new profile. Don’t forget to activate that profile after creating it if you want to configure it.
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Delete

Deletes the currently selected profile without further prompts. Please note that a warning is shown if you
try to delete the active profile, because it cannot be removed while it is in use.

The Default Profile. This is the profile that is used at boot time. It cannot be deleted.

Example: Create a New Profile for Your Dial-Up Home Connection. You come back home with your brand
new laptop, which your system administrator configured so you can connect to your corporate network. You
now want to configure the network to access the Internet from home with a dial-up connection.

1. Create a new profile called “Home”.

2. Switch to it.

3. Reconfigure your network so that the modem, instead of the network card, is used to access the Internet
(see Network and Internet Connection Management, page 103).

4. Connect to the Internet.

5. When back at the office, switch back to the “default” profile.

9.3. Sharing an Internet Connection

This tool configures your system so that it acts as a gateway to the Internet for other machines
connected to it via a LAN. This is very useful at home, for example, if you want all computers
to access the Internet through the same Internet link.

The Internet

Local Network

(wireless or cabled)

Your machine
(gateway)

Other local machines

Figure 9-7. A Simple Gateway Configuration

The overall procedure follows:

1. Configure your Internet access (Network and Internet Connection Management, page 103). In order for your
machine to act as a gateway, you need an already configured and working connection to the Internet, plus
a network connection to your LAN. This implies at least two interfaces, for example, a modem and an
Ethernet card.

2. Set up the gateway (The Gateway Connection Wizard, page 112).

3. Configure the other local machines as clients (Configuring the Clients, page 113).

Warning

This wizard also configures a firewall to block most connections from the Internet. You are encouraged to check
that the firewall configuration (Securing your Internet Access via DrakFirewall , page 142) suits you after completing
the wizard.
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After you complete this wizard, all computers on the LAN will have to access the Internet. Their configuration
will be automated due to the DHCP server, which is installed on your gateway, and the web access will be
optimized through the Squid transparent proxy cache.

9.3.1. The Gateway Connection Wizard

These are the steps the wizard takes:

Note: In order to successfully complete the wizard, some steps require software packages to be installed. Please accept
installation of those packages.

1. Choosing the Internet Interface

You first need to specify the name of the interface connected to the Internet. Make sure you select the
correct one from the drop-down list. It should be the interface name you configured in the Internet Confi-
guration Management tool.

2. Choosing The LAN Network Adapter

If you have more than one Ethernet interface, and depending on what you chose as your Internet interface,
the wizard might ask you to select the one connected to your LAN1. Make sure you select the correct one.

3. Local Area Network Settings

Figure 9-8. Configuring the LAN

At this point, if it is the 1st time the system has been configured as a gateway, the wizard proposes default
parameters for the new local network to be managed. Check that these values are not already in use in
your network, and proceed to the next step.

Otherwise, the wizard will first offer to reconfigure the LAN interface so that it will be compatible with
the gateway services. It is recommended that you leave the default options and click on Next.

4. DNS Configuration

If you plan on having a local name server on your machine, you can check this box. Otherwise, you can
choose to use your provider’s name server. If you don’t know what a name server is, leaving the box
checked is safe.

5. DHCP Server Configuration

1. Note that all traffic to and from this network passing through the gateway will be masqueraded, that is: it will appear
(from an Internet point of view) to come from the gateway instead of from the LAN.
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Installing a DHCP server on your machine allows all client machines to have their network configurations
made automatically. Otherwise, you have to configure each client by hand: IP address, network, gateway,
DNS.

6. Proxy Caching Server (Squid)

A caching server records the Web pages requested by local browsers. Then, if the same page is asked for
again by someone else, it is able to serve it without needing to retrieve it again from the Internet, therefore
saving bandwidth and improving response time. This is very useful if there are many clients behind the
gateway.

The application used to perform this task is Squid (http://www.squid-cache.org/).

7. Broadcast Printer Information

Choose Yes if you want the client machines connected to the gateway to be able to access the printers
accessible from the gateway itself.

Disable Connection Sharing: The next time you launch this wizard, you will be asked whether you want to reconfigure
or disable connection sharing.

9.3.2. Configuring the Clients

The configuration of the clients mainly depends on whether you chose to install a DHCP server on your
gateway or not. By configuring the clients on the local network to use DHCP, they will automatically use the
Mandriva Linux machine as a gateway to the Internet. This works for Windows®, GNU/Linux and any other OS
that supports DHCP.

If you have no DHCP server, you have to configure each of your machines manually, according to the network
parameters set on the connection sharing wizard.

For DHCP, on a Mandriva Linux client system, make sure you selected DHCP in the Protocol pull-down list
when configuring the network, as shown in figure 9-9.

Figure 9-9. Configuring a Client to Use DHCP
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9.4. Managing Wireless Connections (Roaming)

This tool shows the wireless networks currently available. It also allows you to switch between
the networks and to change their configurations. If you haven’t configured your wireless interface
yet, please refer to Wireless Connection, page 104. figure 9-10 shows DrakRoam’s interface: a list of
the available networks, together with their status, and buttons for actions at the bottom.

Tip:

You can also right click on the“signal meter”icon in the panel and choose Wireless networks+Manage wireless
networks. Then enter root’s password to access the tool.

Figure 9-10. DrakRoam’s Interface

The list of detected networks is shown. If you expect other networks, click Refresh.

9.4.1. Switching Networks

To change networks, select one from the list, then click on Connect. If the network is public, you are imme-
diately connected. If it’s private, you are asked for configuration parameters with the same dialog shown in
figure 9-11. Provide the required settings (in particular, the encryption key) and click OK. Settings take effect
immediately.

9.4.2. Configuring a Wireless Connection

If you need to change the network parameters, select the network from the list, then click on Configure. See
figure 9-11 for an example of a secure wireless network connection.
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Figure 9-11. Changing Wireless Network Configuration

Make your adjustments and click OK; the settings take effect immediately. Click on Advanced to fine tune
parameters such as network ID and frequency.
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10.1. Configuring Start-Up Services

At boot time, the system starts a number of services (programs which run in the background
to perform a variety of tasks). This tool gives the administrator control over those services. See
the The Start-Up Files: init sysv chapter of the Reference Manual for more information.

Figure 10-1. Choosing the Services Available at Boot Time

For each service, this is the list of items found in each column:

• Service name;

• Current Status: either running or stopped;

• Info: click on this button to get a little explanation about that service;

• On Boot: check this box if you wish this service to be automatically started at boot time1. Alternatively,
if xinetd is installed and the service is a xinetd service, the label Start when requested will be displayed.
Checking the box will then mean to activate that service in xinetd. You will also have to make sure that the
xinetd service itself is activated.

• Start: immediately starts the service, or restarts it (stop+start) if it is already running;

• Stop: immediately stops the service.

After pressing the Start or Stop buttons, a tool tip shows you the status of the operation.

1. Generally in runlevels 3 and 5.
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10.2. Managing Fonts on your System with DrakFont

This system sdministration tool enables you to review the different font families, styles, and
sizes available on your system. It also allows for fonts to installed or removed.

The main window (see figure 10-2) shows a visual appearance of the currently selected font combination.

Figure 10-2. DrakFont’s Main Window

drakfont is made up of a number of dialogs which are accessible through the buttons located at the bottom.

Get Windows Fonts

This button automatically adds fonts found on your Windows® partitions, if any, of your local hard drives.

Options

Allows you to specify which applications and devices (such as printers) will support the fonts. Select the
ones you want support for and click on the OK button.

Uninstall

Allows you to remove installed fonts, in order to save space for example. Use this with great care, it could
have side effects for your applications. In particular you should not remove fonts you did not install
yourself.

This actually removes all fonts found in a given directory. Note that fonts manually added through drak-
font are found in /usr/share/fonts/drakfont/

Import

Allows you to manually add fonts found outside the Mandriva Linux distribution, from a fonts disk you
have purchased or from the Internet, for example. Supported font types are ttf, pfa, pfb, pcf, pfm,
gsf. Clicking on the Add button will open a standard dialog allowing you to specify the font file to
import. Once you’ve specified all the fonts you want to import, click on the Install fonts button.

Selecting more than one font: To select more than one font, press the CTRL key while selecting the fonts you
want to install and click OK, they will be added to the Import Fonts window. Then, click on the Install fonts button.
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Note: When adding or removing fonts, the change might not appear immediately in the fonts list. Close and re-launch
drakfont to ensure your changes were taken into account.

10.3. Setting your Machine’s Date and Time

This little tool enables you to set your system’s correct internal date and time.

Figure 10-3. Changing Date and Time

You can set the date on the left and the time on the right:

1. Date

To change the year, click on the little arrows on each side of the year; same procedure to change the month.
This updates the month view where you can click on the current day in order to highlight it.

2. Time Zone

We recommend that you check the time-zone settings for your geographical location. Click on the Change
Time Zone button and select the correct place in the tree view.

Once you’ve chosen the time zone, a dialog appears asking you whether your hardware clock is set to
GMT. Answer Yes if only GNU/Linux is installed on your machine, No otherwise.

3. Time

To change the time, you can either move the hour, minute and second hands of the analog clock, or change
the numbers below it.

4. Automatic Clock Synchronization
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If you have a permanent Internet connection and want your system to synchronize its internal clock with
time servers on the Internet, put a check mark in the Enable Network Time Protocol option and select a
server in the Server pull-down list, preferably one near you. If you know the name or the IP address of a
local server you can also enter it manually in that field.

When you’re finished, click on OK to apply your settings or Cancel to close the tool, which will discard your
changes. If you want to return to your previous settings, click on Reset.

10.4. Monitoring System Activity

This tool allows you to look for specific entries in various log files, therefore making it easier to
search for particular incidents or security threats.

10.4.1. Browsing System Logs

Figure 10-4. Browsing and Searching through System Logs

These are the steps to follow in order to browse or look for a specific event into the system logs:

1. Matching Terms

You must choose which specific words to match by filling the Matching (log files contain the words) field
and/or the but not matching (log files which don’t contain the words) field. At least one of the two fields
must be filled.

2. Log File
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Then in the Choose file area select the file you want to perform the search on. Simply check the correspon-
ding box.

Note: The Mandriva Linux Tools Log is filled by Mandriva Linux-specific configuration tools, like those you find in
the Mandriva Linux Control Center. Each time these tools modify the system configuration they write to this log
file.

3. Date of Event

Optionally, you can restrict the search to a specific day. In that case, check the Show only for the selected
day box and choose the desired day from the calendar.

4. Search

When all is set up, click on the Search button. The results appear in the Content of the file area at the bottom.

Clicking on the Save button opens a standard dialog letting you save the search results into a plain text (*.txt)
file.

10.5. Managing Users and Groups

UserDrake allows system administrators to easily add and remove users from the system, to assign users to a
group, and to manage user groups in the same manner.

Note: In this section we will only focus on user management. Group management being similar.

10.5.1. The Interface

Launching UserDrake will display the main window (figure 10-5) which lists the users currently defined on the
system. You can switch from users to groups by clicking on the Groups tab next to the Users tab.

Figure 10-5. The User List in UserDrake

All changes have immediate effect on your local user database. If the user list is modified outside of UserDrake,
you can refresh UserDrake’s window by clicking on the Refresh button.

Note: If you make changes to an already logged in user, those changes won’t take effect until the next time he or she
logs in again.

Available actions are:
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Add User

Adds a new user to the system. We will detail this procedure in Adding a New User, page 122.

Add Group

Adds a new user group to the system.

Edit

Allows you to change the parameters of the selected user or group. We will detail editing user parameters
in Adding a New User, page 122. In the case of a group you will be able to assign or remove users from that
group.

Delete

Removes the selected user or group from the system. A confirmation dialog will be shown, and in the
case of a user you will also be able to remove the user’s /home directory and mailbox.

10.5.2. Adding a New User

We created the non-privileged user Queen Pingusa at installation time, and now we want to create a new user
called Peter Pingus. Then we want to make them both members of the fileshare group, so that they can
share folders with other users on the network (see Allowing Users to Share Folders, page 135, custom option).

Click on the Add User button, a dialog box to add a new user will pop up (see figure 10-6). The only required
field is Login although we strongly recommend that you set up a password for this new user: enter it in both
the Password and Confirm Password fields. You can also choose to add a comment in Full Name. Generally, this
is the full name of the user, but you can put whatever you want.

Figure 10-6. Adding a New User in the System

We now have two users in our list. Select one of them with your mouse, and click on the Edit button. The
dialog box shown in figure 10-7 will pop up. It allows you to modify most available user parameters.
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Figure 10-7. Adding Users to a Group

The dialog is made of the following tabs:

User Data

Allows you to modify information provided when the user was created.

Account Info

Enables you to provide an expiration date for that account, after which the user won’t be able to connect
to the system. This is useful for temporary accounts. It’s also possible to temporarily lock an account to
prevent a user from logging in. Finally, this tab allows you to change the icon associated with the user.

Password Info

Allows you to provide a password expiration date, after which the user will be required to change his
password.

Groups

Shows the list of available groups where you can select the groups to which any user should belong.

For our users we just need to look for the fileshare entry and check the box associated to it. Then click on
the OK button to make the changes effective.

10.6. Backing Up and Restoring your Files

This tool allows you to backup the data present on your computer to different media and also
to a remote machine over a network. It also supports multiple profiles for different backup
scenarios. Once the parameters are set, you can run the backup periodically. Then, you can
forget about it until you wish or need to restore files.

10.6.1. A Practical Example Using the Wizard

You can access this tool by clicking on the Backups icon in Mandriva Linux Control Center’s System section. Click
on the Wizard Configuration button to start the wizard. After making your choices in each step click on Next.
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10.6.1.1. First Step: What to Backup

Figure 10-8. Selecting What to Backup

Select Backup System to include the /etc directory where all your current system configuration files lie. This
allows you to “transport” your system to another computer with little effort: only hardware-dependent confi-
guration will have to be revised.

Note: The “system” backup does not include applications themselves (i.e. executable files, libraries). A priori this makes
sense because it is likely that you will have access to the system’s installation media from which applications can be easily
installed again on the target computer.

Select Backup Users to include all the files included in all of your users’ /home directories. Clicking on the Select
user manually button lets you select individual users and gives you the following options:

• Do not include the browser cache. Selecting this option is recommended due to the very nature of the ever-
changing browser cache.

• Use Incremental/Differential Backups. Selecting this will preserve old backups. Choosing Use Incremental Bac-
kups will only save files which have been changed or added since the last backup operation. Choosing Use
Differential Backups will only save files which have been changed or added since the first backup operation
(also known as the “base” backup). This last option takes more space than the first one, but allows you to
restore the system “as it was” at any given point in time for which a differential backup was made.
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10.6.1.2. Second Step: Where to Store the Backup

Figure 10-9. Selecting Where to Store the Backup

All possible backup media are listed, along with a Configure button to change media-dependent options:

Hard Disk Drive

The local hard disk drive is used to prepare backups for all media except NFS and direct to tape. You
should not perform backups on your local hard disk anyway, you should always backup to remote or
removable media. You can set the directory for storage and the limit of storage space. You can also set
how many days to keep incremental or differential backups in order to save disk space.

Across the Network

To store the backup on a remote computer accessible using different methods. You can set the connection
parameters as well as the access method and its options (if applicable). Please note that NFS backups are
considered to be local disk backups, even if they are effectively stored on a remote system.

On Tape

You can set the tape device if it’s not detected automatically, and tape parameters such as writing directly
on tape, whether or not to rewind, erase and eject the tape.

Optical Media (CD-R)

This is our preferred media for the example, so click on its Configure button to set the required parameters
(see figure 10-10).
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Figure 10-10. Setting Optical Media Parameters

If it isn’t done automatically, use the Choose your CD/DVD device combo box to set the CD/DVD device. Set
the medium’s type and size, multisession and erase options.

For multisession recordings, please bear in mind that the option to erase the medium is only effective for the
1st session and also that session-related information recording takes some space out (20 to 30 MB) for each
session, so the “real data” storage space will actually be less than the medium’s size.
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10.6.1.3. Third Step: Review and Store the Configuration

Figure 10-11. Review Configuration Parameters

The last wizard step shows a summary of the configuration parameters. Use the Previous button to change any
parameter you are not satisfied with. Click on Save to store them on the Default profile. The backup set is
now ready to be performed.

Backup Profiles

You can choose File→Save profile as from the menu and provide a profile name to store the current backup
settings within a named backup profile. You can then run the configuration wizard again, define other settings
and store them under a different profile.

Use the --profile Profile_Name.conf option when you run Drakbackup from the command line to load
the Profile_Name.conf profile.

10.6.1.4. Performing the Backup

Click on Backup Now, make sure the corresponding media is ready (the recordable CDs in our example), and
then on Backup Now from configuration file to perform the backup.

Warning

If the backup set size exceeds the medium’s available capacity, the backup operation might just fail. This is a known
issue and it’s being worked on. As a work-around, please try to remove files from the backup set so its size never
exceeds the medium’s available capacity.

A dialog will display the current progress of the operation. Please be patient: the time it takes to back up
depends on many factors such as the size of the backup file set, the speed of the storage option selected,
and so on. Once the operation is finished a report is shown: look for possible errors on it and take corrective
measures if needed.
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10.6.2. Restoring Backups

Figure 10-12. Choosing the Restore Type to Perform

Make sure the media you want to restore the backup from is accessible and ready and click on the Restore
button. In our example we restore the whole backup so on the restore dialog (figure 10-12) click on Restore all
backups and then on the Restore button to start the restoration process.

Warning

Existing files in the target restoration directory (the same location as the backup was made from, by default) will
be overwritten.

Feel free to investigate the other restore options if you want to restore part of a backup instead of the full file
set, or to restore the backup to a different location.

10.6.3. Automating Periodic Backups

In the tool’s main window, click on Advanced Configuration and then on the When button. In the backup sche-
duling window (see figure 10-13) select Use daemon to define the schedule.
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Figure 10-13. Daemon Options Window

You are then asked to specify the interval (or period) between each backup operation and the storage media. In
our example we set up a customized calendar (custom period selected) to perform a backup from Wednesday
to Friday at a quarter to midnight and store it on CD, using the Default backup profile.

10.6.4. Advanced Backup Wizard Configuration

Click on Advanced Configuration and then on the More Options button to set more backup options (see figure
10-14).

Figure 10-14. Miscellaneous Options Window
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Archiving Program

You can choose between tar (the default) and star which allows you to backup extended ACLs too.

Compression Type

You can choose the compression strategy used for your backups among tar (no compression), tar.gz
(gzip compression) and tar.bz2 (bzip2 compression: better but slower).

Files to Ignore

You can exclude certain files from the backup. The .backupignore file should be present in every directory
of the backup file set where files are to be excluded. Its syntax is very simple: a one-file-per-line list of the
names of the files to exclude.

Tip: You can use the star (* = “matches any string”) and the question mark (? = “matches one and only one
character, regardless of what that character is”) in the .backupignore file to exclude sets of files. For example,
somename* matches all files whose names start with somename, and image00?.jpg matches files named
image001.jpg, image009.jpg, image00a.jpg, image00h.jpg, etc.

Send Reports by Email

Fill the mail address to which a report of the operation will be sent. You can specify many mail addresses
by separating each with a comma (,). Please also complete the Return address for sent mail field with the
email address of the backups administrator, and the SMTP server for mail field with the name or IP address
of the outgoing mail server.

Delete Temporary Files

Select the Delete Hard Drive tar files after backup to other media option to free that space after performing
the backup.

View Restore Log

You can choose to view the restore operation log after each restore. This can be handy to spot and fix
potential problems when restoring files: reading errors, network communications errors, etc.
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11.1. Managing your Hard Drive Partitions with DiskDrake

Partitions are initially set up during the installation process. DiskDrake allows you, to some
extent, to resize your partitions, move them, etc. DiskDrake can also deal with RAID devices
and supports LVM but we will not discuss these advanced uses here.

Warning

DiskDrake is very powerful and can therefore be a dangerous tool. Misuse could very easily lead to data loss on
your hard drive. Because of this potential loss of data, you are strongly advised to take some protective measures
before using DiskDrake:

1. Back up your data. Transfer it to another computer, DVD/CD, etc.

2. Save your current partition table (the table describing the partitions held on your hard drive(s)) to a
floppy disk (see DiskDrake’s action buttons, page 131).

11.1.1. The Interface

Figure 11-1. DiskDrake’s Main Window

DiskDrake enables you to manage partitions on each physical hard drive on your machine, and also on remo-
vable drives: USB hard disks, keys, memory cards, etc. If you only have one IDE disk, you will see a single tab
called hda below the file-system types. If there is more than one drive, then each drive will have its own tab
and will be named according to the Linux name for that drive.

The window (see figure 11-1) is divided into four zones:

• Top. The structure of your hard drive. When you launch DiskDrake it will display the current structure of
the drive. The display is updated as you make changes.

• Left. A menu relevant to the partition currently selected in the above diagram.

• Right. A description of the selected partition.

• Bottom. Buttons for executing general actions. See DiskDrake’s action buttons, page 131.

We will now review the actions available through the buttons at the bottom of the window.
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11.1.2. DiskDrake’s action buttons

Clear all

Clicking on this button will clear all partitions on the current hard drive.

More

Displays a dialog allowing you to:

Save partition table. Allows you to save the current partition table to a file on a disk (a floppy, for exam-
ple). This may prove useful if a problem arises (such as an error made during drive repartitioning).

Restore partition table. Allows you to restore the partition table as previously saved with Save partition
table. Restoring a partition table may recover your data as long as you do not reformat partitions, because
the formatting process overwrites all your data.

Rescue partition table. If you lose your partition table and have no backup, this function scans your hard
drive to try and reconstruct the partition table.

Help

Display this documentation in a browser window.

Undo

Cancels last action. Most modifications made to your partitions are not made permanent until DiskDrake
warns you it will write the partition table. This button therefore allows you to undo all of your modifica-
tions on partitions up to last write.

Toggle to expert mode

This button allows you to access the expert mode functions (which are even more dangerous if you are
not sure what you are doing). Reserved for experts.

Done

Saves your changes and exits DiskDrake.

11.2. Managing Removable Devices

These tools enable system administrators to easily control those options which affect the beha-
vior of removable devices such as floppy, CD and DVD disks. Note that, by default, all remo-
vable devices are automatically made available so users shouldn’t need to manually mount
media.

Warning

Starting with version 2007.1 of Mandriva Linux, removable media such as CD, floppy, USB keys and disks, etc. are
found under /media/ instead of /mnt/.
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Figure 11-2. Changing a Parameter

For each device the following properties may be changed:

• Mount point. The directory from where the device’s files will be accessed. You can either choose an entry
from the list or type in your own path. If the directory does not exist, it is created automatically.

• Options. Controls various device options, notably whether a user is allowed to use new media without
root privileges. By default, the user currently logged on the system’s physical console is given access to
removable media.

• Type. Displays a list of file-system types. If you have a specific medium with a different file system on it,
this is where you can tell Linux how to access it.

Select the property you wish to change and click OK. The corresponding dialog pops up in which you can
change your settings. Then click OK again and save your modifications to the /etc/fstab file: the device is
automatically remounted.

11.3. Importing Remote SMB Directories

This tool allows the system administrator to give users access to remotely shared directories
using the SMB protocol (used mainly by Windows®).

While users can individually access remote shares through their file managers, it may be required in some ca-
ses to import a specific share for it to become immediately available for all users. We’ll go through an example
showing you how to import a directory from a Windows® machine.
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Figure 11-3. Scanning the Whole Network

Choose a Server. Clicking on the Search servers button scans the local network for machines which currently
share directories (including the local one). We’ll choose one of them and make it available locally for all users.

Choose a Share. Clicking on a machine’s name will try to connect to it and browse for available shares. If that
machine has password-protected shares, a dialog pops up asking you to identify yourself. Enter the correct
Username, Password and Domain. The available shares on that machine will then appear. Click on the little
arrow at the left of the machine icon to show available shares.

Tip: If the machine you’re connecting to has both public and password-protected shares, then canceling the password
entry dialog will connect you to that machine, but only to its public shares.

Figure 11-4. Choosing the Remote Directory to Import

Once a share is selected, a Mount point button appears. Clicking on it displays a dialog where you can type the
local directory name where remote files will be accessible.

Once this is done, two more buttons appear:

• Mount. Makes the resource available locally. When this is done, users simply have to point their file manager
to the directory selected as the mount point to get the files hosted by the server.

• Options. Allows you to set a user name and password to access that SMB mount point. Other permissions
and advanced settings can also be set through this button.

Import Share on Each Reboot. When you’re finished configuring the access points for remote directories,
click on Done. A dialog box will appear asking you whether you wish to save your modifications to the
/etc/fstab file (where mount point information is usually stored), or not. Click on Yes to make the shares
configuration persistent between sessions. Click on No to exit without saving your changes.

134



Chapter 11. Mount Points and Remote Directories

11.4. Importing Remote NFS Directories

This tool is exactly the same as the one mentioned in Importing Remote SMB Directories, page
133, except that it controls file sharing through the NFS protocol rather than SMB. Therefore it
allows you to locally import shared files from NFS-friendly machines. The interface is the same
as the one described in Importing Remote SMB Directories, page 133, and the effects are similar.
Only the corresponding machines are different: UNIX® for NFS and Windows® for SMB.

One other difference is that there is no need to provide a password to access NFS shares. The authentication
mechanism is host-based.

11.5. Allowing Users to Share Folders

This tool enables you to share files with other users of your computer network. File sharing
can be done on heterogeneous systems such as GNU/Linux and Windows®.

The file-sharing configuration is done in two simple steps: determining who can export folders, and then
which protocol to use. A third step is necessary if you select the Custom export option.

Figure 11-5. Controlling Exports

1. Who is Allowed to Share Folders

• No sharing. Prevents users from sharing data with others.

• Allow all users. All users are allowed to share data with others.

• Custom. By choosing this option, only users within the fileshare group will be allowed to share data.
If you choose this option, the fileshare group will be created and, as a 3rd step, you will be prompted
to run UserDrake in order to add the allowed users to this group (see Managing Users and Groups, page
121).

2. Choose the Export Protocol
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You must now choose which protocol to use for file sharing. Check one or both of the following:

• SMB. If most of your users use Windows® systems, this is the preferable protocol to select.

• NFS. If most of your users use UNIX® systems (such as GNU/Linux), this is the preferable protocol to
select.

3. Once you have checked the appropriate boxes, click on OK. The required packages will be installed, if
needed. If you uncheck a previously checked box, the corresponding service will be stopped.

4. Lastly, if you have activated the Custom option to allow the users to share folders, you are prompted to
launch UserDrake. There you can add those users to the fileshare group.

Users Can Now Share Folders. Once users are allowed to share data, they can select the folders to be shared
through their preferred file manager.

11.6. Setting up WebDAV Mount Points

WebDAV (Web-based Distributed Authoring and Versioning) is an extension to the HTTP proto-
col which allows you to create, move, copy, and delete resources on a remote web server. In
practice, mounting a remote WebDAV repository on your local machine allows you to modify
a remote web server’s files as if those files were local to the system.

Tip: Browse the WebDAV Resources (http://www.webdav.org/) pages to learn more about this extension.
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Figure 11-6. Managing WebDAV Mounts Points

The first time you launch this tool the required packages are installed if needed, and only two buttons are
available. New, which allows you to define a new mount point, the other one just Quits the application. After
you have defined the mount points, they will appear as new buttons at the top of the buttons list. Clicking on
a mount point button will take you to the mount point menu (see figure 11-7).

When you click on the New button you are asked for the URL of the web server. Enter the complete URL of
the web server, beginning with http:// or https://, then click OK.

Figure 11-7. WebDAV Menu

You must now decide where the web server files will be accessible from. Select the Mount point option and
click OK. There you are able to choose a local directory or type in your own. If the selected mount point does
not exist, it will be created.

If the server requires authentication, do not forget to fill the username and password fields in the Options dialog.
Then all you need to do is to actually mount the remote repository by selecting Mount and clicking OK.

You are now able to browse and modify files on the local mount point you have defined and the changes will
be immediately available on the web server.

To make your settings persistent between sessions, remember to save modifications to the /etc/fstab file, as
suggested when you quit the wizard.
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12.1. Securing your Machine through DrakSec

draksec is a graphical interface to msec (which stands for Mandriva Linux Security Tool). It
allows you to change your system’s security level and to configure every option of msec’s
security features.

msec has two aspects: system behavior configuration and periodic checks of system state. Each security level
modifies the system configuration, making it more and more secure, and verifying more and more security
related aspects.

12.1.1. Setting your Security Level

Expert Tool: This tool is only displayed in expert mode. Choose Options→Expert mode from the menu and then access
the Security section of Mandriva Linux Control Center.

Figure 12-1. Choosing the Security Level of your System

Choose a Security Level. Simply choose the security level you want from the Security Level pull-down list: it
will be effective as soon as you click on OK. Please read the help text regarding security levels very carefully
so that you know what setting a specific security level implies.

Explore Each Level: If you wish to check which options are activated for each security level, review the other tabs: Network
Options, System Options and Periodic Checks. Click on the Help button to display information about the options and
their default values. If some of the default options don’t suit your needs, simply redefine them. See Customizing a Security
Level , page 140, for details.
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Activate Security Alerts. Put a check mark on the Security Alerts box to send by mail possible security issues
found by msec to the local user name or to the e-mail address defined in the Security Administrator field.

Warning

We highly recommend you activate the security alerts option so that the administrator is immediately informed of
possible security issues. Otherwise the administrator will have to regularly check the relevant system log files.

12.1.2. Customizing a Security Level

Clicking on each of the Options tabs (and the Periodic Checks one) lead you to msec’s list of security options.
This allows you to define your own security level based on the security level previously chosen.

Figure 12-2. Modifying Standard Options

For each tab, there are two columns:

1. Options List. All available options are listed.

2. Value. For each option1 you can choose from the corresponding pull-down menu:

• Yes. Activate this option no matter what the default value is.

• No. Deactivate this option no matter what the default value is.

• Default. Keep the default security level behavior.

• Ignore. Use this value if you don’t wish this test to be performed.

• ALL, LOCAL, NONE. The meaning of these are option-dependent. Please see the Help text available
through the Help button for more information.

Clicking on OK accepts the current security level with custom options, applies it to the system and exits the
application.

1. The default security level setting is shown in the Help window.
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12.2. Controlling File Permissions with DrakPerm

drakperm allows you to customize the permissions which should be associated with each file
and directory in your system: configuration files, personal files, applications, etc. If the owners
and permissions listed here don’t match the actual permissions of the system’s files, then msec
(which stands for Mandriva Linux Security Tool) will change them during its hourly checks.
These modifications can help prevent possible security holes or intrusions.

Note: This tool is accessible only in expert mode. Choose Options→Expert mode from the menu and then access the
Security section of Mandriva Linux Control Center.

Figure 12-3. Configuring File-Permission Checks

The list of files and directories which appears depends on the current system’s security level as set by msec,
along with their expected permissions for that security level. For each entry (Path) exists a corresponding
owner (User), owner group (Group) and Permissions. In the drop-down menu, you can choose to display only
msec rules (System settings), your own user-defined rules (Custom settings) or both as in the example shown in
figure 12-3.

Note: You cannot edit system rules, as stated by the “Do not enter” sign on the left. However you can override them by
adding custom rules.

Create Your Own Rules. If you wish to add your own rules for specific files or modify the default behavior,
display the Custom settings list and click on the Add a rule button.
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Figure 12-4. Adding a File-Permissions Rule

Customize Your Home Directory Permissions

1. Create a New Rule in msec

Let’s imagine your current security level is set to 3 (high). This means that only the owners of the home
directories can browse them. If you wish to share the content of Queen’s home directory with other users,
you need to modify the permissions of the /home/queen/ directory.

2. Actually change the Home Permissions

msec only changes file permissions that are more permissive than the one required by a certain security
level. That means that for the change above, the permissions must be changed by hand.

You can do this in Konqueror by modifying the permission properties of your home directory, and checking
the Apply changes to all sub-folders and their contents option.

3. Check Rules Priority

If you create more rules, you can change their priorities by moving them up and down the rules list: use
the Up and Down buttons on your custom rules to have more control over your system’s permissions.

12.3. Securing your Internet Access via DrakFirewall

This little tool allows you to set up a basic firewall on your machine. It filters connection at-
tempts made from the outside, and blocks unauthorized ones. It’s a good idea to run it just
after installing your machine and before connecting to the Internet, therefore minimizing the
risks of your machine being compromised.

This Wizard consists of the steps we detail below.
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12.3.1. Choosing Services to be Available from Outside

Figure 12-5. The DrakFirewall Window

Open Up Ports, If Needed. If checked, uncheck the Everything (no firewall) box, and then check the boxes
corresponding to the services you wish to make available to the outside world. If you wish to authorize a
service which isn’t listed here, click on Advanced to manually enter the port numbers to open.

Opening Unusual Services: Clicking the Advanced option opens a field named Other ports where you can enter any
port to be opened to the outside world. Examples of port specifications are presented just above the input field: use them
as a guide. It’s possible to specify port ranges by using the : syntax such as 24300:24350/udp.

This Won’t Block You from Accessing the Net. Not checking a service in this list won’t stop you from connec-
ting to the Internet. It will only prevent people from the Internet connecting to that service on your machine.
If you don’t plan on hosting any services on your machine (common case for a desktop machine) just leave all
boxes unchecked.

How to Disable the Firewall. On the other hand if you wish to disable the firewall and leave all services
accessible from the outside, check Everything (no firewall), but please bear in mind that this is very insecure,
and therefore not recommended.
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12.3.2. Activating Interactive Firewall Feature

Figure 12-6. Interactive Firewall Options

Stay Informed of Connections on your Machine.

The interactive firewall can warn you of connection attempts on your machine by displaying alert popups
through the network applet. Check the Use Interactive Firewall option to activate this feature.

Port scan detection

Activate this option to be warned of malicious attempts to access your machine.

Other entries corresponding to open ports

Next you are shown a checkbox for each port you have chosen to open during the previous step. Activa-
ting them will popup a warning each time a connection attempt is made on those ports.

12.3.3. Which Interface to Protect

The next step consists of selecting the network interface connected to the Internet.
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Figure 12-7. The Internet Interface

If you don’t know which interfaces you have connected for the Internet, you can check the system network
configuration (see Reconfiguring Interfaces, page 107). You can finally click OK to install the required packages,
activate the firewall and enjoy your secure Internet connection.
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13.1. Configuring the Login Mode

This tool allows a user to be automatically logged into the system at boot time, without a
password being required.

Figure 13-1. Choosing the Login Mode

Here are the available parameters:

Graphical Interface

If you wish to have the X Window System (graphical display) started at boot time, check the Launch the
graphical environment when your system starts box. If you leave it unchecked, the text login will be displayed
and you will need to start the graphical environment manually.

Autologin

If you’re the only person using your machine and nobody else has access to it, you may choose to be
automatically logged in at boot time.

1. Select the Yes, I want to autologin with this (user, desktop) option.

2. Choose the user you want to be logged on automatically in the Default user pull-down menu.

3. Choose the preferred Default desktop in the pull-down menu.

13.2. Changing Your Boot-up Configuration

This tool allows you to configure the bootloader and the boot menu entries.

Warning

Unless you’re an expert, it’s not recommended that you change these settings as it may prevent you from booting
your machine the next time you try to power it on.
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Figure 13-2. Choosing the Boot Mode

13.2.1. Configuring the Bootloader

You can choose between the GRUB and the LILO bootloaders. Either one allows you to boot Mandriva Linux,
it’s just a question of taste.

Unless you know what you’re doing, you shouldn’t change the default Boot device shown, because that’s
where the bootloader installs itself. If more than one OS is installed on your machine, it’s a good idea to delay
booting the default OS by at least 5 seconds so that you can easily select which one to boot.

The dialog finally shows a few options which can be useful depending on your specific hardware.

Enable ACPI

This option provides better power management support if your hardware is ACPI compatible. ACPI is
often needed for newer laptops which no longer support APM.

Clicking on Advanced allows you to select extra options:

Enable APIC

The IO-APIC (http://www.wlug.org.nz/APIC) is only really useful for multi-processor systems. It may
cause problems on single processor systems and should not be activated on single processor machines.

Enable Local APIC

The local APIC can be used by Linux to program interruptions to wake up threads. On multi-processor
machines, it can be used to send interrupts to another processor. If you have a single-processor machine,
do not check this option.

These relatively new APIC features are known to cause problems on some computers because of badly
designed chip sets or poor support in Linux kernel drivers. These problems can cause system freezes or
incorrect device detection. So you may need to deactivate them by removing the check from the corres-
ponding boxes.

Clean /tmp at each boot

This option allows you to wipe the contents of the /tmp directory. For instance, it could contain some files
youx downloaded from the Internet.

Precise RAM size if needed (found XXX MB)

Use this option to tell Linux how much RAM your machine possesses, if the amount found differs to what
your system has, or should this prove to be an issue at boot time.
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13.2.2. Managing Boot Entries

After clicking Next, the list of available entries at boot time is displayed. The default is marked by a star (*).

It’s also possible to make an entry the default by checking the Default check-box in the Modify dialog.

13.3. Customizing your Boot Theme

The Boot Theme utility enables you to change the default theme displayed at boot time, as well
as a few other options.

• Choose one of the available boot modes in the pull-down menu (figure 13-3).

• Uncheck the Display theme under console option if you want a clean, “traditional” console. This relates to
those accessible through the Ctrl-Alt-Fn keys.

Figure 13-3. DrakBoot Theme Window

The boot theme setting will have no effect if your system isn’t set to boot using the graphical mode. Please
refer to Changing Your Boot-up Configuration, page 147, for more information on setting the boot mode.

Installing Fancy New Themes. If you only have one theme available, you may install the bootsplash-themes pac-
kage which you will find in contribs. Other themes are also available on the web.

Create Your Own. The Create new theme button allows you to fully customize an existing boot theme or create
a new boot theme from scratch. Adjust the parameters to your liking and save it. It will then be accessible in
the available Themes list.
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If you plan on using Windows® as well as GNU/Linux by dual-booting (being able to access either system
on the same computer), please note that it is easier to install Windows® before GNU/Linux. If Windows® is
already set up on your system, and you have never installed GNU/Linux before, DrakX — Mandriva Linux’s
installation program — will have to re-size your Windows® partition. This operation can be harmful to your
data. Therefore, you must perform the following steps before proceeding:

1. Run chkdsk on your Windows® computer (also called scandisk on some non-NT systems, such as Win-
dows® 9x). The resizing program can detect some obvious errors, but chkdsk is better suited for this task.
Refer to the chkdsk documentation for more information on the different options it has.

Note: Before using chkdsk make sure your screen saver and any other program that might write to the hard disk
is turned off. To obtain even better results, you should run chkdsk from Windows®’s “Safe Mode”, though it will
take longer.

2. For maximum data security, also run defrag on your partition if you use Windows® 9x1. This further reduces
the risk of data loss. This isn’t mandatory, but it’s highly recommended. Doing so will make the resizing
process much faster and easier.

3. The ultimate insurance against problems is to always back up your data! Of course, you should back up
your data on another computer, upload your back-ups onto the web, on a friend’s computer, etc. Do not
back it up onto the computer on which you want to install GNU/Linux.

1. On NT-based operating systems, defragmentation has little to no effect, provided the disk is formatted with NTFS.
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Chapter 15. Before Installation

This chapter covers issues which should be addressed before you start your new Mandriva Linux installation.
Make sure you read it completely since it will save you a lot of time. Also back up your data (on a different
disk to the one you will install the system into) and plug in and turn on all your external devices (keyboard,
mouse, printer, scanner, etc.).

15.1. Configuring your BIOS

The BIOS (Basic Input/Output System) is used to find the device on which the operating system is located and
starts it up. It’s also used for the initial hardware configuration and low-level hardware access.

The appearance of plug’n’play devices and their widespread use means that all modern BIOSes can initialize
these devices. In order for Linux to recognize plug’n’play devices, your BIOS must be configured to initialize
them.

Changing your BIOS’ settings is usually performed by holding down the Del key (some BIOSes may use the
F1, F2, F10 or Esc keys instead) right after the computer is switched on. Unfortunately, there are so many
types of BIOSes, you will need to look for the appropriate option yourself. It’s often called PNP OS installed (or
Plug’n’Play OS installed). Set this option to No and the BIOS will then initialize any plug’n’play devices, which
helps Linux to recognize them.

Look for Boot sequence or First boot device in the BIOS’ features setup, and set the CD-ROM as the first boot
device.

Note: If you want to use a parallel printer connected locally to your machine, make sure the parallel port mode is set to
ECP+EPP (or at least to one of ECP or EPP) and not to SPP, unless you have a really old printer. If the parallel port
is not set this way you might still be able to print, but your printer will not be detected automatically and you will have
to configure it manually. Also make sure the printer is properly connected to your machine and powered on beforehand.

15.2. Supported Hardware

Mandriva Linux can handle a large number of hardware devices, and the list is far too long to be quoted exhaus-
tively. You may consult an up-to-date list of supported hardware on the Mandriva Linux Hardware Database
(http://www.mandriva.com/hardware) web site.

Warning

Legal Disclaimer: The Mandriva Linux Hardware Database contains information about hardware devices which
have been tested and/or have been reported to function properly with Mandriva Linux. Due to the wide variety of
system configurations, Mandriva cannot guarantee that a specific device will work properly on your system.

Support for USB 1.x and USB 2.0 is now extensive. Most peripherals are fully supported. You can obtain
the list of supported hardware on the Linux-USB device overview (http://www.qbik.ch/usb/devices/) site.
Relevant information can also be found on the Linux USB (http://www.linux-usb.org) web site.
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Chapter 16. Installation with DrakX

16.1. The Mandriva Linux Installer

With the DrakX installation program, it doesn’t matter whether you’re a newbie or a GNU/Linux guru. The job
of DrakX is to provide you with a smooth installation and an easy transition to Mandriva Linux’s latest version.

Tip: Make sure that all your hardware is connected to your computer and powered on during the installation. Printers,
modems, scanners and joysticks are just a few examples of peripherals which DrakX can automatically detect and configure
as Mandriva Linux is being installed.

Begin Installation

1. Stop the Timer

Press any keyboard key (except Enter) when you see Mandriva’s welcome screen appear (figure 16-1). The
first screen offers a list of various possible actions, and if you do nothing, the first option (Boot from Hard
Disk) is carried out when the timer expires.

2. Choose your Language

Press the F2 key to have all options displayed in your language. Simply select your language by using the
up and down arrow keys, then press Enter.

3. Start Installation

Simply select the Installation option on the list, and press Enter.

Figure 16-1. First Installation Welcome Screen

If Something Goes Wild: In case this default procedure does not work for you, read Startup Options, page 156.
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16.1.1. The Installation Process

When the installer starts, you see a nice graphical interface (see figure 16-2). On the left are the various installa-
tion steps, the current one marked by a highlighted bullet. The installation occurs in two phases: installation,
then configuration.

Steps and Substeps. Each step may present various screens. You can surf between those screens with the Next
and Previous buttons. Additionally an Advanced button may be available to show more advanced configuration
options. Note that most of the latter should only be used by expert users. But there’s no harm in looking at
them!

Tip: The Help button displays explanations about the current installation step.

16.1.2. Startup Options

If something goes wrong during the first installation attempt, boot again from the CD, and depending on
your problem, try one of the Fx options at the bottom of the screen. Select an option and press F1 to get more
information about what that specific option does.

Boot Options. This line contains the options passed on to the kernel that will be used for the selected action.
Most machines don’t require specific kernel options.

16.2. Choosing your Language

The first step is to choose your preferred language. If you have already changed the language at the CD boot
splash screen (figure 16-1) and don’t need to install additional languages, you can safely move to the next step.

Figure 16-2. Choosing the Default Language

Open the tree representing the continent you’re located in, then choose your language. Your language choice
will affect the installer, the documentation, and the system in general.

Multi-Language System. Use the list accessible through Multi languages to select other languages to be insta-
lled on your system, thereby installing the language-specific files for system documentation and applications
(translations, fonts, spell checkers, etc.) For example, if Spanish friends are to use your machine, select English
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as the default language in the tree view and Español in the list view. You may choose several, or even install
them all by selecting the All languages option. Make sure you select all languages which are likely to be useful
on the machine now, once the system is installed it may be difficult to configure support for languages not
chosen at install time.

UTF-8 (Unicode) Support: Unicode is a character encoding intended to cover all existing languages and alphabets, and
Mandriva Linux uses it by default. However, if you have previously noticed problems with it for your language, you can
resort to your language-specific encoding by selecting the Old compatibility (non UTF-8) encoding option.

Switching from one Language to Another: To switch between the various languages installed on your system once it is
installed, go to the main menu System+Configuration+Other and choose the LocaleDrake (System) entry to change the
language used by the entire system, or the LocaleDrake (User) entry to changes the language settings only for yourself.

16.3. License Terms of the Distribution

Before continuing, you should carefully read the terms of the license. It covers the entire Mandriva Linux distri-
bution. If you agree with all the terms it contains, select Accept and click Next. If not, clicking on Quit reboots
your computer.

Release Notes: If you are curious about any technical changes which have occurred in the distribution since the last
release, you can click on Release Notes.

16.4. Configuring your Keyboard

This step only shows if your language settings match more than one keyboard layout. Otherwise, your key-
board layout is automatically selected.

157



Chapter 16. Installation with DrakX

Depending on the language you choose (see Choosing your Language, page 156), DrakX automatically selects
a particular type of keyboard configuration. Verify that the selection suits you or choose another keyboard
layout.

More Keyboards. Click on More to display the list of all supported keyboards, if your keyboard is not in the
first list.

Non Latin Alphabets. If you choose a keyboard layout based on a non-Latin alphabet, the next dialog allows
you to choose the key binding which can switch the keyboard between the Latin and non-Latin layouts.

16.5. Security Level

At this point, DrakX allows you to choose your machine’s security level. As a rule of thumb, the security level
should be set higher if the machine is to contain crucial data, or if it’s to be directly exposed to the Internet, or
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hosting many users. The trade-off is that a higher security level is generally obtained at the expense of ease of
use.

1. Choose the Security Level

If you do not know what to choose, read the descriptions, or keep the default option. You will be able to
change it later with the draksec tool in the Mandriva Linux Control Center.

2. Selecting the Administrator Email Address

Fill the Security Administrator field with the e-mail address of the person responsible for security. Security-
related messages will be sent to that address.

16.6. Installation Class

This step is shown only if an existing GNU/Linux partition is found on your machine.

DrakX now needs to know if you want to install from scratch or to upgrade your existing Mandriva Linux
system:

Upgrade

This installation type simply updates the packages currently installed on your Mandriva Linux system.
Your current partitioning scheme and user data won’t be altered. Most of the other configuration steps
remain available and are similar to a standard installation.

Note: Using the “Upgrade” option should work fine on Mandriva Linux systems running versions up to two releases
“in the past”. Performing an upgrade on prior versions is not recommended.

Warning

Depending on your hardware and your installation size, upgrading may take a very long time.
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Install

For the most part, this completely wipes out the old system. However, depending on your partitioning
scheme, you can prevent some of your existing data (particularly /home directories) from being overw-
ritten.

16.7. Where to Install Mandriva on your Hard Disk

You now have to decide where you will install Mandriva Linux on your hard drive. Your hard drive needs to
be partitioned which means it must be logically divided in order to create the required space for your new
Mandriva Linux system.

Because the process of partitioning a hard drive is usually irreversible and can lead to data loss, it can be
intimidating and stressful for the inexperienced user. Fortunately, DrakX includes a wizard which simplifies
this process. Before continuing with this step, read through the rest of this section and above all, take your
time.

Depending on the configuration of your hard drive, several options are available:

Use free space

This option performs an automatic partitioning of any blank areas of your drive. If you use this option
there will be no further prompts.

Use existing partitions

The wizard has detected one or more existing Linux partitions on your hard drive. If you want to use
them, choose this option. Then choose the mount points to be associated with each of the partitions. The
legacy mount points are selected by default, and for the most part it’s a good idea to keep them. Then
choose the partitions to be formatted or preserved.

Erase and use entire disk

Choose this option to delete all existing data and partitions present on your hard drive. You won’t be able
to undo this operation after you confirm.

Warning

If you choose this option, all data on your disk will be deleted.
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Remove Microsoft Windows®

This option appears when the hard drive is entirely taken by Windows®. Choosing this option simply
erases the entire drive, partitioning everything from scratch.

Warning

If you choose this option, all data on your disk will be lost.

Use the free space on the Microsoft Windows® partition

If Windows® is installed on your hard drive, you might have to create free space for GNU/Linux. To do
so, you can either delete your Windows® partition and data (see the “Erase and use entire disk” solution)
or resize your FAT or NTFS partition. Resizing can be performed without the loss of any data, provided
you have previously defragmented the Windows® partition. Backing up your data is strongly recom-
mended. Using this option is recommended if you want to use both Mandriva Linux and Windows® on the
same computer.

Before choosing this option, please understand that after this procedure, the size of your Windows® parti-
tion will be smaller than when you started, which means you will have less free space to store your data
or to install new software.

Custom disk partitioning

Choose this option to manually partition your hard drive. Be careful: it’s a powerful but dangerous choice
and you can very easily lose all your data. This option is only recommended if you performed custom
disk partitioning before, and have enough GNU/Linux experience. For more instructions on how to use
the DiskDrake utility, refer to Managing your Hard Drive Partitions with DiskDrake, page 131.

16.8. Package Selection

We now enter the software package installation itself. It consists of selecting the installation media and the
packages to be installed.

16.8.1. Choosing the Installation Media

Select Available CDs. If you are doing an installation from a CD, you are first asked to select the CDs you
actually have available.

Copy CDs to Hard Drive. You are also given the option to copy all packages on your hard drive. This will
probably speed up installation and will ease later package installation as all packages will already be available
on your hard disk.

16.8.2. Supplementary Installation Media

Depending on your installation media, it is now possible to add new installation media, such as a CD or
remote network repositories from Mandriva Club, for example. If you choose a network repository, you will go
through the following steps:

1. Network Configuration

Simply choose the connection type needed to access the remote repository. Your settings will be preserved
for the actual system network configuration.

2. Media Selection

Choose a mirror from the list of official ones proposed, or the very first entry (URL) and provide the
information (URL or NFS server and path) to access the new media.
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16.8.3. Choosing Package Groups to Install

It’s now time to specify which applications you want to install on your system. There are thousands of pac-
kages available for Mandriva Linux, and to make it simpler to manage, they have been placed into groups of
similar applications.

Mandriva Linux further sorts package groups into general categories. You can mix and match applications
from the various categories, so a Workstation installation can still have applications from the Server category
installed.

1. Workstation: if you plan on using your machine as a workstation, select one or more of the groups in this
category. The special LSB group will configure your system so that it complies as much as possible with
the Linux Standard Base Project (http://www.linux-foundation.org/en/LSB) specifications.

2. Server: if your machine is intended to be a server, select which of the most common services you want to
install on your machine.

3. Graphical Environment: this is where you can choose your preferred graphical environment. You must
select at least one if you want to have a graphical interface available.

Tip: Moving the mouse cursor over a group name displays a short explanatory text about that group.

Select Individual Applications. You can check the Individual package selection box, which is useful if you are
familiar with the packages being offered, or if you want to have total control over what will be installed.

Upgrade Applications Only. If you start the installation in Upgrade mode, you can deselect all groups and
prevent the installation of any new packages. This is useful for repairing or updating an existing system.

16.8.4. Minimal Installation

If you deselect all groups when performing a regular installation (as opposed to an upgrade), a new dialog is
displayed after pressing Next, suggesting different options for a minimal installation:

• With X: installs the minimum number of packages possible to have a working graphical desktop.

• With basic documentation: installs the base system plus basic utilities and their documentation. This installa-
tion is suitable for setting up a server.
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• Truly minimal install: installs the absolute minimum number of packages necessary to get a working Linux
system. With this installation, you only have a command-line interface.

16.8.5. Choosing Individual Packages to Install

If you choose to select which packages to install, the installer presents a tree structure containing all packages
classified by groups and subgroups. While browsing the tree, you can select entire groups, subgroups, or
individual packages.

Package Description. Whenever you select a package on the tree, a description appears on the right to let you
know the purpose of that package.

Server Applications

If a server package has been selected, either because you specifically chose the individual package or because it was
part of a group of packages, you are asked to confirm that you really want those server packages to be installed.
By default Mandriva Linux will automatically start any installed services (servers) at boot time. Even if they are
safe and have no known issues at the time the distribution was shipped, it is entirely possible that security holes
were discovered after this version of Mandriva Linux was finalized. If you don’t know what a particular service is
supposed to do or why it’s being installed, then click No.

Dependencies Between Packages. The Show automatically selected packages option is used to disable the war-
ning dialog that appears whenever the installer automatically selects a package to resolve a dependency issue.
Some packages depend on others and the installation of one particular package may require the installation of
others. The installer can determine which packages are required to satisfy a dependency, and to successfully
complete the installation.

Load/Save the List of Packages. The little floppy disk icon at the bottom of the list allows you to load or
save the package list. This is useful if you have a number of machines that you want to configure identically.
Click on this icon and select whether you wish to Load or Save the package list, then select the medium in the
following screen and click on OK.
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16.9. Root Password

16.9.1. Enter a Password

The Root Password is Key to Your System Security. The root user is the system administrator and is the
only user authorized to make updates, add users, change the overall system configuration, and so on. In
short, root can do everything! That’s why you must choose a password which is difficult to guess: DrakX tells
you if the password you choose is too simple. Depending on the security level you chose, you’re not forced
to enter a password, but we strongly encourage you to do so. GNU/Linux is just as prone to operator error
as any other operating system. Since root can overcome all limitations and unintentionally erase all data on
partitions by carelessly accessing the partitions themselves, becoming root must be difficult.

Choose the Right Password. The password should be a mixture of alphanumeric characters and its minimum
length will vary according to the chosen security level. Never write down root’s password — it makes it far
too easy to compromise your system. However, don’t make the password too long or too complicated because
you must be able to remember it too!

Enter the Password, Twice. The password won’t be displayed on screen as you type it. To reduce the chance
of a blind typing error you have to enter the password twice.

16.9.2. Optional: Choose a Centralized Authentication Scheme

By default, users accounts are created locally on the machine itself. However, in a corporate environment, user
accounts are often stored on a central authentication database. You can change the way users are authenticated
on your computer by clicking on Authentication method. Various authentication methods are available.

If you select a method other than Local file, you are asked to provide some parameters which vary from one
method to the other. If you don’t know those parameters, you should ask your network administrator.
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16.10. Adding a User

Linux is a secure multi-user system. Each user may have his own preferences, files and so on. But unlike
the system administrator called root, the users you add at this point are not authorized to change anything
except their own files and their own configurations, protecting the system from unintentional or malicious
changes which could have a serious impact on it.

Create at Least One User. You are first asked for a real name. DrakX uses the first word you type in this field
and copies it, all in lowercase, to the Login name field, which is the name this user must enter to log on to
the system. Then enter a password, twice (for confirmation). From a security point of view, a non-privileged
(regular) user’s password isn’t as crucial as the root password, but that’s no reason to neglect it by making it
too simple: after all, your files could be the ones at risk.

Create Other Users if Needed. Once you click on Accept user you can add other users. Add a user for each
one of your friends, your father, your sister, etc. Click Next when you’re finished adding users.

User Shell: Clicking on Advanced allows you to change the default shell for that user (bash by default), and to
manually choose the user and group IDs for that user.

Auto Login. Depending on the security level chosen, you may be asked to choose a user who will be automa-
tically logged into the system when the computer boots up. If you’re interested in that feature, check the Use
this feature box, choose the desired user and select a window manager, then click on Next.
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16.11. Installing a Bootloader

This step only shows if there is already a Linux bootloader on your system.

A bootloader is a small program which is started by the computer at boot time. It’s responsible for starting
up the whole system. Normally, the bootloader installation is totally automated. DrakX analyzes the disk boot
sector and acts according to what it finds:

• If a Windows® boot sector is found, it is replaced by a GRUB/LILO boot sector. This way you are able to load
either GNU/Linux or any other OS installed on your machine.

• In any other case it asks you where it should place the boot loader. Generally, the First sector of drive (MBR)
is the safest place.

Choosing Skip won’t install a bootloader. Use this option only if you know what you’re doing.
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16.12. Checking Miscellaneous Parameters

16.12.1. Summary

As a review, DrakX presents a summary of information it gathered about your system. Depending on the
hardware installed on your machine, you may have some or all of the following entries. Each entry is made
up of the hardware item to be configured, followed by a quick summary of the current configuration. Click on
the corresponding Configure button to make any changes.

• Keyboard: check the current keyboard map configuration and change it if necessary.

• Country / Region: check the current country selection. If you’re not in the country selected by DrakX, click
on the Configure button and choose another. If your country isn’t in the list shown, click on Other Countries
to get a complete country list.

• Timezone: by default, DrakX deduces your time zone based on the country you have chosen. You can click
on the Configure button if this is not correct. See Time Zone Options, page 168.

• Mouse: verify the current mouse configuration and change it if necessary.

• Sound card: if a sound card is detected on your system, it is displayed here. If you notice the sound card isn’t
the one actually present on your system, you can click on the button and choose a different driver.

• TV card: if you have a TV card, this is where information about its configuration is displayed. If you want
to try a different driver for your TV card, or its detection wasn’t accurate you can click on Configure to try to
configure it manually.

• Graphical Interface: by default, DrakX configures your graphical interface with a resolution that best matches
your video card and monitor combination. If that doesn’t suit you, or DrakX could not automatically confi-
gure it (not configured is displayed), click on Configure to reconfigure your graphical interface. You can click
on Help from within the configuration wizard to benefit from full in-line help.

• Network: if you wish to configure your Internet or local network access, you can do so from here. Refer
to the printed documentation or use the Mandriva Linux Control Center after the installation has finished to
benefit from full in-line help.

• Proxies: allows you to configure HTTP and FTP proxy addresses if the machine you’re installing on is to be
located behind a proxy server.

• Security Level: this entry allows you to redefine the security level as set in a previous step (see Security Level,
page 158).

167



Chapter 16. Installation with DrakX

• Firewall: if you plan to connect your machine to the Internet, it’s a good idea to protect yourself from in-
trusions by setting up a firewall. Consult Securing your Internet Access via DrakFirewall, page 142 for details
about firewall settings.

• Bootloader: to change your bootloader configuration. This should be reserved to advanced users. Refer to
the printed documentation or the in-line help about bootloader configuration in the Mandriva Linux Control
Center.

• Services: with this entry you can fine tune which services are run on your machine. If you plan to use this
machine as a server it’s a good idea to review this setup.

16.12.2. Time Zone Options

This setup allows you to refine the time zone you are currently located in. After you’ve chosen the location
nearest to your time zone, two more options for time management are shown.

Date, Clock & Time Zone Settings

GNU/Linux manages time in UTC (Coordinated Universal Time) and translates it to local time according
to the time zone you selected. If the machine also hosts another operating system that doesn’t handle time
the same way, it’s better to select the hardware clock set to local time option.

NTP Server

If you check the Automatic time synchronization option the system clock will be regulated automatically
by connecting to a remote time server on the Internet. For this feature to work, you must have a working
Internet connection. We recommend that you choose a time server located near you or the default All
servers entry which will select the best server for you. This option actually installs a time server which can
be used by other machines on your local network as well.

16.12.3. Configuring X, the Graphical Server

X (for X Window System) is the heart of the GNU/Linux graphical interface on which all the graphical environ-
ments (KDE, GNOME, AfterStep, WindowMaker, etc.) bundled with Mandriva Linux rely on.

Graphic Card

If everything works fine, the installer should detect and configure the video card installed on your machi-
ne. If the detection or configuration is incorrect, you can choose the card installed on your system from a
list.
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Monitor

If the installer fails to detect or configure your monitor properly, you can choose from this list the monitor
which is connected to your computer.

Resolution

Here you can choose the resolution and color depth from those available for your graphics hardware.
Choose the one which best suits your needs (you will be able to make changes after the installation). A
sample of the chosen configuration is shown in the monitor picture.

Test

Note: This entry might not appear if your hardware does not allow testing.

The system tries to open a graphical screen at the desired resolution. If you see the test message during
the test and answer Yes, then DrakX will proceed to the next step. If you don’t see it, it means that some
part of the auto-detected configuration was incorrect and the test automatically ends after a few seconds
and returns you to the menu. Change settings until you get a correct graphical display.

Options

Graphic card options

Depending on your hardware capabilities, you can choose here to activate or disable specific features
such as 3D acceleration or special visual effects (translucency).

Graphical interface at startup

This option allows you to choose whether you want your machine to automatically switch to a
graphical interface at boot. Obviously, you may want to select the No option if your machine is to
act as a server, or if you were not successful in getting the display configured.

16.12.4. Selecting Available Services at Boot Time
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This dialog is used to select which services will be automatically started at boot time: DrakX lists all services
available on the current installation. Review each of them carefully and uncheck those which aren’t needed at
boot time.

Tip: A short explanatory text is displayed about a service when it is selected. However, if you’re not sure whether a
service is useful or not, it is safer to leave the default setting.

Server Installation

At this stage, be very careful if you intend to use your machine as a server: you probably don’t want to start any
services which you don’t need. Please remember that some services can be dangerous if they’re enabled on a server.
In general, select only those services you really need.

16.13. Installing Updates from the Internet

By the time you install Mandriva Linux, it’s likely that some packages have been updated since the initial
release. Bugs may have been fixed, security issues resolved, etc.

Choosing Yes displays a list of web locations from which you can retrieve updates. You should choose one
near to you. Review the packages from the tree selection, and press Install to retrieve and install the selected
packages.
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16.14. It’s Done!

There you are. The installation is now complete and your GNU/Linux system is ready to be used. Just click on
Reboot to restart the system. Remember to remove the installation media (CD-ROM or floppy). The first thing
you should see, after your computer has finished doing its hardware tests, is the bootloader menu, which
allows you to choose between the OSes your system can boot.

16.15. How to Uninstall Linux

Warning

Removing partitions on your hard drive will inevitably result in the loss of all data stored on those partitions. Please
make sure you’ve backed up all of the data you want to keep before proceeding.

If for any reason you want to uninstall Mandriva Linux, you can do so. The process of uninstalling Mandriva
Linux is done in two steps:

1. Remove the bootloader from the Master Boot Record (MBR)

a. To do so, reboot your computer with the installation CD or DVD (see The Mandriva Linux Installer,
page 155).

b. Choose the Rescue System option.

c. In the new menu that appears, choose the Restore Windows Boot Loader option, then press Enter
to write the MBR with a Windows® one.

2. Delete all partitions related to Mandriva Linux on your hard drive

These are usually partitions hosting ext3 file systems and the Swap partition. You can also replace them
with a single partition using fdisk.

a. Still in rescue mode, select option Go to console.

b. Run fdisk /dev/hda (if the hard disk containing Mandriva Linux is other than the 1st IDE disk,
change /dev/hda accordingly).

c. Use the p command to display partition information, and then use the d command to delete all
unneeded partitions.
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d. If you want to create a single partition, use the c command, specify 1 as the partition number,
make it use all of the space available, and when asked for the partition type, use the L command
to list the supported partition types and choose the one for the OS you plan to install later.

Some examples:

• c for a FAT32 (Windows® 9x) partition

• 7 for a NTFS (Windows® NT/Windows® 2000/XP) partition,

• 83 for a GNU/Linux partition.

e. Finally use the w command to write changes back to disk.

3. Once this is done, just reset or shutdown the machine using the corresponding buttons.
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Even if using graphical applications is very comfortable and easy for most people, the command line is a very
powerful interface to interact with your system. The shell’s main asset is the number of existing utilities: there
are thousands of them, and each utility is devoted to a particular task. We look at a very small number of these
utilities hoping that you will feel more comfortable interacting with your system through the command line.

Choose System+Terminals→Konsole from the main menu to get a terminal window to have access to
the command line. By default you will be “inside” your personal directory, named after your user
name: /home/your_user_name.

17.1. File Manipulation

All your data is contained within files: office documents, songs, movies, etc. We present some commands to
organize and manage those files.

17.1.1. List the Contents of a Directory

ls (LiSt) is equivalent to the DOS command dir. Its syntax is as follows:

ls [options] <directory> [directory ...]

The most common options are:

• -R: recursively list the contents of the directory and all its subdirectories. Please note that before displaying
a directory’s contents the name of the directory itself is shown.

• -l: use a long listing format. Details about the file such as the file’s type, permissions, owner and size are
displayed.

• -a: show also hidden files. In UNIX® systems, all files whose names start with a period (.) are hidden. Use
this option to show such files when listing a directory. If you don’t want the current directory and its parent
(namely, . and ..) to be displayed use the -A option instead.

Some examples:

• ls -lA /tmp/movies /tmp/images: list the contents of both the movies and images directories inside
the /tmp directory, displaying file details and hidden files, but not displaying the . and .. entries for each
directory;

• ls -R ~/: display, recursively, all the files and directories you have inside your personal directory.

17.1.2. Copy

cp (CoPy) is equivalent to the DOS commands copy and xcopy but has more options. Its syntax is as follows:

cp [options] <file|directory> [file|directory ...] <destination>

The most common options are:

• -R: recursive copy; mandatory for copying a directory, even an empty directory.

• -f: replaces any existing files without requesting confirmation. Use with care.

• -a: archive mode, preserves all file attributes on the copy and performs a recursive copy.

• -v: verbose mode, displays all actions performed by cp.

Some examples:

• cp -f /tmp/images/* images/: copies all files in the /tmp/images directory to the images directory
located in the current directory. It doesn’t request confirmation if a file is going to be overwritten.
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• cp -vR docs/ /shared/mp3s/* mystuff/: copies the whole docs directory, plus all files in the
/shared/mp3s directory to the mystuff directory, displaying all actions performed.

• cp foo bar: makes a copy of the foo file with the name bar in the current directory.

17.1.3. Move

mv (MoVe) is equivalent to the DOS command move. Its syntax is as follows:

mv [options] <file|directory> [file|directory ...] <destination>

Note that when you move multiple files the destination must be a directory. To rename a file you simply move
it to the new name.

The most common options are:

• -f: forces the operation. No warnings are given if an existing file is to be overwritten. Use with care.

• -v: verbose mode, reports all changes and activity.

Some examples:

• mv /tmp/pics/*.png .: move all files in the /tmp/pics directory whose names end with .png to the
current directory.

• mv foo bar: rename file foo to bar. If a bar directory already existed, the effect of this command would
be to move file foo or the whole directory (the directory itself plus all files and directories in it, recursively)
into the bar directory.

• mv -vf file* images/ trash/: move, without requesting confirmation, all files in the current direc-
tory whose names begin with file, together with the entire images directory to the trash directory, and
show each operation carried out.

17.1.4. Remove

The rm command (ReMove) is equivalent to the DOS commands del and deltree, but has more options. Its
syntax is as follows:

rm [options] <file|directory> [file|directory...]

The most common options are:

• -r, or -R: delete recursively. This option is mandatory for deleting a directory, empty or not. However, you
can also use rmdir to delete empty directories.

• -f: forces deletion of the files or directories. Use with care.

Some examples:

• rm images/*.jpg file1: deletes all files with names ending in .jpg in the images directory and deletes
file1 in the current directory.

• rm -Rf images/misc/ file*: deletes, without requesting confirmation, the whole directory misc in
the images directory, together with all files in the current directory whose names begin with file.

Warning

Using rm deletes files irrevocably. There is no easy way to restore them! Be extra careful when using the -f option
to skip confirmation request to ensure that you do not delete something by mistake.
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17.1.5. Create a Directory

mkdir (MaKe DIRectory) is equivalent to the DOS commands mkdir and md. Its syntax is as follows:

mkdir [options] <directory> [directory ...]

Only the -p option is worth noting. It does two things:

1. creates parent directories if they did not exist previously. Without this option, mkdir would just fail,
complaining that these directories do not exist;

2. returns silently if the directory you wanted to create already exists. If the -p option is not specified, mkdir
sends back an error message, complaining that the directory already exists.

Some examples:

• mkdir foo: creates a directory foo in the current directory;

• mkdir -p images/misc: creates the misc directory in the images directory, creating first the latter if it
does not exist.

17.1.6. Change the Working Directory

The current working directory, symbolized by a period (.), is the place on the file system you are “standing
onto”. The double period (..) symbolizes the parent directory of the current one which is “one level up” (or
back) on the file system structure.

cd (Change Directory) lets you navigate the file system structure. Its syntax is as follows:

cd <directory>

Some examples:

• cd /tmp/images: changes to the images directory inside the /tmp directory;

• cd -: changes to the previous current working directory;

• cd: changes to your personal (home) directory;

• cd ~/images: changes to the images directory inside your personal directory.

17.2. Process Manipulation

From the system’s point of view, applications run in one or many processes, consuming system resources,
such as memory and processor time. We present some commands to monitor and manage those processes,
and as a consequence, the applications they belong to.

17.2.1. Information on Processes

The ps command displays a list of processes currently running on the system, according to the criteria you
set.

Running ps without arguments will show only processes initiated by you and attached to the terminal you
are using:

$ ps
PID TTY TIME CMD

18614 pts/3 00:00:00 bash
20173 pts/3 00:00:00 ps

The most common options are:

• a: displays processes started by all users;
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• x: displays processes launched from any terminal, not just yours (or even from no terminal at all);

• u: displays for each process the name of the user who started it and the time at which it was started.

17.2.2. Controlling Processes

Processes are controlled by means of signals. The kill and killall commands are used to send signals to
processes. The kill command requires a process number as an argument, while killall requires a process
name.

Note: Please bear in mind that processes react differently to the same signals. You cannot expect a priori that the process
behaves as you thought it would when you send it a signal.

kill [-SIGNAL] <process_number>

killall [-SIGNAL] <process_name>

Signals can be specified by number or name. Execute kill -l to view a list of available signals. The most
commonly used signals are:

• TERM or 15: this is the default signal sent if the signal name or number is omitted. It terminates the process
gracefully.

• STOP or 19: this signal is used to temporarily pause a process. Send signal CONT or 18 to continue a paused
process.

• KILL or 9: this signal is used to force process termination. It is commonly used to end a process that is not
responding anymore (or “frozen”). It terminates the process abruptly.

Some examples:

• kill 785: asks the process identified by the number 785 to finish execution giving the process the chance
to perform any clean-up operation it needs;

• kill -KILL 785: forces termination of the process identified by the number 785 without giving the pro-
cess the chance to perform any clean-up operation. The process ends immediately;

• killall -TERM make: asks all processes named make launched by this user to finish execution.

Whatever happens, you will only control your own processes (unless you are root) so you do not need to
worry about other users’ processes since they will not be affected.

17.2.3. Mixing ps and kill: top

top is a program which simultaneously fulfills the functions of ps and kill, and is also used to monitor
processes in real-time giving information about CPU and memory usage, running time, etc., as shown in
figure 17-1.
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Figure 17-1. Monitoring Processes with top

The top utility is entirely keyboard controlled. Commands are case-sensitive. You can access help by pressing
h. Its most useful commands are the following:

• k: sends a signal to a process. You are asked for the process’ PID followed by the number or the name of the
signal to be sent (TERM or 15, by default);

• M: sorts display of processes by the amount of memory they take up (field %MEM);

• P: sorts display of processes by the CPU time they take up (field %CPU): this is the default sorting method;

• u: displays a given user’s processes. You are asked to enter the user’s name, not his UID. If you do not enter
any name, all processes are displayed;

• i: by default, all processes, even sleeping ones, are displayed. This command ensures that only processes
currently running are displayed (processes whose STAT field shows R, Running) and not the others. Using
this command again takes you back to showing all processes.

17.3. Commands Documentation

If you want to know more about a given command options and usage, you can consult the commands manual,
or “man page”. The syntax for the man command is:

man [section] <man_page>

Sections are like different chapters of a big book, each one specific to an aspect of the system. Some commands
might appear in different sections, so you might need to specify which section you are interested in.

Sections are numbered from 1 to 9, and there’s a 10th one, called n. You can also specify a to display all
matching sections for a given man page. If you omit the section parameter, the first matching man page is
displayed.

man has its own man page, execute man man to display it.

17.4. Further Reading

Here we’ve just “scratched the surface” on the command line and its powerful tools. If you want to read more
you can try the GNU Linux Tools Summary Guide (http://www.tldp.org/LDP/GNU-Linux-Tools-Summary/
html/index.html) from The Linux Documentation Project website (http://www.tldp.org).
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Appendix A. Where to Get Documentation

Apart from the manuals included with Mandriva Linux, documentation is available from many sources. The
next few pages contain suggestions which you might find useful.

A.1. Mandriva Linux-Specific Documentation

A.1.1. Mandriva’s Own Documentation

Some of these manuals may be available in your Mandriva Linux pack, in the mandriva-doc-MANUAL_
NAME-en package. Once installed, menu entries of the form More Applications+Documentation→Mandriva Li-
nux MANUAL NAME in English are available. Choose them to open the manual in a browser and select the
format you want to use.

If the kerry package is installed on your machine, searching the manuals (or anything on your system) is even
easier:

1.
Click the Kerry icon on the desktop panel, or hit Alt-Space for the Kerry search dialog to pop up.

2. Click Configure, open the Indexing tab, and Add the /usr/share/doc/mandriva path to the index list. By
default only your home folder is searched for.

3. Press OK and let the indexing do its work in the background.

4. In the Search field, type the keywords you are looking for.

5. Press Enter to run the search, and then filter the results by using the options on the right column.

Note: If you do not get results immediately, it may be because Kerry hasn’t finished indexing the files. Please try the
search again after a few minutes.
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Figure A-1. Search Example

Mandriva Control Center Inline Help. All Mandriva Linux Control Center tools have online help, which you
can access through Help→Help from Mandriva Linux Control Center’s menu: the browser opens up with Mandriva
Linux Control Center’s help.

A.1.2. Internet Resources

Internet information sources are widespread and many web sites are devoted to GNU/Linux and its use or
configuration. However, some sources of information are better than others.

Your preferred source of information should be the Mandriva Linux official web site (http://www.
mandrivalinux.com/). In particular, check out the support section (http://expert.mandriva.com). You can
also check out the Mandriva Community Wiki (http://wiki.mandriva.com/en/). It offers a lot of resources,
information and documentation, which will certainly interest Mandriva Linux users.

A.1.2.1. Mandriva Club

If you’re familiar with Mandriva Linux’s web sites, you probably know about Mandriva Club (http://club.
mandriva.com/). It’s the meeting point for all Mandriva Linux users. On it, you will find questions along with
their answers, suggestions and news related to Mandriva Linux and GNU/Linux. You can express your opinions
and influence future development of Mandriva Linux. If you’re not a member yet, we encourage you to join.

One specific area of the Club is of particular interest: the Mandriva Club Knowledge Base (http://club.
mandriva.com/xwiki/bin/view/KB/) is the Mandriva Linux user’s database. It is probably the largest collection
of Mandriva Linux-related documentation on the web.

It collects submissions by Mandriva Linux users. It also features a discussion forum and a community newslet-
ter. These articles are meant to be practical and to target beginner and intermediate users.

Topics range from administrative issues, such as the handling of the shell, to the tweaking of X, GNU/Linux’s
graphical subsystem.
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A.1.2.2. Mandriva Security Advisories

The Mandriva Security Advisories web site (http://www.mandriva.com/security/) is Mandriva’s very own
security site. It covers package vulnerabilities.

A.1.2.3. Mandriva E-training

The Mandriva eTraining web site allows you to buy quality GNU/Linux training to improve your Open Source
knowledge. You can access this web site (http://etraining.mandriva.com/) by using your Mandriva Club
account. A free demo on Samba is available, and many more if you are a registered Club member.

A.2. GNU/Linux Useful Resources

In this section, we present resources useful for any GNU/Linux distribution. Most are not written specifically
for Mandriva Linux, but may nevertheless prove useful.

A.2.1. The /usr/share/doc Directory

Most packages include their own documentation in one of the sub-directories of /usr/share/doc, which will
be named after the specific package. Mandriva Linux’s own documentation, when installed, is available in the
/usr/share/doc/mandriva/ directory.

A.2.2. The Man Pages

The Manual Pages (also known as “man pages”) are a set of exhaustive documents, which help you acquire
better knowledge of GNU/Linux commands. The latter are usually issued through the “command line” and
allow great control over your system (see the Introduction to the Command Line chapter of the Reference
Manual). Although these man pages might seem discouraging at first, they offer great detail and we encourage
you to browse through them when a problem occurs.

This should be your primary source of information for shell commands. Almost all commands have a manual
page. Other items, such as certain configuration files, library functions for programmers and others system
aspects also have their own man pages.

Man page contents are arranged in different sections. References to these are made in the following manner:
for example, open(2), fstab(5) respectively refers to the open page in section 2 and the fstab page in section 5.

Tip: The easiest way to view a man page is through a browser. Using Konqueror, type man:/man(1) in the Location
bar for the man page for the man command to be displayed. For example, to display the man page for fstab(5), type
man:/fstab(5) in the Location field.

To display a man page in a terminal (or shell), type man. The syntax to obtain a man page is:

man [options] [section] <manual page>

man also has documentation, which can be obtained by typing man man. Manual pages are formatted and
then displayed using the less pager.

The names of the manual pages and their relevant sections appear at the top of each page. At the bottom of
the page are references to other pages with related subjects (usually in the SEE ALSO section).

You can start by consulting the pages related to the different commands covered in the Reference Manual: ls(1),
chmod(1), etc.
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If you cannot find the right manual page — for example, you want to use the mknod function in one of your
programs but you end up on the mknod command page — make sure you spell out the section explicitly. In
our example: man 2 mknod. If you forget the exact section, man -a mknod will read through all the sections
looking for pages named mknod.
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Appendix B. About the Making of this Manual

B.1. Technical Infrastructure

This manual is written and maintained by NeoDoc (http://www.neodoc.biz). Translations are assured by
NeoDoc, Mandriva and other translators.

This document was written in DocBook XML. The set of files involved were managed using the Borges Colla-
borative Content Creation System (C3S) (http://sourceforge.net/projects/borges-dms). The XML source
files were processed by xsltproc, and jadetex (for the electronic version) using a customized version of Nor-
man Walsh’s stylesheets. Screen shots were taken using xwd or GIMP and converted with convert (from the
ImageMagick package). All these programs are free software and all of them are available in your Mandriva
Linux distribution.

B.2. Help Improve Mandriva Linux Documentation

In the open-source philosophy, contributors are always welcomed! Updating the Mandriva Linux documenta-
tion pool is quite a task. You could provide help in many different ways. In fact, the documentation team is
constantly looking for talented volunteers to help us to accomplish the following tasks:

• writing or updating;

• translating;

• copy editing;

• XML/XSLT programming.

If you have a lot of time, you can write or update a whole chapter; if you speak a foreign language, you can
help us translate our manuals; if you have ideas on how to improve the content, let us know; if you have
programming skills and would like to help us enhance the Borges Collaborative Content Creation System
(C3S) (http://sourceforge.net/projects/borges-dms), join in. And please don’t hesitate to contact us if
you find any mistakes in the documentation so we can correct them!

For any information about the Mandriva Linux documentation project, please contact the documentation admi-
nistrator (mailto:documentation@mandriva.com) or visit the Mandriva Linux Documentation Project Pages
(http://wiki.mandriva.com/Development/Tasks/Documentation).

Note: Please note that since June 2004 the Mandriva Linux documentation and the development of Borges is handled
by NeoDoc (http://www.neodoc.biz).
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The following text is the GPL license that applies to most programs found in Mandriva Linux distributions.
The original can be found at the GNU website (http://www.gnu.org/copyleft/gpl.html).

Version 2, June 1991 Copyright (C) 1989, 1991 Free Software Foundation, Inc. 59 Temple Place - Suite 330,
Boston, MA 02111-1307, USA

Everyone is permitted to copy and distribute verbatim copies of this license document, but changing it is not
allowed.

C.1. Preamble

The licenses for most software are designed to take away your freedom to share and change it. By contrast, the
GNU General Public License is intended to guarantee your freedom to share and change free software — to
make sure the software is free for all its users. This General Public License applies to most of the Free Software
Foundation’s software and to any other program whose authors commit to using it. (Some other Free Software
Foundation software is covered by the GNU Library General Public License instead.) You can apply it to your
programs, too.

When we speak of free software, we are referring to freedom, not price. Our General Public Licenses are
designed to make sure that you have the freedom to distribute copies of free software (and charge for this
service if you wish), that you receive source code or can get it if you want it, that you can change the software
or use pieces of it in new free programs; and that you know you can do these things.

To protect your rights, we need to make restrictions that forbid anyone to deny you these rights or to ask you
to surrender the rights. These restrictions translate to certain responsibilities for you if you distribute copies
of the software, or if you modify it.

For example, if you distribute copies of such a program, whether gratis or for a fee, you must give the recipients
all the rights that you have. You must make sure that they, too, receive or can get the source code. And you
must show them these terms so they know their rights.

We protect your rights with two steps:

1. copyright the software, and

2. offer you this license which gives you legal permission to copy, distribute and/or modify the software.

Also, for each author’s protection and ours, we want to make certain that everyone understands that there
is no warranty for this free software. If the software is modified by someone else and passed on, we want its
recipients to know that what they have is not the original, so that any problems introduced by others will not
reflect on the original authors’ reputations.

Finally, any free program is threatened constantly by software patents. We wish to avoid the danger that redis-
tributors of a free program will individually obtain patent licenses, in effect making the program proprietary.
To prevent this, we have made it clear that any patent must be licensed for everyone’s free use or not licensed
at all.

The precise terms and conditions for copying, distribution and modification follow.

C.2. Terms and conditions for copying, distribution and modification

• 0. This License applies to any program or other work which contains a notice placed by the copyright holder
saying it may be distributed under the terms of this General Public License. The “Program”, below, refers to
any such program or work, and a “work based on the Program” means either the Program or any derivative
work under copyright law: that is to say, a work containing the Program or a portion of it, either verbatim or
with modifications and/or translated into another language. (Hereinafter, translation is included without
limitation in the term “modification”.) Each licensee is addressed as “you”.
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Activities other than copying, distribution and modification are not covered by this License; they are outside
its scope. The act of running the Program is not restricted, and the output from the Program is covered only
if its contents constitute a work based on the Program (independent of having been made by running the
Program). Whether that is true depends on what the Program does.

• 1. You may copy and distribute verbatim copies of the Program’s source code as you receive it, in any me-
dium, provided that you conspicuously and appropriately publish on each copy an appropriate copyright
notice and disclaimer of warranty; keep intact all the notices that refer to this License and to the absence of
any warranty; and give any other recipients of the Program a copy of this License along with the Program.

You may charge a fee for the physical act of transferring a copy, and you may at your option offer warranty
protection in exchange for a fee.

• 2. You may modify your copy or copies of the Program or any portion of it, thus forming a work based
on the Program, and copy and distribute such modifications or work under the terms of Section 1 above,
provided that you also meet all of these conditions:

a. You must cause the modified files to carry prominent notices stating that you changed the files and the
date of any change.

b. You must cause any work that you distribute or publish, that in whole or in part contains or is derived
from the Program or any part thereof, to be licensed as a whole at no charge to all third parties under
the terms of this License.

c. If the modified program normally reads commands interactively when run, you must cause it, when
started running for such interactive use in the most ordinary way, to print or display an announcement
including an appropriate copyright notice and a notice that there is no warranty (or else, saying that you
provide a warranty) and that users may redistribute the program under these conditions, and telling
the user how to view a copy of this License. (Exception: if the Program itself is interactive but does not
normally print such an announcement, your work based on the Program is not required to print an
announcement.)

These requirements apply to the modified work as a whole. If identifiable sections of that work are not de-
rived from the Program, and can be reasonably considered independent and separate works in themselves,
then this License, and its terms, do not apply to those sections when you distribute them as separate works.
But when you distribute the same sections as part of a whole which is a work based on the Program, the
distribution of the whole must be on the terms of this License, whose permissions for other licensees extend
to the entire whole, and thus to each and every part regardless of who wrote it.

Thus, it is not the intent of this section to claim rights or contest your rights to work written entirely by you;
rather, the intent is to exercise the right to control the distribution of derivative or collective works based on
the Program.

In addition, mere aggregation of another work not based on the Program with the Program (or with a work
based on the Program) on a volume of a storage or distribution medium does not bring the other work
under the scope of this License.

• 3. You may copy and distribute the Program (or a work based on it, under Section 2) in object code or
executable form under the terms of Sections 1 and 2 above provided that you also do one of the following:

a. Accompany it with the complete corresponding machine-readable source code, which must be distribu-
ted under the terms of Sections 1 and 2 above on a medium customarily used for software interchange;
or,

b. Accompany it with a written offer, valid for at least three years, to give any third party, for a charge no
more than your cost of physically performing source distribution, a complete machine-readable copy of
the corresponding source code, to be distributed under the terms of Sections 1 and 2 above on a medium
customarily used for software interchange; or,

c. Accompany it with the information you received as to the offer to distribute corresponding source code.
(This alternative is allowed only for noncommercial distribution and only if you received the program
in object code or executable form with such an offer, in accord with Subsection b above.)

The source code for a work means the preferred form of the work for making modifications to it. For an
executable work, complete source code means all the source code for all modules it contains, plus any asso-
ciated interface definition files, plus the scripts used to control compilation and installation of the executable.
However, as a special exception, the source code distributed need not include anything that is normally dis-
tributed (in either source or binary form) with the major components (compiler, kernel, and so on) of the
operating system on which the executable runs, unless that component itself accompanies the executable.
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If distribution of executable or object code is made by offering access to copy from a designated place, then
offering equivalent access to copy the source code from the same place counts as distribution of the source
code, even though third parties are not compelled to copy the source along with the object code.

• 4. You may not copy, modify, sublicense, or distribute the Program except as expressly provided under this
License. Any attempt otherwise to copy, modify, sublicense or distribute the Program is void, and will au-
tomatically terminate your rights under this License. However, parties who have received copies, or rights,
from you under this License will not have their licenses terminated so long as such parties remain in full
compliance.

• 5. You are not required to accept this License, since you have not signed it. However, nothing else grants you
permission to modify or distribute the Program or its derivative works. These actions are prohibited by law
if you do not accept this License. Therefore, by modifying or distributing the Program (or any work based
on the Program), you indicate your acceptance of this License to do so, and all its terms and conditions for
copying, distributing or modifying the Program or works based on it.

• 6. Each time you redistribute the Program (or any work based on the Program), the recipient automatically
receives a license from the original licensor to copy, distribute or modify the Program subject to these terms
and conditions. You may not impose any further restrictions on the recipients’ exercise of the rights granted
herein. You are not responsible for enforcing compliance by third parties to this License.

• 7. If, as a consequence of a court judgment or allegation of patent infringement or for any other reason (not
limited to patent issues), conditions are imposed on you (whether by court order, agreement or otherwise)
that contradict the conditions of this License, they do not excuse you from the conditions of this License.
If you cannot distribute so as to satisfy simultaneously your obligations under this License and any other
pertinent obligations, then as a consequence you may not distribute the Program at all. For example, if a
patent license would not permit royalty-free redistribution of the Program by all those who receive copies
directly or indirectly through you, then the only way you could satisfy both it and this License would be to
refrain entirely from distribution of the Program.

If any portion of this section is held invalid or unenforceable under any particular circumstance, the balance
of the section is intended to apply and the section as a whole is intended to apply in other circumstances.

It is not the purpose of this section to induce you to infringe any patents or other property right claims
or to contest validity of any such claims; this section has the sole purpose of protecting the integrity of
the free software distribution system, which is implemented by public license practices. Many people have
made generous contributions to the wide range of software distributed through that system in reliance on
consistent application of that system; it is up to the author/donor to decide if he or she is willing to distribute
software through any other system and a licensee cannot impose that choice.

This section is intended to make thoroughly clear what is believed to be a consequence of the rest of this
License.

• 8. If the distribution and/or use of the Program is restricted in certain countries either by patents or by
copyrighted interfaces, the original copyright holder who places the Program under this License may add
an explicit geographical distribution limitation excluding those countries, so that distribution is permitted
only in or among countries not thus excluded. In such case, this License incorporates the limitation as if
written in the body of this License.

• 9. The Free Software Foundation may publish revised and/or new versions of the General Public License
from time to time. Such new versions will be similar in spirit to the present version, but may differ in detail
to address new problems or concerns.

Each version is given a distinguishing version number. If the Program specifies a version number of this Li-
cense which applies to it and "any later version", you have the option of following the terms and conditions
either of that version or of any later version published by the Free Software Foundation. If the Program
does not specify a version number of this License, you may choose any version ever published by the Free
Software Foundation.

• 10. If you wish to incorporate parts of the Program into other free programs whose distribution condi-
tions are different, write to the author to ask for permission. For software which is copyrighted by the Free
Software Foundation, write to the Free Software Foundation; we sometimes make exceptions for this. Our
decision will be guided by the two goals of preserving the free status of all derivatives of our free software
and of promoting the sharing and reuse of software generally.
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NO WARRANTY

• 11. BECAUSE THE PROGRAM IS LICENSED FREE OF CHARGE, THERE IS NO WARRANTY FOR THE
PROGRAM, TO THE EXTENT PERMITTED BY APPLICABLE LAW. EXCEPT WHEN OTHERWISE STA-
TED IN WRITING THE COPYRIGHT HOLDERS AND/OR OTHER PARTIES PROVIDE THE PROGRAM
“AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT
NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTI-
CULAR PURPOSE. THE ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE PROGRAM
IS WITH YOU. SHOULD THE PROGRAM PROVE DEFECTIVE, YOU ASSUME THE COST OF ALL NE-
CESSARY SERVICING, REPAIR OR CORRECTION.

• 12. IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRITING WILL
ANY COPYRIGHT HOLDER, OR ANY OTHER PARTY WHO MAY MODIFY AND/OR REDISTRIBUTE
THE PROGRAM AS PERMITTED ABOVE, BE LIABLE TO YOU FOR DAMAGES, INCLUDING ANY GE-
NERAL, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OR
INABILITY TO USE THE PROGRAM (INCLUDING BUT NOT LIMITED TO LOSS OF DATA OR DATA
BEING RENDERED INACCURATE OR LOSSES SUSTAINED BY YOU OR THIRD PARTIES OR A FAILU-
RE OF THE PROGRAM TO OPERATE WITH ANY OTHER PROGRAMS), EVEN IF SUCH HOLDER OR
OTHER PARTY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

END OF TERMS AND CONDITIONS
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