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Preface

1. About Mandriva Linux

Mandriva Linux is a GNU/Linux distribution supported by Mandriva S.A., which was born on the Internet in
1998. Its main goal was and still is to provide an easy-to-use and friendly GNU/Linux system. Mandriva’s two
pillars are open source and collaborative work.

Note: In April 2005, the Mandrakesoft company changed its name to Mandriva to reflect its merger with Brazil-based
Connectiva. Its core product, Mandrakelinux, became Mandriva Linux.

1.1. Contacting the Mandriva Linux Community

The following are various web links pointing you to the most important Mandriva Linux-related sources. If you
want to know more about the Mandriva company, connect to our web site (http://www.mandriva.com/). You
can also check out the Mandriva Linux distribution web site (http://www.mandriva.com/community/) and all
of its derivatives.

Mandriva Expert (http://www.mandrivaexpert.com/) is Mandriva’s support platform. It offers a new expe-
rience based on trust and the pleasure of rewarding others for their contributions.

We also invite you to subscribe to the various mailing lists (http://www.mandriva.com/community/
resources/newsgroups) where the Mandriva Linux community demonstrates its high spirits and keen debates.

Please also remember to connect to our security page (http://www.mandriva.com/security). It gathers all
security-related material about Mandriva Linux distributions. You will find security and bug advisories, as well
as kernel update procedures, the different security-oriented mailing lists which you can join, etc. This page is
a must for any server administrator or user concerned about security.

1.2. Join the Club!

Mandriva Club is the place where users meet to help each other out, exchange valuable information about
Mandriva Linux, and get informed of the latest Mandriva, Linux and Open Source news. Club subscribers
have privileged access to an even wider array of services.

With your Mandriva ID, you have free access to:

• help (forums, chat, Knowledge Base with tutorials, how-tos, tips and tricks);

• news;

• more Mandriva- and community-contributed content.

As a Club member, you have exclusive access to:

• 50,000 software packages, including commercial software, drivers, and demos;

• super-fast download servers;

• official Mandriva Linux documentation;

• access to expert and eTraining online;

• permanent special discounts at Mandriva Store;

• ... and much more!

Mandriva Club is where you get the best Mandriva Linux experience, learning from others, teaching others,
accessing exclusive features and contributing to the development of Mandriva Linux and Free and Open
Source Software in general.
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Preface

1.3. Purchasing Mandriva Products

Mandriva Linux users may purchase products on-line through the Mandriva Store (http://store.mandriva.
com/). You will not only find Mandriva Linux software, operating systems and “live” boot CDs, such as Live, but
also special subscription offers, support, third-party software and licenses, documentation, GNU/Linux-related
books, as well as other Mandriva goodies.

We couldn’t close this section without mentioning the latest innovation from Mandriva. Mandriva Flash is a
pre-installed Mandriva Linux distribution on a simple 2GB USB 2.0 key. You only need to plug the key in to
start your Linux system anywhere, and save and exchange your data on the free 1GB space.

1.4. Contributing to Mandriva Linux

The skills of the many-talented folks who use Mandriva Linux can be very useful in the making of the Mandriva
Linux system:

• Packaging. A GNU/Linux system is mainly made of programs found on the Internet. These need to be pac-
kaged in order to work together.

• Programming. There are many projects directly supported by Mandriva: find the one that most appeals to
you and offer your help to the main developer(s).

• Internationalization. You can help us translate web pages, programs and their respective documentation.

Consult the development projects (http://www.mandriva.com/en/community/contribute/join) page to
learn more about how you can contribute to the evolution of Mandriva Linux.

2. About this Quick Start Guide

The goal of this manual is to introduce you to the unique features of Mandriva One, and help you use and
administer the system in general. Whether you are a Linux newcomer or an experienced user, you will find
useful information here to completely master your system.

Booting the system. Your product is a “live” CD or DVD, meaning, that you can use it directly without actually
installing it. So, we will assist you with the few startup steps required to bring up your system.

Using the system. If you are new to Linux, you may find yourself like a stranger in a new country. We guide
you in your new environment, and you will soon feel at home.

Taking advantage of your peripherals. Want to use your printer, scanner, or webcam? It’s very easy. Mandriva
Linux supports most devices, and offers great applications to get the most out of them.

Let’s Relax. Mandriva Linux is not only about work! It offers a full range of games for all tastes. We have selected
the nicest ones for you.

Increase your system speed and share it with others. You’ll quickly become a Mandriva Linux fan and find
yourself using the system more often than expected. We show you how to install it on your hard drive for
increased performance, and how to easily make copies of it for your friends and relatives.

3. Starting the MandrivaOne Live CD

MandrivaOne lets you use a fully working Mandriva Linux operating system, with office, Internet and multi-
media tools, even games, off the CD/DVD without the need to install anything on your computer: all the
software runs directly from the CD/DVD.

Use MandrivaOne to try Mandriva Linux before installing it, to do all your work without “interfering” with the
computer’s already installed operating system and files, or to repair a damaged system.

Please refer to “Share and Install your Linux System”, page 33 for more information.

2
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3.1. Booting the CD

Make sure the computer is setup to boot from the CD-ROM drive, insert the MandrivaOne CD and reboot the
computer. Please refer to the computer’s documentation if you need more information on how to set it up to
boot from the CD-ROM.

There are some parameters (language, country, keyboard layout, timezone, etc.) which need to be setup on
each boot; you only need to select your preferences from the suggested ones. Please note the following:

• If you select the Refuse option when you are shown the licensing terms, you are not able to continue using
MandrivaOne, the computer will be shut down when you click on Quit.

• After selecting the timezone you are asked if your system’s clock is set to UTC (Coordinated Universal
Time). If you’re unsure please answer No.

3.2. Default User Paswords

The Live distribution is configured so that the default user (guest) and the administrator (root) have no
password. For most operations you won’t be even asked for these passwords, however if it happens, simply
leave it blank.

3
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Chapter 1. Using the Internet

MandrivaOne is an excellent tool to use the Internet. We show you how to manage your email using KMail,
browse the web with Konqueror and chat with your friends and colleagues with Kopete.

1.1. Sending and Receiving Emails

Choose Internet→Mail Client from the main menu to launch KMail. A configuration wizard appears.

1.1.1. Mail Configuration

Figure 1-1. Mail Account Type

Select the account type from the suggested list and advance to the next step. Both IMAP and POP3 accounts
setup are the same.

Figure 1-2. Your Personal Data

Then, you are asked about your name, email address and company name, fill these with your personal data.

Figure 1-3. Account Credentials

5



Chapter 1. Using the Internet

You are then asked for the account credentials: username and password. Your ISP or system administrator
should have provided these along with your email address.

Figure 1-4. Mail Servers

You are finally asked to provide mail server parameters. Again, your ISP or system administrator
should have provided you with the incoming and outgoing mail servers. Outgoing servers are usually
of the smtp.provider.net form. Incoming POP3 servers are usually of the pop.provider.net or
pop3.provider.net forms. Incoming IMAP servers are usually of the imap.provider.net form. The
mail.provider.net form is also common for both incoming and outgoing mail servers.

1.1.2. Mail Client Interface

Folder
List

Toolbar

Message List

Message View 
Pane

Figure 1-5. KMail Client Interface

Toolbar. Where the main action buttons lie. See table 1-1.

Message List. Where information (subject, date, sender, etc.) about messages stored in the currently selected
folder is displayed.

Message View Pane. Where the currently selected message content is displayed.

Folder List. Where all folders are listed. The default folders are inbox (incoming messages), outbox (unsent
templates), sent-mail (already sent messages), trash (deleted messages), drafts (draft messages) and
templates (templates for writing messages). There is also a special folder named Searches which contains
the results of a search for messages.

6



Chapter 1. Using the Internet

1.1.3. KMail Usage

The following table shows the most important buttons available in KMail’s toolbar, their equivalent keyboard
shortcuts and a brief explanation of the functions they provide.

Button Keyboard Shortcut Function

Ctrl-N Compose a New Message. You need to complete the To and
Subject fields in the message-compose window.

Ctrl-L

Get new messages for all defined e-mail accounts. Keep this button
pressed to display a list of all defined accounts; select the one you
want to get mail from in order to retrieve messages only for that
account.

R Reply to the author of the selected message. A message-compose
window pops up with some fields already set.

F Forward (send to a third party) the selected message.

Del

Delete the selected messages. Deleted messages are moved to the
Trash folder. You can recover messages moved to the trash
folder, but deletion from the Trash folder cannot be undone: be
careful!

Table 1-1. KMail’s Toolbar Buttons

Note: Some of those buttons have a little arrow at the bottom right corner. An additional menu with related actions
can be displayed by pressing the mouse button a little longer.

1.2. Browsing the Web

Choose Internet→Web Browser from the main menu to launch Konqueror. The home page opens. Type
in an URL in the Location bar to open a different page.

7
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1.2.1. Browser Interface

Toolbar
Location Bar

Display
Area

Bookmarks
Bar

Browser
Tabs

Figure 1-6. Konqueror Web Browser Interface

Toolbar. Contains all buttons used to navigate and perform common actions (see table 1-2).

Location Bar. Where you enter a site’s URL (or a local file using file:// as the protocol part of the URL).

Bookmarks Bar. Contains buttons which give you quick access to your favorite sites.

Tabbed Browsing. Allows you to open many sites in the same window instead of opening new windows,
which makes browsing much simpler.

Display Area. Where the contents of the web sites and local files you browse are displayed.

1.2.2. Surfing the Web

Button Keyboard Shortcut Function

Alt-left_arrow
Go back. Returns to the page you visited before the current one.
Keep this button pressed to display the list of all URLs you can
access.

Alt-right_arrow Go forward. Returns to the page you visited after the current one.
The same back-button considerations apply.

F5

Reload. Refreshes the current page. By default, Konqueror first
looks in the browser’s cache (on-disk temporary storage space)
and uses the local copy. Press the Shift key while clicking on the
reload button to force Konqueror to fetch the page from the
Internet.

Esc Stop. Aborts the transfer of the currently requested object and
cancels the page-loading operation.

Table 1-2. Konqueror’s Toolbar Buttons

Konqueror’s browser allows you to browse many web pages at a time by using tabbed browsing.
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Creates and opens a new tab (Ctrl-Shift-N). Just type an URL on the location bar to open a new page on
this tab.

Tip: You can also press the Ctrl-Shift-D keys to duplicate the current tab, that is to open the same page you are currently
browsing, but on a different tab. This is handy for example with long pages allowing you to browse the same page in two
different positions at the same time.

Closes the currently displayed tab (Ctrl-W).

For bookmark management it is recommended you use social bookmark sites, such as Del.Icio.Us (http:
//del.icio.us), so you always have bookmarks with you on the go.

1.3. Chatting With Friends and Colleagues

Choose Internet→Instant Messenger from the main menu to launch Kopete. A configuration wizard
appears.

1.3.1. Configuring Kopete

Figure 1-7. Messaging Service Selection

Kopete supports communications with many popular messaging applications such as MSN, Yahoo, ICQ, IRC,
etc. Select the messaging service from the list and advance to the next step. Please bear in mind that the
different messaging protocols have different configuration parameters. We show you how to setup an instant
messaging service account and then an IRC service account.

9
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Figure 1-8. Account Parameters

Now you have to provide the account parameters: as a minimum a username (or email address) and a pass-
word; some messaging services may need other options too. Refer to the messaging service documentation
for more information on the account parameters to be set.

Tip: Most messaging services have a Register New Account button that you can click to get a new account with that
service.

Finally you are invited to connect to the messaging service and finish the messaging service configuration
wizard. Uncheck the Connect now option if you wish to connect later.

Choose Settings→Configure from the menu, then select the Accounts section and click on the New button to add
an account for a different messaging service. We now add an account for IRC server irc.freenode.net,
channel #mandriva, where you can get support for your MandrivaOne system from other users of Mandriva
Linux.
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Figure 1-9. IRC Basic Parameters

Provide your nickname1 and an alternate one (in case someone else already has registered the nickname you’ve
chosen), and optionally a username and a password.

Tip: It’s common to append a _ to the nickname to form the alternative nickname.

1. On IRC channels you are identified by your nickname and people will know you by it.
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Figure 1-10. IRC Network Parameters

Then, select the Connection tab and choose an IRC network using the Network pulldown list. You can also select
the default encoding and other options. Advance to the final step and finish the wizard.

1.3.2. Kopete Interface

Buddy List

Toolbar

Service
Status

Figure 1-11. IM and Chat Interface

Toolbar. Where the main action buttons lie. See table 1-3.

Buddy List. Where an entry is displayed for each of your buddies who is online, together with an icon iden-
tifying the protocol they are using. Buddy status is indicated as follows:

•

12
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The buddy is currently online and available;

•

the buddy is currently online, but not available. Depending on the messaging service you might be able to
send him messages anyway, which your buddy sees when he’s available again;

•

the buddy isn’t currently online, you cannot send him messages. Please note that you might not see this status
at all if you decide to hide offline buddies.

Service Status. One icon is displayed for each messaging service configured. If the icon is colored, it means
you are currently online on that service, otherwise the icon is grayed. Right click on the service’s icon to access
a menu with actions for that particular messaging service.

1.3.3. Chatting and IM With Kopete

Button Function

Set Status. Displays a list of all possible online status from where you can select the
desired one. Please bear in mind that this status applies to all currently configured
messaging services. It can be thought of like a kind of global status setting.

Add Buddy. Select the messaging service from the suggested ones and then fill in the
buddy’s ID and optionally select a group using the Group pulldown list; click on OK to
add the buddy to your buddy list.
Popular messaging services (MSN, Yahoo, ICQ, Jabber, etc.) store the buddy list on the
server, so you get the same buddy list no matter where you connect to that service from.

When this button is pressed offline users are shown on the buddy list. This is handy to
see which buddies you have on your list for the different messaging services.

Table 1-3. Kopete’s Toolbar Buttons

To start chatting with a buddy, simply double click on his nick on the Buddy List. The window is divided in
two, you type on the lower frame, and see the conversation on the upper frame.

IRC is a bit different, you first have to join a channel on a server. Think of channels as chat rooms where you
can speak about a given topic. To join a channel:

1. Click on the IRC service status icon.

2. Select the Join Channel menu entry.

3. Type the name of the channel in the dialog box that appears. Channel names start with a sharp symbol
(#), for example #mandriva.

4. A window similar to the IM one appears, it also has a list on the right with the people connected on that
channel. If you don’t see a list of people, it means you are alone on that channel, please try a different
channel or wait for someone to join the channel.

Repeat the above procedure to connect to other IRC channels on the same server, a window opens for each
channel you connect to so you can chat simultaneously on all channels you join.

There are many resources on the Internet about the so-called “netiquette”, which are norms and rules (some
can be described as common sense) one should observe for fair behavior when chatting with other people.
You can perform a search for “chat netiquette” (using Google) (http://www.google.com/search?q=chat+
netiquette) for more information.
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Chapter 2. Multimedia

With MandrivaOne you can enjoy multimedia: listen to music, retouch your photos, etc.

2.1. Playing Music

2.1.1. Audio CDs

When you insert an audio CD in your CD drive a window pops up, if you choose to play the CD, the KsCD
player starts up.

Figure 2-1. KsCD’s Main Window

Tip:

Once KsCD is launched, this quick-launch icon appears near the clock. Right-click on it, to access KsCD’s main
features.

On the left you have the typical CD player controls: Play/Pause, Stop, Eject, etc. The ones below alter the
playing order. The CDDB button can be used if your CD information doesn’t appear automatically, it displays
the CD’s title, artist and tracklist information. Click on the last button to access more advanced configuration
options.

2.1.2. Audio Files

Choose Multimedia→Audio Player from the main menu to launch Amarok. You are presented with a
wizard you can safely Skip.
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Playlist

Browser Volume
Control

Play
Controls

Figure 2-2. Amarok’s Main Window

figure 2-2 shows the main interface components of Amarok:

Browser. This displays various information depending on the function selected using the tabs at its left.

Playlist. Where the files to be played are shown. Right click on any file to access a menu allowing you to play
the file, remove it from the playlist, etc.

Play Controls. Amarok’s play controls are “standard” audio equipment ones: Previous/Next Tracks, Play,
Stop. The Play button doubles as a Pause button. Keep the Stop button pressed to select whether to stop playing
immediately, after the current playing song has finished, or after the whole playlist has been played.

Volume Control. Slide it right to increase the volume and left to decrease it. Right click on it and select Equalizer
from the menu that pops up to open an equalizer window where you can enhance bass and treble, and even
select some preset equalization curves.

The Collection browser enables you to view and organize your entire music collection. To use it, you
need to create a collection first: click on the Build Collection button, check all the folders you want
Amarok to look for music files and click Ok to start building the collection.

Warning

If you added files from removable devices (such as a USB key or an external hard drive), make sure they are available
at the same location as when you originally added them to your collection or Amarok won’t be able to find the
files they contain.

Then, start adding files to the Playlist by double clicking on them in the collection browser. Once satisfied with
your songs selection, simply press the

(Play) button to start enjoying your music.

2.2. CD/DVD Burning

We concentrate on using K3b to perform common CD burning operations. DVD recording is very similar to
its CD counterpart.

Copyrighted Material. Please note that data, audio, video CD or DVD copying is often forbidden by copyright law. We
assume that if you want to duplicate copyrighted material, it’s because you have the right to do so.
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Choose Multimedia→CD & DVD Burning from the main menu to start K3b. figure 2-3 shows K3b’s interface
with a new data project open.

File
Manager

Project
Manager

Toolbar

Figure 2-3. K3b’s Interface

Toolbar. Where buttons to perform common actions lie: open and save projects, erase rewritable media, copy
CDs, etc.

File Manager. To choose which files to include in the burned CD. Use the left-side tree to navigate the file
system and drag and drop the files you want to include in the project into the Project Manager.

Project Manager. Where all files which will be on the burned CD are shown and handled. Files can be removed
and their location (directory) on the CD can be changed here.

2.2.1. Burning a Set of Files or Directories

Choose File+New Project→New Data CD Project from K3b’s menu . Then drag and drop the files and directories
you want to include on the CD into the Project Manager (see figure 2-4).

17



Chapter 2. Multimedia

Figure 2-4. Selecting Files and Directories to Include on a CD

Note: Adding directories containing many files can take some time. Please be patient and wait until the Adding files
to Project PROJECT_NAME message disappears.

The space occupied by the selected files and directories is shown by a color-coded bar at the bottom of the Pro-
ject Manager, together with the volume expressed in MB and the available MB of the medium’s total capacity.
The bar’s color codes are as follows:

Green

The size of the set is less than that of the selected medium’s capacity (700 MB by default). There are no
capacity-related problems.

Yellow

The size of the set is nearly equal to the selected medium’s capacity. If it’s a few MB below the medium’s
capacity, there won’t be any capacity-related problems; if it’s a few MB above the medium’s capacity, the
CD might be written without problems, but there’s little guarantee of success.

Red

The size of the set exceeds the medium’s capacity by many MB. The CD will not be recorded properly.

Right-clicking on any file or directory in the Project Manager pops up a contextual menu with options to
remove and rename files, create new (empty) directories, etc. Files and directories can be relocated (change the
directory under which you want them to appear) on the CD using drag-and-drop.

Tip: Renaming the top element of the left side tree in the Project Manager changes the CD’s volume name (K3b data
project by default for data CDs).

Insert a recordable medium in the CD burner and click on the Burn button or choose the Project→Burn menu
entry. Then select writing parameters (see figure 2-5) and click the Burn button to start writing the CD.
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Figure 2-5. Setting Writing Parameters

2.2.2. Burning Audio CDs (CDDA)

By audio CDs, we mean the ones you play in your car or home stereo equipment, not data CDs containing
OGG, MP3 or any other digital audio format files.

K3b supports recording audio CDs from tracks digitized in Wave (*.wav), Ogg Vorbis (*.ogg), and MP3 (*.
mp3) formats. You can mix digital audio formats since K3b decompresses the compressed ones on-the-fly. K3b
can also create digital audio tracks from audio CDs.

Choose File+New Project→New Audio CD Project from K3b’s menu. Select K3b’s File Manager’s filter to Sound
Files, navigate to where the digitized audio files are and then drag the audio tracks and drop them in the
Project Manager (see figure 2-6).

Figure 2-6. Selecting Audio Tracks to Include on the CD
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Use drag and drop to move the files up and down the compilation. Once you have the tracks compiled in the
order you want in the Project Manager, you can write them to CD.

2.3. Playing Movies

Choose Multimedia→Media Player from the main menu to launch KMplayer.

Player
Controls

Status

Tool Bar

Display
Area

Figure 2-7. KMplayer’s Interface

KMplayer’s interface (figure 2-7) is comprised of the following:

Tool Bar. The tool bar has buttons to open media, control playback (Play, Pause, Stop buttons), switch to or
from full-screen display, and others.

Player Controls. The set of the usual VCR controls: Eject, Previous, Play (keyboard shortcut: R), Next, Stop
(keyboard shortcut: S) and Pause (keyboard shortcut: P).

Display Area. Where the movie being played is shown. Press the F key to switch between full-screen and
windowed modes.

Status. Located at the bottom of KMplayer’s window, it shows information about the player status and the
movie being played.

How to Play a Video File

1. Choose Source→Open to display a standard open file dialog.

2. Go to the folder containing the movie you want to play and select it.

3. Click Open. The movie starts playing immediately.

How to Play a DVD

1. Insert the DVD title on the drive.

2. Choose Source→DVD→Open DVD.

3. The disc is read and starts playing immediately.

Note: DVD titles usually have a menu where you can select options such as the language and subtitles for the movie:
browse through the menus with the mouse and select options by clicking on them.
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2.4. Digital Photo Studio

Choose Graphics→Photo Management from the main menu to launch digiKam. The 1st time you are
asked to provide a folder to store pictures into. You can accept the default /home/your_user_name/
Pictures.

2.4.1. Building a Photo Album

Choose Album→New Album from the menu and fill album properties (see figure 2-8), then accept
your settings to create the album.

Figure 2-8. New Album Settings

Choose Album+Import→Add Images from the menu and use the standard file dialog to select the
pictures you want to add to your newly created album, then click on Add.

Tip: You can add all the pictures contained in a given folder by choosing Album+Import→Import Folders from the menu
and browsing for a folder, instead of files.

2.4.2. Touching-Up Pictures

Double click on a picture to open the image edit window. Note that all touch-up operations may affect the
quality of the picture’s on-disk file. Also bear in mind that on-screen rendering is quite different from printing
your digital pictures on photographic paper. So if you intend to both print and publish your pictures for online
viewing, it might be wise to treat both copies differently from the beginning.

Tip: Press Ctrl-Z to undo the last transformation operation. However, once you have saved the image, changes cannot
be undone.
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Rotation

Simply choose one of the entries (90o, 180o or 270o) of the Transform+Rotate menu.

Note: When rotating pictures “by hand” it is better to correct the EXIF orientation information in order for EXIF
information to reflect the picture correctly. On the album browsing window, select the image and choose the appropriate
entry of the Image→Correct Exif Orientation Tag menu.

Brightness, Contrast and Gamma

Choose Fix+Colors→Brightness/Contrast/Gamma from the menu and use the sliders to adjust the
brightness, contrast and gamma of the picture using the picture copy as a guide.

Sharpen

Choose Fix→Sharpen from the menu, drag the square to the part of the image to be used as a guide,
and use the slider to sharpen the picture.
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Red-Eye Reduction

Before After

Select the pupil of the eye to fix, choose Fix→Red Eye Reduction from the menu, and then select the
aggressive (only part of the eye selected) or mild (more than the eye selected) option to reduce the
red-eye flash effect. Repeat for the other eye, if needed.

Image Resizing and Cropping

Multi-megapixel images are excellent for photographic paper print-ups, but are far from adequate for
e-mailing or publishing on the web. Choose Transform→Resize from the menu, then select the desired
size, either in pixels or in percentage, and whether or not to keep (recommended) the aspect ratio.

You can also crop an image to a desired size while keeping the aspect ratio. Choose Transform→
Aspect Ratio Crop from the menu, drag the square to frame the part of the image you are interested
on and select the aspect ratio, orientation, width and height (one follows the other according to the

aspect ratio selected).
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Tip: For electronic publication, the usual aspect ratio is 4:3, while for printing the usual aspect ratio is 3:2.

Usually a size of 640x480 is enough for e-mailing a photo, while 800x600 is enough for web publishing.
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MandrivaOne can be used to perform office work with the OpenOffice.org office suite: we show you how to write
documents with OpenOffice.org Writer, spreadsheets with OpenOffice.org Calc and presentations with OpenOf-
fice.org Impress. OpenOffice.org tools are Microsoft® Office-compatible, meaning that you can easily exchange
documents between them.

Tip:

With OpenOffice.org, you can export your documents in PDF format (choosing File→Export as PDF from
the menu). This allows you to publish your documents in the Adobe® Reader® format.

3.1. Writing Documents

Choose Office→Word Processor from the main menu to launch OpenOffice.org Writer.

3.1.1. Word Processor Interface

Format Bar

Rulers

Insertion
Point

Page
Style

Work
Area

Figure 3-1. OpenOffice.org Writer’s Main Window

Format Bar

This is the standard format bar for all OpenOffice.org applications. You can use it to change fonts, colors,
alignment, etc. of the application’s data.

Rulers

Define the horizontal location of the text and format elements. Rulers are very useful when you want to
establish tabulation and paragraph indentation.

Work Area

This is where you enter the content of your document: words, numbers, images, tables, hyperlinks, etc.
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Insertion Point

All characters typed on your keyboard are placed at the left of this point. Also called the cursor.

Page Style

Many elements define style: page size, margins, text-orientation, etc. Page style can be changed by choo-
sing Format→Page from the menu. You may use the predefined styles, or define your own.

3.1.2. Styles

Word processor users often waste a lot of time formatting their documents: changing paragraph alignment,
font family, weight and size, etc. Instead, they should concentrate on document structure and content writing.

Styles provide a structure-centric approach to writing documents with a word processor, while nor-
malizing document formatting and layout, and easily automating the generation and maintenance of
tables of contents (TOC), indexes, references, etc. In OpenOffice.org Writer, styles are handled using

the Stylist. Click on its icon in the Format Bar to open or close it.

When you have a... Then apply the ... style

Chapter Title Heading 1

Section Title Heading 2

Sub-Section Title Heading 3

Sub-Subsection Title Heading 4

Paragraph Text Body, First Line Indent

List Item List Indent

Table 3-1. Suggested Text Styles

Use the styles listed in table 3-1, as a guide. Select the region of the document to apply the style to, and in the
Stylist window, double-click on the style you want to apply to that region.

3.1.3. Lists

Use lists to enumerate the properties of an object (“unordered” or “bullet” list), or the steps to be performed
to do a task (an “ordered” or “numbered” list).

Click on this button to format the selected text into an unordered list. Select the list items and choose
Format→Bullets and Numbering from the menu to select the bullet type from a predefined set.

Clicking on this button formats the selected text into an ordered list. The same rules as for unordered
lists apply to the numbering format.

3.1.4. Page Headers and Footers

By default page headers and footers are common to all pages of a document. Use them to describe certain as-
pects of the document’s content, for example: page number, total number of pages, chapter, section, document
title, etc.

Choose Insert+Header→Default from the menu to add a page header to your document, and choose In-
sert+Footer→Default to add a page footer to your document. Just type the header or footer text or use one
or more of the Insert→Fields menu items to compose your headers and footers.
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3.2. Calculations and Simulations

Choose Office→Spreadsheet from the main menu to launch OpenOffice.org Calc.

3.2.1. Spreadsheet Interface

Format
Bar

Work
Area

Select
All

Formula
Bar

Sheet Changing
Buttons and Tabs

Figure 3-2. OpenOffice.org Calc’s Main Window

Format Bar

This is the standard format bar for all OpenOffice.org applications, you can use it to change fonts, colors,
alignment, etc. of the application’s data.

Formula Bar

Use it to enter, edit or delete formulas inside cells.

Work Area

This is where you enter the data in the spreadsheet: numbers, dates, formulas, images, etc.

Select All

Clicking on this little area at the top left corner of the Work Area selects all cells at once. It’s useful when
you need to make changes which are “global” to the spreadsheet. For example, changing all font sizes in
the cells to 10pts (points).

Sheet Changing Buttons and Tabs

Spreadsheets usually contain more than one sheet. You can use these buttons to easily navigate through
each of the spreadsheet’s sheets. From left to right they are: Go to the first sheet, Go to the previous sheet,
Go to the next sheet and Go to the last sheet. You may also use the tabs to switch between sheets.
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3.2.2. Entering Data

To enter data into a cell, navigate to the cell and type the data in it, pressing the Enter key when you are
finished.

Auto-completion simplifies data entry by “guessing” the next cell’s value, using the current cell’s value as a
base. It works for any kind of data which can be associated to a series of integral numbers.

To use auto-completion, put your mouse over the base cell “handle” (the little square located at the bottom
right of the cell border), click on it and drag the cell. The cell values are then shown in a tool-tip. Release the
mouse button to complete the cells once the desired final value is shown.

Cell data can also be sorted according to different criteria. Select the cells you want to sort and then open the
sort options dialog choosing Data→Sort from the menu. Specify the sort criteria, order and additional options
and click on OK to sort the cells.

Tip: Make sure you also select columns and rows which act as “headers” for the data so they “follow” the sorting of the
data.

3.2.3. Adding Formulas

Formulas can be used to “automate” the spreadsheet. For example, it allows you to run complex simulations.
Within cells, formulas are defined by preceding all cell data with the = sign. Anything else is treated as “static”
data.

Operations are expressed using conventional algebraic notation. For example, =3*A25+4*(A20+C34/B34)
divides the value in cell C34 by the value in cell B34, adds the value in A20 to the result, multiplies that by 4
and adds it to 3 times the value of cell A25. Therefore, rather complex expressions can be made using simpler
ones as a base.

OpenOffice.org Calc gives you many pre-defined functions which you can use in your formulas. You can explore
them by choosing the Insert→Function menu.

Tip:

You can also click on the function wizard button for assistance with formula entry.

3.2.4. Charts: Explaining Data in a Simpler Way

When a spreadsheet contains too much information, it becomes difficult to understand how pieces of data
relate to one another: too many numbers and too little meaning. The best way to represent this kind of data is
through a chart.

As in all data-analysis functions, you must select the region you intend to show in the chart. So, select a range
of cells and then choose Insert→Chart from the menu to bring up the chart assistant.

Make your selections for the chart type, variant, title, axis titles, etc., and then click Create to create and insert
the chart in the spreadsheet.

Tip: Charts are “dynamic” in the spreadsheet, which means that when you change data in a cell belonging to a chart,
the chart is automatically updated.

Tip: Double clicking and then right-clicking on an inserted chart brings up a menu showing options to change many
chart parameters.
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3.3. Communicating Your Ideas

Choose Office→Presentation from the main menu to launch OpenOffice.org Impress. A wizard offers you
assistance for creating a presentation, but we won’t detail it here. Just create an empty presentation by clicking
Create.

3.3.1. Presentation Interface

Toolbar

Work
Area

Slide Format Bar

Layout
TemplatesSlide

Navigation

Figure 3-3. OpenOffice.org Impress’ Main Window

Slide Format Bar

There are options for changing the slide shading, background color, line thickness, etc.

Work Area

This is where you compose the slides which build your presentation.

Toolbar

Contains the main tools you use to create your slides: the text, shapes, curves, lines and arrow input;
object rotate, alignment and arrangement; and others.

Tip: Some of these buttons contain a little triangle on one side. Keeping these buttons pressed opens a menu of
options for that tool. For example: filled or hollow rectangles, sharp or round edges, etc.

Layout Templates

Contains a gallery of the templates available. Just click on the template you want to switch the current
slide to it.

Slide Navigation

Displays a list of all the slides comprising the presentation. Slides are displayed as miniatures, so you can
see what they look like at a glance. To open a slide, search for it in the list, then click on it.
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3.3.2. Adding Slides to Your Presentation

Click on this button on the Toolbar or choose Insert→Slide from the menu to add a new slide, after
the current one, with the currently selected slide template.

Tip: Choose Insert→Duplicate Slide instead if you want to base your new slide’s content on the current one.

3.3.3. Simple Charts

Choose Insert→Chart from the menu to insert a chart diagram into the current slide. A “default” bar
chart is inserted and OpenOffice.org Impress switches to chart mode. Click “outside” the chart area to
return to the slide design mode.

You can drag the border handles to adjust the chart’s size. Double click on the drawn chart, then right-click on
it and select Chart Data to enter the data according to the chart you want to build (see figure 3-4).

Figure 3-4. Entering Chart Data

Once you have entered the chart’s data, close the data entry window and click on Yes to update the chart in
the slide.

Repeat the double-click / right-click sequence to change the chart’s title, legends, axis, type (2D or 3D, bar,
pie, points, lines, etc.), selecting the appropriate entries from the pop-up menu.

3.3.4. Slide Background

Use the Format→Page menu and click the Background tab to define colors, gradients, patterns, or bitmapped
backgrounds for the slide. Each background type has options of its own. Feel free to explore them.

Note: Using bitmaps for backgrounds increases the file’s size considerably. This could lead to a performance hit, especially
on older systems.

Once the background is selected, you can make that background the default one for all slides. Make your
choice and the slide(s) background(s) will be changed.

3.3.5. Transitions, Animations and Effects

The Slide Show menu has slide transitions, animations and effects options and wizards which let you add
“dynamism” to your presentations. However, you should try not to overuse transitions, animations and effects
because they can be distracting to your audience, turning their attention to the effects themselves instead of
the content of your presentation.
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3.3.6. Running Your Presentation

Choose Slide Show→Slide Show, or press the F5 key to run your presentation. The presentation then takes up
the entire screen. Press the Esc key to stop the presentation.

3.4. Going Further

The tutorials available at the Tutorials for OpenOffice (http://www.tutorialsforopenoffice.org) Web site
are helpful if you want to learn more about the use of OpenOffice.org suite’s major components. Check the
tutorials for Writer (http://www.tutorialsforopenoffice.org/category_index/wordprocessing.html),
Calc (http://www.tutorialsforopenoffice.org/category_index/spreadsheet.html), and Impress (http:
//www.tutorialsforopenoffice.org/category_index/presentation.html).

You can also use the inline help which is accessible through the Help→OpenOffice.org Help menu, or
by pressing the F1 key. You are bound to find the answers to your questions.
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Chapter 4. Share and Install your Linux System

You can easily install the Live CD/DVD to your own system’s hard disk by following a few simple steps.

4.1. Live Install

4.1.1. Before Installation

Before installing MandrivaOne to the system’s hard disk and if there is already another operating system pre-
sent on the hard disk (like Windows® for example), it is strongly recommended you perform a disk defrag-
mentation in order to optimize the available space on the hard disk.

Warning

Always perform a backup of existing data onto a removable device or on another system before attempting to install
anything. Backups are the only safeguard against data loss.

4.1.2. Copy Files to Hard Disk

Click on this icon on the desktop to start the install wizard. The following steps are performed:

1. Where to Install Mandriva on your Hard Disk

Depending on what you currently have on your hard disk, you can now choose where your new Mandriva
system will reside. Bear in mind that reusing existing partitions of an former operating system or deleting
them will result in data loss. If you select the Custom disk partitioning option, you can control your partitions
using DiskDrake (see Managing Your Partitions in Starter Guide).

2. File Copy

Then, files are copied to the hard disk, no intervention is required on your part. This takes a few minutes,
depending on your system’s speed.

3. Bootloader setup

This step installs the menu that allows you to choose which operating system to boot at machine startup.
You can safely accept the default settings. Click on Advanced if you need to have access to more configu-
ration options.

Note: If your Windows® installation has many partitions (typically a laptop with partitions for the operating system
itself, for diagnosis software, for recovery software, etc.) you may have more than one Windows entries. The first
one should boot your Windows® operating system.

4. Finish

Just click on the Finish button and then restart the computer (Main menu+Log Out+Restart Computer),
removing the CD/DVD when prompted to.

4.1.3. System Configuration

A few settings have to be configured after the system boots from the hard disk.
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4.1.3.1. Networking

This is basically divided in two parts: selecting the network type; and configuring the required network para-
meters, which depend on the network type selected. Make sure you have all the required network settings (de-
pending on the network type: IP address, DNS servers, gateway IP address, etc.): your ISP or system/network
administrator should have provided them.

Figure 4-1. Choosing the Connection Type

Dial-up Connection. Select the Analog telephone modem (POTS) network type.

Cable-modem. Some cable-modem connections require you to select the Ethernet network type. Check with your ISP
or system/network administrator.

Cellular Networks. To connect to a wireless cellular network type, choose the GPRS/Edge/3G entry.

1. Connection Type

Your network device is automatically detected according to the network type you selected. If this is not
the case, you have the option to manually select the network device.

2. Network Parameters

Fill all required parameters for the connection type you chose.

3. Connection Status

After setting up all of the parameters, you are asked if you want to start the connection at boot; unless
you have a dial-up connection type (or some other “not-always-on” type), leave the box for this option
checked.

4. Finally, you are asked to connect to the network to test everything works as expected. If something fails,
go back, check and change the settings as required. You are now connected to the network, click on the
Finish button.

4.1.3.2. Setting the Root Password

The root user is the system’s administrator, and basically can do whatever he wants with the system, so it’s
extremely important to select a good, hard to guess, password to protect the root account. This password
will be asked of you whenever you wish to do administrative tasks (such as installing new software) on the
system.
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Choosing a good password: The password should be a mixture of alphanumeric characters and at least 8 characters
long. Never write down root’s password — it makes it far too easy to compromise your system. One caveat: do not
make the password too long or too complicated because you must be able to remember it too!

The password is not displayed on screen as you type it. You are asked to enter the password twice, for confir-
mation. Please note that if you type it incorrectly, you have to use this “incorrect” password at least on the 1st

login as root, so please type carefully.

4.1.3.3. Creating User Accounts

You must create an unprivileged (also called “regular”, or “normal”) user for everyday usage of the system.

1. Fill in the fields with the required information and then click on Accept user to create the account. Please
note that even if this user’s password is not as crucial as root’s there’s no reason to neglect it or leave it
blank, after all it is your files which are at stake.

2. If other people are going to use the system continue creating users for each of them, then click on Done
when you have finished adding users.

4.1.3.4. Registration Wizard

Whether you already have Mandriva accounts or wish to register your new product to benefit from all the as-
sociated advantages, this wizard will guide you. Make sure you read explanations carefully before advancing,
or click on Skip wizard to skip it altogether.

Once this is done, the system is ready to be used, just go ahead and provide your credentials (username and
password) to start using the system.
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To begin with, a bit of vocabulary.

Package
Software needs to be broken down into different files to ease its development and management. An
application ends up being lots of pieces: the binaries, the documentation and the resources the application
needs (images, icons, translations, sounds, etc.). A package is the set of all of an application’s components,
stored in a single file in a way that’s very simple to install, update and remove.

Dependency
Applications rely on software libraries or components made by different developers to perform a given
set of functions, not part of the main functionality but needed to achieve it. A dependency is a package
another package needs in order to work properly. Mandriva Linux’s package management tool takes care
of all the dependencies automatically.

Update
Software is a living thing: new features are added, existing ones are enhanced and problems (bugs) are
fixed. An update is a package which brings in some or all of these enhancements and fixes into an existing
application. It is recommended that you check for updates often in order to keep your system in good
shape and free from bugs and security threats.

Source
A source is a repository of packages, and the place where packages are installed from. Sources for the
media used during system installation are automatically created, you can add your own sources for
updates and packages you find on the Internet.

Media
The place where (software) packages are stored, physically, be it CDs, DVDs, or an FTP server.

Repository
Centralized place containing media (and thus, packages).

Mandriva Linux uses the RPM packaging system. Mandriva Linux provides convenient tools to simplify packa-
ge maintenance. The urpmi set of tools is command line based; here we will concentrate on Rpmdrake: Mandriva
Linux’s graphical software installation tool and the Software Media Manager. figure 5-1 shows the Software Ma-
nagement section of Mandriva Linux Control Center.
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Figure 5-1. Software Management in the Mandriva Linux Control Center

Rpmdrake can be used in one of three modes: install

, remove

and update

, each explained in Adding and Removing Software, page 38. Media management is covered in The Software
Media Manager, page 41.

5.1. Adding and Removing Software

Adding Extra Media on First Launch: When you launch this tool for the first time, you are prompted to add new
official installation media. That will give you access, over the Internet, to many more packages than those that could fit
in your CD or DVD. Add them if you have a fast Internet link.

When launching Rpmdrake you have to wait a few seconds while the package databases are scanned. Then
you are presented with Rpmdrake’s main interface.
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Package
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Figure 5-2. Rpmdrake Interface

Package Set. Use this pulldown list to select the types of package to be displayed: all of them (installed or not);
only installed ones (to be uninstalled); only uninstalled ones (to be installed); and a few options for updated
packages (all, security fixes, bug fixes, normal updates). Each time a package set is selected, the Categories
Tree is rebuilt to display matching packages only.

Package Search. If you are not sure about a package name, use this facility to search for it. Type the string to
be searched for, select the criteria using the pulldown list, and click Search. You can search for package names
(in names), package descriptions (in descriptions) and the package providing a given file (in file names).

Note: If your software media repositories are configured to use the synthesized package lists (the summary synthesis files,
not the full hdlist ones) you will not be able to look for the package providing a given file. You will only be able to
search for package names and descriptions.

Categories Tree. To ease management, packages are classified into categories (Networking, Office, Games,
Development, Graphics, etc.). Open a category to display packages which match the current criteria set using
Package Set and Package Search.

Package List. Where currently matching packages (Set, Category and Search Criteria) are displayed. This is
where you select packages to be installed, removed and upgraded.

Package Details. Displays details about the currently selected package in the Package List.

Actions on Packages

1. Limit List of Packages Displayed

Use the Package Set pulldown list, the Categories Tree and, optionally, the Package Search facility to brow-
se for packages to be installed, removed or updated.

2. Select Packages

In the Packages List, select packages to be installed, removed or updated. If the checkbox by the package
name is empty, it means that the package can be installed or upgraded, once selected it will be marked
with the

icon. If the checkbox by the package name has the

icon, it means the package is already installed, select it for removal and it will be marked with the

icon.

3. Apply Changes
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Once you are satisfied with your choices, click on Apply to perform the actual install, remove and upgrade
of these packages. A new window appears, where you can see the progress of actions being taken. If you
prefer to leave without doing anything, you can just click on Quit.

Handling Dependencies

It may happen that you select a package which requires dependencies (additional libraries or another tool)
or which is a dependency of other packages. In this case Rpmdrake displays an information window allowing
you to choose whether to accept the selected dependencies, to Cancel the operation, or to get More info on the
operation (figure 5-3).

Figure 5-3. Dependency Alert Box

Alternative Dependencies. You may also want to install a package which requires dependencies, and various
packages are capable of providing that dependency. The list of alternatives is then presented (figure 5-4).
You may read the additional information presented by clicking the Info... button to help you choose the best
alternative.

Figure 5-4. Alternative Packages

Note: Due to dependencies, the disk space required by the selected packages might be greater than the size required by
the chosen package by itself.

5.2. Updating Packages

This simple interface allows you to quickly check for available updates and to install them with one
click.

Adding Update Media. The first time you launch this tool, you are prompted to add update media. Follow
the instructions to do so.
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Figure 5-5. Updating Packages

1. By default, all updates (except the kernel ones) are selected for installation, review the list.

2. Click Update to launch the update process which consists of downloading and installing all selected up-
dated packages.

Kernel Update: Kernel updates are not selected by default. You will need to manually select the corresponding
kernel-*-latest package.

Updates notification: The Mandriva Update applet, sitting on your panel, can warn you of updates availability once
update media is configured. It shows a red icon

when updates are available and a green one

when your system is up to date.

5.3. The Software Media Manager

Use this tool to configure the package media repositories. figure 5-6 shows some media already
defined: “Main”, “Contrib”, etc. You can also add other software media: a CD from a magazine
containing RPMs, a Web repository, etc.
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Figure 5-6. The “Software Media Manager”

Use check boxes of the left-hand columns to flag the repositories

Enabled?

Uncheck this box to temporarily disable the corresponding medium. The packages contained in this me-
dium will not be available until you enable the medium again.

Updates?

This box must be checked for update media, that is, media that contains updates of packages that are
already in another medium, albeit with an older version number. Thus only update media are taken into
account when looking for updates.

Action Buttons on the Right

Remove

Discard a medium which you no longer use. Simply select the medium to be removed in the list and click
this button.

Edit

Change the medium’s parameters: the URL or the relative path to the synthesis/hdlist (if you do not
know what we are talking about, it is wise to leave this window via Cancel instead of Save changes).

In case you need to pass through a specific proxy to access this particular medium, you can configure it
here by clicking on Proxy.

Faster Media Updates. The relative path string allows you to change from using hdlist files to
synthesis files, which are much smaller but with less information on packages. Synthesized files only
carry information about package names, their dependencies and a short summary, so you won’t be able
to search for files inside packages from synthesized lists. Also, you won’t be able to see the full description
for a package if you click on its name.

To switch to the synthesis form of hdlist, simply prefix the file name with synthesis., so that for
example: media_info/hdlist_main.cz becomes media_info/synthesis.hdlist_main.cz.
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Add

Add to your system all publicly available official package sources from Internet repositories. This is useful
for example if you have a fast Internet connection or only have the first installation CD at hand. Choose a
mirror geographically near to your location.

After choosing a mirror and clicking Ok, package information for the source you chose is downloaded
and all included packages will be available.

Add custom

This button provides access to a new dialog, in which you define all needed parameters for a new software
package medium. Please bear in mind that the required parameters, and available options, depend on the
type of medium being defined.

Figure 5-7. Adding a Custom Package Repository Media

Update

You are shown a list of already defined, enabled, media; select the ones you want to update the list of
available packages for, and click Update. This is useful for remote media to which new packages are being
added.

Manage keys

It is important that any package you install is authenticated. To do so, each package can be electronically
signed with a “key”, and you can allow/disallow keys on a per-medium basis. On figure 5-8, you can
see that the Mandriva Linux key is allowed for medium “Main”. Click on Add to allow another key for
the selected medium (beware, do this with care, as with all security-related questions), and on Remove to
remove a key from the selected medium.

Figure 5-8. Package Repository Authentication Key Management
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Proxy

If you are sitting behind a firewall and you still need to access remote media (especially for package
updates), you can do so if you have a proxy server which leads to the Internet (at least in an area where
you can find a package server). Normally it should be enough to fill in the Proxy hostname to get it working
(figure 5-9). If you need a user / password combination to get through the proxy, you can also specify
these here. Just confirm your changes by clicking on OK and you are done.

Figure 5-9. Specifying a Proxy for Remote Media

Parallel

If you are running a large network of computers, you may want to install a package on all the computers
in parallel; this button opens a dialog window allowing the configuration of the “Parallel” mode. As it
is rather complicated and only useful to a limited group of people, this short introduction will not give
further details about it.

Global options

This button allows you to configure the program used to retrieve remote packages and whether the pac-
kages should be checked against a key. These choices affect all package sources.

Up and Down arrows

These buttons allow changing the order in which sources will be used when installing packages. By de-
fault, the newest version of a given package will always be installed, but if the same version is found on
two different media, the one from the first medium in the list will be installed.

Tip: Therefore, it is better to move fastest media up...
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6.1. Configuring Your Hardware

6.1.1. Hardware Detection and Configuration

The HardDrake project has been developed to simplify hardware detection and configuration
under GNU/Linux by providing a user-friendly interface.

6.1.1.1. Introducing HardDrake

HardDrake is a service for hardware detection, run at system boot time, and also a full GUI-based tool which
ties together many of the tools already included in a GNU/Linux distribution. It automates and simplifies the
process of installing new hardware. For the most part, HardDrake is able to detect most devices.

On one hand, HardDrake is used to display information, and on the other, it can launch configuration tools.
With its easy-to-use interface, you can browse all the hardware your system contains.

6.1.1.2. Using HardDrake

To launch HardDrake, you can start it through:

• the Mandriva Linux Control Center: click on the Hardware category, and then on the Hardware icon.

• a terminal: type harddrake2 as root. You can also pass parameters to HardDrake through the command
line (type harddrake2 -h to get a list of possible parameters).

• the desktop: go to the main menu. The HardDrake entry is an item in the System+Configuration→Hardware
sub-menu.

After all devices have been detected, the main HardDrake window appears (see figure 6-1).

On the left is the device tree that shows all the hardware categories.

Figure 6-1. Selected Device
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By selecting a device, you see additional information about it in the right frame. To better understand the
meaning of the information presented, you can consult the help page accessible by choosing Help→Fields
description from the menu.

Depending on the device selected, other buttons may appear:

• Set current driver options. This pops up a window with all the module device parameters listed. For experts
only!

• Run config tool. Launches the Mandriva Linux configuration tool (available through Mandriva Linux Control
Center) associated with that device.

Unknown hardware. A special category called Unknown/Others might also show up, containing all the
unknown hardware in your system, as well as known hardware which does not fit into any existing categories
(such as thermal sensors, random number generators, etc.).

6.1.2. Problems and Troubleshooting

If you think you have found a bug related to HardDrake, report it using the Mandriva Linux bug reporting tool.

Sound Cards. HardDrake does not probe for ISA PnP devices. If you have an ISA PnP sound card, run
sndconfig or alsaconf from the command line. You may need to install the sndconfig or alsa-utils pac-
kage.

6.2. Controlling the Graphical Configuration

This set of tools allows you to configure your graphical display. With it, you can change your video card, your
resolution and your monitor. It can be useful if you change one of your graphical components after the initial
installation.

If you don’t see a graphical login at boot: If the graphical server cannot start because of a configuration error, a dialog
offers to reconfigure the graphical server. You get a tool similar to the one described in Controlling All Video Parameters,
page 48, but in text mode.

The graphical configuration tools are accessible through different icons in the Hardware section of the Mandriva
Linux Control Center.

6.2.1. Changing the Monitor

This tool allows you to change the monitor type currently in use. When you click on it, a window
pops up, listing many monitor models (see figure 6-2). If your monitor was automatically detected,
it is listed as Plug’n Play along with its model.

46



Chapter 6. Hardware Setup

Figure 6-2. Choosing a New Monitor

If your monitor wasn’t automatically detected, you can choose it from the list. If you don’t find your monitor
or a compatible one, choose one with parameters corresponding to the monitor from the Generic entry, at the
bottom.

6.2.2. Changing the Resolution

This tool enables you to change the current screen resolution (800x600, 1024x768, 1152x864,
etc.) and the color depth. Simply choose the one you want to use.
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Figure 6-3. Changing the Resolution of Your Screen

The monitor in the window displays what the desktop will look like with the chosen configuration (see fi-
gure 6-3). If it looks good, click OK. The changes will be activated after you quit and restart your graphical
environment.

Monitor and Resolution Ratio. By default, the available resolution list only shows resolutions supported
by your video card and monitor combination. There is a special entry named Other that adds more possible
resolutions along with their ratios. Bear in mind that most monitors are designed with a 4:3 horizontal vs.
vertical ratio.

6.2.3. Controlling All Video Parameters

If you change your video card after installing your system, or want to have full control over the
graphic configuration, run this tool.
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Figure 6-4. XFdrake Main Window

The buttons allow you to change aspects of the graphical configuration:

Graphic Card

The button displays the name of the graphic card currently configured. Click on it if you want to change
it. Depending on your card, different servers may be available, with or without 3D acceleration. You may
need to try different ones until you get the best result.

Note: You may be asked if you want to use a proprietary driver for your card, answer Yes to use the driver provided
by the card’s manufacturer. This driver may give you access to more features and also make your card perform
better on 3D applications, like games.

In case you cannot find the graphic card you have, but you know which driver supports it, select it from
the Xorg entry at the bottom.

Monitor

Enables you to change the monitor with the tool described in Changing the Monitor, page 46.

Resolution

Enables you to change the pixel resolution and the color depth with the tool described in Changing the
Resolution, page 47.

Changing the resolution using the desktop applet:

If you are using KDE, you can also change the screen resolution on the fly by using the screen resize applet,
accessible by choosing System+Configuration+Hardware→Screen Resize & Rotate from the main menu.

Other buttons are also available:
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Test

Allows you to verify that your modifications actually work. It is highly recommended that you do test it,
because if it does not work, it will be harder to recover a working graphical environment later. If the test
fails, simply wait until it ends. If you are not satisfied with the suggested settings, choose No during the
test, and you will return to XFdrake’s main menu.

If the test is not available: Depending on your video card, video testing may not be available. You will be warned
of such a situation. If it happens that the settings are incorrect and your display does not work, launch XFdrake
as root in the console to use XFdrake’s text version.

Options

Graphic card options

Depending on your hardware capabilities, you can choose to enable or disable specific features such
as 3D acceleration or special visual effects (translucency).

Graphical interface at startup

Use this option to choose whether you want your machine to automatically switch to a graphical
interface at boot. Obviously, you may want to select the No option if your machine is to act as a
server, or if you were not successful in getting the display configured.

Quit

If you modify your graphical display in some way, the current configuration is displayed and XFdrake
asks you whether you want to keep your changes or not. This is your last chance to go back to the old
configuration. If all seems OK, click on Yes. If you want to restore the previous parameters, click on No.

The changes are activated after you confirm them and you restart your graphical environment.

6.3. Configuring a 3D Desktop

This tool is accessible from the Hardware section of Mandriva Linux Control Center and lets you configure
a 3D desktop for stunning visual effects on your desktop, together with a change from a flat desktop
to a cubic one.

Note: The first time you run Drak3D, a few required packages may be installed. Then, its main window is displayed (see
figure 6-5).
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Figure 6-5. Activating 3D Desktop Effects

You can choose between the following special featured desktops:

• Metisse;

• 3D desktop (cube workspace).

6.3.1. Metisse

Metisse is a window manager developed by the In Situ project (http://www-ihm.lri.fr/). Available under
the GPL License and exclusively for Mandriva Linux, Metisse differs from a classic 3D desktop (“the cube”, see
below 3D desktop Cube Workspace, page 51) because it focuses on an innovative interaction with windows.

Activate Metisse. Clicking OK will install the required packages and suggest that you log out in order to
activate the changes.

Once you’re logged in again, you will see nine squares at the bottom right of your desktop. Those represent
the nine virtual desktops you can use to organize your applications. The main options of Metisse are detailed
in .

6.3.2. 3D desktop Cube Workspace

Select the 3D desktop (cube workspace) option to enable the 3D desktop. Click Advanced settings to check your
options (see figure 6-5).

Optional Configuration

1. Choose a Graphical Server

There are two approaches: native support and Xgl. Depending on your hardware, Drak3D selects the most
appropriate one for you.

2. Choose a 3D Window Manager

Two options are available: Compiz and Beryl. The former is simpler and better tested, the latter has more
effects. See the Beryl Project Page (http://www.beryl-project.org/) for more details.
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To try out that 3D desktop, click OK. Changes take effect the next time you log into your computer.

Once the 3D desktop is active, the desktop manager (KDE or GNOME) shows 4 virtual desktops, corresponding
to the viewports (the cube faces): explore and enjoy them!

Please see for more information on keyboard shortcuts and mouse usage with the 3D desktop.

6.3.3. No 3D desktop effects

Select the No 3D desktop effects option to disable the 3D desktop completely, and return to your normal desk-
top.

6.4. Changing Your Keyboard Layout

This tool allows you to define another keyboard layout, useful when the keyboard you want
to use is different from the one chosen at installation time.

Figure 6-6. Choosing a Different Keyboard Layout

Select your keyboard’s layout (which is closely associated to the language you speak) and then its type (or
model) from the lists shown in figure 6-6. If you own a multimedia keyboard and it is listed in the list of ma-
nufacturers, chances are that most multimedia keys on it will be supported. Otherwise, choose your keyboard
type under the Generic branch. Changes are effective immediately after clicking OK.

Note: If you choose a keyboard layout based on a non-Latin alphabet, you are asked to choose the key combination that
will switch the keyboard configuration between the Latin and non-Latin layouts.
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6.5. Changing Your Mouse

This tool enables you to set up a different mouse, which is useful if the mouse you are currently
using is not the same as the one you chose at installation time.

Note: The Synaptics Touchpad function is automatically configured to work with almost every touch pad found on
notebook computers. The same goes for Wacom® tablets.

Figure 6-7. Choosing a Different Mouse

Mice are sorted into a tree according to their connection type and model (see figure 6-7). Highlight the mouse
of your choice and click OK. Changes take effect immediately after the mouse test is done.

Tip: The Any PS/2 & USB mice option works with virtually all modern mice.

6.6. Configuring Printers with PrinterDrake

This tool allows you to:

• Configure a newly installed printer;

• configure your machine to act as a server for a printer connected to your local network;

• set up your machine to access network printers served by other servers.

6.6.1. Automatic Installation

If you connect and power on a USB printer, a dialog pops up.
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Figure 6-8. A new Printer was Detected

Deactivate Automatic Detection. If you don’t want the “automatic setup” popup to show again, check Do not
setup printer automatically again.

Then just click Ok, all required packages will be installed, and the printer configured for you to let you use it
right away: nothing else to do!

Configuration. It is however recommended that you check the printer default parameters, especially paper
size. To do this launch PrinterDrake from the Mandriva Linux Control Center and follow the instructions from
Reconfiguring an Existing Printer, page 61.

6.6.2. Manual Configuration

Tip: If you have just installed a printer that wasn’t available when you installed Mandriva Linux, make sure it is correctly
connected and powered on before launching the configuration tool.

When you first launch the PrinterDrake tool, it may be in one of these states:

6.6.2.1. There is no printer directly connected to the computer.

Figure 6-9. Activate Printing
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The tool did not detect any local printers. However you can print on network printers, or manually installed
printers which weren’t detected by clicking on Yes.

Figure 6-10. Activating Network Printers

• Select the Local CUPS printing system option if you wish to configure your machine to act as a print server
for either a local printer which was not detected, or a networked printer connected to your local network.

Any required software will be installed and then the main configuration interface (see figure 6-12) appears.
Click on Add Printer to install the network printer.

• Select the Remote server option if you wish to be able to print on printers served by another CUPS print
server on the network. Your applications will immediately have access to all public printers served by that
server. You only need to provide the hostname or IP address of that server in the field (ask your system
administrator).

When this is done, the main configuration interface (see figure 6-12) appears. The Configured on other machi-
nes tab will be filled with the available network printers.

6.6.2.2. New Printer Detected

The following window appears when PrinterDrake detects a new printer at launch time.

55



Chapter 6. Hardware Setup

Figure 6-11. A New Printer Is Detected

Simply confirm the automatic installation of the new printer. The main configuration interface (see figure 6-12)
is then displayed. Make sure you check that the printer parameters fit your needs (see Reconfiguring an Existing
Printer, page 61).

6.6.2.3. A Printer is Already Configured

The main configuration interface (see figure 6-12) is shown. Make sure that the printer parameters fit your
needs (see Reconfiguring an Existing Printer, page 61).

6.6.3. The Printer Management Interface

Local and Remote Printers. Use the printer configuration tool’s first tab for locally connected printers
(Configured on this machine), and the other tab for printers available on your local network (Configured on
other machines).
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Figure 6-12. Managing Printers

The following buttons give you access to all available maintenance tasks:

• Add Printer: launches the printer configuration wizard described in The Printer Configuration Wizard, page
60.

• Set as default: sets the selected printer as the default printer when no specific printer is chosen at print time.
A cross appears in the Def. column of that printer.

• Edit: opens the printer configuration dialog described in Reconfiguring an Existing Printer, page 61.

• Delete: removes the selected printer from the available printer pool.

• Refresh: updates the list of available printers, especially useful for networked printers.

• Configure CUPS: by default, your system is open. PrinterDrake uses all of the network’s available printers and
shares all of its local printers with the local network. Click on this button if you don’t want to access network
printers, or if you want to restrict the access to your local printers. This dialog also lets you configure access
to print servers outside the local network (see Print Server General Configuration, page 57).

Note: The Options→Expert mode menu adds extra features to the tool. See Expert Mode, page 63.

6.6.4. Print Server General Configuration

The Configure CUPS button allows you to control the behavior of printers connected to your machine and to
your network.
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Figure 6-13. CUPS Printer Server Configuration

This dialog enables you to switch between the client and server printing modes through the Remote CUPS
server and no local CUPS daemon button.

This button enables you to select between two remote server access methods.

In the first method your server must have a CUPS daemon running and be listening on port 631 in order
to manage the print queue and to listen for jobs coming in from applications. In this case the CUPS server
broadcasts its presence to the entire network. This is the default configuration.

In the second method, the CUPS daemon is still required to manage the queue and to handle jobs coming in
on port 631, but it does not broadcast its presence to the network. In this case the clients do not need to run a
CUPS daemon, instead they have a configuration file which contains the IP address of the server. In this way
the clients know they can sent jobs directly to the IP address.

Advantages Disadvantages

Method 1 No client configuration required Runs with at least one open port
and consumes extra machine
resources

Method 2 No local printing system. No open
ports

If the IP of the server changes or
the client changes to another
network, then reconfiguration is
required.

Table 6-1. Considerations
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6.6.4.1. Client Mode

Figure 6-14. Client Mode Configuration

Select the On option to connect to another printer server. Then you only need to specify the name or IP address
of that server in the next field below.

If you choose this mode, your printing configuration is now finished. Accept the options by clicking the OK
buttons, and you will be able to check the list of available printers in the Configured on other machines tab of
the main interface (see figure 6-12).

6.6.4.2. Server Mode

If you want your machine to access locally connected printers (through parallel or USB ports), or network
printers not already configured on another server, you need to select the Off option. Click OK to fine tune your
printer server (see figure 6-13).

A number of options are available to further secure and enhance your print server features:

The printers on this machine are available to other computers

Allows other computers to print on printers configured locally. Remember to restrict access by clicking
on Printer sharing on hosts/networks (see below).

Automatically find available printers on remote machines

Tells your print server to automatically make all printers found on other servers available to the local
network, as if they were locally connected to your print server. This way your system’s users are able to
print on any printer the print server can “see”. If the remote printers you intend to use are served by a
server not on your local network, you can still tell the print server to use them with the Additional CUPS
servers button (see below).

Printer sharing on hosts/networks

Allows you to specify from which networks the local printers are made available.

Additional CUPS servers

Allows you to specify one or more CUPS servers to which you can connect and access printers. Specify
the IP address and port of the CUPS server in the dialog.
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Japanese text printing mode

Replaces the original text filter for one more suited to Japanese texts, but with less features. Use it if you
have to print Japanese text-only files.

6.6.5. The Printer Configuration Wizard

Click on Add printer and the configuration wizard comes up.

6.6.5.1. Detect Printers or Specify Access Path

The first step serves to either specify an access address to a network printer, or to activate auto-detection of
locally connected printers, network printers, and finally printers served by SMB (Windows®) servers.

Figure 6-15. Printer Type

Specifying the Location. If you happen to know all parameters required to access a specific network printer,
select Enter host name/IP address of network printer. Configuration steps are then similar to the ones involved
in auto-detection procedure.

6.6.5.2. Choose the Printer

Figure 6-16. Detected Printers List

1. Choose the Printer to be Configured

Select the printer you want to add from the list of detected printers. If the detected printer isn’t the correct
one check the Manual configuration box and proceed with the printer model step. If autodetection fails,
remove the check mark from all check boxes, click on Next and follow the instructions below.
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2. Specifying the Driver Manually

PrinterDrake displays your printer’s model name. Choose Select model manually if it’s incorrect. Select the
printer you have or a compatible one (see Choose the Printer, page 60) if yours is not specifically listed.

3. Manufacturer-Supplied Driver

If you want to install the driver supplied by your printer manufacturer, click on the Install a manufacturer-
supplied PPD file button and select the medium containing the PPD file and browse to it. Accept subsequent
dialogs to use your chosen PPD file.

4. HP Multifunction Devices

If you own a multi-function device such as those of HP or Sony, an information window pops up and
gives you information about your scanner and scanner software (Installing and Sharing Scanners, page 63).
Additional required packages are also installed.

Fax Virtual Printer. If your device also provides fax functions, you are given an option to create a virtual
fax printer that will actually queue the printed documents so they can be later sent via fax.

5. Optional Configuration Step

If your printer has optional add-on devices (finishers, extra paper trays, etc.), you are asked which features
are actually installed.

6.6.5.3. Printer Test

Several test pages are available (see figure 6-17). We recommend you print at least one test page so you can
immediately correct the parameters if something is incorrect. The printer should begin to print almost imme-
diately.

Figure 6-17. Testing the Printer

6.6.5.4. It’s Done

If you’re not satisfied with your test page, answer the appropriate question with No and you will be led to the
printer configuration menu (see figure 6-18) where you can correct the settings. See Reconfiguring an Existing
Printer, page 61.

Your printer will now appear in the list of available printers in the main window (see figure 6-12).
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6.6.6. Reconfiguring an Existing Printer

Double-clicking on a printer’s name in the list, or clicking on the Edit button, displays a menu where you can
choose actions to take on the selected printer (figure 6-18). You can change the printer name, options, etc.

Figure 6-18. Modifying an Existing Printer

Here are some of the most useful entries:

• Printer name, description, location. If you have many printers around it is better to give them explicit names,
and meaningful descriptions, plus a location so people don’t end up looking desperately for their printouts
in many floors.

• Printer Options. Shows the different options available for that printer (paper size, printout mode, etc.), so
you can set a default value for them.

• Make this printer invisible for other computers. Printers are normally made available to other computers in the
local network. Using this option you can disable this behavior for the currently selected printer.

• Disable Printer. Use this option to remove a printer from those to the system’s users. You might need to
temporarily disable a printer under maintenance so that users don’t try to use it in the meantime. When a
printer is disabled, that option changes to Enable printer.

• Learn how to use this printer. Displays information on how to use a particular printer model. In the case of a
multi-function device from HP, additional information for the “extra” functions is also displayed.

• Remove printer. Deletes that printer’s configuration from the system.

Select an action in the dialog and then click on the Do it! button to perform it.

6.6.7. Controlling Automatic Installations

Open the Options→Configure Auto Administration menu to go to the automatic installation options form.
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Figure 6-19. Set Automatic Installation Options

You can here configure whether new printers should be automatically detected, automatically configured, etc.

6.6.8. Expert Mode

The expert mode activates additional features in the application.

More Technical Installation Wizard. The installation wizard displays more technical information and allows
you to configure printer name and other options directly from within the wizard.

Choose a Different Printer Driver. Different drivers are available for the same printer. In expert mode, a
third level appears in the printer model selection list (see Choose the Printer, page 60) letting you change each
printer’s driver.

No Automatic Configuration. If PrinterDrake is in expert mode, it doesn’t automatically configure new local
printers on start-up. Use the Add printer button to configure the printer. However you can choose to Configure
Auto Administration from the Options menu to override that behavior.

Automatic correction of CUPS configuration. This new option appears in the CUPS server configuration
window (figure 6-13. It is activated by default. Leave the mouse over the option name to get more information
about what it does.

6.7. Installing and Sharing Scanners

The ScannerDrake wizard helps you install your scanner. Make sure your scanner is powered
on and launch ScannerDrake by clicking on the Scanners entry of the Mandriva Linux Control
Center’s Hardware section.

Tip: Please note that not all scanners are supported under GNU/Linux. Before buying new hardware, remem-
ber to check out Mandriva’s Hardware Database (http://hcl.mandriva.com) and the SANE home page (http:
//www.sane-project.org/) for compatibility issues.
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6.7.1. Main Interface and Scanner Installation

The program tries to detect your scanner’s manufacturer and model. If it finds the scanner then information
about it is displayed in the upper part of the wizard’s main window. The window also offers a few action
buttons (figure 6-20).

Figure 6-20. Installing your Scanner

Search for new scanners

Click on this button to autodetect a new scanner you have just plugged in.

Add a scanner manually

Use this button if the automatic detection fails and then look for the specific model you own by browsing
through the list of available scanners and models.
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Figure 6-21. The Tree-list of All Known Scanner Models

Choose the right Port. After choosing the appropriate model, you can leave the default Auto-detect available
ports option unless you have a parallel port scanner, in which case selecting /dev/parport0 in the pull-down
list should be the right choice.

HP multi-function devices

Note that HP multi-function devices, such as the OfficeJet and PSC printers, must be configured through Printer-
Drake. Please refer to Configuring Printers with PrinterDrake, page 53. The scanning part of non-HP multi-function
devices can be set up with ScannerDrake as a stand-alone scanner.

6.7.2. Share your Scanner

ScannerDrake allows for scanner sharing between users connected via a LAN.
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Figure 6-22. Sharing Scanners within a LAN

Share Your Own Scanner

1. Check the The scanners on this machine are available to other computers box.

2. Click the Scanner sharing to hosts button and then Add host to specify which hosts will be actually allowed
to access your scanner.

Use Other People Scanners

1. Check the Use scanners on remote computers box.

2. Click the Use the scanners on hosts button and then Add host to specify which hosts serve the scanner you
wish to use.

6.8. Setting up your UPS

This tool will configure the NUT (Network UPS Tool) service for you. The service checks the UPS
connected to your machine and automatically shuts it down when the UPS is about to run out of battery
power.

Automatic Installation. Open the Mandriva Linux Control Center in the hardware section and click on Set up a
UPS for power monitoring to launch DrakUPS. Check the Connected through a serial port or a USB cable button
to let DrakUPS autodetect your UPS.

Manual Configuration (Serial Port)

1. Select the Manual configuration option.

2. Select your UPS from the list of manufacturers and models.
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3. Then assign a Name, Driver, and Port1.

If all went well your UPS should now be configured and ready to help avoid bad power outage surprises.

1. The Name and Driver fields should automatically be filled. Of course, you can change its name but we recommend you
keep the driver name.
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7.1. Network and Internet Connection Management

Tip: Before connecting to the Internet, you are encouraged to set up a firewall on your machine so as to avoid bad
surprises such as intrusions into your system. You can set up a very simple, yet effective firewall using DrakFirewall.
Please refer to Securing your Internet Access via DrakFirewall , page 93 for more information.

The drakconnect set of tools allows you to easily configure your network access, whether it be to the Internet
or to a local network. Open Mandriva Linux Control Center and select the Network & Internet section to access
drakconnect tools. A view of the main interface is shown in figure 7-1.

Figure 7-1. DrakConnect Tools

7.1.1. Setting Up a New Network Interface

drakconnect supports different types of Internet and network connections. The first step consists
of choosing which type of connection you want to configure. Always make sure you have all the
information provided by your ISP or network administrator at hand.

Note: After a connection has been configured, it can be further modified using the Manage Connections interface (see
Reconfiguring Interfaces, page 72).

7.1.1.1. Wired Ethernet Connection

1. Select the Ethernet type

Your NICs are detected automatically; if you have more than one, you need to select the one you want to
configure. You can also load a driver for your NIC manually.
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2. Automatic or Static Configuration

You now have to specify whether the network parameters are automatically set up (Automatic IP
(BOOTP/DHCP)) or not (Manual configuration): fill the next steps with the parameters that your ISP or
network administrator gave you.

3. Connection Control

Allow users to manage the connection

If you want users to be able to bring up or shutdown the connection without having to provide the
root password (see Monitoring Connections, page 73) check this box.

Start the connection at boot

Uncheck this if you want the connection to be activated on demand only.

The Net Applet: An applet appears in the desktop’s panel indicating that the connection is up

or down

. Right click on it to access a menu that also lets you control the connection’s state, as well as other parameters.

7.1.1.2. Wireless Connection

This entry allows you to configure WiFi PCMCIA or PCI devices.

1. Select the Wireless type

If your WiFi card is not listed, choose the Use a Windows driver entry. Then, select the driver from the
manufacturer’s card drivers CD.

2. Choose Network

A list of detected networks is then shown. Select yours; otherwise, choose unlisted.

3. Wireless Settings

Operating Mode

The mode the card will operate on, with respect to the other WiFi devices in the network. The most
common one is Managed to simply connect to an existing access point.

Network Name (ESSID)

The name of the network you want to connect to. Ask your network administrator.

Encryption Mode

This depends on the network settings, ask your network administrator.

Encryption Key

This also depends on the network settings, ask your network administrator for the key the network
uses.

4. Network Configuration

This is similar to the traditional Ethernet network setup: see Wired Ethernet Connection, page 69.

5. Connection Control

Check the Allow access point roaming box if you want the connection to automatically switch from one
access point to another, depending on its signal strength. This is particularly useful when moving a laptop
around.

Managing Connections. Consult Managing Wireless Connections (Roaming), page 76 to learn how to configure
and manage various wireless networks.
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7.1.1.3. ISDN Connection

Simply make sure you select the right parameters in all steps, concerning your area and provider.

The last step gives you the option to handle the connection status through the net applet. This can prove useful
if you only need the Internet connection from time to time.

7.1.1.4. Modem Connection (POTS)

1. A list of detected modems is shown. If no modem was detected, only the Manual choice option is shown,
click on Next and choose the communications port the modem is connected to. The required packages are
installed.

2. You then see a list of countries/ISPs. If yours is listed, select it and continue to the next step: some para-
meters (connection name, phone number to dial, and authentication scheme) will be automatically set. If
not, select the Unlisted - edit manually option.

3. Verify the parameters, add the missing ones provided by your ISP.

Figure 7-2. Entering Dial-up Connection Parameters

All parameters should be obvious, except for the authentication type. The value in the Authentication pull-
down depends on what your ISP supports: Script-based (an old type of authentication method based on
“expect” and “send” types of chat between your system and your ISP); Terminal based (a terminal window
pops up when the connection is made and you have to login interactively); PAP, CHAP, or PAP/CHAP
(authentication information exchange protocols, CHAP is preferred because it is more secure, PAP/CHAP
will automatically choose the supported one).

4. Then come the IP, DNS and gateway settings. Nowadays, most ISPs provide them automatically when a
connection is made, so selecting the Automatic option on them is usually a safe bet.

5. Connection Control

Allow users to manage the connection

You are then asked whether you want to allow users to start the connection. That allows them to do
so without needing the root password.

Start the connection at boot

It is probably safer and cheaper to choose No.

6. Finally you are asked to test the connection: we recommend you to do so to make sure all parameters are
accurate. You can now control your Internet connection using the net applet. You can also use the kppp
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remote access connection dialer (package kppp) by choosing Internet+Remote Access→KPPP from the main
menu.

7.1.1.5. DVB Connection

This connection type is used for satellite connections.

1. Choose the connection card you want to configure, and then the adapter settings.

2. Network configuration is then similar to the LAN connection type (see Wired Ethernet Connection, page
69).

7.1.1.6. GPRS, Edge and 3G

This connection type supports Internet connections through cellular phone networks, accessed through a
PCMCIA card. Third generation (3G) technologies, as well as older ones (GPRS/Edge) are supported. Support
for newest HSDPA standard is also available.

7.1.2. Internet Settings

Figure 7-3. Configuring the Internet Access

This tool allows you to specify Internet access parameters if they need to be modified after your
initial configuration. Please bear in mind that these parameters are system-wide and apply to all
interfaces. To change the gateway address see Reconfiguring Interfaces, page 72.
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7.1.3. Reconfiguring Interfaces

Figure 7-4. Managing Network Connections

This tool allows you to modify network interface-specific parameters, after you have set them up
through the new interface wizard (see Setting Up a New Network Interface, page 69). Use the drop-
down list at the top to select the interface you want to configure. The tabs allow you to change
parameters and options according to the network interface type selected.
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7.1.4. Monitoring Connections

Figure 7-5. Real-Time Network Connection Monitoring

This tool shows network interface activity. You can specify some options for the traffic graphic
and statistics: update interval, scale, etc. (see figure 7-5). It can also be used to control the status of
the network connection, bringing it up or down using the button at the lower left.

Note: The network monitoring interface can be brought up by users through the net applet to monitor traffic.

7.1.5. Removing a Connection

This tool simply allows you to remove a network interface. Select the interface to be removed in
the Net Device pull-down list.

Warning

You will not be asked for confirmation. Once an interface is selected for removal, pressing the Next button deletes
it immediately.

7.1.6. Proxy Settings

If your Internet connections must (or can) pass through a proxy, this tool allows you to define
the hostnames or IP addresses of proxies for the FTP and HTTP protocols. Fill the fields with the
required values and click OK.

What’s a Proxy. A proxy is a server that retrieves information from the Internet on your behalf, keeping a local
copy of the web pages that are most frequently requested. They are referred to as “caching proxies”, and opti-
mize bandwidth usage. In some organizations, you cannot access the Internet directly. You must pass through
a proxy that authenticates you before allowing you to connect to the Internet. This is usually combined with
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a firewall that only guarantees the proxy direct access to the Internet. They are referred to as “authentication
proxies”. In corporate or business environments, proxies perform both caching and authentication functions
for performance and security reasons.

7.2. Activating and Managing Network Profiles

Mandriva Linux Control Center profiles enable you to store different configuration sets for your machi-
ne, for example for different locations. This is especially useful for laptops that need different confi-
gurations for home, at the office, the coffee shop, etc. The parameters that can change from one profile

to another are:

Network Configuration

Activates different interfaces, with different configurations, for wireless-type connections, for example.

Services Configuration

Allows you to activate different services from one profile to another, for example a firewall at home and
no firewall at the office (see Configuring Start-Up Services, page 79).

7.2.1. Profile Handling

New profiles you want to create are based on the active one. All modifications are automatically recorded in
the active profile. A single menu (Profiles) lets you manage them.

Figure 7-6. The Network Profiles Interface

Activate

Make the selected profile active.

Clone

Creates a new profile based on the settings of the selected one. A dialog pops up asking for the name of
the new profile. Don’t forget to activate that profile after creating it if you want to configure it.
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Delete

Deletes the currently selected profile without further prompts. Please note that a warning is shown if you
try to delete the active profile, because it cannot be removed while it is in use.

The Default Profile. This is the profile that is used at boot time. It cannot be deleted.

Example: Create a New Profile for Your Dial-Up Home Connection. You come back home with your brand
new laptop, which your system administrator configured so you can connect to your corporate network. You
now want to configure the network to access the Internet from home with a dial-up connection.

1. Create a new profile called “Home”.

2. Switch to it.

3. Reconfigure your network so that the modem, instead of the network card, is used to access the Internet
(see Network and Internet Connection Management, page 69).

4. Connect to the Internet.

5. When back at the office, switch back to the “default” profile.

7.3. Managing Wireless Connections (Roaming)

This tool shows the wireless networks currently available. It also allows you to switch between
the networks and to change their configurations. If you haven’t configured your wireless interface
yet, please refer to Wireless Connection, page 70. figure 7-7 shows DrakRoam’s interface: a list of the
available networks, together with their status, and buttons for actions at the bottom.

Tip:

You can also right click on the“signal meter”icon in the panel and choose Wireless networks+Manage wireless
networks. Then enter root’s password to access the tool.
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Figure 7-7. DrakRoam’s Interface

The list of detected networks is shown. If you expect other networks, click Refresh.

7.3.1. Switching Networks

To change networks, select one from the list, then click on Connect. If the network is public, you are imme-
diately connected. If it’s private, you are asked for configuration parameters with the same dialog shown in
figure 7-8. Provide the required settings (in particular, the encryption key) and click OK. Settings take effect
immediately.

7.3.2. Configuring a Wireless Connection

If you need to change the network parameters, select the network from the list, then click on Configure. See
figure 7-8 for an example of a secure wireless network connection.
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Figure 7-8. Changing Wireless Network Configuration

Make your adjustments and click OK; the settings take effect immediately. Click on Advanced to fine tune
parameters such as network ID and frequency.
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8.1. Configuring Start-Up Services

At boot time, the system starts a number of services (programs which run in the background
to perform a variety of tasks). This tool gives the administrator control over those services. See
the The Start-Up Files: init sysv chapter of the Reference Manual for more information.

Figure 8-1. Choosing the Services Available at Boot Time

For each service, this is the list of items found in each column:

• Service name;

• Current Status: either running or stopped;

• Info: click on this button to get a little explanation about that service;

• On Boot: check this box if you wish this service to be automatically started at boot time1. Alternatively,
if xinetd is installed and the service is a xinetd service, the label Start when requested will be displayed.
Checking the box will then mean to activate that service in xinetd. You will also have to make sure that the
xinetd service itself is activated.

• Start: immediately starts the service, or restarts it (stop+start) if it is already running;

• Stop: immediately stops the service.

After pressing the Start or Stop buttons, a tool tip shows you the status of the operation.

1. Generally in runlevels 3 and 5.
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8.2. Managing Fonts on your System with DrakFont

This system sdministration tool enables you to review the different font families, styles, and
sizes available on your system. It also allows for fonts to installed or removed.

The main window (see figure 8-2) shows a visual appearance of the currently selected font combination.

Figure 8-2. DrakFont’s Main Window

drakfont is made up of a number of dialogs which are accessible through the buttons located at the bottom.

Get Windows Fonts

This button automatically adds fonts found on your Windows® partitions, if any, of your local hard drives.

Options

Allows you to specify which applications and devices (such as printers) will support the fonts. Select the
ones you want support for and click on the OK button.

Uninstall

Allows you to remove installed fonts, in order to save space for example. Use this with great care, it could
have side effects for your applications. In particular you should not remove fonts you did not install
yourself.

This actually removes all fonts found in a given directory. Note that fonts manually added through drak-
font are found in /usr/share/fonts/drakfont/

Import

Allows you to manually add fonts found outside the Mandriva Linux distribution, from a fonts disk you
have purchased or from the Internet, for example. Supported font types are ttf, pfa, pfb, pcf, pfm,
gsf. Clicking on the Add button will open a standard dialog allowing you to specify the font file to
import. Once you’ve specified all the fonts you want to import, click on the Install fonts button.

Selecting more than one font: To select more than one font, press the CTRL key while selecting the fonts you
want to install and click OK, they will be added to the Import Fonts window. Then, click on the Install fonts button.
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Note: When adding or removing fonts, the change might not appear immediately in the fonts list. Close and re-launch
drakfont to ensure your changes were taken into account.

8.3. Setting your Machine’s Date and Time

This little tool enables you to set your system’s correct internal date and time.

Figure 8-3. Changing Date and Time

You can set the date on the left and the time on the right:

1. Date

To change the year, click on the little arrows on each side of the year; same procedure to change the month.
This updates the month view where you can click on the current day in order to highlight it.

2. Time Zone

We recommend that you check the time-zone settings for your geographical location. Click on the Change
Time Zone button and select the correct place in the tree view.

Once you’ve chosen the time zone, a dialog appears asking you whether your hardware clock is set to
GMT. Answer Yes if only GNU/Linux is installed on your machine, No otherwise.

3. Time

To change the time, you can either move the hour, minute and second hands of the analog clock, or change
the numbers below it.

4. Automatic Clock Synchronization
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If you have a permanent Internet connection and want your system to synchronize its internal clock with
time servers on the Internet, put a check mark in the Enable Network Time Protocol option and select a
server in the Server pull-down list, preferably one near you. If you know the name or the IP address of a
local server you can also enter it manually in that field.

When you’re finished, click on OK to apply your settings or Cancel to close the tool, which will discard your
changes. If you want to return to your previous settings, click on Reset.

8.4. Monitoring System Activity

This tool allows you to look for specific entries in various log files, therefore making it easier to
search for particular incidents or security threats.

8.4.1. Browsing System Logs

Figure 8-4. Browsing and Searching through System Logs

These are the steps to follow in order to browse or look for a specific event into the system logs:

1. Matching Terms

You must choose which specific words to match by filling the Matching (log files contain the words) field
and/or the but not matching (log files which don’t contain the words) field. At least one of the two fields
must be filled.

2. Log File
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Then in the Choose file area select the file you want to perform the search on. Simply check the correspon-
ding box.

Note: The Mandriva Linux Tools Log is filled by Mandriva Linux-specific configuration tools, like those you find in
the Mandriva Linux Control Center. Each time these tools modify the system configuration they write to this log
file.

3. Date of Event

Optionally, you can restrict the search to a specific day. In that case, check the Show only for the selected
day box and choose the desired day from the calendar.

4. Search

When all is set up, click on the Search button. The results appear in the Content of the file area at the bottom.

Clicking on the Save button opens a standard dialog letting you save the search results into a plain text (*.txt)
file.

8.5. Managing Users and Groups

UserDrake allows system administrators to easily add and remove users from the system, to assign users to a
group, and to manage user groups in the same manner.

Note: In this section we will only focus on user management. Group management being similar.

8.5.1. The Interface

Launching UserDrake will display the main window (figure 8-5) which lists the users currently defined on the
system. You can switch from users to groups by clicking on the Groups tab next to the Users tab.

Figure 8-5. The User List in UserDrake

All changes have immediate effect on your local user database. If the user list is modified outside of UserDrake,
you can refresh UserDrake’s window by clicking on the Refresh button.

Note: If you make changes to an already logged in user, those changes won’t take effect until the next time he or she
logs in again.

Available actions are:
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Add User

Adds a new user to the system. We will detail this procedure in Adding a New User, page 84.

Add Group

Adds a new user group to the system.

Edit

Allows you to change the parameters of the selected user or group. We will detail editing user parameters
in Adding a New User, page 84. In the case of a group you will be able to assign or remove users from that
group.

Delete

Removes the selected user or group from the system. A confirmation dialog will be shown, and in the
case of a user you will also be able to remove the user’s /home directory and mailbox.

8.5.2. Adding a New User

We created the non-privileged user Queen Pingusa at installation time, and now we want to create a new user
called Peter Pingus. Then we want to make them both members of the fileshare group, so that they can
share folders with other users on the network .

Click on the Add User button, a dialog box to add a new user will pop up (see figure 8-6). The only required
field is Login although we strongly recommend that you set up a password for this new user: enter it in both
the Password and Confirm Password fields. You can also choose to add a comment in Full Name. Generally, this
is the full name of the user, but you can put whatever you want.

Figure 8-6. Adding a New User in the System

We now have two users in our list. Select one of them with your mouse, and click on the Edit button. The
dialog box shown in figure 8-7 will pop up. It allows you to modify most available user parameters.
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Figure 8-7. Adding Users to a Group

The dialog is made of the following tabs:

User Data

Allows you to modify information provided when the user was created.

Account Info

Enables you to provide an expiration date for that account, after which the user won’t be able to connect
to the system. This is useful for temporary accounts. It’s also possible to temporarily lock an account to
prevent a user from logging in. Finally, this tab allows you to change the icon associated with the user.

Password Info

Allows you to provide a password expiration date, after which the user will be required to change his
password.

Groups

Shows the list of available groups where you can select the groups to which any user should belong.

For our users we just need to look for the fileshare entry and check the box associated to it. Then click on
the OK button to make the changes effective.

8.6. Backing Up and Restoring your Files

This tool allows you to backup the data present on your computer to different media and also
to a remote machine over a network. It also supports multiple profiles for different backup
scenarios. Once the parameters are set, you can run the backup periodically. Then, you can
forget about it until you wish or need to restore files.

8.6.1. A Practical Example Using the Wizard

You can access this tool by clicking on the Backups icon in Mandriva Linux Control Center’s System section. Click
on the Wizard Configuration button to start the wizard. After making your choices in each step click on Next.

85



Chapter 8. Personalizing your System

8.6.1.1. First Step: What to Backup

Figure 8-8. Selecting What to Backup

Select Backup System to include the /etc directory where all your current system configuration files lie. This
allows you to “transport” your system to another computer with little effort: only hardware-dependent confi-
guration will have to be revised.

Note: The “system” backup does not include applications themselves (i.e. executable files, libraries). A priori this makes
sense because it is likely that you will have access to the system’s installation media from which applications can be easily
installed again on the target computer.

Select Backup Users to include all the files included in all of your users’ /home directories. Clicking on the Select
user manually button lets you select individual users and gives you the following options:

• Do not include the browser cache. Selecting this option is recommended due to the very nature of the ever-
changing browser cache.

• Use Incremental/Differential Backups. Selecting this will preserve old backups. Choosing Use Incremental Bac-
kups will only save files which have been changed or added since the last backup operation. Choosing Use
Differential Backups will only save files which have been changed or added since the first backup operation
(also known as the “base” backup). This last option takes more space than the first one, but allows you to
restore the system “as it was” at any given point in time for which a differential backup was made.
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8.6.1.2. Second Step: Where to Store the Backup

Figure 8-9. Selecting Where to Store the Backup

All possible backup media are listed, along with a Configure button to change media-dependent options:

Hard Disk Drive

The local hard disk drive is used to prepare backups for all media except NFS and direct to tape. You
should not perform backups on your local hard disk anyway, you should always backup to remote or
removable media. You can set the directory for storage and the limit of storage space. You can also set
how many days to keep incremental or differential backups in order to save disk space.

Across the Network

To store the backup on a remote computer accessible using different methods. You can set the connection
parameters as well as the access method and its options (if applicable). Please note that NFS backups are
considered to be local disk backups, even if they are effectively stored on a remote system.

On Tape

You can set the tape device if it’s not detected automatically, and tape parameters such as writing directly
on tape, whether or not to rewind, erase and eject the tape.

Optical Media (CD-R)

This is our preferred media for the example, so click on its Configure button to set the required parameters
(see figure 8-10).
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Figure 8-10. Setting Optical Media Parameters

If it isn’t done automatically, use the Choose your CD/DVD device combo box to set the CD/DVD device. Set
the medium’s type and size, multisession and erase options.

For multisession recordings, please bear in mind that the option to erase the medium is only effective for the
1st session and also that session-related information recording takes some space out (20 to 30 MB) for each
session, so the “real data” storage space will actually be less than the medium’s size.
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8.6.1.3. Third Step: Review and Store the Configuration

Figure 8-11. Review Configuration Parameters

The last wizard step shows a summary of the configuration parameters. Use the Previous button to change any
parameter you are not satisfied with. Click on Save to store them on the Default profile. The backup set is
now ready to be performed.

Backup Profiles

You can choose File→Save profile as from the menu and provide a profile name to store the current backup
settings within a named backup profile. You can then run the configuration wizard again, define other settings
and store them under a different profile.

Use the --profile Profile_Name.conf option when you run Drakbackup from the command line to load
the Profile_Name.conf profile.

8.6.1.4. Performing the Backup

Click on Backup Now, make sure the corresponding media is ready (the recordable CDs in our example), and
then on Backup Now from configuration file to perform the backup.

Warning

If the backup set size exceeds the medium’s available capacity, the backup operation might just fail. This is a known
issue and it’s being worked on. As a work-around, please try to remove files from the backup set so its size never
exceeds the medium’s available capacity.

A dialog will display the current progress of the operation. Please be patient: the time it takes to back up
depends on many factors such as the size of the backup file set, the speed of the storage option selected,
and so on. Once the operation is finished a report is shown: look for possible errors on it and take corrective
measures if needed.
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8.6.2. Restoring Backups

Figure 8-12. Choosing the Restore Type to Perform

Make sure the media you want to restore the backup from is accessible and ready and click on the Restore
button. In our example we restore the whole backup so on the restore dialog (figure 8-12) click on Restore all
backups and then on the Restore button to start the restoration process.

Warning

Existing files in the target restoration directory (the same location as the backup was made from, by default) will
be overwritten.

Feel free to investigate the other restore options if you want to restore part of a backup instead of the full file
set, or to restore the backup to a different location.

8.6.3. Automating Periodic Backups

In the tool’s main window, click on Advanced Configuration and then on the When button. In the backup sche-
duling window (see figure 8-13) select Use daemon to define the schedule.
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Figure 8-13. Daemon Options Window

You are then asked to specify the interval (or period) between each backup operation and the storage media. In
our example we set up a customized calendar (custom period selected) to perform a backup from Wednesday
to Friday at a quarter to midnight and store it on CD, using the Default backup profile.

8.6.4. Advanced Backup Wizard Configuration

Click on Advanced Configuration and then on the More Options button to set more backup options (see figure
8-14).

Figure 8-14. Miscellaneous Options Window
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Archiving Program

You can choose between tar (the default) and star which allows you to backup extended ACLs too.

Compression Type

You can choose the compression strategy used for your backups among tar (no compression), tar.gz
(gzip compression) and tar.bz2 (bzip2 compression: better but slower).

Files to Ignore

You can exclude certain files from the backup. The .backupignore file should be present in every directory
of the backup file set where files are to be excluded. Its syntax is very simple: a one-file-per-line list of the
names of the files to exclude.

Tip: You can use the star (* = “matches any string”) and the question mark (? = “matches one and only one
character, regardless of what that character is”) in the .backupignore file to exclude sets of files. For example,
somename* matches all files whose names start with somename, and image00?.jpg matches files named
image001.jpg, image009.jpg, image00a.jpg, image00h.jpg, etc.

Send Reports by Email

Fill the mail address to which a report of the operation will be sent. You can specify many mail addresses
by separating each with a comma (,). Please also complete the Return address for sent mail field with the
email address of the backups administrator, and the SMTP server for mail field with the name or IP address
of the outgoing mail server.

Delete Temporary Files

Select the Delete Hard Drive tar files after backup to other media option to free that space after performing
the backup.

View Restore Log

You can choose to view the restore operation log after each restore. This can be handy to spot and fix
potential problems when restoring files: reading errors, network communications errors, etc.
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9.1. Securing your Internet Access via DrakFirewall

This little tool allows you to set up a basic firewall on your machine. It filters connection at-
tempts made from the outside, and blocks unauthorized ones. It’s a good idea to run it just
after installing your machine and before connecting to the Internet, therefore minimizing the
risks of your machine being compromised.

This Wizard consists of the steps we detail below.

9.1.1. Choosing Services to be Available from Outside

Figure 9-1. The DrakFirewall Window

Open Up Ports, If Needed. If checked, uncheck the Everything (no firewall) box, and then check the boxes
corresponding to the services you wish to make available to the outside world. If you wish to authorize a
service which isn’t listed here, click on Advanced to manually enter the port numbers to open.

Opening Unusual Services: Clicking the Advanced option opens a field named Other ports where you can enter any
port to be opened to the outside world. Examples of port specifications are presented just above the input field: use them
as a guide. It’s possible to specify port ranges by using the : syntax such as 24300:24350/udp.

This Won’t Block You from Accessing the Net. Not checking a service in this list won’t stop you from connec-
ting to the Internet. It will only prevent people from the Internet connecting to that service on your machine.
If you don’t plan on hosting any services on your machine (common case for a desktop machine) just leave all
boxes unchecked.

How to Disable the Firewall. On the other hand if you wish to disable the firewall and leave all services
accessible from the outside, check Everything (no firewall), but please bear in mind that this is very insecure,
and therefore not recommended.
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9.1.2. Activating Interactive Firewall Feature

Figure 9-2. Interactive Firewall Options

Stay Informed of Connections on your Machine.

The interactive firewall can warn you of connection attempts on your machine by displaying alert popups
through the network applet. Check the Use Interactive Firewall option to activate this feature.

Port scan detection

Activate this option to be warned of malicious attempts to access your machine.

Other entries corresponding to open ports

Next you are shown a checkbox for each port you have chosen to open during the previous step. Activa-
ting them will popup a warning each time a connection attempt is made on those ports.

9.1.3. Which Interface to Protect

The next step consists of selecting the network interface connected to the Internet.
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Figure 9-3. The Internet Interface

If you don’t know which interfaces you have connected for the Internet, you can check the system network
configuration (see Reconfiguring Interfaces, page 72). You can finally click OK to install the required packages,
activate the firewall and enjoy your secure Internet connection.
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